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This is the manual for OpenToonz, an open-source full-featured 2D animation creation software.
http://opentoonz.github.io

Note: This manual is an ongoing project, which aims to provide the first and most complete reference for OpenToonz
features, and as such there will always be room for improvements and updates. Collaboration is welcome!

To contribute to OpenToonz’s documentation, please visit the OpenToonz docs repository.
https://github.com/opentoonz/opentoonz_docs
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2 Getting Started:



CHAPTER 1

Installing OpenToonz

1.1 Downloading OpenToonz

You can download the appropriate version of OpenToonz for your operating system from the Download page in
the official OpenToonz web site. Choose either the Windows or macOS version to start downloading the installer
application.

At the bottom of that same page it’s also possible to find the developer’s “Nightly Builds” (new versions of the software
compiled each night for testing purposes), with which you will be able to try out the latest features and bug fixes, as
they are being included in OpenToonz.

Note: WARNING: Use at you own risk! A Nightly Build version could potentially be an unstable one, so it is not
adviced nor supported, for use in production environments.

Note: All other builds apart from the ones downloaded from the official web site ARE NOT officially supported by
OpenToonz.

Morevna Project provides builds for Windows 32-bit, Windows 64-bit, macOS, and appimage as well as snap for
Linux.

Finally, there’s also an OpenToonz fork called Tahoma2D avalaible for Windows, macOS and Linux, that could rep-
resent a good alternative for certain use cases, where it could be possible to find slightly different approaches to some
of the core features in the software, as well as its own new solutions and tools.

All in all, the OpenToonz ecosystem is an open, diverse and fluid one, which means that most novel features, improve-
ments and fixes developed for one of its variants, would most probably end up appearing in the other ones too, within
time.

3

https://opentoonz.github.io/e/download/opentoonz.html
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1.2 Installing on Windows

Execute the OpenToonzSetup.exe file and follow these steps:

Note: Microsoft Defender’s Smart Screen might alert that the installer is not signed. Just click on the “Run anyway”
button (select “More info” to make it visible) to proceed with the installation.

1. Choose the language for the installer messages.

2. Accept OpenToonz Terms of Use.

4 Chapter 1. Installing OpenToonz
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3. Decide where to install the OpenToonz stuff folder and if you wish to overwrite any settings in a preexist-
ing OpenToonz stuff folder in the chosen location (except for user’s personal settings, which will always be
preserved).

1.2. Installing on Windows 5
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4. Decide whether or not to create a desktop icon during the installation process.

6 Chapter 1. Installing OpenToonz
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5. Press the Install button to start the installation process with the chosen settings.

1.2. Installing on Windows 7
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6. Decide whether or not to Launch OpenToonz right away after closing the installer.

8 Chapter 1. Installing OpenToonz
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1.2.1 Chocolatey

choco install opentoonz

1.3 Installing on OS X

Follow these steps:

1. Right-click on the OpenToonz.pkg file in Finder & select Open.

2. Press the Continue button.

1.3. Installing on OS X 9



OpenToonz Documentation, Release 1.7.1

3. Choose a language and press the Continue button.

4. Press the Agree button to accept the OpenToonz Terms of Use.

10 Chapter 1. Installing OpenToonz
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5. Select the install destination (will be Macintosh HD unless multiple disks are available) and press the Continue
button.

6. Press the Install button to start the installation process with the chosen settings.

1.3. Installing on OS X 11
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7. Press the Close button to exit the installer.

12 Chapter 1. Installing OpenToonz
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1.3.1 Homebrew

brew cask install opentoonz

1.4 Installing on Linux

1.4.1 ALT Linux

# apt-get install opentoonz opentoonz-doc

1.4.2 Arch Linux

# pacman -S opentoonz

1.4.3 Debian GNU/Linux

1. Download PGP signing key package.

wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/
deb-multimedia-keyring_2016.8.1_all.deb

2. Install PGP package.

sudo dpkg -i deb-multimedia-keyring_2016.8.1_all.deb

3. Add repository address to your sources list.

echo "deb http://www.deb-multimedia.org stable main" | sudo tee -a /etc/apt/
sources.list Builds for testing and sid also avalaible.

Note: Debian packages avalaible only for amd64, arm64 and i386 architectures.

4. Install OpenToonz.

sudo apt update && apt install opentoonz opentoonz-data

Tip: For updating enter sudo apt update && apt upgrade.

1.4.4 Fedora

# dnf install opentoonz

1.4.5 Gentoo

sudo emerge media-gfx/opentoonz
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1.4.6 NixOS

nix-env -iA nixos.opentoonz

1.4.7 openSUSE

sudo zypper install opentoonz

1.4.8 Solus

sudo eopkg install opentoonz

1.4.9 Void Linux

sudo xbps-install -S opentoonz

1.4.10 Universal binaries

Flatpak

1. Installing.

flatpak install flathub io.github.OpenToonz

2. Run.

flatpak run io.github.OpenToonz

Snap

sudo snap install opentoonz

1.5 Installing on FreeBSD

# cd /usr/ports/multimedia/opentoonz && make install clean

1.6 Installing on DragonFly BSD

# pkg install opentoonz
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CHAPTER 2

Using FFmpeg with OpenToonz

2.1 What is FFmpeg?

To render your animation as an mp4 or webm, or also as a gif on Mac, OpenToonz requires the FFmpeg multimedia
framework to be installed on your machine.
For more information, please visit this page: About FFmpeg

2.2 Installing FFmpeg for Windows

2.2.1 Downloading

To download FFmpeg, first visit this page: Download FFmpeg
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Select the Windows icon and then select the Windows builds link:

You will be taken to an FFmpeg Builds page with some options for the version of FFmpeg that you want to
download:
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In the majority of cases, the default choices are fine.
Click on the blue Download Build button, this will begin downloading a zip archive containing FFmpeg.

2.2.2 Installing

Once you have downloaded the FFmpeg zip archive, open it and double-click on the first folder.

Within the bin folder are the executable files that you will need.

• Create a new folder on your computer, the recommended location is C:\.

• Name the new folder FFmpeg.

• Drag the contents of the bin folder from the archive into the newly created folder.

• Next, start OpenToonz and open the Preferences window with File → Preferences. . .

• Navigate to the Import/Export category; at the top you will see a box with the text FFmpeg path.

• Insert the path to your FFmpeg folder that you created earlier, if you have used the recommended path, this will
be C:\FFmpeg\:

• Restart OpenToonz.

• Open the Output Settings window with Render → Output Settings. . .

In the File Settings subsection, you should now see mp4 and webm.
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2.3 Installing FFmpeg for Mac

2.3.1 Downloading

To download FFmpeg, first visit this page: Download FFmpeg
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Select the Apple icon and select the Static and Shared builds link.

You will be taken to an FFmpeg Builds page with some options for the version of FFmpeg that you want to
download:
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Make sure macOS 64-bit is selected under the Architecture column.

Click on the blue Download Build button, this will begin downloading a zip archive containing FFmpeg.

2.3.2 Installing

Once you have downloaded the FFmpeg zip archive, open it and double-click on the first folder.

Within the bin folder are the executable files that you will need.

• Open Finder and create a new folder, the Applications/OpenToonz folder is the recommended location.

• Name the new folder FFmpeg.

• Drag the contents of the bin folder from the archive into the newly created folder.

Tip: For macOS 10.15 and later, each executable within the FFmpeg folder needs to be opened before using Open-
Toonz (this only needs to be done one time, due to security features). In Finder, right-click on each executable (ffmpeg,
ffprobe, and etc.) and select Open With → Terminal. Once the Terminal windows have launched successfully,
Terminal can be closed.

• Next, start OpenToonz and open the Preferences window with File → Preferences. . .

• Navigate to the Import/Export category; at the top you will see a box with the text FFmpeg path.

• Insert the path to your FFmpeg folder that you created earlier, if you have used the recommended path, this will
be /Applications/OpenToonz/FFmpeg:

• Restart OpenToonz.

• Open the Output Settings window with Render → Output Settings. . .
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In the File Settings subsection, you should now see mp4, webm and gif.

2.4 Installing FFmpeg for Linux

To install FFmpeg, enter the following command in the shell depending on your distribution.

Arch Linux: # pacman -S extra/ffmpeg

Debian GNU/Linux: # apt install ffmpeg

Gentoo Linux: # emerge media-video/ffmpeg

Solus: # eopkg install ffmpeg

If you are using a other Linux distribution please refer to its documentation or visit the FFmpeg website.

Tip: To make it possible to export files in mp4, webm or gif formats, you need to specify the path to FFmpeg installed
on your system, usually it is /usr/bin/ffmpeg. Enter command which ffmpeg in the shell to find out.

• Start OpenToonz and open the Preferences window with File → Preferences. . .

• Navigate to the Import/Export category; at the top you will see a box with the text FFmpeg path.

• Insert the path /usr/bin.
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• Restart OpenToonz.

• Open the Output Settings window with Render → Output Settings. . .

In the File Settings subsection, you should now see mp4, webm and gif.
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CHAPTER 3

What’s New in OpenToonz

In this section you can find a list of Highlights in the latest release of OpenToonz; these may include New Features,
Bug Fixes or Enhancements to already existent features. Here, you can also find links to past versions’ Release Notes,
to keep track of OpenToonz development history throughout time.

3.1 v1.6

3.1.1 Highlights

• Rhubarb integration for automatic lip-syncing [Tahoma2D port, with modifications].

• Xsheet/Timeline: Ability to Shift + drag an exposed cell to move it, while automatically adjusting
neighbouring hold cells.

• Xsheet/Timeline: Restored original Toonz feature for changing parent of a column from the XSheet
header [Tahoma2D port].

• Xsheet/Timeline: Cell Mark feature for identifying desired cells using colored dots.

• UI: Xsheet Minimum Layout for ultra-compact column size.

• UI: Xsheet zoom control.

• UI: Zoom in/out and fit floating panel geometry commands.

• Color Display: 30bit color display feature.

• I/O: Export Xsheet to PDF.

• I/O: Export to TVPaint JSON file format.

• I/O: OpenEXR image format support.
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• I/O: File Path Processing Using Regular Expressions.

• Cleanup: Enabled to Cleanup without Line Processing, allows applying Autocenter, Rotation, etc.
without further processing of the images.

• Rendering: Multi-Thread FFMPEG option for faster rendering.

• Brush and Paint Brush Tools: Lock Alpha setting for Toonz Raster and Raster level types.

• Style Editor: Hex editbox for color values in Style Editor.

• Style Editor: Hex color names editor.

• Effects: Linear color space option for all Layer Blending Ino effects.

• Effects: Conical Transform option for Fractal Noise Iwa effect.

• Effects: Image Size option for the Input Size parameter for Tile Iwa effect.

• Effects: GPU HSL Blend shader effect.

• Effects: Bokeh Advanced Iwa effect.

• Effects: Compass Gadget for Radial and Spin Blur effects.

• Camera Capture: Camera calibration.

• Audio: Improved Audio Recording.

• Xsheet/Timeline: Enhanced Note level column.

• Viewer: Enhanced Flipbook playback.

• Schematic: Allowed Renaming Pass Through Nodes (Tahoma2D port).

• I/O: Enabled to set Raster level frame number format.

• I/O: Enabled to use PNG for new Raster levels.

• I/O: Enhanced FFMPEG GIF export.

• File Browser: Enabled to view palette files from the File Browser.

• Palette: Enabled to paste style’s color into a color field.

• Effects: Fx Intensity parameter for controlling global effect intensity.

• Effects: Redesigned Pass Through effect node.

• Camera Capture: Enabled inputting frame with suffix in Camera Capture.

• Stop-motion: Enhanced Stop motion feature.

• Packaging Opentoonz for Fedora distribution.

• Crash on showing snapshot in flipbook.

• Crash on saving scene containing missing palette level.
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• Crash on undoing tool.

• Crash after starting a pen stroke from inactive window.

• Crash on Stage Schematic Column Right click.

• Crash on rendering ArtContour fx.

• Crash on rendering PaletteFilter Fx (and other fxs) with hyphen.

• Crash on cleaning up zerary column.

• Crash on creating a zerary fx in the camera column.

• Crash on creating Macro Fx from the Fx Browser.

• Crash On Inserting Fx.

• Crash on clicking shortcut tree.

• Crashes when using Type tool.

• Crash on deleting control point while dragging.

• Crash on switching scenes while selecting raster level frame.

• Undo Malfunction.

• File browser assertion failure.

• “Show Folder Contents” command for UNC path.

• Viewer playback.

• Flipbook wobbling when dragging while playing.

• Pressing Shift key loses focus when renaming cell.

• Autorenumber of Raster Level.

• Cell Selection on Click.

• GIF rendering on older versions.

• Saving TLV.

• Output file name for movie format.

• PSD loading and level format preferences.

• Backtab key to work for moving styles shortcut scope.

• FrameIDs Inconsistency in Level Strip Commands.

• Memo Popup Background Color.

• FX gadget picking.

• Margin of Directional Blur Fx Iwa.
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• Zerary Fx bugs.

• Friction parameter behavior of the Particles Fx.

• Rendering Fx After Xsheet Node.

• Channel clamping behavior in Layer Blending Fxs.

• Fx Gadget Offset.

• Bokeh Fxs Artifacts.

• Schematic node placement fix.

• Shortcut loading from file.

• Tool options’ shortcuts to work without opening tool options bar.

• Camera capture’s level control.

• Mesh file naming.

• Wheel scrolling on the output settings popup

• Missing Checkboxes in Menu Item

• Convert to TLV Palette Saving

• Raster Deformation Slowness

. . . and much more!

Please see the v1.6 Release Notes hosted in GitHub, for the full list of new features, enhancements and bug fixes.

3.2 Previous Versions of OpenToonz

Here you can find links to previous versions’ full Release Notes, hosted in GitHub:

v1.5 Release Notes

v1.4 Release Notes

v1.3 Release Notes

v1.2.1 Release Notes

v1.2 Release Notes

v1.1.3 Release Notes

v1.1.2 Release Notes

v1.1 Release Notes

v1.0.3 Release Notes

v1.0.2 Release Notes

v1.0 Release Notes
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CHAPTER 4

Production Workflow

4.1 Traditional Workflow

The following is an example of how OpenToonz allows the management of a traditional animation production.
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4.1.1 Scanning

Hand-drawn elements are first defined in an OpenToonz Xsheet, and then acquired by using a scanner. These elements
can consist of animation levels, i.e. sequences of drawings belonging to the same animation, or background images
and overlays.

The scanned images then pass through a cleanup process, and are auto centered when necessary, using their pegbar
holes as a guide and their related field guide setting. In the case of lineart drawings, these are further prepared for the
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painting process.

See Scanning Paper Drawings .

4.1.2 Paperless Drawing

Additional drawings and animation levels can be drawn directly in OpenToonz. Drawings can be an important part of
the scene, such as a background or a character’s prop, or incidental elements needed to achieve a particular result, for
example a mask image to create a matte effect.

See Drawing Animation Levels .

4.1.3 Color Model

Color models are created for accurate color-referencing during production, when painting characters and props. They
can be drawings made in OpenToonz, scanned images processed in OpenToonz, or images coming from a 3rd party
software.

In case of OpenToonz drawings, the color model palette can be defined by creating styles and colors to be used for
painting animation levels.

See Managing Palettes and Styles and Using a Color Model .

4.1.4 Ink & Painting

Animation levels scanned and cleaned up in OpenToonz, and those made directly in OpenToonz, are painted by using
the styles stored in the palette and a set of tools.

Palette styles are interactively “linked” to drawn lines and filled areas by using indexes. The main advantage of
this method is that if you edit a style of the palette, all the lines and filled areas using that style will be automatically
updated. This allows you to change or calibrate colors also after the painting process has been done, without correcting
the style line by line, or area by area.

See Managing Palettes and Styles and Painting Animation Levels .

4.1.5 Compositing

All OpenToonz painted levels and images are exposed in the Xsheet where the timing of all the elements of a scene
can be controlled. Images, animations and clips from 3rd party software can be loaded as well.

After adding and arranging the required elements to the Xsheet as layered columns, they are then animated by using
interpolated keys placed on necessary parameters. Elements that can be animated in this way include the camera,
columns, pegbars and the table.

Special FX, such as blurs, lights, keys, masks, warps, gradients, etc. can be applied to the content of Xsheet columns,
and can also be animated by setting key value to the parameters.

Object and special FX transformations are mapped in the function editor window, where set key values and related
interpolations can be controlled and modified by using function curves or numerical columns.

See Working in Xsheet , Creating Movements , Applying Special FX and Editing Using Spreadsheet and Curves .
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4.1.6 Render Farm

The scene is rendered in order to compose all the transformations and applied special FX in a sequence of frames in
the format and resolution you prefer.

The OpenToonz render farm allows you to batch-render OpenToonz scenes by using a series of computers connected
on the same network using TCP/IP.

See Rendering the Animation and Using the Toonz Farm .

4.2 Paperless Workflow

The following is an example of how OpenToonz allows the management of a paperless animation production.

30 Chapter 4. Production Workflow



OpenToonz Documentation, Release 1.7.1

4.2.1 Preproduction: Concept

Even if a paperless project can be run regardless of the script, the concept of a format with few settings and a stable
cast of characters will ease the arrangement of libraries to be prepared before the actual episode production.
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4.2.2 Preproduction: Graphic Design

The graphic design of characters, props and locations is equally important, in order to find out a style that will fit well
both with the drawing capabilities of the software and with the cutout animation technique.

In particular when designing character models and props, for which you could develop a specific line style to apply to
vectors, or use very neat lines typical of vector animations, you should consider a design where the model animation
pivot points can be easily disguised under drawings features (for example the pivot point of a ponytail linked to the
character’s head can be disguised under a ribbon).

4.2.3 Preproduction: Storyboard

While usually the storyboard is used by the director to control the rhythm of the action, in case of a paperless production
it also identifies all the elements needed for the production of each scene, by listing all of the character animations and
poses, and identifying all of the props and backgrounds that are needed to implement the story.

4.2.4 Animatic

The animatic is created starting from the scanned storyboard drawings. In OpenToonz, or in a third-party software, the
storyboard drawings are imported, timing is adjusted and camera movements are set. Audio files too can be imported
for reference.

In case the animatic is created in OpenToonz, it can also be split so that each cut can be used as a starting point for the
final compositing of each scene.

4.2.5 Libraries

Libraries are prepared by drawing directly in OpenToonz all of the elements composing the scenes, such as locations,
characters, props, etc.

As far as the characters are concerned, they will be decomposed in multiple levels (i.e. head, torso, arms etc.) used as
skeleton components rejoined through a hierarchy which at the end will make models available to the animators.

According to the storyboard analysis, the drawings needed both for the canonical turn-around model (i.e. a collection
of models as seen from different points of view: front, back, side and three-quarter views) and for additional move-
ments are prepared. Starting from these reference animations, such as running or walking cycles, jumping, may be
stored as well in order to be re-used in the scene production.

Props and backgrounds can be also created with third-party software, including rendered images from 3D software.

See Drawing Animation Levels and Creating Cutout Animation .

4.2.6 Layout

In the layout phase, all of the elements that are necessary for the scene (backgrounds, props, characters, reference ani-
mations) are loaded from the library in Xsheet, usually as Sub-Xsheets. They are put in place according to the animatic.
Basic animation is achieved by setting key positions for animated characters or importing reference animations.

Camera movements and animation timing previously set in the animatic are refined.

See Working in Xsheet and Using Sub-Xsheets .
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4.2.7 Animation

The animation for the scene defined in the layout is refined by adding key position to the character movements.
Character poses are added by tweaking the model to achieve a more fluid animation.

The right speed for all the movements is set by controlling interpolation mode in the function editor.

See Animating Objects and Using the Function Editor .

4.2.8 Special FX

Special FX, such as blur, glow, color corrections, particles, are applied to the scene elements.

Additional animation elements related to special FX, for example masks or images for the particles effect, are drawn
directly in the scene, or imported from external files.

See Applying Special FX .

4.2.9 Render

The scene has to be rendered in order to compose all the transformations and applied special FX in a sequence of
frames in the format and resolution you prefer.

The OpenToonz render farm allows you to batch-render OpenToonz scenes by using a series of computers connected
on the same network using TCP/IP.

See Rendering the Animation and Using the Toonz Farm .
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CHAPTER 5

Interface Overview

OpenToonz interface is organized into rooms, also known as workspaces: each room is a different collection of
windows which are laid out at specific positions on the screen.

5.1 Using Rooms
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Available rooms are listed on the far right of the menu bar. Each of them always displays the content of the current
scene.

Rooms can be named and their order can be rearranged. New rooms can be added and existing rooms can be deleted.
When a room is added it is empty; to configure it, panes can be added one by one (see below).

Tip: To enter a room:

Click the related tab on the far right of the menu bar.

Tip: To name a room:

Double-click the tab and type the name you want to assign to the room.

Tip: To order room tabs:

Click and drag the tab to the new position.

Tip: To add a new room:

Right-click in the room tab area and choose New Room from the menu that opens.

Tip: To delete a room:

Right-click the room tab and choose Delete Room “<Name>” from the menu that opens. The current room cannot be
deleted.

Tip: To return to the set of rooms provided with OpenToonz:

Choose Windows → Workspace → Reset to Default Rooms.

5.1.1 Customizing Rooms

Rooms can be modified by setting different sizes to different panes, and adding or removing panes. To prevent the
accidental addition or removal of panes, rooms configuration can be locked.

Most of the panes can be maximized to fill the full interface, and can be added as floating windows by using the
Windows menu.

Tip: To resize a pane in the room:

Click any vertical or horizontal separator and drag it to the new position.

Note: Some panes like the toolbar and the level strip have some fixed size, therefore they cannot be resized.
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Tip: To open a pane as a floating window:

Select in the Windows menu the pane you want to open.

Tip: To resize a floating window:

Click and drag the border or corner of a window.

Tip: To close a floating window or a dialog:

Click the close button at the right of the title bar.

Tip: To add a pane to a room:

1. Use the Windows menu to open the pane as a floating window.

2. Click and drag its title bar to move it around and release to dock it according to the highlighted insertion point.

Note: Trying to dock a pane to the leftmost/rightmost part of the interface may fail if the main OpenToonz window is
maximized at that moment. To overcome this, you can restore the main window size, dock the desired pane, and then
maximize it back.

Tip: To remove a pane from a room:

1. Click and drag the title bar of the pane you want to remove to undock it from the room.

2. Close the floating window.

Tip: To maximize, or minimize a maximized pane:

Double-click its title bar.

Note: Some panes like the toolbar and the level strip have some fixed size, therefore they cannot be maximized.

Tip: To lock/unlock the rooms configuration:

Activate/deactivate the Windows → Workspace → Lock Room Panes option.

5.2 Room Panes

Below there is a list of the panes (in the same order in which they appear in the Windows menu) that can be used to
build rooms and that can be opened as floating windows.
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5.2.1 Batch Servers

The Batch Servers window allows you to process the batch list by using the render farm, and contains information
about the list of server (rendering) nodes defined for the farm.

See Monitoring the Server Nodes .
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5.2.2 Cleanup Settings
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The Cleanup Settings pane allows you to define the parameters for the clean-up process of scanned raster images, in
order to convert them into Toonz Raster images, ready to be painted in OpenToonz.

See Cleaning-up Scanned Drawings .

5.2.3 Color Model

The color model viewer displays the image, or animation level, you loaded as reference to paint the current animation
level.

See Using a Color Model .
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5.2.4 File Browser

The file browser allows you to load and save files, and to access projects.

On the left there is a file tree with some main folders containing material stored on your computer: My Computer,
Network, My Documents, History, Library and Projects. You can open folders and sub-folders in order to retrieve files
that are displayed in the area on the right.

See Managing Projects and Using the File Browser .
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5.2.5 Flipbook

The flipbook can display animation levels, clips or sequences of images. It can be used to check levels for instance
before loading them, or to control a rendered sequence.

See Using the Flipbook .
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5.2.6 Function Editor

The function editor maps objects and FX transformations with key values and related interpolations by using a spread-
sheet or a graph editor. It is divided into two sections: on the left there is an area where the spreadsheet or graph editor
is displayed, on the right top is an area where the interpolation of the current transformation segment is displayed, and
on the right bottom is the objects/FX tree.

See Using the Function Editor .
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5.2.7 Level Strip

The level strip displays the sequence of drawings belonging to the level currently selected in the Xsheet.

It helps you to edit the sequence of drawings and to see all the drawings of the current level, even if those drawings
are not exposed in a Xsheet.

See Editing Animation Levels .
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5.2.8 Palette

It displays the styles defined for the current level, or in case it is inactive the styles defined for a previously selected
level.

See The Palette Window .

5.2.9 Scene Cast

The scene cast pane lets you control the files loaded in the scene, save them and load new ones. It can be organized in
folders and sub-folders.

See Using the Scene Cast .
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5.2.10 Schematic

The schematic can alternatively display stage information or special FX usage.

The stage schematic displays as nodes all the objects defined in a scene, i.e. columns, pegbars, cameras, the table and
motion paths, and allows you to manage the way they are linked to each other.

The FX schematic allows you to apply FX to the content of Xsheet columns, and to manage the way they are applied.
All the columns and FX are displayed as nodes that can be connected in order to set the way FX affect the scene
content.

See Using the Stage Schematic and Using the FX Schematic .

5.2.11 Studio Palette
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The studio palette allows you to store an unlimited number of level palettes. From here any palette can be retrieved
and assigned to the current level in order to paint it, with no need to define the same styles again and again. It also
includes a viewer displaying the styles of the currently selected palette.

See Using the Studio Palette .

5.2.12 Style Editor

The style editor allows you to modify the palette styles. You can choose the type of style among color, texture, vector
and raster. There also is a settings tab where you can decide some parameters for the style.

See Editing Styles .
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5.2.13 Tasks

The Tasks window contains the task tree with all the tasks submitted to the batch processing, and information about
the task currently selected in the tree. From the task tree you can start or stop a task execution, or remove it.

See Managing and Executing Render Tasks .

5.2.14 Message Center

The message center displays in a list the messages OpenToonz is sending to the user. You can set filters on the
messages showed in the window using the appropriate radio buttons, or you can clear the list completely by pressing
the Clear button.

5.2.15 Toolbar

The toolbar contains tools to draw, select and edit drawings, and to animate objects like the camera, columns and
pegbars. The tools in the toolbar can only be used in the main viewer.

Note: If the toolbar is too short to display all the tools, it can be scrolled by using arrow buttons available at its ends.
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Animate modifies the position, rotation and size of the current objects (see Animating Objects ).

Selection performs a selection and transforms it (see Using the Selection Tool ).

Brush draws in the work area in freehand mode (see Drawing with the Brush Tool ).

Geometric draws geometric shapes (see Drawing with the Geometric Tool ).

Type adds text by setting the font and size (see Adding Text ).

Fill fills drawing areas with the current style (see Filling Areas ).

Paint Brush paints lines and areas in Toonz raster drawings in freehand mode. (see Filling Areas ).

Eraser deletes vectors in vector drawings, and painted areas and lines in raster drawings (see Drawing Tools ).

Tape joins two open ends of one or two vectors in vector drawings, or closes gaps in raster drawings (see Joining
and Splitting ).

Style Picker picks a style from the current drawing, that becomes the current style in the palette and in the style
editor.

RGB Picker picks red, green and blue values from the viewer content, and applies them to the current style (see
Plain Colors ).

Control Point Editor modifies the vector shape by editing its control points (see Editing Vector Control Points ).

Pinch modifies the vector shape by clicking and dragging anywhere on the vector (see Changing the Bend of
Vectors ).

Pump locally modifies the vector thickness by clicking on the section you want to affect and then dragging up or
down (see Using Other Modifier Tools ).

Magnet deforms several vectors at once by clicking the area you want to affect and dragging (see Using Other
Modifier Tools ).

Bender bends vectors in vector drawings (see Using Other Modifier Tools ).

Iron removes creases from vectors by moving the cursor on the vector you want to flatten (see Using Other
Modifier Tools ).

Cutter splits a vector in two sections when clicking on it (see Joining and Splitting ).

Skeleton defines character models, and animates them as in cutout animation (see Using the Skeleton Tool )

Hook defines reference points to be used in the stage schematic to move an object, or link one object to another
(see Using Hooks ).

Tracker tracks specific regions in a sequence of images (see Tracking Points ).

Plastic builds a mesh that allows to deform and animate a character or part of it (see Using Plastic tool ).
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Zoom zooms in and out the viewer content; after you click you can drag up to zoom in the work area, or drag
down to zoom out.

Hand pans over the viewer content; if the 3D view is activated, the Hand tool lets you pan over the 3D view as
well.

Rotate rotates the viewer content; if the 3D view is activated, the Rotate tool lets you change the point of view.

5.2.16 Tool Options Bar

The tool options bar displays settings for the current tool, if it has any.

For example it lets you set the thickness and other properties of the Brush tool.

Note: If the tool options bar is too short to display all the tool options, it can be scrolled by using arrow buttons
available at its ends.

5.2.17 Command Bar

The Command Bar is a place where the user can display favorite OpenToonz tools and commands to have them readily
available.

The Command Bar pane can be docked in any part of the OpenToonz UI.

Note: If the Command Bar is too short to display all the command buttons, a double-arrow symbol will appear at the
right end of it, allowing to display a drop down menu with the rest of them.

Tip: To display the Command Bar:

• Choose Windows → Command Bar.

Tip: To customize the Command Bar buttons:

1. Choose Windows → Command Bar to open the Command Bar.

2. Right click on it and select Customize Command Bar from the menu that opens. The Customize Command
Bar window will open.
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3. To add a command: Search for a command in the Toolbar Items list (right) and drag it to the Command Bar
list (left).

4. To add a separator: At the end of the Toolbar Items list (right), drag the —-Separator—- item to the Command
Bar list (left).

5. To delete a command: Locate the command in the Command Bar list (left), right click on it and select Remove
from the menu that opens.

6. Click OK to accept the changes or Cancel to discard them.
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5.2.18 Viewer

The viewer is the work area where you can draw images and see at the same time the result of your compositing. It is
endless and you can scroll, zoom in, zoom out and rotate it the way you prefer.

It has different modes of visualization among which you can choose the more suitable to the operation you are per-
forming.

See Using the Viewer and Previewing the Animation .

5.2.19 ComboViewer
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The comboviewer integrates in a single pane a viewer, horizontal toolbar and a tool options bar. It’s and alternative
work area where you can draw images and see at the same time the result of your compositing. It is endless and you
can scroll, zoom in, zoom out and rotate it the way you prefer.

It has different modes of visualization among which you can choose the more suitable to the operation you are per-
forming.

See Using the Viewer and Previewing the Animation .

5.2.20 Xsheet

The Xsheet allows you to manage the scene content, in the same manner as the timeline. It is organized in columns,
and columns are divided into cells, representing the content of that column in that particular frame. In the columns
you can load animation levels, clips, images, audio files or other Xsheets.

Each column has its own header containing information about its content. The column on the far left displays the
frame number, with a cursor placed on the current frame. The headers area and the frame column are always visible,
even when scrolling the Xsheet area; in this way it’s easier to understand how the scene is built.

Frames are rendered reading images from left to right in each cell row.

See Working in Xsheet .
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5.2.21 Timeline

The timeline allows you to manage the scene content, in the same manner as the Xsheet. It is organized in horizontal
layers, and layers are divided into cells, representing the content of that layer in that particular frame. In the layers
you can load animation levels, clips, images, audio files or other timelines.

At the leftmost part each layer has its own header containing information about its content. At the top part of the
timeline there is a time ruler that displays the frame number, with a cursor placed on the current frame. The headers
area and the time ruler are always visible, even when scrolling the timeline area; in this way it’s easier to understand
how the scene is built.

Frames are rendered reading images from bottom to top in each cell column.

See Working in Xsheet .
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5.2.22 History

The history pane, lets you check and undo/redo the history of the latest actions performed in the current OpenToonz
scene.

See Assigning Memory for the Undo Operation .
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5.2.23 Record Audio

The record audio window, lets you record a live audio source, listen to it, and insert it into a new audio column of the
Xsheet. The insertion point will be located at the right of the selected cell column, and starting at the selected cell
frame.

Note: Currently, this window cannot be docked to form part of a room, like the other ones in the Windows menu.
Instead it must be opened as a floating window, when needed.

5.3 Customizing the Interface Appearance

The appearance of the OpenToonz interface can be customized to suit any production need by choosing a specific
language and interface theme.

OpenToonz allows users to choose a specific language for the software interface, including menus, commands, tooltips,
and on-screen messages. Currently available languages are: English, German, Spanish, French, Italian, Russian,
Japanese and Chinese.

There are also several included themes to choose from: Default, Blue, Dark, Light and Neutral.

The interface themes are defined by means of a QSS file, whose concepts, terminology, and syntax are inspired by
CSS files (HTML Cascading Style Sheets). The QSS files also refers to a set of PNG images that are used to create
interface widgets.

These files are stored in a folder named as the QSS file, and located in the C:\OpenToonz stuff\config\qss
folder on Windows and OpenToonz stuff\config\qss folder on Macintosh.

Note: The QSS file for Macintosh is named with the _mac suffix.

The QSS file can be edited with any text editor software, e.g. Notepad or TextEdit; the PNG images with any image
editor software. Editing the QSS file requires some skill in CSS language, but some changes like colors of pane
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Fig. 1: The OpenToonz interface theme set to Default and to Light.

elements, can be easily done by expressing them with red, green and blue values.

Note: The QSS files defining the colors and the images used in the OpenToonz interface have to be written according
to a specific syntax, otherwise OpenToonz interface will not be displayed properly. If you decide to edit a QSS file,
make a backup copy first in case you need to revert the file to the original version.

Tip: To choose the interface language:

1. Choose File → Preferences. . . → Interface.

2. In the Language* option menu choose the language you want to use in the interface.

3. Restart OpenToonz to have the interface in the selected language.

Tip: To choose the interface theme:

1. Choose File → Preferences. . . → Interface.

2. In the Theme option menu choose the style to be applied to the interface.

Tip: To create a new theme:

1. Navigate to C:\OpenToonz stuff\config\qss folder on Windows and OpenToonz
stuff\config\qss folder on Macintosh.

2. Duplicate one of the already existing style folder.

3. Rename the folder and the QSS files inside it with the name you want to assign to the style.

4. Edit the QSS file and the PNG images contained in the new folder.

Note: The new style will be available in the Preferences dialog the next time you run OpenToonz.

Tip: To edit style QSS file:
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Open and edit with a text editor software (e.g. Notepad or TextEdit) the QSS files available in the style folder.

Tip: To edit style images:

Open and edit with an image editor software the PNG files available in the style folder.
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CHAPTER 6

Managing Projects

Projects are an easy way to manage scenes and files used in them. They allow you to organize your production
material not only by defining default settings used throughout the production, but also default folders where files will
be automatically saved, and from where they will be retrieved when needed. This means that, for example, as soon as
you scan drawings, they will be saved automatically in the input default folders you specified for your project.

The main advantage of managing the production through projects, is that a consistency of production settings and
production material can be achieved.

The consistency of production settings is achieved because all the scenes of a projects, as soon as they are created,
inherit all the settings from the project (see Setting Up a Scene ).

The right use of production material is achieved because once you have defined a production structure through projects,
all the scenes are able to save and retrieve files by using the project default folders.

6.1 Setting the Projectroot

The projectroot is the folder where the project information and database are stored; it is displayed in the OpenToonz
browser as one of the main folders with the related path in brackets.

The default value is C:\OpenToonz stuff\projects on Windows and /Applications/OpenToonz/
OpenToonz stuff/projects on Macintosh.

Note: If your production has to be managed on more than one computer on a network, you can share the same project
database on all the computers you want, by defining the same projectroot on each computer.

It is also possible to define more than one projectroot if needed: in this case projectroot folders will be visible in the
OpenToonz browser, each with the related path in brackets.
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The projectroot information can be changed at any moment, for instance if you need to move the project database files
from one computer to another.

Tip: To set the projectroot on Windows:

1. Open the Run application dialog by selecting Run from the Start menu.

2. Type regedit in the text box and click OK. This will open the Registry Editor application.

3. Navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\OpenToonz\OpenToonz and double-click
TOONZPROJECTS in the right part of the window: the Edit String dialog opens.

4. Enter the new path for the projectroot.

5. Click OK and exit from the Registry Editor application.

6. Restart OpenToonz to make the change effective.

Tip: To add a projectroot on Windows:

1. Open the registry editor to edit the TOONZPROJECTS registry as described above.

2. Enter the path for the new projectroot, separated by a semicolon (e.g. C:\production01;
D:\production02 ).

3. Click OK and exit from the Registry Editor application.

4. Restart OpenToonz to make the change effective.

Tip: To set the projectroot on Macintosh:

1. Right-click the OpenToonz icon in the Applications/OpenToonz folder, and choose Show Package Con-
tents from the menu that opens.

2. In the folder that opens browse to the Contents/Resources folder and open the SystemVar.ini file
with a text editor application, such as TextEdit.

3. Look for the following line where the projectroot is defined: TOONZPROJECTS=”/Applications/
OpenToonz/OpenToonz stuff/projects”

4. Change the path in inverted commas by typing a new one.

5. Save the SystemVar.ini file.
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Tip: To add a projectroot on Macintosh:

1. Open the configuration file to edit the TOONZPROJECTS variable as described above.

2. Change the path in inverted commas by adding a new path for the new projectroot, separated by a semicolon
(e.g. /Applications/OpenToonz/OpenToonz stuff/production01 ; /Applications/
OpenToonz/OpenToonz stuff/production02 ).

3. Save the SystemVar.ini file.

4. Restart OpenToonz to make the change effective.
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6.2 Setting up Projects

When you define a new project you can specify its default folders, while its default settings will be inherited from the
current project. Default folders and settings can be modified at any time to satisfy new production needs.

Project information is stored in an XML file named as the project with the _otprj suffix, in a folder named as the
project located in the projectroot (see Setting the Projectroot ).
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Projects can be organized in folders and can contain sub-projects that can be browsed in the OpenToonz file browser.
This allows you to customize the project structures in order to follow your production needs, for instance creating a
folder for each episode, then a project for each scene belonging to that episode. As the project browser will display
the project tree and all the folders contained in the projectroot, you can also organize your folder structure in the
projectroot by using the OS file system.

There is always one current project selected in the project browser: when you start working on a scene, automatically
it will belong to the current project, inheriting its settings and default folders.

If you want a new scene to be part of a new project, first you have to define a new project. If you want it to be part of
a previously created project, first you have to set that project as the current one.

Note: If you want to use the farm for rendering scenes, all the server (rendering) nodes of the farm have to share the
same projectroot (see Installing the Toonz Farm on Windows ) and all the drives containing the projects database, have
to be shared on the network.

Tip: To create a new project:

1. Choose File → Project Management → New Project. . .

2. Select the projectroot or repository (see Configuring the Version Control in OpenToonz ), and the project or
folder where you want to create the new project.

3. Type the name of the project and set the path to the folders you want to use as default.

4. Click the OK button.

Tip: To change the current project:

Click the small round button on the left of the project name in the project tree available in the OpenToonz file browser.
It becomes red when selected.

Tip: To add a scene to a project:

1. Set the project as the current one.

2. Choose File → New Scene.

Tip: To change project default folders:

Select File → Project Management → Project Settings. . . and change default folders paths.

Note: When changing default folders, scenes previously created in the same project may fail retrieving used files.

6.3 Project Default Folders

Projects have default folders where scanned drawings, painted drawings, scenes, rendered frames and palettes are
automatically saved. These folders are shared by all of the scenes created for that particular project, and are labelled
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in the following way:

• +inputs is the folder where all scanned drawings are saved (as TIF files).

• +drawings is the folder where OpenToonz cleaned up drawings, drawings made directly in OpenToonz and
imported OpenToonz drawings are saved (TLV and PLI files).

• +scenes is the folder where the OpenToonz scenes are saved (TNZ files).

• +extras is the folder where all the imported non-OpenToonz levels, images and audio files are saved.

• +outputs is the folder where rendered images are saved.

• +palettes is the folder where the project palettes of the studio palette are saved, and where the Raster Drawing
Palette, shared by all the raster levels belonging to the project, is stored.

For each of these folders you can specify different locations on your computer network depending on the way you set
up the storage of your production material.

Absolute or relative paths can be specified for the default folders definition.

If you specify an absolute path, the folders will be created, when needed, where specified. For example
you can set +drawings to be C:\production\drawings01 on Windows, or /Volume/Macintosh HD/
production/drawing01 on Macintosh: this means that the OpenToonz drawn and cleaned up levels will
be automatically saved in C:\production\drawings01 on Windows, or in /Volume/Macintosh HD/
production/drawing01 on Macintosh.

If you specify a relative path, all the folders you specify in the path will be created, when needed, in the project folder
under the selected projectroot or repository (see Configuring the Version Control in OpenToonz ). For example, for
the project myproject, you can set +drawings to be sequence01\mydrawings : this means that the OpenToonz
drawn and cleaned up levels will be automatically saved in the myproject\sequence01\mydrawings folder
located in the selected projectroot or repository.

The $scenepath variable can also be used to automatically create specific folders according to the scene you are
working on. The variable can be either appended to the specified paths, or used in the path definition.

The labels of the default folders you can find in the project settings (i.e. +drawings, +extras, etc.) can be used as
aliases in OpenToonz. For example if some material is retrieved from the extras default folder, its loading path will
contain the alias +extras. They can be also used when you need to specify a saving path, for example in the Path field
of the New Level dialog.

When in a scene you load material not located in the current project folders, you can choose whether to import files,
that is to say copy them in the related project folders, or to create a link with the external file. The link is defined by
an absolute path.

Note: Files loaded in a scene without importing can be imported later on at once by using the Collect Assets feature
(see Collecting Assets ).

Note: All shared disks involved in the folder definitions, i.e. disks where production material has to be written
and read, must be shared granting full permissions to any user, otherwise the exchange of files will not succeed. For
Windows, disks must have a Share Permission set to Full Control for Everyone; for Macintosh, the sharing settings
must allow any user to read from and write to disks.

Note: When no project is defined, the OpenToonz stuff/sandbox project is used by default.
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Tip: To set default folders for a new project:

Do one of the following:

• Type the path to the folder you want to use as default.

• Use the browser button on the right of each text field, to set the folder you want to use as default.

6.3.1 Adding Custom Default Folders

Besides the basic default folders you can also add your own default folders, and use the related aliases, by defining
a TXT file named project_folders.txt in the OpenToonz stuff\profiles folder. In this file you can
also change the order of the folders already available to change the way they are listed in the project settings dialog.

The following is an example of a projectfolders.txt file:

inputs
drawings
backgrounds
scenes
extras
outputs
palettes
3D

where the +backgrounds and +3D aliases were added to the default ones.

Tip: To add more default folders to projects:

1. Open the OpenToonz stuff\profiles\project_folders.txt file.

2. List the default folders you want to define, one per line, and save the file.

6.3.2 Using the $scenepath Variable in Folder Definition

The $scenepath variable can also be used in the definition of the +inputs, +drawings, and +extras aliases when typing
the default folder path. In this case the path where you save the current scene will replace the $scenepath variable in
the path definition, with the needed folders automatically created during the saving process.

For example if +drawings is $scenepath\mydrawings, and you save the scene scene01 in +scenes\seq01
, OpenToonz drawn or cleaned up levels for that scene will be saved in seq01\scene01\mydrawings ; when
you save the scene scene02, in seq01\scene02\mydrawings ; and so on.

In this way the needed default folders are automatically created with the same given name (mydrawings), one for each
scene, according to the path used when saving the scene. As a consequence, if the variable is used in this way for all
the aliases, all the files related to a scene will be stored in a folder named as the scene.
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A second example: if +drawings is mydrawings\$scenepath, when you save the scene scene01
in +scenes\seq01 , OpenToonz drawn or cleaned up levels for that scene will be saved in
mydrawings\seq01\scene01 ; when you save the scene scene02, in mydrawings\seq01\scene02 ; and
so on.

In this case the needed default folders are automatically created with the name and path of folders used when saving
the scene, inside the path specified (mydrawings). As a consequence, if the variable is used in this way for all the
aliases, all the files used in the project will be stored in a main folder for each alias, whose content is divided into
folders named as the scenes.

Note: The definition of the +palettes alias cannot include $scenepath, as the palettes refer to the whole project, not
to specific scenes.

Note: It is not possible to use at the same time for an alias the $scenepath variable in folder definition and the Append
$scenepath option.
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6.3.3 Using the Append $scenepath Option

The Append $scenepath option is available for the +inputs, +drawings and +extras aliases. If you activate the Append
$scenepath option for an alias, the path where you save the current scene will be added to the path of the alias, with
the needed folders automatically created during the saving process.

For example if +drawings is mydrawings , and you save the scene scene01 in +scenes\seq01 , Open-
Toonz drawn or cleaned up levels for that scene will be saved in mydrawings\seq01\scene01 ; if you save
the scene scene02 in +scenes\seq01 , OpenToonz drawn or cleaned up levels for that scene will be saved in
mydrawings\seq01\scene02 ; and so on.
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This allows OpenToonz to create scene-related folders automatically when saving OpenToonz files or importing ex-
ternal files, while allowing the use of the generic aliases +drawings, +inputs and +extras, no matter where levels are
loaded from within the current project.

Note: When a scene is saved in the +scenes folder, the value for $scenepath is the scene name; for example if you
save the scene scene02 in +scenes, $scenepath will be scene02.

Note: It is not possible to use for an alias the Append $scenepath option and at the same time the $scenepath variable
in defining the related folder.

6.4 Using the Project Browser

The project browser is available at the end of the file browser tree. It lists all of the projects that have been created,
whose actual location is in the projectroot that was defined in the initial installation of OpenToonz. The projectroot
value is displayed in brackets.

The name of the folders which the aliases point to are displayed in blue.

Note: In case more than one projectroot is defined, each will be listed with the related projectroot value in brackets
(see Setting the Projectroot ).

6.4.1 Default Folders with Relative Paths

When default folders are defined by using a relative path, in the project browser you will see all the folders specified
in the path under the projectroot, and the project folders tree will be the same of the file system tree. The folders that
are the target of the paths are displayed in blue.

For example, for the project Project01, with +drawings that is section01\prod drawings , the project browser
will display the following:

Projects

Project01

section01 prod drawings

If the option Append $scenepath is activated, and you save the scene scene01 in +scenes\seq01 , the project
browser will display the following:

Projects

Project01

section01

prod drawings

seq01 scene01

If the $scenepath is used in the folder definition, with +drawings that is $scenepath\prod drawings, and you
save the scene scene01 in +scenes\seq01 , the project browser will display the following:

Projects
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Project01

seq01

scene01 prod drawings

If the $scenepath is used in the folder definition, with +drawings that is mydrawings\$scenepath, and you save
the scene scene01 in +scenes\seq01 , the project browser will display the following:

Projects

Project01

prod drawings

seq01 scene01

6.4.2 Default Folders with Absolute Paths

When default folders are defined by using an absolute path, in the project browser you will see only the related aliases,
whatever their location on the network is. In this way you can quickly access the production material without browsing
the computer, or the network. The aliases are displayed in blue, because they are the location the default folders paths
point to.

For example, for the project Project01, with +drawings that is C:\production\prod drawings on Windows,
or /Volume/Macintosh HD/production/prod drawings on Macintosh, the project browser will display
the following:

Projects

Project01 +drawings

where +drawings is an alias for C:\production\prod drawings on Windows, or /Volume/Macintosh
HD/production/prod drawings on Macintosh.

If the option Append $scenepath is activated, and you save the scene scene01 in +scenes\seq01 , the project
browser will display the following:

Projects

Project01

+drawings

seq01 scene01

If the $scenepath is used in the folder definition, with +drawings that is C:\$scenepath\prod drawings
on Windows, or /Volume/Macintosh HD/$scenepath/prod drawings on Macintosh, and you save the
scene scene01 in +scenes\seq01 , the project browser will display the following:

Projects

Project01

+scenes

scene01.tnz +drawings

with +drawings that is C:\seq01\scene01\prod drawings on Windows, or /Volume/Macintosh HD/
seq01/scene01/prod drawings on Macintosh, and is located under the related scene file (TNZ format).

If the $scenepath is used in the folder definition, with +drawings that is C:\prod drawings\$scenepath
on Windows, or /Volume/Macintosh HD/prod drawings/$scenepath on Macintosh, and you save the
scene scene01 in +scenes\seq01 , the project browser will display the same as above, but this time +drawings
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is C:\prod drawings\seq01\scene01 on Windows, or /Volume/Macintosh HD/prod drawings/
seq01/scene01 on Macintosh.
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CHAPTER 7

Setting Up a Scene

7.1 Scene Settings and Project Default Settings

When you start working on a scene, automatically it will belong to the current project, inheriting its settings and default
folders. In this way all the scenes belonging to a project are created with the same settings, assuring the consistency
of the production (see Managing Projects ).

Settings concern different tasks you may perform in OpenToonz, such as the scanning, or cleanup process, the camera
size and resolution, the frame rate, the output options, etc. They can be accessed in dialogs you can open with
commands available in the related menu; for example the scan and cleanup settings commands are available in the
Scan & Cleanup menu.

Settings for a particular scene can always be changed independently from the other ones, and will be automatically
saved when the scene is saved.

If you want to change the default values you can save current scene settings as default, so that all new scenes created
for that project will have those values.

Tip: To save current scene settings as project default settings:

Select File → Project Management → Save Default Settings: all the settings from the current scene will become the
project default.

7.2 Choosing the Working Unit

Positions, distances and sizes can be expressed in several units of measure: inches, millimeters, centimeters, fields and
pixels.

The field unit is equal to 1/2 inch on the horizontal dimension, and it depends on the A/R set in the field guide
information of the Scene Settings. . . dialog on the vertical dimension (see Using the Viewer ). For example if the
A/R value is 1.77778, two horizontal fields are equal to an inch, while one vertical field equals to an inch divided by
1.77778.
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In the Files → Preferences. . . → Interface dialog you can set the following default units:

• The Unit is used to display all measures in text fields, and applied when moving or changing the size of stage
objects.

• The Camera Unit is used to display and define the camera size in the Xsheet → Camera Settings. . . dialog (see
Defining Camera Settings ).

You can also express values in an unit different from the default one by entering any of the following units and
abbreviations: in, inch, ” , ‘ ‘ (two apostrophes), cm, mm, fld, field and px, after the input value itself. As soon as the
value is entered it’s converted in the default unit.

If a value without a specific unit is used, it is supposed to be expressed in the default unit.

Tip: To set the default working units:

1. Choose File → Preferences. . . → Interface.

2. Do one of the following:

• In the Unit option menu choose the unit you want to use as default.

• In the Camera Unit option menu choose the unit you want to use to express the camera size.

7.3 Setting the Frame Rate

The frame rate is the number of frames per second of animation, and has to be set according to the type of output you
have to render, for instance it should usually be 24 for cinematic production, 25 for PAL output, or 30 for NTSC.

The current scene frame rate can be set in the Scene Settings. . . dialog, and it is displayed in the bottom bar of any
Viewer pane. In case the play back is activated, the actual frame rate is displayed on its left.

Apart from affecting the playback speed when previewing or rendering a scene, the frame rate also determines the
frame count of an audio file when it is imported into the Xsheet (see Creating a Soundtrack ).
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Even if a scene has been composited with a specific frame rate for a certain output, it is possible to render it out at
a different frame rate by using the Stretch from FPS: To: option in the Output Settings. . . → More Settings dialog
section (see Choosing the Output Settings ).

Tip: To set the frame rate:

1. Choose Xsheet → Scene Settings. . . → More.

2. In the Frame Rate text field set the frame rate value.

7.4 Defining Camera Settings

The Current Camera Settings dialog, that can be opened from the Xsheet menu, contains parameters for defining the
current camera frame size and resolution.

More than one camera can be defined for each scene, in order to have different output resolutions, or to shot only a
particular area of the scene (see Using the Stage Schematic ).

The camera frame size can be expressed in any unit, but will be visualized in the default one chosen in the Prefer-
ences. . . → Interface dialog (see Choosing the Working Unit ).

In OpenToonz the Camera is defined by different parameters:

• X (Width) and Y (Height) frame size of the camera, expressed in the default Camera Unit (usually inches).

• A/R is the aspect ratio value resulting by dividing Width/Height.
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• X and Y resolution Pixels of the resulting image frame seen by the camera.

• X and Y DPI values, calculated using the standard formulas: XDpi=XPx/Width, and YDpi=YPx/Height. This
two fields can be forced to have the same value, by activating the equal-sign button between them.

When inserting a value in one field, the others change accordingly as needed for having a consistent camera. You can
decide which set of values has to be considered fixed by OpenToonz. The lock-shaped buttons and the radio buttons
at the leftmost column of the camera parameters, let you select which column and row of values has to be preserved
by OpenToonz, while changing the others as needed.

The Use Current Level Settings button let you set the camera for framing exactly the content of the selected level.
Just press this button and OpenToonz will calculate the appropriate values for the camera.

Camera resolutions can also be selected from a list of predefined camera settings. You can add any camera preset you
define to the list, as well as remove any predefined camera from it.

Note: The predefined cameras list is saved in the file reslist.txt stored in the projectroot (see Setting the
Projectroot ).

Tip: To add a preset camera resolution:

1. Set the resolution and A/R for the camera you want to save.

2. Click the Add button on the right of the preset cameras list.

3. Assign a name to the camera resolution and click the OK button.

Tip: To remove a preset camera resolution:

1. Select the camera resolution you want to remove in the preset cameras list.

2. Click the Remove button on the right of the preset cameras list.

7.5 Color Calibration using Look-up Tables

OpenToonz can manage the previsualization of color through the use of 3D Look-up Tables. By applying a 3D LUT
file, properly configured for the current display monitor, it will be possible to work on different color spaces, such as
Rec. 709, DCI-P3 or Rec. 2020.
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Once a 3DLUT is active, all colors displayed on Viewer, Combo Viewer, Flipbook, Color Model, Palette, and Style
Editor will be corrected.

Note: Currently, only the .3dl file format is supported. It must follow specification written here.

Note: Currently, only the Windows version of OpenToonz can detect the currently connected monitor. For other
platforms only one 3D LUT file can be applied for any type of monitors. (Even on Windows, connecting multiple
different monitors at the same time is not supported for now. It will only identify the first registered monitor).

Note: PLEASE NOTE: At the moment, using Plastic deformation together with this feature causes a display issue
such that the deformed image is not shown in Camera Stand mode of the Viewer.

Tip: To apply a 3DLUT file for previsualizing color:

1. Choose File → Preferences. . . → Interface.

2. Activate the Color Calibration using 3D Look-up Table option.

3. In the 3DLUT File for [monitor]: option, press the file browser button to navigate and select the desired .3DL
file.

4. Restart OpenToonz for the changes to take effect.

7.6 Assigning Memory for the Undo Operations

All the operations performed in the software can be undone by using the Edit → Undo command, even to go back for
several steps.

Undo operations require computer memory in order to be performed, and some of them may require more memory
than some others, according to their complexity.

To prevent most of the computer memory to be used by undo operations while you work, a situation that slows down
the software performance, it is possible to set a limit for it by specifying the Undo Memory Size (MB) in the Files →
Preferences. . . → General dialog.

As soon as the limit is reached, the oldest undo operations will be discarded to make room for the new ones.

7.7 Optimizing the Memory Usage

When working with Raster images, predominantly being animation levels scanned with OpenToonz or GTS, an exten-
sive usage of computer memory may be required during the cleanup, painting and rendering processes.

After a certain amount of time the computer performance may worsen, as the memory gets fragmented because of the
several writing and reading accesses. To prevent this behavior, the Minimize Raster Memory Fragmentation* option
can be activated in the Files → Preferences. . . → General dialog. When activated, a section of computer memory is
reserved and used only for operations concerning Raster images.

If you are working mainly with vector images, that have been drawn inside OpenToonz, this option should be deacti-
vated, as the reserved memory section would be otherwise unused by the computer.
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Note: The change set for this option is valid only after OpenToonz is restarted.
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Scanning Paper Drawings

Note: Currently OpenToonz DOES NOT SUPPORT the native scanning functionality, as described in this page.
Instead you can use the provided GTS scanning and cleaning software, please follow this link to download GTS .

Note: This manual page is preserved in its original form, in case the scanning code of OpenToonz is reactivated in a
future version.

In order to be managed by OpenToonz, paper drawings have to be scanned into OpenToonz. Paper drawings can be
both animation levels, consisting of a large number of sequenced drawings, and other elements such as backgrounds
and overlays.

The scan process can be done in different modes, and in case autocenter is needed it has to follow specific guidelines.

Animation levels have to be defined first and then scanned according to a defined set of parameters.

8.1 Supported Scanners

OpenToonz supports directly, by using internal drivers, some specific scanners via a USB connection; all the other
scanners are supported via any type of connection by using TWAIN drivers.
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Note: For an updated list of directly supported scanners, please visit the OpenToonz Web site .

If your scanner is supported via internal drivers, the scanning process is managed completely by OpenToonz and the
Scan Settings dialog; if it is not, the scanning process is managed by the TWAIN interface.

On Windows, the TWAIN drivers provided with the scanner need to be installed. Note that if you decide to use internal
drivers, you have to disable the Windows Image Acquisition (WIA) service on your computer; if you want to use
TWAIN drivers, you have to enable it.

On macOS, you need to install the TWAIN drivers only if you are going to use them. Note that if you decide to use
internal drivers, any TWAIN driver referring to that scanner has to be removed.

The driver you want to use must be selected according to your scanner before starting the scanning process. You can
choose whether to use the internal or TWAIN drivers; in the latter case, you have to select which driver to use from a
list based on the TWAIN drivers installed on your computer.

Note: When using TWAIN drivers you need to specify the driver every time you restart OpenToonz: the dialog box
is automatically displayed when you select any Scan related command.

Tip: To install TWAIN drivers:

Refer to the scanner documentation for more details.

Tip: Windows only - To disable or enable the Windows Image Acquisition (WIA) service:

1. Open the Control Panel → Administrative Tools → Services dialog.

2. Right-click the Windows Image Acquisition (WIA) service and choose Properties from the menu that opens.

3. In the Properties dialog do one of the following:

• Set the Startup Type option to Disabled to use internal drivers.

• Set the Startup Type option to Automatic to use TWAIN drivers.

4. Restart the computer.

Tip: Macintosh only - To remove the scanner TWAIN drivers:

Refer to the scanner documentation for more details.
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Tip: To define the scanner:

1. Choose Scan & Cleanup → Define Scanner. . . .

2. Do one of the following:

• If your scanner is directly supported, choose Scanner Driver → Internal, and click the OK button.

• If your scanner is not directly supported, be sure that TWAIN drivers are installed, and choose Scanner Driver
→ TWAIN, and click the OK button: in the dialog that opens, select the TWAIN driver related to your scanner.

8.2 Scanning Modes

Drawings can be scanned mainly in three different modes: black and white, greyscale and color.

The first two modes can be used to acquire standard lineart drawings whose outline is usually made in a single color,
that during the scanning is acquired as black or dark grey. Even if the outline color is lost during the scanning, later on
you can assign one or more colors to it during the painting process.

Black and white scanning gives you the most immediate results, and fewer parameters need to be set. Once a
Threshold: value is set, pixels of the scanned image are considered as either black or white. Due to the simplicity
of this concept, less time is required to scan the image, and scanned files are lighter to manage. Even if images show
hard edges, the proper antialiasing will be added during the cleanup process.

Greyscale scanning, being based on a range of grey values, requires a longer scanning time. Determining Brightness:
and Contrast: parameters depends considerably on the individual animated sequence and on what you want to achieve.
The greyscale mode also offers Autoadjust options during the cleanup process, useful to even the differences between
drawings made by key animators and those made by in-betweeners. See Autoadjusting Greyscale Lineart Drawings .

Color scanning is for scanning colored lineart and other colored images as backgrounds and overlays. Using colors
in lineart allows you to draw different lines with different colors, for example a character outline in black and its body
shadow in red or in blue. As colored lines can be identified later during the cleanup process, scanning colored artwork
in colors allows you to preserve different line colors with no need of intensive painting work. See Processing Colored
Lineart Drawings .

8.3 Scanning Guidelines for Autocentering

To autocenter scanned drawings during the cleanup process, the pegbar holes need to be detected on the images (see
Autocentering ). For this reason they have to be scanned in black, by properly preparing the scanner and performing
the scanning process according to the following guidelines.

8.3.1 Preparing Scanners

• If you use the scanner automatic paper feeder, you should stick a piece of thin black tape in the feeder on the
opposite side of the scanner lamp. Be sure to stick the black tape in a position to face the peg holes when the
paper is fed into the scanner.

• If you use the scanner bed, you should place a black sheet of paper under the scanner cover, so that when a
drawing is scanned facing down the glass of the scanner bed, the black paper will be behind it. The black paper
must be larger than your animation paper, but it does not have to cover the entire scanner bed.
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8.3.2 Scanning Artwork

• It is better to use quite thick animation paper for your artwork: very thin paper may jam the scanner, and the
scanner light may pass through picking up some grey from the black paper or tape placed behind it. When this
happens, the process will take longer to perform and will produce a poor quality result.

• Avoid using black or colored paper reinforcements around the pegbar holes in your drawing sheets. The scanner
has to read the exact shape of the hole punches, and colored reinforcements may cause holes to be scanned
larger than their actual size. If you do use white reinforcements, make sure they are aligned directly over the
peg holes: if the holes are slightly covered by the reinforcement, the registration may fail.

• Do not draw too close to the pegbar holes. Avoid drawing anything with the same shape or area of the pegbar
hole in the pegbar holes area; leave at least 1 cm (~1/2”) of clear space between the pegbar holes and the rest of
your drawings. Lines drawn near the pegbar holes may cause the registration to fail.

8.4 Defining Animation Levels to Scan

To scan an animation level, first you have to define its name, the number of frames it is made of, and the way its
drawings are numbered. Its size and resolution will be set during the scanning session.

The definition can be made drawing by drawing directly in the Xsheet/Timeline, or at once by using the New Level
dialog. You can assign it the name and the numbering order you prefer.

In case you use the New Level dialog you can set the number of drawings the level is made of, the animation step
to expose the level repeating its frames, and the increment, that sets the way the level drawings are numbered. For
example a Step: value 2 repeats each drawing twice in the Xsheet column (or Timeline layer), while an Increment:
value 2 numbers the drawings 1, 3, 5, etc.
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By default scanned drawings are saved in the +inputs directory of the current project; if the +inputs definition uses
the $scenepath variable, they are saved only if the scene is saved (see Project Default Folders ).

You can change the location by using either the Path: field in the New Level dialog, or the Level Settings window in
case you define a level directly in Xsheet/Timeline.

Settings such as the length of the level and the numbering order can be edited later, as you are free to arrange the
images composing your animation level the way you prefer (see Editing Animation Levels ).

When an animation level is defined, the name and numbers for the drawings of the level are displayed in red as no
level actually exists yet; the column/layer cells where the level is exposed are colored in light blue, the color denoting
full-color images (see Working with Columns/Layers ).

Tip: To define an animation level directly in Xsheet:

1. Double-click a cell, then type a name and a number; the name and the number must be separated by a space.

2. Press Enter to add a new drawing, and type a different number that will be assigned to the new drawing.

3. Go on adding all the drawings you need.

4. Click a different cell to end the process.

Tip: To define an animation level with the New Level dialog:

1. Do one of the following:

• Select a cell in the Xsheet/Timeline where you want to place your animation level to scan and choose Level →
New → New Level. . .

• Right-click the cell in the Xsheet/Timeline where you want to place your animation level to scan and choose
New Level from the menu that opens.

Note: If any level is already exposed in the cell column/layer, it will shift down/right from the cell you selected on.

2. In the New Level dialog choose Scan Level from the Type: option menu and define its settings, then click the
OK button.

Tip: To define the saving location for the level to be scanned:

Do one of the following:

• If you are using the New Level dialog, type in the Path: field, or use the browser button, to set the path for the
saving location.

• If you are defining the level directly in Xsheet/Timeline, right-click the level cells and select Level Settings
from the menu that opens. In the Level Settings window, type in the Path: field, or use the browser button, to
set the path for the saving location.

Note: If in the browser you choose any project default folder, in the Path: field the full path will be replace by the
related default folder alias (see Project Default Folders ).
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8.5 Scanning Drawings

According to the driver you are using, internal or TWAIN, the scanning process will be controlled either by the Scan
Settings dialog or the TWAIN interface.

The Scan Settings dialog allows you to define the following:

• Paper Format sets the size for the drawings to be scanned. The option menu contains a list of already defined
formats.

• Reverse Order makes the scanning process in a reverse order, starting from the last selected frame to the first
one.

• Paper Feeder lets the scanner use the automatic document feeder, in case the scanner has one, to scan all the
selected drawings without having to insert one image at a time into the scanner.

• Mode is for setting the scanning mode among: Black and White, Greyscale and Color.

The TWAIN interface is related to the scanner you are using and will be available only when the TWAIN drivers,
provided with the scanner, are installed on your computer. Refer to the scanner documentation for more details.

Note: The Scan Settings dialog can be used in combination with the TWAIN interface settings to set the Reverse
Order option.

The settings, either defined in the Scan Settings dialog or in the TWAIN interface, will be used to scan the drawings
selected in the Xsheet/Timeline. In case you select several drawings, and you are using the scanner paper feeder, all
the drawings to be scanned will be taken from the feeder; if you are not using the paper feeder, you will be prompted
to replace the drawing on the scanner bed, before scanning the following drawing.

You can also select non-consecutive drawings and drawings from different animation levels. Levels will be scanned
starting from the first selected column/layer. Only exposed drawings will be scanned according the level numbering
order, regardless of the way the animation level is exposed in one or several Xsheet columns (or Timeline layers). The
opposite order will be followed if the Reverse Order option is on.

As soon as a drawing is scanned, it is saved and its name and number displayed in the Xsheet/Timeline turn black, as
the level now has physical drawings saved on disk.

Images are saved as compressed TIF files with a progressive four-digits number written between the file name and the
file extension, e.g. animation.0001.tif , animation.0002.tif , etc. They are displayed in the OpenToonz
browser with a double dot before the file extension, e.g. animation..tif .
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If you need to scan again an animation level, or a part of it, select the relevant drawings and scan them again. Drawings
can be also inserted by editing the level sequence (see Renumbering and Adding Frames in a Level ).

Tip: To scan an animation level:

1. In the Xsheet/Timeline, select the drawings you want to scan.

2. Choose Scan & Cleanup → Scan Settings. . . and use the dialog to control scan options.

3. Do one of the following:

• If you are using the internal drivers, choose Scan & Cleanup → Scan: the selected drawings will be scanned
and automatically saved.

• If you are using the TWAIN drivers, choose Scan & Cleanup → Scan, and guide the scanning process by using
the TWAIN interface that opens: the selected drawings will be scanned and automatically saved.

4. In case you selected several drawings, do one of the following:

• If you are using the scanner paper feeder, wait for all of the drawings to be scanned.

• If you are not using the paper feeder, you will be prompted to replace the drawing on the scanner bed, before
scanning the following drawing.

Note: After a drawing is scanned, or several drawings are scanned at once by using the paper feeder, in some TWAIN
interfaces you may need to use a specific command (such as Back to Application) to return to OpenToonz before
proceeding with the next scanning session. Refer to the scanner documentation for more details.

8.5.1 Setting the Cropbox

When using directly supported scanners it is possible to define a cropbox smaller than the paper format to optimize
the scanning process. When the cropbox is set the final scanned image will be the size of the selected paper format,
but only the area defined by the cropbox is actually scanned, thus speeding up the scanning operations.

Once defined the cropbox will be used for any scanning performed for the scene.

Note: The cropbox size information is not saved along with the scene file; it is also automatically reset when working
on a new scene.

Tip: To define the scanning cropbox:

1. Choose Scan & Cleanup → Set Cropbox: the drawing currently placed in the scanner is scanned and the
cropbox is displayed in red.

2. Use the handles along the cropbox to set its size, and click and drag anywhere to change its position.

Note: The cropbox default size is the same as the size of the scanned image.

Note: The cropbox cannot be moved outside the area of the scanned image.
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Tip: To use the defined cropbox when scanning:

Scan drawings after defining the cropbox size (see above ).

Tip: To dismiss the scanning cropbox visualization:

Choose Scan & Cleanup → Set Cropbox.

Tip: To reset the scanning cropbox:

Choose Scan & Cleanup → Reset Cropbox.
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Cleaning-up Scanned Drawings

In order to be painted and edited with OpenToonz, scanned drawings have to undergo the cleanup process. The process
involves autocentering, to align each drawing according to the pegbar holes; line processing, to recognize the drawing
outline; image cropping and re-sizing, to make the drawings fit properly the camera.

The process generates a Toonz raster level (TLV format) and the related default palette (TPL format), where the styles
used to paint the level will be stored.

Note: If the computer performance slows down during the cleanup process of very high resolution images, try
activating the Minimize Raster Memory Fragmentation option in the Files → Preferences. . . → General dialog
(see Optimizing the Memory Usage ).

89



OpenToonz Documentation, Release 1.7.1

90 Chapter 9. Cleaning-up Scanned Drawings



OpenToonz Documentation, Release 1.7.1

9.1 The Cleanup Settings
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The cleanup process can be controlled by using the Cleanup Settings that include Cleanup, Processing and Camera
parameters.

Usually settings are defined and checked for one of the level drawings, then applied to the whole animation level. If
all of the drawings in the scene have the same characteristics, it is very likely that the same settings can be used for
every drawing throughout all of the animation levels.

Tip: To define cleanup settings:

Choose Scan & Cleanup → Cleanup Settings. . . and use the dialog to control the cleanup process parameters and
options.

9.1.1 Defining Cleanup Parameters

The Cleanup parameters set the autocentering information and some geometric transformations.

Autocentering

The Autocenter option aligns lineart drawings and full-color images according to the shape and position of the pegbar
holes, in order to set the correct registration for them, once they are used in an animation scene.

Pegbar holes have to be included properly during the scanning process in order to be recognized during the process
(see Scanning Guidelines for Autocentering ).

In case the autocenter fails because it’s not possible to recognize properly the pegbar holes, an error message is
displayed; yet the drawings and images are processed according to the other set parameters.

Autocenter parameters are the following:

• Autocenter, when activated, triggers the autocenter process.

• Pegbar Holes, sets the side of the drawing along which holes should be detected.

• Field Guide, specifies the size of the reference field guide that has to be used to set the center of the processed
drawings and images, and the type of pegbar holes that have to be detected (such as Acme or Oxbry).

Tip: To check the autocenter on a selected drawing:

1. Activate the Autocenter option.

2. Set the side where Pegbar Holes have to be detected.

3. Set the Field Guide to be used as reference to set the center in the correct place, and to match the shape of the
pegbar holes.

4. Choose Scan & Cleanup → Preview Cleanup to preview the process in the Viewer.
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Other Cleanup Parameters

The Cleanup pane contains also other parameters that can be activated regardless of the autocenter, as they will affect
processed images even if the Autocenter option is not activated. Parameters are the following:

• Rotate, rotates the image by 90° steps clockwise. It can be used to set the right orientation for images scanned
with a different direction in order to fit the scanner bed.

• Flip, mirrors the image horizontally, vertically or both, according to the activated options. It can be used, for
example, when processing a shadow level drawn on the other side of the paper where the character level is
drawn, in order to match the two animation levels later.

• Save In, lets you define the folder where the cleaned up drawings are saved. By default it is set to the +drawings
default folder of the current project (see Project Default Folders ).

9.1.2 Defining Line Processing Parameters

The Processing parameters set the line processing options in order to prepare drawings for the painting process, rec-
ognizing black lines (in black and white or grayscale lineart drawings), or colored lines (in colored lineart drawings).

Tip: To set the type of line processing:

Set the Line Processing option to None, if no line processing is required, Greyscale, if lines have to be recognized as
black, or Color, if lines have to be recognized as colored ones.
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Processing Black and White or Greyscale Lineart Drawings

For black and white or greyscale lineart drawings, a set of parameters are available to calibrate the black line recogni-
tion process.

The result of the process can be previewed in the OpenToonz main Viewer (see Previewing the Cleanup Process ).

Parameters are the following:

• Antialias:, can be set to Standard, None or Morphological. Use Standard to keep the antialias resulting from
current camera and defined settings. Use None to eliminate the antialiasing from the processed line, so that the
resulting line will be fully solid with no semi-transparent pixels that smooths its edges. Use Morphological to
replace the standard antialias with one obtained by analyzing the image edges.

• Autoadjust, corrects the levels of grey in the drawings in order to avoid darker and lighter drawings in a se-
quence (see Autoadjusting Greyscale Lineart Drawings ). (NOTE: This feature is currently not available in
OpenToonz).

• Sharpness:, defines how sharp the processed lines will be. Higher values produce sharper, harder lines, and
lower values create smoother lines.

• Despeckling:, removes small spots or marks from the processed images. Its value expresses the size in pixels
of the side of the maximum area that has to be removed. The spots and marks removed by this option can also
be checked by activating the Opacity Check (see Using the Opacity Check ).
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• MLAA Intensity:, sets the intensity of the morphological antialias. The higher the value the more blurred the
line. (It is available only when Morphological is selected).

• Brightness:, controls the thickness of the recognized line: the lower the value, the thicker the line.

• Contrast:, controls the antialiasing of the recognized line: a higher value produces more solid pixels, a lower
value lines with more antialiased pixels. The amount of antialiasing can also be checked by activating the
Opacity Check (see Using the Opacity Check ).

Note: If the Antialias is set on None or Morphological, the Contrast: parameter will become deactivated.

Tip: To set the line processing for black and white or greyscale lineart drawings:

1. Activate the Line Processing → Greyscale option.

2. Define the parameters according to your needs.

3. Preview the result of the cleanup process (see Previewing the Cleanup Process ).

Autoadjusting Greyscale Lineart Drawings

Note: The Autoadjust clean-up options explained here are currently unavailable in OpenToonz. There is no certainty
about its reinclusion at a later version or not. If you judge them to be useful for your workflow, you could file an Issue
about that in the OpenToonz’ GitHub repository or in the various OpenToonz forums.

The Autoadjust option available among the Cleanup parameters allows you to even the differences between drawings
made by key animators and those made by in-betweeners by adjusting the line darkness of all of the level drawings.

Note: The Autoadjust option has effect only on drawings scanned in greyscale mode, while it has no effect on
drawings scanned in black and white.

Three different autoadjust algorithms are available:

• Black Eq, computes the average of the darkest grey tone found in drawing lines below a certain threshold and
sets this value to the conventional black level, so that grey levels of each image are automatically adjusted.

• Histogram, makes a histogram of the grey levels of the first image and equalizes the histograms of the following
images according to it. It works well when the content of the images (apart from line darkness) does not vary
too much across the level.

• Histo-L, takes into account the number of lines in each image to normalize the histogram of grey levels, before
the histogram equalization is performed. This is useful for example when a character becomes bigger or smaller
in an animated level, or when parts of the character are animated independently in some frames.

Note: The advantage of the Histo-L mode over the others is that it adjusts the grey levels of each image independently,
while the other algorithms equalize each image to make it look like the first one of the level.

Only the effects of the Black Eq process can be checked using the Scan & Cleanup → Cleanup Preview command;
the effects of Histogram and Histo-L are only visible selecting a sequence of at least two frames (i.e. one as reference
frame and the others to be auto-adjusted) and processing them using the Scan & Cleanup → Cleanup command. You
may need to make a few trials using different algorithms before obtaining the desired results.
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Note: These algorithms work on the area of the drawing specified in the Field text boxes, excluding a 5 mm boundary
edge. In this way any line might be drawn to delimit the camera shot on paper, and the pegbar holes, do not affect the
result.

Processing Colored Lineart Drawings
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For colored lineart drawings, a set of parameters are available to calibrate the line recognition process, and to set which
and how colors have to be detected in the drawings (see Defining Colors for the Color Line Processing ).

For all the cleanup colors you can define a color to be assigned automatically to the lines after the processing, with
no need to paint them. The two colors, the one used for the recognition and the one to be assigned to the recognized
lines, are available at the bottom area of the Style Editor pane.

Different parameters are available for the black color, that usually defines the main outline in lineart drawings, and for
the additional colors, that usually defines special outlines for areas such as shadows and highlights.

The result of the process can be previewed in the OpenToonz main Viewer (see Previewing the Cleanup Process ).

General parameters are the following:

• Antialias:, can be set to Standard, None or Morphological. Use Standard to keep the antialias resulting from
current camera and defined settings. Use None to remove the antialiasing from the processed line, so that the
resulting line will be fully solid with no semi-transparent pixels smoothing its edges. Use Morphological to
replace the standard antialias with the one obtained by analyzing the image edges.

Note: If the Antialias is set to None or Morphological, the Contrast parameter will become desactivated.

• Sharpness:, defines how sharp the processed lines will be. Higher values produce sharper, harder lines, and
lower values create smoother lines.

• Despeckling:, removes small spots or marks from the processed images. Its value expresses the size in pixels
of the side of the maximum area that has to be removed. The spots and marks removed by this option can also
be checked by activating the Opacity Check (see Using the Opacity Check ).

• MLAA Intensity:, sets the intensity of the morphological antialias. The higher the value the more blurred the
line. (It is available only when Morphological is selected).

In the color list, parameters for the black color are the following:

• Brightness:, controls the thickness of the recognized line: the lower the value, the thicker the line.

• Contrast:, controls the antialiasing of the recognized line: a higher value produces more solid pixels, a lower
value lines with more antialiased pixels. The amount of antialiasing can also be checked by activating the
Opacity Check (see Using the Opacity Check ).
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• Color Threshold:, sets pixels that have to be considered as black and those that have to be considered as colors:
the higher the value, the higher the number of pixels that will be considered as colored.

• White Threshold:, sets pixels that have to be considered as white, for example to eliminate the paper color: the
higher the value, the higher the number of pixels that will be considered as white.

In the color list, parameters for the other colors are the following:

• Brightness:, controls the thickness of the recognized colored line: the lower the value, the thicker the line.

• Contrast:, controls the antialiasing of the recognized colored line: a higher value produces more solid pixels, a
lower value lines with more antialiased pixels. The amount of antialiasing can also be checked by activating the
Opacity Check (see Using the Opacity Check ).

• H Range:, sets the range of the hue for color recognition: the higher the value, the higher the number of
differently colored pixels that will be associated to the defined color.

• Line Width:, sets the width of the recognized colored line: the higher the value, the higher the number of
desaturated pixels that will be associated to the defined color, thus increasing the line thickness.

Tip: To set the line processing for colored lineart drawings:

1. Activate the Line Processing → Color option.

2. Define the general parameters according to your needs.

3. Define the colors you want to be detected in the drawings (see Defining Colors for the Color Line Processing ).

4. Define the color parameters according to your needs.

5. Preview the result of the cleanup process (see Previewing the Cleanup Process ).

Defining Colors for the Color Line Processing

The colors used to recognize and process drawing lines when doing color line processing can be defined by using the
style editor or picking color values directly from the drawing you want to process.

It is possible to add colors to the list, or remove them if they are not needed anymore. The maximum number of color
you can define is 7 (black included).

Note: The first color of the list, i.e. the black color, cannot be edited or removed.

Tip: To define colors:

1. Select the color you want to define in the list available in the Processing parameters.

2. Define the color by doing one of the following:

• Use the Style Editor (see Editing Styles ).

• Use the RGB Picker tool ( ) to pick the value of the line color from the drawings visible in the Viewer (see
Plain Colors ).

Tip: To define colors to be assigned to lines after cleanup processing:

1. Select the color for which you want to define the post-process color.
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2. At the bottom of the Style Editor select the square on the right of the current color: this is the color to be assigned
after the processing is done.

3. Edit the color in the Style Editor.

Tip: To add a color in the color list:

Click the + button available under the color list.

Tip: To remove a color from the color list:

1. Select the color you want to remove from the list.

2. Click the - button available under the color list.

9.1.3 Defining Camera

The Camera parameters define the size and resolution of the camera that is used to crop and resize drawings during
the cleanup process, in order to prepare and optimize them for the scene.

For example if the cleanup camera is 1920x1080 pixels (HD 1080) with a 16 field size, the cleaned up drawings will
be cropped according to the 16 field size and will have the resolution of 1920x1080 pixels.

The cleanup camera definition is similar to the definition of the stage camera (see Defining Camera Settings ). Usually
the two cameras have the same parameters, but sometimes you may need to define a cleanup camera that is larger than
the stage camera especially if you want drawings border area to overflow the shot.

You can also set other parameters and options:

• The Closest Field parameter (NOT AVAILABLE in OpenToonz) defines the smallest field size you will zoom
into the drawing, with the camera when compositing the scene. This value is meaningful if it is smaller than
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the camera field size, as it increases the final image resolution, preventing zoomed-in images from appearing
jagged. For example if the cleanup camera is 1920x1080 pixels (HD 1080) with a 16 field size and the Closest
Field is set to 8, the cleaned up drawings will have to be of twice the camera resolution, that is 3840 by 2160
pixels, so that when the camera closes up, the original image pixel resolution is preserved.

• The X and Y offset parameters shift the camera position, in case you want to define for the drawings a center
different from the one automatically set by the reference field guide when the Autocenter is on, or different
from the actual center of the image if the Autocenter is off ; after the cleanup, the camera center will be the new
center for the processed drawings.

The cleanup camera size, resolution and offset can also be graphically controlled in OpenToonz’s main Viewer when
checking the cleanup process with the Camera Test mode (see Using the Camera Test ).

9.1.4 Saving and Loading Cleanup Settings

Cleanup settings can be saved as CLN files in order to be loaded back and used in a different scene.

They can also be associated specifically to an animation level by saving them in the same location and with the same
name of the level: in this way the settings will be automatically displayed when the level is selected, and used every
time the level is cleaned up.

Loaded cleanup settings can also become the default settings for the scene or for the project (see Scene Settings and
Project Default Settings ).

Tip: To save the cleanup settings:

1. Select an empty cell in the Xsheet/Timeline.

2. Click the Save Settings button in the bottom bar of the Cleanup Settings window.

3. In the browser that opens choose for the CLN file a location and name, and click the Save button.

Tip: To load saved cleanup settings:

1. Select an empty cell in the Xsheet/Timeline.

2. Click the Load Settings button in the bottom bar of the Cleanup Settings window.

3. In the browser that opens retrieve the CLN file you want to load, and click the Load button.

Tip: To save the current cleanup settings for a specific level:

1. Select any cell where the level is exposed in the Xsheet/Timeline.

2. Click the Save Settings button in the bottom bar of the Cleanup Settings window.

3. In the browser that opens save the CLN file in the same location and with the same name as the level, and click
the Save button.

Tip: To load cleanup settings for a specific level:
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1. Select any cell where the level is exposed in the Xsheet/Timeline.

2. Click the Load Settings button in the bottom bar of the Cleanup Settings window.

3. In the browser that opens retrieve the CLN file you want to load, and click the Load button.

4. Click the Save Settings button and in the browser that opens save the CLN file in the same location and with
the same name as the level, and click the Save button.

Tip: To reset cleanup settings to the scene default:

Click the Reset Settings button in the bottom bar of the Cleanup Settings window.

9.2 Checking the Cleanup Process

While defining the cleanup settings it is possible to preview the full cleanup process, or perform the camera test only,
in order to check the result before performing the final cleanup.

9.2.1 Previewing the Cleanup Process

The full cleanup process can be checked in the main Viewer.

Previewing the Cleanup Process in the Main Viewer

A cleanup preview can be activated in the main viewer to display the drawing selected in the Xsheet/Timeline as it will
be after the real cleanup process according to the defined cleanup settings, displaying at the same time all the other
drawings and images exposed in the Xsheet/Timeline at that frame.

If you change any parameter in the cleanup settings, the preview automatically updates to display how the changes
affect the process.

Note: The Opacity Check when activated, affects also the cleanup preview in the main Viewer (see below ).

Note: The Preview Cleanup and the Camera Test checks cannot be activated at the same time: when one is activated
the other one is automatically deactivated.

Tip: To activate the cleanup preview in the main Viewer:

In the Xsheet/Timeline select the scanned drawing you want to preview, and choose Scan & Cleanup → Preview
Cleanup.

Tip: To deactivate the cleanup preview in the main Viewer:

Choose Scan & Cleanup → Preview Cleanup.
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Tip: To preview a different drawing:

Select it in the Xsheet/Timeline.

Tip: To exit the preview cleanup mode:

Choose Scan & Cleanup → Preview Cleanup to deactivate it.

Using the Opacity Check

When calibrating the line processing it is important to check the amount of antialiasing along the drawing outline to
understand how smooth the result will be, and to check the small spots and marks that are removed from the drawing
because of the Despeckling: function (see Defining Line Processing Parameters ).

The Opacity check, when activated, displays fully solid pixels in black, and semi-transparent pixels belonging to the
line antialiasing in red; moreover pixels that will be removed because of the Despeckling: function are displayed in
green.

The check is visible both in the preview area (NOT AVAILABLE in OpenToonz) of the Cleanup Settings pane, and
with the Preview Cleanup mode, in the main Viewer.

Tip: To activate and deactivate the opacity check:

Choose Scan & Cleanup → Opacity Check or press its default shortcut Alt + 1.

9.2.2 Using the Camera Test

The Camera Test can be used to check the cleanup process as concerning the Cleanup and the Camera parameters.
It displays the drawing selected in the Xsheet/Timeline directly in the Viewer without line processing but with the
position modified according to the Cleanup parameters (Autocenter, Rotate and Flip), and the size modified according
to the Camera parameters. In particular a red box displays how the cleanup camera will crop the drawing, and a blue
box displays the camera Closest Field.

It is possible to modify the camera box directly in the Viewer thus updating the cleanup camera information visible in
the Cleanup Settings dialog (see Defining Camera ).

If you change any of the Cleanup or Camera parameters, the camera test automatically updates to display how the
changes affect the process.

Note: The Preview Cleanup and the Camera Test checks cannot be activated at the same time: when one is activated
the other one is automatically deactivated.

Tip: To activate the camera test:

In the Xsheet/Timeline select the drawing you want to preview, and choose Scan & Cleanup → Camera Test.

Tip: To deactivate the camera test:
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Choose Scan & Cleanup → Camera Test.

Tip: To modify the cleanup camera directly in the Viewer:

Do any of the following:

• Operate the handles on the top and right edges to scale the camera size horizontally or vertically, thus changing
the camera A/R as well.

• Operate the handle on the top right corner to scale the camera size while keeping the A/R.

• Activate the DPI Lock in the cleanup camera parameters, and operate the handles to scale also the camera
resolution (NOT AVAILABLE in OpenToonz).

• Move the camera box to modify the cleanup camera X and Y offset.

Tip: To perform the camera test on a different drawing:

Select it in the Xsheet/Timeline.

Tip: To exit the camera test mode:

Choose Scan & Cleanup → Camera Test to deactivate it.

9.3 Cleaning up Drawings

Once the cleanup settings are defined and the process is checked, it is possible to cleanup all of the drawings of the
scene, or a selection of them.

Drawings can be processed directly inside the scene after performing a selection, or they can be processed automati-
cally in batch mode.

In both cases they will be cleaned up according to the Cleanup Settings defined for the scene, unless a specific CLN
file was saved for any of the animation levels in the scene.

By default cleaned up drawings are saved in the +drawings directory of the current project (see Project Default Folders
), but you can change the location by using the Save In option available in the cleanup settings dialog.

Cleaned up animation levels are saved as TLV files; the related palettes are saved in the same location and with the
same name of the animation levels as TPL files.

It is also possible to automatically create a backup copy of the cleaned up drawings that will be stored in a subfolder
named nopaint inside the same location where the cleaned up drawings are saved. In this way it will be possible to
retrieve the original drawing in case some mistakes (e.g. a deletion of a drawing section) are made during the painting
process.

Tip: To automatically create a backup copy of the cleaned up drawings:

1. Choose File → Preferences. . . → Drawing.

2. Activate the Keep Original Cleaned Up Drawings As Backup option.
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Tip: To revert to the original cleaned up drawings:

1. In the Level Strip select the drawings you want to revert (see Using the Level Strip ).

2. Do one of the following:

• Choose Level → Revert to Cleaned Up.

• Right click the selection and choose Replace level → Revert to Cleaned Up from the menu that opens.

9.3.1 Cleaning up Drawings Directly in the Scene

When cleaning up drawings directly in the scene it is possible to perform a selection of drawings and process them
with the current cleanup settings. In this case you can also manage the process frame by frame, as you are prompted
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to choose an action for each drawing of the selection.

You can also select non-consecutive drawings and drawings from different animation levels. Levels will be processed
starting from the first selected column/layer, considering only exposed drawings according to their numbering order.

When a drawing is cleaned up, its cell color turns from light blue to green, the color denoting Toonz raster levels (see
Working with Xsheet Columns ). If you cleanup partially an animation level, the remaining cells where the level is
exposed will have a double color (green and blue), to stress the fact that the level is partially processed.

When drawings belonging to partially processed levels are selected to be cleaned up, you are prompted whether to
cleanup selected drawings overwriting the previous cleaned up version, or to add non-cleaned up frames to the existing
level, or to delete the existing level and create a new level with the selected drawings only.

If you want you can also revert to the scanned version of the level you cleaned up by using the Level Settings dialog
(see Editing Level Settings ).

Note: If you want to create a new TLV level from an already cleaned up level you can selet it and run the cleanup
again. A questions pop up will appear and giving you the possibility to set a different name for the new TLV level by
adding a suffix.

Tip: To process the selection according to the chosen settings:

1. In the Xsheet/Timeline select the drawings you want to process.

2. Choose Scan & Cleanup → Cleanup.

3. In the Cleanup dialog for each drawing choose one of the following:

• Cleanup: the current drawing will be cleaned up.

• Skip: the current drawing will not be cleanup up and the dialog displays the next drawing.

• Cleanup All: all the selected drawings will be cleaned up without further prompts.

• Cancel: the cleanup process will be interrupted.

Tip: To revert to the scanned version of a cleaned up level:

1. Select any drawing of the cleaned up level.

2. Choose Level → Level Settings. . .

3. Copy the Scan Path: information, and paste it in the Path: text field.

9.3.2 Cleaning up Drawings in Batch Mode

The cleanup of drawings exposed in a scene can be added to a task list and performed in batch mode in order to run it
in the background while you perform other work on your computer.

Cleanup tasks can be submitted from the OpenToonz browser and can be managed and executed in the Tasks pane,
together with render tasks (see for Rendering Scenes in Batch Mode).
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The Tasks pane is divided into two sections: on the left there is the task tree where all of the cleanup tasks are
displayed with a brush icon and all of the render tasks with a clapboard icon; on the right there is information about
the task selected in the tree.

The Task list can be saved as TNZBAT files and loaded back later in case you want to manage it through different
working sessions.

Tip: To save a task list:

1. Do one of the following:

• Click the Save Task List ( ) or the Save Task List As button ( ) in the bottom bar of the Tasks pane.

• Right-click the Tasks item at the top of the list and choose Save Task List or the Save Task List As from the
menu that opens.

2. Use the browser that opens to save the list.
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Tip: To load a task list:

1. Do one of the following:

• Click the Load Task List button ( ) in the bottom bar of the Tasks pane.

• Right-click the Tasks item at the top of the list and choose Load Task List from the menu that opens.

2. Use the browser that opens to retrieve and load a previously saved list.

Tip: To resize the tasks pane sections:

Do any of the following:

• Click and drag the separator to resize sections.

• Click and drag the separator toward the window border to hide a section.

• Click and drag the separator collapsed to the window border toward the window center to display again the
hidden section.

9.3.3 Managing and Executing Cleanup Tasks

When a cleanup task is selected in the tree, in the section on the right of the Tasks pane task-related properties are
displayed, some of which can be edited to configure the task. Properties are the following:

• Name:, displays the tasks name; it can be edited to better identify the task.

• Status:, displays if the task is waiting, running, completed or failed.

• Command Line:, displays the command line related to the task execution with arguments and qualifiers.

• Server:, displays the computer that is running, or will run, the task.

• Submitted By:, displays the user that submitted the task.

• Submitted On:, displays the computer from where the task was submitted.

• Submission Date:, displays when the task was submitted.

• Start Date:, displays when the execution of the task started.

• Completion Date:, displays when the execution of the task was completed.

• Duration:, displays how long the execution lasted.

• Step Count:, displays the number of frames rendered.

• Failed Steps:, displays the number of frames that failed to be rendered.

• Successful Steps:, displays the number of frames successfully rendered.

• Priority:, sets the importance or urgency of the task: tasks with a higher priority will be executed first. This can
be edited to change the priority of a task.

• Visible Only, when activated, limits the cleanup process only to columns whose camera stand toggle ( ) is
on, that is to say whose content is visible (see Working with Xsheet Columns).

• Overwrite, when activated, processes levels even if they are already available in the destination folder, over-
writing them.
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• Dependencies:, lets you set which of the other submitted tasks have to be successfully completed before starting
the current task execution: these tasks can be added from the box on the right where all submitted tasks are
displayed.

Task execution can be started and stopped from the task list. If you are using the OpenToonz render farm, render tasks
and sub-tasks will be distributed on the farm, one for each computer, so that several tasks can be executed at the same
time (see Using the OpenToonz Farm ).

When the tasks are executed, the icon color tells the status of the task according to the following color code:

• Grey, when the task is waiting or is not executed yet.

• Yellow, when the task is being executed.

• Green, when the task was successfully executed.

• Orange, when the task was executed with some errors.

• Red, when the task execution has failed.

Tip: To add scenes to cleanup in the task list:

Do one of the following:

• Click the Add Cleanup Task button ( ) in the bottom bar of the Tasks pane and use the browser to select a
scene file.

• Select the scenes in the OpenToonz Browser, then right-click any of them and choose Add As Cleanup Task
from the menu that opens.

Tip: To configure the cleanup task in the task list:

1. Select the cleanup task in the task list.

2. Configure it by using the options available on the right of the list.

Tip: To select tasks in the task list:

Do any of the following:

• Click a task to select it.

• Shift-click a task to extend the selection up to that task.

• Ctrl-click (PC) or Cmd-click (Mac) a task to add it to, or remove it from the selection.

Tip: To execute selected tasks:

Do one of the following:

• Click the Start button ( ) in the bottom bar of the pane.

• Right-click any selected task icons and choose Start from the menu that opens.

Tip: To stop the execution of selected tasks:
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Do one of the following:

• Click the Stop button ( ) in the bottom bar of the pane.

• Right-click any selected task icon and choose Stop from the menu that opens.

Tip: To remove selected tasks from the list:

Do one of the following:

• Click the Remove button ( ) in the bottom bar of the Tasks pane.

• Right-click any selected task in the list and choose Remove from the menu that opens.

Tip: To add tasks to the Dependencies list:

• Select a task in the list on the right and click the << Add button.

Tip: To remove tasks from the Dependencies list:

• Select a task in the list on the left and click the Remove >> button.
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CHAPTER 10

Drawing Animation Levels

In OpenToonz it is possible to create and draw Toonz Vector levels (PLI format), Toonz Raster levels (TLV format)
and standard Raster levels (TIF format) directly in the viewer. Drawing tools can also be used for touch-up in cleaned
up drawings, and loaded raster images.

10.1 Drawing In OpenToonz

To draw an animation level, first you have to define its type: Toonz Vector, Toonz Raster or Raster; and its settings like
its name, the number of frames it’s made of and the way its drawings are numbered.

Toonz Vector levels are defined by drawing of vector strokes; strokes and areas defined by strokes can be painted by
using the styles available in the level palette. Toonz Vector levels have an unlimited size and resolution, as they are
vector-based. They are saved as PLI files.

Toonz Raster levels are defined by drawing bitmap lines; lines and areas defined by lines can be painted by using the
styles available in the level palette. Toonz Raster levels have a specified size and resolution, defined when they are
created. They are saved as TLV files.

Raster levels are defined by drawing bitmap lines using the styles available in the Raster Drawing Palette, that is
shared by all of the Raster levels of the same project (see Project Default Folders ). Raster levels have a specified
size and resolution, defined when they are created. They are saved as sequences of individual TIF files, one per level
frame.

When an animation level is defined, you can select any of its frames in the Xsheet/Timeline or in the Level Strip, and
start drawing in the viewer. You can do this both, when you want to create a drawing from scratch, and when you want
to edit a previously made drawing.

When selected in the Xsheet/Timeline, the viewer displays the whole scene content at the current frame; when selected
in the Level Strip, the viewer displays the selected frame of the current animation level only, to let you work more
easily on it.
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10.1.1 Setting the Default Type of Level to Draw

It’s possible to define the default level type that will be created when you draw inside OpenToonz.

By default Toonz Vector and Toonz Raster levels are saved in the +drawing folder of the current project when the
scene is saved, while Raster levels are saved in the +extras folder (see Project Default Folders ).

Tip: To define the Default Type of Level to Draw:

1. Open File → Preferences. . . → Drawing.

2. Choose the level type you want to use as default from the Default Level Type: option menu. Width, Height
and DPI fields are available for Toonz Raster Level and Raster Level options.

Note: The Width, Height and DPI values set in the File → Preferences. . . → Drawing section will also be used as
default for the New Level dialog.

10.1.2 Drawing Animation Levels

Animation levels can be created in the following ways:

• Using the New Level dialog.

• Setting the Autocreation option to Enabled.

• Setting the Autocreation option to Use Xsheet as Animation Sheet.

Using the New Level Dialog

New animation levels can be defined by using a dialog that lets you set the number of drawings the level is made of,
the animation step used to expose the frames in the Xsheet/Timeline, and the increment, that sets the way the level
drawings are numbered. For example, a Step 2 repeats each drawing twice in the Xsheet column or Timeline layer,
while an Increment 2 will number its drawings as 1, 3, 5, etc. The dialog also allows you to choose a destination
folder, different from the default one, by using the Save In field.

In case you define a Toonz Raster or a Raster level, you can set its Width, Height and DPI values, according to the
way you want to use it in the scene.

Settings like the length of the level and the numbering order can be edited later, as you are free to arrange the images
composing an animation level the way you prefer (see Editing Animation Levels ).

When a new level is created in an empty column, the color of that column header and the cells where the new level
gets exposed are colored denoting the type of level: light yellow for Toonz Vector levels, light green for Toonz Raster
levels, and light blue for Raster levels (see Working with Xsheet Columns ).

Note: The New Level dialog inherits the Default Level Type settings defined in Preferences. . . → Drawing.

Tip: To create a new animation level to draw:

1. Do one of the following:

• Select a cell in the Xsheet/Timeline where you want to place your animation level and choose Level → New →
New Level. . .
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• Right-click the cell in the Xsheet/Timeline where you want to place your animation level and choose New
Level. . . from the menu that opens.

• (If the Xsheet/Timeline toolbar is visible) Click any of the three New Level buttons at the leftmost part of it.

2. Choose the type of level: Toonz Vector, Toonz Raster or Raster, from the Type: option menu and define its
settings, then click the OK button.

Note: When using the Xsheet/Timeline’s toolbar buttons to create a new level, the corresponding level type is already
preselected in the dialog’s dropdown menu.

Note: If a level is already exposed in the cell column, the new level will be created in an empty column.

Tip: To define the saving location for the level you want to draw:

In the New Level dialog type in the Save In: field, or use the Browser button, to set the path for the saving location.

Note: If in the browser you choose any project folder, in the path field the full path will be replaced by the correspon-
dent folder alias (see Project Default Folders ).

Using the Autocreation Option

When in Preferences → Drawing the Autocreation: option is set to Enabled, it is possible to create new drawings
automatically by using drawing tools in the viewer. If the currently selected cell is empty, a new level will be auto-
matically created and named with the first available letter of the alphabet; if the currently selected cell is the one right
after one containing a level drawing (either in the Xsheet/Timeline or the Level Strip) a new drawing will be added to
that level.

Note: The level type will be the one defined in Preferences. . . → Drawing as Default Level Type.

Using the Xsheet as Animation Sheet

When in Preferences. . . → Drawing the Autocreation: option is set to Use the Xsheet as Animation Sheet, it’s
possible to create new drawings automatically by using drawing tools in the viewer. If the currently selected cell is
empty and belongs to an empty column, a new level will be automatically created and named with the first available
letter of the alphabet; if the currently selected cell is anywhere after one containing a level drawing, a new drawing
will be added to that level. In both cases the drawings will take its number from the scene current frame ; if that
drawing number already existed in the level, a letter will be added to its number (e.g. A.0001a.ext).

This working method allows you to work as a traditional animator: you can start creating the key drawings, and then
add breakdown drawings, and then inbetween drawings. You can quickly check your animation flipping it in the
viewer.

When you add a new drawing it will be repeated as a hold along the column/layer up to the following one.

It’s also possible to create a new drawing in a cell that contains a hold: the new drawing will replace the hold up to the
following drawing. Drawings can also be duplicated creating a copy with a different number.
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Once the animation is completed you can renumber the whole sequence according to the Xsheet/Timeline frame
numbering.

Note: The level type will be the one defined in Preferences. . . → Drawing as Default Level Type.

Tip: To create a new animation level

Click an empty cell in the Xsheet/Timeline and start drawing using a drawing tool in the viewer.

Tip: To add a drawing to an existing level

Click an empty cell in the column/layer containing the existing level and start drawing using a drawing tool in the
viewer.

Tip: To automatically renumber the drawings

1. Select the cells with the drawings you want to renumber.

2. Choose the Cells → Autorenumber command.

Note: The Autorenumber command is also available in the menu that opens when right-clicking in a
cell.

10.1.3 Using the Viewer

In the viewer, it’s possible to use the tools available in the toolbar to draw, paint, edit and model drawings. The work
area of the viewer is endless and you can scroll, zoom in, zoom out and rotate it.

In the title bar you can find information about what is currently displayed and selected, the zoom percentage, and a set
of buttons that lets you set the view mode (see Using the Viewer ).

At the bottom of the viewer another customizable set of buttons is available.

The frame bar and the playback buttons let you set the current frame and move through animation frames. The set
frame rate is visualized, and, in case the playback is activated, the actual frame rate is displayed on its left.

The other buttons are relevant only using the Animate tool ( ) to animate objects and when previewing the animation
in the viewer (see Animating Objects and Previewing the Animation ).

Note: If the bottom bar is too short to display all the options, it can be scrolled by using arrow buttons available at its
ends.

Note: In case a frame range is defined by playback markers, the playback buttons operate on the defined range only
(see Using the Playback Markers ).

Tip: To navigate the work area:
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Do one of the following:

• Use the Zoom tool ( ): to zoom in, click and drag up; to zoom out, click and drag down. The point where
you click is the center of the zooming action.

• Use the zoom shortcut keys (by default + and - keys) to zoom in and zoom out at specific steps (e.g. 50%, 100%,
200%, etc.).

• Use the mouse wheel to zoom in and zoom out.

• Middle-click and drag or use the Hand tool ( ) to scroll in any direction.

• Use the Rotate tool ( ) to rotate the viewer: an horizon line is displayed to let you understand the amount of
rotation; the center of rotation is the absolute center of the work area.

• Use the reset view shortcut (by default the Alt + 0 key) or right-click in the viewer and select Reset View from
the menu that opens, to display the viewer at its actual size, centered on the absolute center with no rotation
applied.

• Right-click and choose Fit to Window to automatically zoom the viewer so that it fits the camera box.

Tip: To play the scene contents back:

Do one of the following:

• Use the Play button.

• Drag the frame bar cursor.

Tip: To set the current frame:

Do one of the following:

• Use the playback buttons.

• Drag the frame bar cursor.

• Type in the Current Frame field the number of the frame you want to view.

Tip: To set the playback frame rate:

Do one of the following:

• Enter a value in the FPS field.

• Use the frame rate slider.

Adjusting the Viewer Visualization

The way the viewer visualizes the scene content can be adjusted according to the task to perform.

Full Screen mode can be entered to maximize the viewer to the monitor screen, hiding any interface window border.
This is available only on the Windows platform.
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Vector drawings, that can slow down the visualization performance when used in large amounts in a scene, can be
visualized as raster drawings, faster to visualize, still preserving their vector nature, by using the Visualize Vector As
Raster option.

Note: If the current level is vector-based, it will still be displayed as vector to allow any drawing/editing operation
you may perform.

Raster drawings and images that usually are displayed in the viewer according to their DPI value, can be displayed at
their actual pixel size, that is to say that one pixel from the image is displayed as one pixel of the screen monitor, to
better examine them.

Note: Visualizing an image at its actual pixel size is different from zooming in because zooming always takes into
account the image DPI information.

Tip: Windows only - To enter the viewer full screen mode:

Right-click the viewer and choose Full Screen Mode from the menu that opens.

Tip: Windows only - To exit the viewer full screen mode:

Right-click the viewer and choose Exit Full Screen Mode from the menu that opens.

Tip: To activate or deactivate the raster visualization for vector drawings:

Activate or deactivate the View → Visualize Vector As Raster option.

Tip: To display raster drawings and images at their actual pixel size:

1. In the Xsheet/Timeline select the level to which the drawing or image belongs so that it becomes the current
level.

2. Select the drawing or image in the Level Strip in order to display it alone.

3. Use the Actual Pixel Size shortcut (by default the N key) or right-click in the viewer and choose Actual Pixel
Size from the menu that opens.

Customizing the Viewer

The Viewer can be customized according to your needs: the background colors visible in the Viewer and inside the
camera box can be changed; a Field Guide and a Safe Area can be displayed for reference; the Table and Camera Box
can be hidden; Custom Guides can be added to help you in aligning objects or composing the elements of the scene
for a particular frame. The View → Inks Only check allows to hide the painted areas of the levels, facilitating the
drawing process.

The set of buttons and information available in the bottom bar of the Viewer can be customized as well, so that only
the elements you require are visible.

Tip: To change the Viewer Background color:
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1. Open the File → Preferences. . . → Colors dialog.

2. Define the Viewer BG Color by doing one of the following:

• Set the Red, Green and Blue values.

• Click the color thumbnail and use the Style Editor to edit it (see Plain Colors ).

Tip: To change the Camera Box Background color:

1. Open the Xsheet → Scene Settings. . . dialog.

2. Define the Camera BG Color by doing one of the following:

• Set the Red, Green, Blue and Alpha values.

• Click the color thumbnail and use the Style Editor to edit it (see Plain Colors ).

Tip: To show or hide the Table:

Choose View → Table to show or hide the table.

Tip: To show or hide the Camera Box:

Choose View → Camera Box to show or hide the camera box.

Tip: To show or hide the Camera Background color:

Choose View → Camera BG Color to show or hide the camera box background color.

Tip: To show or hide the Field Guide:

Choose View → Field Guide to show or hide the field guide.

Tip: To define the displayed Field Guide:

1. Open the Xsheet → Scene Settings. . . dialog.

2. Define the Field Guide Size: and A/R:. Size is the number of width fields of the field guide (1 field is equal to
1 inch), and the A/R is the ratio between the field guide width and height.

Tip: To show or hide the Safe Area:

Choose View → Safe Area to show or hide the safe area.

Tip: To add a Custom Guide:
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Click in the ruler: a click in the horizontal ruler will create a vertical guide, a click in the vertical ruler will create an
horizontal guide.

Tip: To move a Custom Guide:

Drag the custom guide marker in the ruler.

Tip: To delete a Custom Guide:

Do one of the following:

• Right-click on the guide marker in the ruler.

• Drag its marker outside of the Viewer, in the opposite direction of the guide itself.

Tip: To show or hide Custom Guides:

Choose View → Guides to show or hide the guides.

Tip: To show or hide the Rulers where Custom Guide markers are located:

Choose View → Rulers to show or hide the rulers.

Note: When the Viewer work area is rotated, guides are rotated as well, but rulers and guide markers will preserve
their position and orientation. However the position of a guide will still be controlled by markers, even if they visually
don’t match anymore.

Tip: To customize the set of buttons in the bottom bar of the viewer:

Click the option button ( ) on the far left of the bottom area, and select the elements to show, or deselect those to
hide, in the menu that opens.

10.1.4 Drawing Tools

You can draw by using the Brush ( ) and Geometric ( ) tools. For both tools you can set the thickness of the
line you are going to draw: values range from 0 to 100 for Toonz Vector levels, and from 1 to 100 for Toonz Raster
and Raster levels.

Note: For Toonz Raster and Raster levels it’s possible to set a Brush tool size higher than 100 by typing it in the Size
value fields.

Note: Min and Max Size/Thickness can be modified by either of these methods:
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• Pressing Ctrl + Alt and moving the mouse. Moving horizontally changes the Max value, while moving vertically
changes the Min value.

• Using the predefined keyboard shortcuts. U and I for respectively decreasing and increasing the Max value, or
H and J for respectively decreasing and increasing the Min value.

With the Brush tool ( ), you can take full advantage of the pressure sensitivity if you are using a pressure sensitive
tablet. The more you press on the tablet, the thicker the line you draw.

With the Geometric tool ( ), the thickness value is constantly applied to the whole shape you draw.

When creating vector drawings the size/thickness can also be set to 0 (zero): in this case vector strokes will only exist
as a wireframe even if you zoom in or zoom out, and they will be not visible when the animation is rendered.

Note: For vector drawings, line thickness can be changed and tweaked afterwards by using other tools (see Editing
Drawings ).

Drawing with the Brush Tool

The Brush tool ( ) allows you to draw freehand lines with the current style.

When using a pressure sensitive tablet, and the Pressure option is activated, varying the pressure of the pen on the
tablet will allow you to create variable-thickness lines that will make your drawings more expressive.

When using the Brush tool ( ) on Toonz Raster and Raster drawings, the cursor displays the exact pixel area that
will be affected by the brush: the inner jagged circle representing the Minimum Size, and the outer one the Maximum
Size of the brush.

In the tool options bar you can set the following:

• Size Min and Max sets the size of the brush; the size will vary between the two values if you’re using a pressure
sensitive tablet. If the two values are the same, your lines will have a constant thickness. When using a mouse
to draw, the Maximum thickness value will be used.

• Accuracy sets how accurate the generated line is compared to what you draw with the mouse or tablet pen: a
high value will generate lines that completely preserves the movement you perform (even a trembling hand); a
low value will simplify the line. This is available for Toonz Vector drawings only.

• Smooth allows for stroke stabilization while drawing. This is available for Toonz Vector and Toonz Raster
drawings only.

• Hardness sets the amount of antialiasing along the line border. This is available for Toonz Raster and Raster
drawings only.

• Opacity Min and Max sets the opacity of the brush; the opacity will vary between the two values if you’re
using a pressure sensitive tablet. Overlapping areas are not considered while drawing a single line, but only
when different lines are overlapping. This is available for Raster drawings only.

• Break automatically breaks the drawn stroke into sections, if very sharp angles are drawn: in this way, drawn
shapes may result simpler and easier to fill. This is available for Toonz Vector drawings only.

• Draw Order allows to choose how new drawings will be ordered with respect to already drawn lines. The
options are: Over All, Under All and Palette Order. When using Palette Order new lines will be drawn
above or below already existing ones, using the relative indexes of the palette Styles as the sorting factor. This
is available for Toonz Raster drawings only.
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• Pencil mode draws lines without antialiasing, that is with jagged edges. This is available for Toonz Raster
drawings only.

• Pressure detects, in case you are using a graphic tablet, the pressure of the pen on the tablet, allowing the
creation of variable-thickness lines.

• Range allows for the automatic creation of a series of in-between strokes, by drawing just the extremes of the
animation on subsequent frames of a level, in the Level Strip, or subsequent exposed cells of a level in the
Xsheet/Timeline. By pressing Ctrl key, you can draw intermediate strokes to form a more complex animation
sequence. This method is similar to the one used by the Inbetween command (see Using the In-betweener with
Vector Drawings ). This is available for Toonz Vector drawings only.

• Snap allows for the snapping of the cursor to other already drawn strokes of the same level, while drawing a
new stroke. It has three levels of sensitivity: Low, Med and High. This is available for Toonz Vector drawings
only.

• Preset: let you choose a brush preset in the option menu on the right. You can add or remove a preset clicking
the + and - buttons. A presets list is created for each level type and each added preset will be available for next
use.

• Cap option sets the shape of the ends of the stroke you are going to draw. Options are Butt for squared ends,
Round for semicircular ends, and Projecting for squared ends extending beyond the end of the line, according
to the vector thickness. This is available for Toonz Vector drawings only.

• Join option sets the shape of the straight corners along the stroke you are going to draw. Options are Miter
for pointed corners, Round for rounded corners, Bevel for squared corner. This is available for Toonz Vector
drawings only.

• Miter: sets the maximum length of a miter join, that is computed multiplying the miter value by the stroke
thickness. If the length exceeds the maximum value, the Miter join is turned into a Bevel join. This is available
for Toonz Vector drawings only, and only if the Join option is set to miter.

Note: If the tool options bar is too short to display all the tool options, it can be scrolled by using arrow buttons
available at its ends.

Tip: To add a new brush preset:

1. Click the + button on the right of the presets list.

Tip: To remove a new brush preset:

1. Click the - button on the right of the presets list.

Drawing with the Geometric Tool

The Geometric tool ( ) allows you to draw rectangles, circles, ellipses, regular polygons, polylines and arcs.

In the tool options bar you can set the following:

• Thickness sets the size of the brush used to draw the geometric shapes.

• Hardness sets the amount of antialiasing along the shape border. This is available for Toonz Raster and Raster
drawings only.
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• Opacity sets the opacity of the shape border. Overlapping areas are not considered while drawing over the same
shape, but only when different shapes are overlapping. This is available for Raster drawings only.

• Shape: sets the type of shape you want to draw. Available options are: Rectangle, Circle, Ellipse, Line, Polyline,
Arc and Polygon. In case you want to draw a Polygon, the Polygon Sides: lets you set the number of sides.

• Auto Group automatically defines any drawn closed shape (i.e. rectangles, circles, ellipses, polygons and
closed polylines) as a group, thus creating a new layer that is placed in front of the other drawing vectors,
without intersecting them (see Grouping and Ungrouping Vectors ). This is available for Toonz Vector drawings
only.

• Auto Fill automatically paints the area defined by any drawn closed shape (i.e. rectangles, circles, ellipses,
polygons and closed polylines) with the same style used for drawing. This is available for Toonz Vector drawings
only.

• Snap allows for the snapping of the cursor to other already drawn strokes of the same level, while drawing the
shape. It has three levels of sensitivity: Low, Med and High. This is available for Toonz Vector drawings only.

• Selective allows the drawing operations not to affect already drawn lines. This is available for Toonz Raster
drawings only.

• Pencil mode draws geometric shapes without antialiasing, that is with jagged edges. This is available for Toonz
Raster drawings only.

• Cap option sets the shape of the ends of open shapes you are going to draw. Options are Butt for squared ends,
Round for semicircular ends, and Projecting for squared ends extending beyond the end of the line, according
to the vector thickness. This is available for Toonz Vector drawings only.

• Join option sets the shape of the straight corners along the shapes you are going to draw. Options are Miter
for pointed corners, Round for rounded corners, Bevel for squared corner. This is available for Toonz Vector
drawings only.

• Miter: sets the maximum length of a miter join, that is computed multiplying the miter value by the stroke
thickness. If the length exceeds the maximum value, the Miter join is turned into a Bevel join. This is available
for Toonz Vector levels only, and only if the Join option is set to Miter.

Note: If the tool options bar is too short to display all the tool options, it can be scrolled by using arrow buttons
available at its ends.

While Rectangles and Ellipses are defined by a (bounding) box, Circles and Polygons are defined by a center and
radius; Polylines can be used to create open or closed shapes by defining a series of lines; Arcs let you set the end
points of a curve, and then the bend.

Tip: To draw a rectangle or an ellipse:

Click to define the upper left corner, drag, and release to define the bottom right corner. If you press the Shift key
while dragging, the shape will be regular, i.e. a square or a circle; if you press the Alt key, shapes will be drawn
starting from their center. It’s possible to press both keys at the same time.

Tip: To draw a circle:

Click to define the center, drag and release to define the radius.

Tip: To draw a polygon:
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1. Set the number of sides in the Polygon Sides: field.

2. Click to define the center, drag and release to define the radius of a circle bounding the polygon.

Tip: To draw a polyline:

1. Do one of the following:

• Click to define the first point as a corner point.

• Click and drag to define the first point as a control point; while dragging you can set the control point handles.

2. Do one of the following:

• Click to define the end point of the line as a corner point. If you press the Shift key, you will draw a vertical,
horizontal or 45° line.

• Click and drag to define the end point of the line as a control point; while dragging you can set the control
point handles.

3. Do one of the following:

• Click or click and drag again to define the end point of another line connected to the end point of the previous
line.

• Double click to define the last point of an open shape.

• Click or click and drag again on the first point you defined to draw a closed shape.

Note: Press the Ctrl key to add a linear point after a Nonlinear one.

Note: Press the ESC key to cancel the creation of the polyline.

Tip: To draw an arc:

1. Click to define the first end point.

2. Click to define the second endpoint.

3. Drag to set the bend, and click to draw the arc.

Adding Text

Text can be added by using the Type tool ( ).

Note: It is also possible to work with editable and animatable text in OpenToonz through the use of the Text Iwa
effect. For more information, please see Text Iwa .

In the tool options bar you can set the following:

• Font: to be used, taken from a list based on the Operating System default fonts folder.

• Style:, for the chosen font.
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• Size:, for the chosen font.

Note: Already written text can be resized by using the Selection tool ( ) (see Editing
Drawings ).

• Vertical Orientation, lets you place the text vertically, one letter under another, instead of horizon-
tally.

The current palette Style is applied to the text you type. The palette style can be changed while typing text, thus you
can have characters with different styles in the same text editing session (see Editing Styles ).

Note: For vector levels, as soon as the text is committed, it’s converted into vector outlines, and can no longer be
edited as text.

Tip: To add text:

1. Select the Type tool ( ) and click in the viewer where you want to start writing.

2. Choose options Font, Style, Size and Vertical Orientation. These options can be changed as long as you are
in text editing mode.

3. Change the current color Style in the palette, if you want to use more than one style in the same text editing
session.

4. Click inside the text editing area to change the text insertion point.

5. Click outside the text editing area, or select a different tool, to commit the text.

Using the Eraser

The Eraser tool ( ) allows you to partially erase lines, both in vector and raster drawings.

In the tool options bar you can set the following:

• Size sets the eraser size.

• Hardness sets the amount of antialiasing along the eraser border. This is available for Toonz Raster and Raster
drawings only.

• Opacity set the opacity of the eraser; passing twice on an area is not considered while performing a single
erasing operation, but only when performing different erasing operations. This is available for Raster drawings
only.

• Type: has the options Normal, to use the standard eraser; Rectangular, to perform the erasing inside the box
you define; Freehand, to perform the erasing inside the area you outline by clicking and dragging; and Polyline,
to perform the erasing inside the area you outline by defining a series of lines. In vector drawings, a stroke is
erased only if it is fully included in the area you define.

• Mode: has the options Areas, to erase only areas, Lines, to erase only the drawing outline, and Lines & Areas,
to perform both the operations. This is available only for Toonz Raster drawings.

• Selective allows you to erase only lines or areas made with the current style. This is available only for Toonz
Vector and Toonz Raster drawings.
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• Invert performs the erasing on the outside of the area defined with the Rectangular, Freehand or Polyline
options. In vector drawings, a stroke is erased only if it is fully outside of the area you define.

• Frame Range allows you to perform Rectangular, Freehand and Polyline erasing on a range of frames, by
defining an area in the first and then in the last frame of the range.

• Pencil mode erases lines without antialiasing, that is with jagged edges. This is available for Toonz Raster
drawings only.

Note: If the tool options bar is too short to display all the tool options, it can be scrolled by using arrow buttons
available at its ends.

Note: The Eraser tool ( ) can be automatically selected by using the eraser of the tablet pen.

10.1.5 Converting Raster Drawings to Vectors

Scanned drawings and raster ones, i.e. drawings not based on vectors, can be converted into Toonz Vector levels.

Two main conversion modes are available: Centerline and Outline. The choice between the two modes depends on
which conversion best fits your needs.

In Centerline mode a single vector stroke with a variable thickness is generated for each line in the drawing. This
means that the converted drawing can be edited like vector-based drawings made directly in OpenToonz, for example

you can change the bend of a stroke with the Pinch ( ) or Control Point Editor tools, and the thickness with the

Pump tool ( ).

In Outline mode two vector strokes are generated to define each line in the drawing, and areas filled with different
colors are separated by a stroke. This means that, for example, to change the bend of a line you have to change the
bend of the two strokes defining it, and to change the thickness you have to model one or both strokes defining it. The
thickness of all the strokes is set to 0, so that they won’t be visible in the final render.

Note: Parameters that are not considered necessary by the user can be hidden using the Options button ( ) at the
bottom right of the Convert To vector Pop Up.

In Outline mode the following settings are available:

• Accuracy sets how much the vector strokes will follow the shape of the original drawing lines. High values
create more precise strokes, but makes them more complex.

• Despeckling removes small spots or marks from the converted images. Its value expresses the size in pixels of
the maximum area that has to be removed.

• Preserve Painted Areas, when activated, includes all the colors in the converted level.

• Adherence sets how much smooth curves bend toward full corners.

• Angle sets the angular threshold below which full corners are inserted in the image

• Curve Radius sets the measure of a curve’s radius below which it is replaced by a smooth corner

• Max Colors defines the maximum number of colors that are considered in the Raster image and used in the
vector one. The value has to be set taking care of the real number of colors used in the Raster image. High
values increase the time needed for the conversion. This is relevant for Raster levels only.
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• Transparent Color defines the color that has to be set as the transparent background of the resulting vector
level. This is relevant for Raster levels only.

• Tone Threshold sets the value of the darkest pixels to be taken into account to detect lines to be converted
to vector; for low values only the darkest pixels are considered thus resulting in thinner lines; for high values
lighter pixels are considered too, thus resulting in thicker lines. This is relevant for Toonz Raster levels only.

In Centerline mode the following settings are available:

• Threshold sets the value of the darkest pixels to be taken into account to detect lines to be converted to vector
strokes; for low values only the darkest pixels are considered thus resulting in thinner strokes; for high values
lighter pixels are considered too, thus resulting in thicker strokes. For Toonz Raster levels (TLV files) the process
examines only pixels belonging to the lines; for Raster levels it examines pixels of the whole image.

• Accuracy sets how much the vector stroke will follow the shape of the original drawing lines. High values
create more precise strokes but makes them more complex.

• Despeckling ignores during the conversion small areas generated by the image noise; the higher the value, the
larger the areas ignored.

• Max Thickness sets the maximum vector stroke thickness; if this value is low very thick lines will be converted
in two centerline strokes defining the line outline; if this value is high, they will be converted in a single centerline
stroke.

• Thickness Calibration Start: and End: calibrates the vector stroke thickness defined according to the Thresh-
old value; a low value will reduce the stroke thickness preserving its integrity. A different value inserted in the
Start / End field determines an animation of the thickness along the length of the level.

• Preserve Painted Areas, when activated, preserves all painted areas in Toonz Raster levels (TLV files) and all
the areas painted with colors different from the line color in Raster levels.

• Add Border adds a vector stroke along the image border in order to detect also areas bleeding off the image
edge.

• Enhanced ink recognition, when activated, allows to vectorize Raster images (such as TGA, TIF, PNG etc. . . )
without antialiasing along the lines. An heuristic is used to recognize lines and painted areas creating a PLI
level, where the lines are seen as ink and the painted areas as paint.

It’s possible to select the images or the level frames that have to be converted directly in the Xsheet/Timeline.

When a conversion is performed, a new level is created according to the selection you made, and exposed in the
Xsheet/Timeline in the next column/layer to that containing the source level. The new file will have the same name of
the starting one, but with a PLI extension, and a “v” suffix, and is saved in the +drawings default folder.

Note: In case a PLI level with the same name already exists, the name of the new file will be followed by a progressive
number.

Tip: To convert raster drawings into vectors:

1. Select the level frames to convert in the Xsheet/Timeline.

2. Choose Level → Convert → Convert to Vectors. . .

3. In the dialog set parameters for the conversion.

4. Click the Convert button.
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Checking the Convert to Vectors Process

At the bottom of the Convert-to-Vectors Settings window a preview area is available to display the drawing selected
in the Xsheet/Timeline, as it will be after the conversion according to the defined settings. At the same time it allows
you to compare the final result with the original Raster drawing that is displayed on the left side, and to highlight the

vector strokes structure by clicking the Centerlines Check button ( ).

You can activate or deactivate it, resize it or navigate its content.

If you change any parameter in the Convert-to-Vector Settings, the previewed drawing automatically updates to
display how the changes affect the result.

Tip: To activate the preview area:

1. In the Xsheet/Timeline select the drawing you want to preview.

2. Click the Preview button ( ) in the bottom bar of the Convert-to-Vector Settings window.

Tip: To deactivate the preview area:

Click the Preview button ( ) in the bottom bar of the Convert-to-Vector Settings window.

Tip: To resize the preview area:

Do any of the following:

• Click and drag the horizontal separator.

• Click and drag the separator toward the window border to hide the preview area.

• Click and drag the separator collapsed to the window border toward the window center to display again the
preview area.

Tip: To navigate the preview area:

Do one of the following:

• Use the mouse wheel, or the zoom shortcut keys (by default + and - keys) to zoom in and zoom out.

• Middle-click and drag to scroll in any direction.

• Use the reset view shortcut (by default the 0 key) to display preview at its actual size

Tip: To activate and deactivate the Centerlines Check:

Click the Centerlines Check button ( ) in the bottom bar of the Convert-to-Vector Settings window.

Saving and Loading Convert To Vector Settings

Convert To Vector settings can be saved as tnzsettings files in order to have different settings for each level and to be
loaded back and used in a different scene.
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Loaded Convert To Vector settings can also become the default settings for the scene or for the project (see Scene
Settings and Project Default Settings ).

Tip: To save the Convert To Vector settings:

1. Click the Save Settings button ( ) in the bottom bar of the Convert-to-Vector Settings window.

2. In the browser that opens choose for the tnzsettings file a location and a name, and click the Save button.

Tip: To load saved Convert To Vector settings:

1. Click the Load Settings button ( ) in the bottom bar of the Convert-to-Vector Settings window.

2. In the browser that opens retrieve the tnzsettings file you want to load, and click the Load button.

Tip: To reset the Convert To Vector settings to the scene default:

Click the Reset Settings button ( ) in the bottom bar of the Convert-to-Vector Settings window.

10.2 Changing the Canvas Size

It’s possible to change the size of Toonz Raster and Raster levels, in order to increase or decrease the area around the
images of a level.
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The new size can be set in any unit supported by OpenToonz, by using absolute or relative values. If the canvas is
enlarged, some white transparent area is added; if the canvas is reduced, some cropping is applied to the level images.

Tip: To change the canvas size:

1. Select the Toonz Raster or Raster level you want to modify in the Xsheet/Timeline.

2. Choose Level → Canvas Size. . . , the Canvas Size dialog opens.

3. In the dialog set the Unit to express the new size of the canvas, and set the Width and Height of the new canvas;
activate the Relative option to define the new size by specifying only the size the canvas has to increase or
decrease.

4. Use the Anchor diagram to decide the position of the current canvas in the new one: the arrows are a reference
to see how the new size will increase or decrease the current canvas size.

5. Click the Resize button.

Note: In case the new canvas size is smaller than the current one, a confirmation dialog will open, asking you whether
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you want to crop the canvas.

10.3 Editing Drawings

Toonz Vector, Toonz Raster and Raster levels, can be manipulated in OpenToonz.

To edit a drawing, for example to copy a part of it, you have first to select it in the Xsheet/Timeline or in the Level
Strip. When selected in the Xsheet/Timeline, the viewer displays the whole scene contents at the current frame, when
selected in the Level Strip, the viewer displays the selected frame of the current animation level only, to let you work
more easily on it.

Drawings can be also selected directly in the viewer: this allows you to work on the different drawings visible at a
certain frame with no need to retrieve them in the Xsheet/Timeline or Level Strip.

Note: All the editing performed on drawings is not saved until you save the related level, or use the Save All command
(see Saving Levels ).

Tip: To select the drawing to edit:

Do one of the following:

• Select it in the Xsheet/Timeline or Level Strip.

• Right-click in the viewer the drawing you want to edit and in the menu that opens choose the Select command
related to the column containing the drawing you want to edit.

Note: The right-click menu first lists all the columns containing overlapping drawings, then the columns and objects
that are hierarchically linked to the clicked one.

10.3.1 Using the Selection Tool

The Selection tool ( ) allows you to edit, move, rotate, scale and distort a selection in a drawing.

In the tool options bar you can set the following:

• Type: has the options Rectangular, to select the area of the box you define by clicking and dragging; Freehand,
to select the area you outline by clicking and dragging; and Polyline, to select the area you outline by defining
a series of lines. In vector drawings, a vector stroke is selected only if it is fully included in the area you define.

• Mode: has the options Standard, to select vectors; Selected Frames, to edit all the lines of selected frames
at once; Whole Level, to transform all of the drawings of the current animation level; Same Style, to select at
once all of the vectors painted with the same style in the current drawing; Same Style on Selected Frames, to
select at once all of the vector strokes painted with the same style in the selected frames of the current animation
level; Same Style on Whole Level, to select at once all of the vector strokes painted with the same style in all
the drawings of the current animation level; Boundary Strokes, to select all the boundary strokes of the current
drawing; Boundary Strokes on Selected Frames, to select all the boundary strokes of the selected frames;
Boundary Strokes on Whole Level, to select all the boundary strokes of the whole level.This is available for
Toonz Vector drawings only.
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• Preserve Thickness will preserve the original thickness of the drawing vectors while performing resizing oper-
ations. This is available for Toonz Vector drawings only.

• Scale H and V set the horizontal and vertical scaling of the current selection.

• Link will maintain the proportion of the selection while draging over any of the Scale H or V letters in the tool
options bar.

• Rotation sets the rotation of the current selection.

• Position X and Y set a vertical and horizontal offset for the selection.

• Thickness sets the thickness of the selected vector strokes. In case the selected strokes have variable thick-
ness, or different thickness values, the highest value is displayed, and any change will affect the other values
accordingly. This is available for Toonz Vector drawings only.

• Cap: sets the shape of the ends of the selected vector strokes. Options are Butt for squared ends, Round for
semicircular ends, and Projecting for squared ends extending beyond the end of the line, according to the stroke
thickness. This is available for Toonz Vector drawings only.

Fig. 1: A butt cap, a round cap and a projecting cap.

• Join: sets the shape of the straight corners along the selected vector strokes. Options are Miter for pointed
corners, Round for rounded corners, Bevel for squared corner. This is available for Toonz Vector drawings
only.

Fig. 2: Miter joins, round joins and bevel joins.

• Miter: sets the maximum length of a Miter join, that is computed multiplying the Miter value by the stroke
thickness. If the length exceeds the maximum value, the Miter join is turned into a Bevel join. This is available
for Toonz Vector drawings only, and only if the Join: option is set to Miter.

• Modify Savebox check box allows you to resize the Savebox of a drawing. The drawing part that, because of
the editing, falls outside of the savebox will be erased. This is available for Toonz Raster drawings only.
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Note: The Savebox size can be set automatically to the minimum size by activating the Preferences → Drawing
→ Minimize Savebox after Editing option.

• No Antialiasing when activated, the antialiasing is not applied when the selection is deformed or rotated. This
is available on Toonz Raster and Raster drawings only.

Note: If the tool options bar is too short to display all the tool options, it can be scrolled by using the arrow buttons
available at its ends.

When a selection is made, it is displayed with a bounding box with handles that allow you to perform the following
transformations:

• Move, click and drag the inside of the raster selection, or any selected vector of a vector selection,
to move it; by pressing the Shift key while dragging, the movement will be constrained on the
horizontal or vertical direction.

Note: The keyboard arrow keys can be used as well to move the selection one pixel in any
direction; if they are used while pressing the Shift key, the movement will be in 10 pixels steps.

• Rotate, click and drag outside any corner handle to rotate the selection.

• Scale, click and drag any corner handle to scale the selection freely; by pressing the Shift key while
dragging the scaling will be uniform; by pressing the Alt key the scaling will be applied from the
center.

• Scale in one direction, click and drag any side handle to scale the selection in one direction; by
pressing the Alt key the scaling will be applied symmetrically from the center.

• Center, click and drag the center handle to change the center of rotation, and the center used when
Alt-scaling.

• Distort, Ctrl-click (PC) or Cmd-click (Mac) any corner handle to distort the selection, or any side
handle to shear it.

Note: Ctrl-click (PC) or Cmd-click (Mac) operations are not allowed in Whole Level modes
(see above).

• Thickness, click the double arrow-head at the bottom right corner of the selection and drag up to
increase the thickness of selected lines, down to decrease it. This option is available for Toonz Vector
drawings only.

To apply the transformations you can click outside the selection.

Note: As you roll over the handles, the cursor changes shape to indicate the operations you may perform.

Selections can also be Cut, Copied, Pasted and Deleted by using the relevant command in the Edit menu. Cut or Copy
and Paste also work from one drawing to another, or onto a new one. This allows you to copy or move a section of a
drawing to another drawing, or split a drawing into several ones.

When a drawing in a Toonz level, or a section of it is pasted to another one, the Styles of the pasted drawing are added
to the palette of the target level, unless the same Styles are already available in the palette.
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Note: The selection can also be used to change the Style of vector strokes by choosing it in the palette, or by creating
a new Style while selected. See Editing Styles .

Tip: To edit the drawing savebox:

1. Activate the Modify Savebox option to visualize the savebox around the drawing.

2. Use the handles to resize it.

3. Deactivate the Modify Savebox option to confirm the changes.

Tip: To select and transform an area in a Toonz Raster or Raster level:

1. Select the area by doing one of the following:

• Set the type to Rectangular and click and drag to define the box whose area you want to select.

• Set the type to Freehand and click and drag to outline the area you want to select.

• Set the type to Polyline and click to outline the area you want to select by defining a series of lines.

2. Do one of the following to make geometric transformations:

• Operate the handles available along the bounding box.

• Edit the scale, rotation and position values available in the tool options bar.

Fig. 3: First define the area you want to select, then use the bounding box to make geometric transformations.

Tip: To select and transform vectors in a Toonz Vector level:

1. Select the vectors by doing one of the following:

• Click a stroke to select it.
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• Shift-click to add a stroke to or remove it from the current selection.

• Set the type to Rectangular and click and drag to the right to define a box and select all the strokes that are
completely included in the box; click and drag to the left to select all the strokes that are partially included in
the box.

• Set the type to Freehand and click and drag to outline an area and select all the strokes that are completely
included in the area.

• Set the type to Polyline and click to outline an area by defining a series of lines and select all the strokes that
are completely included in the area.

• Set the mode to Same Style and click to select automatically all the vectors painted with the same style used for
the vector you select in the current drawing, or Shift-click to add them to or remove them from the selection.

Note: When clicking a stroke belonging to a group, the whole group is selected (see Grouping and
Ungrouping Vectors ).

2. Do one of the following to make a geometric transformations:

• Operate the handles available along the bounding box.

• Edit the scale, rotation, position and thickness values available in the tool options bar.

Fig. 4: First select the vector strokes you want to transform, then use the bounding box to make geometric transforma-
tions.

Tip: To select and transform all the drawings of a Toonz Vector level:

1. Do one of the following:

• Set the mode to Whole Level to automatically select all the strokes in all of the drawings of the current animation
level.

• Set the mode to Same Style on Whole Level and click to select at once all of the strokes painted with the same
style used for the stroke you selected in all of the drawings of the current animation level, or Shift-click to add
them to or remove them from the selection.
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2. Do one of the following to make geometric transformations affecting all of the level drawings:

• Operate the handles available along the bounding box.

• Edit the scale, rotation, position and thickness values available in the tool options bar.

Note: When working on the whole level the bounding box displayed in the current level drawing is double-lined.

Tip: To paste a selection in another existing drawing:

1. Make a selection in the current drawing.

2. Copy/cut it.

3. Select the other drawing in the Level Strip or in the Xsheet/Timeline.

4. Paste the copied/cut selection.

Note: Selections from Toonz Raster and Toonz Vector levels can be pasted in any other type of drawing, automatically
converting the pasted selection to the appropriate type; selections from standard Raster levels can only be pasted in
other Raster drawings.

Tip: To paste a selection in a new drawing:

1. Make a selection in the current drawing.

2. Copy/cut it.

3. Select an empty frame in the level strip or an empty cell in the .

4. Paste the copied/cut selection.

Tip: To merge several drawings into one drawing:

1. Select the area you want to merge and copy/cut it.

2. Select the drawing you want to paste the selection to.

3. Paste the copied/cut selection.

Note: Several raster animation levels can also be merged at once by using the related command (see Merging
Animation Levels ).

Tip: To split a drawing into several drawings:

1. Select the area you want to use as a new drawing and copy/cut it.

2. Select an empty cell in the .

3. Paste the copied/cut selection: automatically a new drawing will be created.
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10.3.2 Grouping and Ungrouping Vectors

All the vector strokes of a drawing lie on the same plane, therefore drawing areas are outlined by segments defined by
strokes intersections. This means that if you draw two intersecting squares, automatically three areas are defined: one
belonging only to the first square, one to the second one, and another defined by the intersection.

Fig. 5: Painting a drawing that contains intersecting vector strokes and shapes may be an issue, because all of them lie
on the same layer.

To organize strokes you can use the grouping features, that creates a new group entity containing only the strokes you
select.

In the case of two intersecting squares, if you want the two squares to be overlapping instead of intersecting, you can
create a group containing the strokes of the first square, and another those of the second square, thus defining two
groups whose order can be arranged.

It’s possible to create as many groups as you want in any drawing; groups can be made of one stroke only as well, for
instance a circle, or a line.

When drawing with the Geometric tool ( ), closed shapes (i.e. rectangles, circles, ellipses, polygons and closed
polylines) can be defined automatically as a group by activating the Auto Group option (see Drawing with the Geo-
metric Tool ).

When your strokes selection includes one or several groups, the new group will include them as well, preserving them
and their original sorting order position in case the group is released.

Note: It’s not possible to define a group if the selection includes only some strokes belonging to a group.

When a group is released, if no other group is defined in the same drawing, all the strokes will lie at the same plane; if
other groups are defined, the strokes of the released group will lie on a plane behind, in front of, or between the other
groups, according to the original group sorting order position.

It’s possible to enter groups to isolate them visually from the rest of the drawing and better understand which strokes
are inside and which outside the group. In this way it’s also easier to work on the drawing, for instance to fill an area
or to change the color of some strokes.
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Fig. 6: First define groups, then set a proper layering order to solve the intersection problems.

As the Selection tool ( ) considers the group as a whole, if you want to select a stroke belonging to a group, first
you have to enter the group, and then select the stroke.

Note: As groups define which strokes belong to a certain plane, when using the Fill tool ( ), only areas defined by
strokes within the same group can be filled.

Tip: To Define a group:

1. Use the Selection tool ( ) to select the strokes you want to be in a group.

2. Do one of the following:

• Choose Edit → Group → Group.

• Right-click on the selection and choose Group from the menu that opens.

Tip: To Release a group:

1. Select the group you want to release.

2. Do one of the following:

• Choose Edit → Group → Ungroup.

• Right-click on the selection and choose Ungroup from the menu that opens.

Tip: To Enter a group:

Do one of the following:

• Select the group, then choose Edit → Group → Enter Group.
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• Right-click the group and choose Enter Group from the menu that opens.

• Double-click the group.

Tip: To Exit a group:

Do one of the following:

• Choose Edit → Group → Exit Group.

• Right-click the group and choose Exit Group from the menu that opens.

• Double-click outside the group.

Tip: To Select a group:

Choose the Selection tool ( ) and do any of the following:

• Click any stroke belonging to the group.

• Click and drag to select at least one stroke belonging to the group.

• Set the type to Rectangular and click and drag to define a box and select at least one stroke belonging to the
group.

• Set the type to Freehand and click and drag to outline an area and select at least one stroke belonging to the
group.

• Set the type to Polyline and click to outline an area by defining a series of lines and select at least one stroke
belonging to the group.

Tip: To Select a stroke in a group:

1. Enter the group.

2. Click the stroke to select it.

10.3.3 Setting Stroke and Group Sorting Order

For each vector drawing, strokes and groups sorting order can be changed by setting what has to lie in front of, and
what behind.

Tip: To bring the selection to front:

Do one of the following:

• Choose Edit → Arrange → Bring to Front.

• Right-click on the selection and choose Bring to Front from the menu that opens.

Tip: To bring the selection one level forward:

Do one of the following:
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Fig. 7: Select vector strokes, create groups and set their layering order to better manage the drawing.

• Choose Edit → Arrange → Bring Forward.

• Right-click on the selection and choose Bring Forward from the menu that opens.

Tip: To send the selection back:

Do one of the following:

• Choose Edit → Arrange → Send Back.

• Right-click on the selection and choose Send Back from the menu that opens.

Tip: To send the selection one level backward:

Do one of the following:

• Choose Edit → Arrange → Send Backward.

• Right-click on the selection and choose Send Backward from the menu that opens.

10.3.4 Editing Vector Drawings

Vector drawings can be edited in some additional ways by using the set of tools. This allows you for example to better
calibrate the bend of a vector, or to change its thickness.

All these transformations can be also achieved on already painted drawings, because the fill styles used to paint will
automatically follow the shape of the areas you modify, working like “liquid” color, flooding an area defined by an
outline.
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Editing Vector Control Points

To modify a vector by editing its control points you can use the Control Point Editor tool ( ).

Control points have handles whose length and direction define the bend of the vector. With this tool you can select a
vector and modify the control point handles, or the bend of a curve defined by control points, and move, add or delete
control points.

Control point handles may be linked, that is to say they share the same direction, or not, creating a cusp in the vector;
they can also be collapsed in the control point in order to turn it in a corner point. In case only one handle is collapsed,
the point will be corner on one side and smooth on the other. When a section of the vector is defined by two corner
points, it will be a straight line.

The option Auto Select Drawing is available to automatically select any vector of any drawing visible in the viewer.

Fig. 8: Click to select a vector stroke and edit its control points; Alt-click to unlink control point handles; Ctrl-click
(PC) or Cmd-click (Mac) the selected stroke to add a control point.

Tip: To select a vector:

Click it.

Tip: To edit the bend of a vector:

Do any of the following:

• Click and drag the ends of the control point handles.

• Click and drag the curve defined by the control points to edit it.

• Shift-click and drag the curve defined by the control point to edit it by keeping the control points position fixed.

Tip: To unlink the control point handles:

Alt-click one of the handle ends and drag.

Tip: To link the control point handles:

Alt-click one of the handle ends and drag: the other handle snaps to the direction of the one you are dragging.

Tip: To add a control point:
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Ctrl-click (Pc) or Cmd-click (Mac) the vector where you want to add a control point.

Tip: To select control points:

Do one of the following:

• Click a control point to select it.

• Ctrl-click (Pc) or Cmd-click (Mac) a control point to add it to the selection.

• Click and drag to select all of the control points that are included in the selection area.

Tip: To move the selection:

Do one of the following:

• Click any selected control point and drag.

• Use the Arrow keys to move the selection one pixel right, left, up or down.

Tip: To delete the selection:

Choose Edit → Delete.

Tip: To turn a control point into a corner point:

Do one of the following:

• Alt-click the control point.

• Move the handle ends to the control point, in order to collapse them.

• Right-click the control point and choose Set Linear Control Point from the menu that opens.

Tip: To retrieve handles from a corner point:

Do one of the following:

• Alt-click the corner point.

• Right-click the control point and choose Set Nonlinear Control Point from the menu that opens.

Changing the Bend of Vector Strokes

To modify a bend of a vector stroke in a more intuitive way you can use the Pinch tool ( ). You can use it anywhere
you want on the stroke, in order to modify the bend in any direction.

When the tool is selected, a segment of the center line of the closest stroke is highlighted: the segment shows the
length of the stroke that will be affected by the pinching.

The length of the segment depends on the corner points, that the tool automatically detects along the stroke, according
to the Corner value. It can also be manually set by activating the Manual option, and thus using the Size value to set
the affected length.
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When the Manual mode is activated, a handle is displayed along the highlighted stroke to control interactively the
length of the segment that will be affected by the tool. The handle has a double circle and a square at its ends, that
allows you to do the following:

• Double circle lets you move the handle along the segment.

• Square lets you increase the length of the segment affected by the tool by clicking and dragging right, or
decrease it by clicking and dragging left.

In both Automatic and Manual modes, different types of editing can be performed when clicking and moving the
cursor:

• Click and drag to change the bend of the highlighted segment.

• Shift-click and drag to edit the highlighted segment by adding a cusp.

• Ctrl-click (Pc) or Cmd-click (Mac) and drag to edit the highlighted segment by adding a corner.

Tip: To modify the bend of a stroke:

1. Change the length of the segment affected by the tool by setting the Corner value in the tool options bar.

2. Click, Shift-click, or Ctrl-click (Pc) or Cmd-click (Mac) and drag to modify the bend of the highlighted segment.

Fig. 9: Click and drag to change the bend; Shift-click to add a cusp; Ctrl-click (PC) or Cmd-click (Mac) to add a
corner.

Tip: To modify the bend of a stroke in manual mode:

1. Activate the Manual option in the tool options bar.

2. Change the length of the segment affected by the tool by doing one of the following:

• Set the Size value in the tool options bar.

• Click and drag the small square at one end of the handle displayed along the highlighted stroke.

3. Click, Shift-click, or Ctrl-click (PC) or Cmd-click (Mac) and drag to modify the bend of the highlighted segment.

Tip: To eliminate a corner point from a segment:

1. Click and drag the point until the smooth segment is formed again.

2. Click and drag to correct the bend of the newly smoothed segment.
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Using Other Modifier Tools

To modify the thickness of a stroke you can use the Pump tool ( ). You can use it anywhere you want on the stroke
to increase or decrease the thickness locally. When the tool is selected, a segment of the closest stroke is highlighted:
the segment shows the length of the stroke that will be affected by the tool. To modify this length you can change the
Size value in the tool options bar.

Note: It’s possible to modify the thickness of a stroke, a stroke selection, or strokes in all of the level drawings, by

using the Selection tool ( ) and its related options (see Using the Selection Tool ).

To distort more than one stroke at once, you can use the Magnet tool ( ). The tool affects all stroke included in
a circular area and allows you to distort them in the direction of your dragging. Highlighted segments will show the
strokes that will be affected. To modify the action range of the tool, represented by a circle, you can change the tool
size in the tool options bar.

To bend a part of a drawing, for example a character’s arm, you can use the Bender tool ( ). The tool allows
you to define a line and then bend all the strokes intersected by the segment. While bending you can see the af-
fected strokes assuming their position after the transformation. The bending can be performed in both clockwise and
counterclockwise direction; once you start dragging you cannot change the bend direction.

Note: If you move the cursor far from the bending center, you will be able to set with more precision the amount of
bend you want to apply to the strokes.

To smooth a stroke, you can use the Iron tool ( ). When used again and again on the same stroke, it increasingly
flatten the bends of the stroke. When the tool is selected, the cursor snaps to the closest stroke to indicate where you
are going to operate.

Tip: To modify the thickness of a stroke:

1. Select the Pump tool ( ).

2. Set the Size: value in the tool options bar.

3. Click the point of the stroke where you want to modify the thickness and drag up to increase it, or down to
decrease it.

Tip: To distort several strokes at once:

1. Select the Magnet tool ( ).

2. Click in the Viewer: all the strokes included in the circle will be affected by the tool.

3. Drag to distort the strokes in the direction of your dragging.

Tip: To bend one or several strokes:

1. Select the Bender tool ( ).

2. Click on one side of the strokes you want to bend to set the center of the bend.
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Fig. 10: Using the Pump tool to change the thickness of drawn strokes.

3. Click on the opposite side of the strokes: all strokes intersected by the defined line will be affected by the
bending.

4. Drag in the direction you want to bend strokes.

Tip: To smooth a stroke:

1. Select the Iron tool ( ).

2. Click and drag along the stroke you want to smooth. By dragging over and over the stroke will increasingly
flatten.

Joining and Splitting

To join the ends of two different vector strokes, you can use the Tape tool ( ). This way it will be possible to handle
them as a single stroke, for instance for modifying their bend, or thickness, as a whole.

When the tool is used, the pointer snaps to the closest detected stroke endpoint in order to make the operation easier.

Note: The Tape tool ( ) can also be used to close gaps along the drawing outline for painting purposes (see Closing
Gaps in Drawing Outline ).

To do the contrary, that is to say splitting a stroke in two sections, you can use the Cutter tool ( ).

Tip: To join two open ends of one or two strokes:

1. Select the Tape tool ( ), and activate the Join Vectors option; activate also the Smooth option if you want a
smooth joining with no corners.
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2. Do one of the following:

• Set the type to Normal and the mode to Endpoint to Endpoint, click a stroke endpoint and drag to a different
endpoint; the pointer snaps to the closest detected stroke endpoint.

• Set the type to Rectangular, and click and drag to define a box including the endpoints you want to connect;
the endpoints will be automatically joined according to the set Distance value.

Note: If the strokes you are going to join have different Styles, the Style of the first vector where you click on will be
assigned to the second one after joining.

Tip: To split a stroke:

1. Select the Cutter tool ( ): the pointer snaps to the closest stroke indicating, with a small highlighted segment,
the point where you are going to split the stroke.

2. Click to split the stroke at the highlighted point.

Cleaning up Strokes Intersections

Vector strokes intersections may be a weak point in drawings to be painted, because if a gap occurs, drawing areas
cannot be painted properly.

The best solution for this kind of issue is to overlap the final section of strokes, in order to define clear intersections,
then automatically remove the sections that overflow.

Tip: To cleanup vector intersections:

1. Use the Selection tool ( ) to select the strokes whose intersections you want to cleanup.

2. Do one of the following:

• Choose Level → Optimize → Remove Vector Overflow.

• Right-click the selection and choose Remove Vector Overflow from the menu that opens.

10.4 Animation Techniques

Besides drawing frame by frame, one image at a time, until you achieve the animation you want, some other techniques
are easier to achieve thanks to OpenToonz features.

Whatever the technique is, you can control your work and how smooth the animation is by using the onion skin, that
allows you to view more than one image in the viewer at the same time as reference.

10.4.1 Modelling a Vector Drawing

Instead of animating a level by starting every time from a blank frame, you can duplicate a vector drawing and
make subsequent modifications. You can do it even if the drawings are painted, because the styles used to paint will
automatically follow the shape of the areas you modify (see Editing Drawings ).
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The sequence of the animation level drawings can be easily controlled in the Level Strip.

You can use both the Cells → Duplicate Drawing command and the standard Copy and Paste commands to make a
copy of a drawing that you can later modify to create slight movements.

When you use the Duplicate Drawing command, the selected drawing is duplicated in the following frame. If the
following frame already contains a drawing, it’s shifted down in order to insert the duplicated drawing in the sequence.

When you use the Copy and Paste commands, you can also decide the frame of the Level Strip where you want to
paste the drawing.

Once finished, you can make a copy of the modified drawing, and modify it in its turn. You can go on duplicating and
modifying drawings until you complete the animation level.

Tip: To create an animation level by modelling vector drawings:

1. In the Viewer, select a drawing of the vector animation level you want to edit.

2. In the Level Strip, select the drawing you want to duplicate.

3. Copy the selected drawing in the following frame by doing one of the following:

• Choose Cells → Duplicate Drawing.

• Choose Edit → Copy, then select the following frame and choose Paste.

4. Select the new drawing in the Level Strip.

5. Use modifier tools to modify the drawing.

6. Go on duplicating and modifying drawings until you complete the animation level.

10.4.2 Using the In-betweener with Vector Drawings

An animation technique reserved to vector animation levels is the use of the Inbetween command. Inbetween creates
in-between drawings from the two extremes of a range of selected frames in the Level Strip.

When more than two frames are selected in the Level Strip, a vertical strip labeled INBETWEEN is displayed on the
right of each frame. By clicking on it, all frames between the first and the last selected, will be overwritten by images
interpolating from the first to the last drawings.

The interpolated drawings are created by taking into account the number of the strokes, and the strokes’ direction.
This means that the result will depend on the way drawings were made. For example if the first image is a single
shape drawn clockwise, and the last is another shape, you will get different results depending on the way it was drawn,
clockwise or counterclockwise.

To obtain the best results with complex drawings, copy the drawing you want to interpolate from, and paste it in
another frame of the level strip. Modify the pasted drawing without adding and deleting strokes, but only distorting
and moving existing strokes (see Editing Drawings ). Select the whole range and then perform the interpolation.

The interpolation acceleration can be controlled in the dialog that opens prior to performing in-betweening. Options
are the following:

• Linear, for a constant interpolation.

• Ease In, for an interpolation starting slowly, then getting faster.

• Ease Out, for an interpolation starting quickly, then getting slower.

• Ease In / Ease Out, for an interpolation starting slowly, getting faster, then getting slower again.

10.4. Animation Techniques 145



OpenToonz Documentation, Release 1.7.1

Fig. 11: Duplicate a drawing; modify it; insert blank frames; select the frame range, then click the INBETWEEN
vertical bar.
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If you want the interpolation to happen slower or faster, you can insert frames, or cut them, and use the in-betweener
again.

Tip: To create in-between drawings:

1. Select the level where you want to perform interpolation.

2. In the Level Strip select the frame range, from the drawing you want to interpolate from, to the one you want to
interpolate to. If you want the interpolation to last more frames, make room for more drawings with the Edit →
Insert command.

3. Click the vertical strip labeled INBETWEEN displayed on the right of the frame range selection.

4. Select the Interpolation: mode among Linear, Ease In, Ease Out, Ease In / Esase Out, and click the Inbe-
tween button.

Tip: To optimize the in-betweening process:

1. Create and paint the drawing you want to interpolate from.

2. Do one of the following:

• Copy and Paste it in another frame of the Level Strip, considering the number of in-between drawings you want
to achieve.

• Duplicate it and insert as many empty frames as the number of in-between drawings you want to achieve.

3. Modify the pasted or duplicated drawing using the modifier tools, to create the final drawing of the interpolation.

4. Select the frame range from the drawing you want to interpolate from, to the one you want to interpolate to.

5. Click the vertical INBETWEEN strip displayed on the right of the frame range selection.

10.4.3 Rotoscoping

Rotoscoping consists of tracing drawings taking a live clip as reference.

As you can import clips and image sequences in a scene, you can simply load them, and create an animation level by
drawing in the Viewer, while the frames of the clips are visible underneath. See Using the File Browser .

The way to obtain best results is not trying to reproduce with fidelity the clip, but to use its frames just as a reference
to better understand the movement or the transformation of the clip’s subject. In this way you can take advantage, for
example, of a natural movement represented in the clip, without renouncing an expressive drawing style.

Tip: To perform rotoscoping:

1. Load a video clip or image sequence in an Xsheet column (or Timeline layer).

2. In the Xsheet/Timeline select a cell in a column on the right of the column (or in a layer on top of the layer)
containing the clip you loaded. The image of the clip placed at the same frame of the cell you selected will be
visible in the Viewer while you’re drawing.

3. Create a new animation level and use tools to trace the first drawing in the Viewer.

4. Move to subsequent frames, and trace the next drawings.
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Fig. 12: Using the rotoscoping technique to trace the movement of a hand.

10.4.4 Cloning Levels

Sometimes it may be useful to create a clone of a level, or a part of it, in order to edit it without affecting the original
one. For example you may want to create a new animation level starting from the drawings of another level, in order
to have two sequences similar but not identical.

The Clone Cells command allows you to create an independent copy of the selected cells, preserving the numbering
order and assigning a new name to it. The _clone suffix appended to the name of the level is the default.

The cloned level will contain only drawings exposed in the selected cells, even if the original level is composed of
more drawings; they will be automatically exposed in the column on the right (or layer on top) of the selection, shifting
the following columns/layers.

The new level will be available in the Scene Cast as a new element; it will be saved in the +drawings or +extras
default folder, according to the format of the original file, as soon as you save it with the Save Level command, or you
save the scene.

The cell selection can also spread over several columns/layers: in this case the same number of new columns/layers
will be inserted to make room for the cloning result. If more than one level is selected, the same number of new levels
will be created and it’s not possible to assign a name to the cloned levels.

Tip: To clone levels:

1. Select the cells you want to clone.

2. Choose Cells → Clone Cells.

3. Enter a Level Name: and press OK to confirm.
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10.5 Using Onion Skin

If you want to view more than one level drawing at the same time in the Viewer as reference when you create drawings,
or you want to check the animation, you can activate the Onion Skin mode.

The Onion Skin is available both in the Xsheet/Timeline and in the Level Strip, according to where the cursor showing
the current frame is displayed, as the onion skin can be activated starting from the cursor and managed in the frame
number column/bar.

Fig. 13: A column animation displayed with the relative Onion Skin set for 6 previous frames, step two, and an
absolute Onion Skin set at frame 35.

When a frame of the Level Strip is selected, the onion skin applies to the current level only, referring to the sequence
of the full animation level as it was created.

When a cell of the Xsheet/Timeline is selected, the onion skin applies to the current level, according to how the drawing
sequence is exposed in the scene, including movements and transformations performed thanks to the object animation
(see Animating Objects ), while the rest of the scene in the current frame will be visible as usual. If you want, you can
also extend the onion skin to the whole content of the Xsheet/Timeline, to allow references to all of the animated or
moving elements in the scene as well.

The relative Onion Skin mode displays frames in relation to the position of the current frame. For instance you can
activate the frame previous to the current one, and every time you change the current frame, the previous frame will
be displayed.

The fixed Onion Skin mode displays the selected frame independently from the current frame. For instance you can
activate frame 5, and every time you change the current frame, frame 5 will be displayed in Onion Skin mode.

The way images are displayed in Onion Skin mode can be customized in the Preferences. . . → Onion Skin section.
It’s possible to define the Paper Thickness, to set an independent color correction for previous and following frames,
and to Display Lines Only for Toonz Vector and Toonz Raster.
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Tip: To activate or deactivate frames in Relative Onion Skin mode:

Do one of the following:

• In the Xsheet, click the small romboid markers available to the left of the frames column (or above the frame
bar in the Timeline). Click and drag automatically activates or deactivates a series of frames.

• In the Level Strip, click the small circular markers available to the left of the strip frames. Click and drag
automatically activates or deactivates a series of frames.

Tip: To activate or deactivate frames in Fixed Onion Skin mode:

Do one of the following:

• In the Xsheet, click the small ghosted romboid markers available to the very left of the frames column (or above
the frame bar in the Timeline). Click and drag automatically activates or deactivates a series of frames.

• In the Level Strip, click the small ghosted circular markers available to the very left of the strip frames. Click
and drag automatically activates or deactivates a series of frames.

Tip: To Deactivate (or Activate again) the Onion Skin mode:

Do one of the following:

• Double-click over the big circle to the left of the current frame cursor. Double-click again to activate it back.

• Right-click in the Viewer or in the frames column/bar of the Xsheet/Timeline, and choose Deactivate Onion
Skin or Activate Onion Skin in the menu that opens.

Note: The first time you activate Onion Skin mode by Right-clicking in the Viewer or the
Xsheet/Timeline frames column/bar, a default relative onion skin mode activates, showing the previous
three frames.

Tip: To Extend the onion skin to the Whole Scene Content:

1. Activate the onion skin in the Xsheet/Timeline.

2. Right-click in the Viewer or in the frame column/bar of the Xsheet/Timeline, and choose Extend Onion Skin
to Scene from the menu that opens.

Tip: To Limit the onion skin to the Current Level:

Right-click in the Viewer or in the frame column/bar of the Xsheet/Timeline, and choose Limit Onion Skin to Level
from the menu that opens.

Tip: To customize the way images are displayed in onion skin mode:

1. Choose File → Preferences. . . → Onion Skin.

2. Do any of the following:
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• Set a value for the Paper Thickness parameter; the lower the value, the more transparent the drawings displayed
in Onion Skin mode will be.

• Use the Previous Frames Correction to set a color for displaying previous frames.

• Use the Following Frames Correction to set a color for displaying following frames.

• Activate the Display Lines Only option to display Toonz Vector or Toonz Raster levels with lines only.

10.6 Using Shift and Trace

The Shift and Trace function can help you in the creation of animated levels as if you were drawing on paper using a
light table; in fact it allows you to use the previous and next key drawings as references, while you insert an inbetween
or a break down.

It’s possible to temporary move and rotate the drawings you want to use as reference, to fit the position where you
want to draw the inbetween. It’s also possible to automatically set the position of the reference drawings creating and
editing a path of action line.

To better check the new drawing and the animation, you can toggle the Shift and Trace visualization on or off the
Viewer.

Tip: To enter the Shift and Trace view:

1. Position the frame cursor on the frame where you want to draw the inbetween drawing.

2. Enable View → Shift and Trace; the previous and next drawings will be visualized.

Tip: To Edit the Position of the reference drawings:

1. Position the frame cursor where you want to draw the inbetween drawing and sketch the path of action line
beteween your reference points.

2. Activate View → Edit Shift.

3. Click on the drawing you want to reposition in the Viewer, or use the Previous Drawing / Following Drawing
options in the tool options bar; the related reference drawing bounding box will be displayed.

4. Do any of the following:

• Click and drag inside the bounding box to move the reference drawing.

• Click and drag outside the bounding box to rotate the reference drawing.

• Click and drag the center handle to change the center of rotation.

• Click and drag any corner handle of the bounding box to scale the reference drawing from its center.

5. Repeat the same steps on the second reference drawing.

Tip: To automatically Edit the Position of the reference drawings:

1. Position the frame cursor where you want to draw the inbetween drawing and sketch the path of action line
beteween your reference points.

2. Activate View → Edit Shift.
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3. Ctrl-click and drag to create a path, from the reference point in the first drawing, to the reference point in the
second one. The starting and the ending points will be overlapped at the center of the path.

4. Click and drag the handle along the path to change its shape; the reference drawings will move according to the
handle position and rotate according to the path shape modification.

5. If needed, use the bounding box handles to fix the rotation of the reference drawing.

Note: Clicking and dragging one of the reference drawings will remove the path of action line.

Tip: To Toggle the Shift and Trace visualization:

Activate View → No Shift to toggle the visualization of the reference drawings back to their original position.

Tip: To Reset the position of the reference drawings:

Choose the View → Reset Shift command.

Tip: To Reset the transformations of one of the reference drawings:

In the tool options bar click on either Reset Previous or Reset Following buttons.

Tip: To Create an inbetween drawing using the Shift and Trace feature:

1. Create the first key drawing.

2. Create the second key drawing.

3. Select the cell where you want to create the inbetween drawing.

4. Activate View → Shift and Trace.

5. Sketch the path of action line beteween your reference points.

6. Activate View → Edit Shift and edit the position of the reference drawings.

7. Create the inbetween drawing.
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Editing Animation Levels

Once you have created your animation levels, you may need to work on them in order to add or insert new drawings,
or rearrange the frame sequence.

All the editing can be saved by saving the level, or by saving the scene with the Save All command, thus automatically
saving all of its levels.

11.1 Using the Level Strip

An animation level can be managed in the Level Strip. The Level Strip shows all of the drawings of the current level
(even drawings not currently exposed in the Xsheet/Timeline) according to their numbering order.

Note: In case a frame range of the animation level has been loaded with the Load Level dialog, only the frames within
the allocated frame range will be visible in the level strip (see Using the File Browser ).

When a level is selected, each frame of the strip contains a level drawing, according to the level numbering order.
When a frame in the strip is selected, the related drawing is displayed in the Viewer, replacing any previous displayed
content, to let you work on it more easily.

When one or more frames are selected you can perform standard cut, copy, paste, delete and insert operations. New
drawings can be added, and any sequence can be renumbered. From the Level Strip, drawings can be also exposed in
the Xsheet/Timeline.

When you change the order of the drawings in the Level Strip, or when a drawing is cut, deleted or inserted, and
drawings are exposed in the scene, the Xsheet/Timeline will continue to contain a reference to that particular frame
of the animation level, whatever its content is. When the Xsheet/Timeline contains a reference to a drawing that is
eliminated in the Level Strip, the level name and number turn red, to warn you that there is no drawing available for
that cell anymore.

The width of the level strip pane cannot be resized freely, because it depends on the size of the animation level preview
icons, but it can be customized in the Preferences. . . → Interface dialog.
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Tip: To edit an animation level in the Level Strip:

Do one of the following:

• Select in the Xsheet/Timeline a cell containing a drawing from the animation level you want to edit.

• Right-click the level icon in the Scene Cast and choose Display in Level Strip from the menu that opens.

Tip: To scroll the Level Strip:

Do one of the following:

• Middle-click and drag to scroll up or down.

• Use the mouse wheel to scroll up or down.

• Use the scrolling bars to scroll only within the actual level extent.

• Use the Up Arrow and Down Arrow keys to move one frame up or down.

• Use the Page Up and Page Down keys to scroll the visible frames up or down.

• Use the Home and End keys to scroll up to the beginning or the end of the level strip content.

Tip: To select drawings in the Level Strip:

Do one of the following:

• Click a drawing to select it.

• Click and drag to select a series of drawings.

• Shift-click a frame to extend the selection up to that frame.

• Ctrl-click (PC) or Cmd-click (Mac) the frames to add them to, or remove them from the selection.

• Use the Edit → Select All command to select all of the level drawings.

• Use the Edit → Invert Selection command to invert the current selection of drawings.

Note: The Select All and Invert Selection commands are also available in the menu that opens when right-clicking in
the Level Strip.

Tip: To exit the Level Strip editing mode:

Click a cell or select a frame in the frames area of the Xsheet/Timeline.

Tip: To customize the Level Strip thumbnail size:

1. Choose File → Preferences. . . → Interface.

2. Set the width and height values of the Level Strip Thumbnail Size option.

3. Restart OpenToonz to make the changes effective.
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11.1.1 Editing Level Frames

The level content can be edited one frame at a time, for example for retouching some artwork or copying a part of a
drawing to a different frame, or several frames at the same time, for example to rearrange the drawing sequence.

Tip: To edit a drawing of an animation level:

1. Select the frame in the Level Strip containing the drawing you want to modify.

2. Use the tools to edit the drawing in the Viewer.

Tip: To edit drawings of an animation level with the Edit menu commands:

1. Select the frames you want to edit.

2. Do any of the following:

• Use the Copy command to keep in memory selected drawings for further operations.

• Use the Cut command to eliminate selected drawings from the animation level and keep them in memory for
further operations. The frames elimination causes a gap in the level numbering order.

• Use the Paste command to paste drawings kept in memory in the animation level, starting from the selected
insertion frame. The operation shifts down the following frames, and automatically renumbers them. If before
the insertion frame there is a numbering gap, the pasted frames will fill the gap before starting to shift and
renumber the following frames.

• Use the Paste Into command to paste drawings kept in memory in the frames selected in the level strip, over-
writing their content. If the selection contains less frames than those kept in memory, frames in excess will be
ignored; if the selection contains more frames than those kept in memory, frames in excess will be left as they
are.

• Use the Delete command to delete selected drawings.

• Use the Insert command to insert empty (white) frames before the selection; inserted frames will be as many as
the selected ones. The operation shifts down the following frames, and automatically renumbers them.

Note: All of the Edit menu commands are also available in the menu that opens when right-clicking in the Level
Strip.

Tip: To edit drawings of an animation level with the Cells menu commands:

1. Select the frames you want to edit.

2. Do any of the following:

• Use the Reverse command to invert the order of selected drawings.

• Use the Swing command to append selected drawings to the end of the selection in a reversed order. The last
drawing of the selection will not be repeated.

• Use the Step 2, Step 3 or Step 4 command to repeat selected drawings in order to have a step 2, step 3 or step 4
animation.

• Use the Each 2, Each 3 or Each 4, command to preserve only one drawing each 2, each 3 or each 4, of the
selection, and delete the others.
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• Use the Duplicate Drawing command to make a copy of the first drawing of the selection in the following
frame. If the following frames already contain drawings, the duplicated drawing will be inserted by shifting the
others down in the Xsheet (or right in the Timeline).

• Use the Merge command to paste in the current level the drawings copied from a different level, according to
their original frame position and regardless of the currently selected frames.

Note: All of the Cells menu commands are also available in the menu that opens when right-clicking in the Level
Strip.

11.1.2 Renumbering and Adding Frames in a Level

When you need to add one or several drawings to a level, you first need to create room for the new drawings. This task
can be achieved either using the Insert command (see Editing Level Frames ), or the Renumber. . . dialog.

While the inserting operation automatically shifts the numbering of the following frames in order to make room for
the new ones, the renumbering lets you control the way frames have to be renumbered.

After the renumbering, drawings are rearranged to have an incremental numbering in the Level Strip, where blank
frames are not considered. For example for a level where frames 4 and 5 are renumbered 11 and 12, the Level Strip
will display only five frames correctly numbered 1, 2, 3, 11 and 12.

If you need to add a range of frames to a level, for instance for scanning them or creating some artwork, you can add
it with the Add Frames dialog. This dialog allows you also to insert drawings in a level numbered in an irregular way,
for example after some frames which have been cut or renumbered.

Both the renumbering and the adding frames operation fails if the numbering assigned to the frames is used by already
existing frames.

Note: If the Automatically Create Drawings option is activated in the Preferences. . . → Drawing dialog, when you
want to add a drawing at the end of the sequence simply select the first grey frame available, and draw in the Viewer.

Tip: To renumber drawings of an animation level:

1. Select the drawings you want to renumber; also a non-continuous selection is allowed.

2. Select Level → Renumber. . .

3. In the dialog that opens set the Start Frame number that will be assigned to the first drawing of the selection,
and the Step used to number all following frames in the selection.

Tip: To add drawings to an animation level:

1. Select Level → Add Frames. . .

2. In the dialog that opens sets the frame range you want to add, and the Step used to number the frames in the
range.

Note: The Add Frames and Renumber commands are also available in the menu that opens when right-clicking in
the Level Strip.
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11.1.3 Reverting Level Frames to a Previous Version

In case some mistakes are made during the editing of a level, or during the painting process, e.g. a drawing section is
accidentally deleted, it is possible to retrieve the last saved version of the level frames.

For Toonz Raster levels generated from a cleanup process, it is also possible to retrieve the original cleaned up draw-
ings.

Note: In order to revert to the original cleaned up drawings the Preferences. . . → Drawing → Keep Original Cleaned
Up Drawings As Backup option has to be activated when the cleanup is performed (see Cleaning up Drawings ).

Tip: To reload the level drawings to the last saved version:

1. In the Level Strip select the drawings you want to reload.

2. Do one of the following:

• Choose Level → Reload.

• Right click the selection and choose Reload from the menu that opens.

Tip: To revert to the original cleaned up drawings:

1. In the Level Strip select the drawings you want to revert.

2. Do one of the following:

• Choose Level → Revert to Cleaned Up.

• Right click the selection and choose Revert to Cleaned Up from the menu that opens.

11.2 Merging Animation Levels

Toonz Vector levels and standard Raster levels can be easily merged into a single animation level generated by flatten-
ing them according to their stacking order, using the Xsheet → Merge Levels command. Toonz Raster levels can be
merged using the Xsheet → Merge TLV Levels command.

This can be useful for instance if you are sketching an animation with drawings repeated in several cells and exposed
in several columns, and you want to generate a single sequence of drawings.

In both cases there is no limit to the number of columns/layers you can merge.

11.2.1 Merging Toonz Vector Levels or Raster Levels

Using the Xsheet → Merge Levels command the number of resulting drawings will depend on the number of drawings
exposed in the first Xsheet column on the left of the selection (or in the first Timeline layer on the bottom of the
selection). When merging Raster levels, the resolution of the resulting drawings will depend on the resolution of the
drawings exposed in the first Xsheet column on the left of the selection (or in the bottom Timeline layer on the bottom
of the selection).

Animation levels are merged according to the following guidelines:
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• The frame numbering order is followed; this means that all the drawings exposed at frame 1 will be merged to
the drawing exposed at frame 1 of the first column/layer of the selection.

• If two different drawings are associated at different frames to the same drawing exposed in the first column/layer
of the selection, only the first one will be applied.

• Drawings not corresponding to any drawing exposed in the first column/layer of the selection will be ignored.

• It is not possible to merge columns/layers if more than one level is exposed in any of them.

When levels are merged, any geometrical transformation achieved by editing and moving the related column or pegbar,
will be retained.

For Toonz Vector levels each drawing of the merged levels will be retained as a group of vectors in the resulting level;
the palette of the resulting level will contain all of the styles used in the drawings of the merged levels.

Tip: To merge animation levels:

1. Select the columns/layers where the animation levels you want to merge are exposed.

2. Choose Xsheet → Merge Levels.

11.2.2 Merging Toonz Raster Levels

The Xsheet → Merge TLV Levels allows to combine several columns containing Toonz Raster Levels creating a new
TLV level. The merged columns will be eliminated from the Xsheet/Timeline and replaced with a new TLV level.

Using the Xsheet → Merge TLV Levels command the number of resulting drawings will depend on the frames com-
bination of the involved levels. When merging Toonz Raster levels, the resolution of the resulting level will depend on
the resolution of the drawings exposed in the first Xsheet column on the left of the selection (or in the first Timeline
layer on the bottom of the selection).

Animation levels are merged according to the following guidelines:

• The frame numbering order is followed; this means that the merged level will be created following the frames
numbering.

• If a combination of drawings will be reused, the drawing previously created will be reused.

• Also, the palettes of the selected levels will be merged.

When levels are merged, any geometrical transformation achieved by editing and moving the related column or pegbar,
will be retained.

Tip: It is not possible to merge columns/layers if more than one level is exposed in any of them.

Tip: To merge Toonz Raster (TLV) levels:

1. Select two ore more columns/layers where the levels you want to merge are exposed.

2. Choose Xsheet → Merge TLV Levels

3. Define the File Name and Save in location in the pop up that opens and press Apply.
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11.3 Processing Levels

Some commands are available to process Raster level images in order to adjust their brightness and contrast, to fade
their colors toward a defined set of Red, Green, Blue and Alpha values, to adjust their levels or to binarize them. The
Adjust Thickness command is available to modify the thickness of the lines in Toonz Vector Levels only.

A preview area is available to check the result of the applied processing: you can navigate its content and set its size.

The processed images are stored in the cache and will be saved on disk by using the Save Level, Save All Levels, or
Save All commands.

Tip: To resize the preview area:

Do any of the following:

• Click and drag the horizontal separator.

• Click and drag the separator toward the window border to hide the preview area.

• Click and drag the separator collapsed to the window border toward the window center to display again the
preview area.

Tip: To navigate the preview area:

Do one of the following:

• Use the mouse wheel, or the zoom shortcut keys (by default + and - keys) to zoom in and zoom out.

• Middle-click and drag to scroll in any direction.

• Use the reset view shortcut (by default the 0 key) to display preview at its actual size.

11.3.1 Brightness and Contrast

In case it is needed to adjust drawings in order to increase the darkness and the opacity of the drawing, it is possible to
process them by calibrating the brightness and contrast.This is available only for raster levels.

Tip: To process drawings brightness and contrast:

1. Select the level frames to process in the Xsheet/Timeline or the Level Strip.

2. Choose Level → Adjust → Brightness and Contrast. . .

3. In the dialog that opens set the brightness and contrast variation.

4. Click the Apply button.

11.3.2 Antialias

Allows to add antialias or to make it smoother or harder on Raster and Toonz Raster levels.

Tip: To use the Antialias command:

1. Select the level frames to process in the Xsheet/Timeline or the Level Strip.
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2. Choose Level → Adjust → Antialias. . .

3. In the dialog that opens set the Threshold and Softness values.

4. Click the Apply button.

11.3.3 Adjust Levels

Adjusts the highlights and shadows of the Source content by remapping pixels intensity according to the Input and
Output levels values for the RGB, Red, Green, Blue and Alpha channels.

Tip: To adjust images levels:

1. Select the level frames to adjust in the Xsheet/Timeline or the Level Strip.

2. Choose Level → Adjust → Adjust Levels. . .

3. Adjust the image levels

4. Click the Apply button.

11.3.4 Adjust Thickness

The Adjust Thickness command allows to modify the thickness of the selected lines in the level. If no line is selected
the command acts on the whole level, otherwise it works only on selected lines.

Tip: To adjust the thickness of the lines:

1. Select the level frames to adjust in the Xsheet/Timeline or the Level Strip.

2. Choose Level → Adjust → Adjust Thickness. . .

3. Choose a mode. The modes are: Scale Thickness that scale lines up or down using a percentage value, Add
Thickness that add an amount of thickness to the lines using the current unit, Costant Thickness that apply a
thickness value, ignoring its variations, using the current unit.

4. Set Start and End values.

5. Press the Apply button.

11.3.5 Color Fade

In case it is needed to adjust the drawing colors it is possible to fade the drawings toward a color defined by Red,
Green, Blue and Alpha values. The Intensity, expressed as a percentage, ranges from 0 to 100.The original color will
fade to the color you set according with the Intensity parameter. This is available only for Raster levels.

Tip: To fade drawing colors:

1. Select the level frames to fade in the Xsheet/Timeline or the Level Strip.

2. Choose Level → Adjust → Color Fade. . .

3. In the dialog that opens set the color you want to fade the selection to, by doing one of the following:
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• Set the Red, Green, Blue and Alpha values.

• Click the color thumbnails and use the Style Editor to edit them (see Editing Styles ).

• Move the intensity sliders to set the color values.

4. Click the Apply button.

11.3.6 Binarize

Allows you to process images with colored Raster lines, recognizing basic colors (red, green, blue, cyan, magenta and
yellow) plus black. The process will produce an uniform background color, eliminating shadows and dirty pixels.

The colored lines are identified and all the pixels belonging to each line are changed to the maximum value of the
identified color. Anti-aliasing is removed.

The use of this command is useful to pre-process scanned images, in order to simplify the Cleanup process.

The preview is available to check the result. The Alpha toggle allows to produce images with a transparent back-
ground.

Tip: To binarize images:

1. Select the level frames to process in the Xsheet/Timeline or the Level Strip.

2. Choose Level → Adjust → Binarize. . .

3. Activate the Preview toggle to check the result.

4. Activate the Alpha toggle if you need transparent background.

5. Click the Apply button.

11.4 Saving Levels

All the editing performed in the Level Strip is not saved until you manually save the level. You can also automatically
save all of the editing done on any level of the Xsheet/Timeline by saving the scene using the Save All command (see
Saving and Loading Scenes ).

When saving an animation level it is possible to automatically create a backup file of the previous version by setting
the Backup Scene and Animation Levels when Saving option in the Preferences. . . → Saving dialog section. The
backup version will be created in the same location where the level is saved, and will have an _backup suffix.

Note: An asterisk after the level name in the Level Strip title bar denotes that there are unsaved changes for the
current level.

Tip: To save the current level:

Do one of the following:

• Choose Level → Save Level.

• Right-click in the Scene Cast and choose Save Level from the menu that opens.
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Tip: To save the current level with a different name in a different location:

1. Choose Level → Save Level As. . .

2. In the file browser that opens select a location and name for the level you want to save, and click the Save button.

Note: The Save Level As. . . command creates a copy of the level with a different file name and location, but does
not change the name and location of the level used in the scene.

11.5 Exporting Levels

Animation levels created with OpenToonz can be exported in a variety of image file formats, in order to be used
in third-party software. The levels are exported as a sequence of files named with a progressive four-digits number
written between the file name and the file extension, e.g. animation.0001.tif , animation.0002.tif , etc.
or a single file in case of the .TLV format. File formats available are BMP, JPG, PNG, TGA ,TIF and TLV (the .TLV
format is available only to export vector levels (.PLI); aditional options for the chosen format can be set in the same
way as to when using the Render → Output Settings. . . dialog (see Choosing the Output Settings ).

When exporting Vector levels, the size and resolution of the exported sequence can be defined in the Export Level. . .
dialog. The default size and resolution are those defined in the Camera Settings window, and the preview of the
resulting image is visible in the preview area of the Export Options tab, to understand how the exported images will
be cropped (see Defining Camera Settings ). The size of the exported image can be changed by entering a scale value
in the Scale field.

Note: Any trucking, resizing and animation of the camera is not considered when exporting Vector levels.

The Retas Compliant option can be used to automatically name the exported sequence with a a progressive four-digits
number suffix before the file extension (e.g. animation0001.tga , animation0002.tga , etc.) and set the
exporting format to TGA.

Background Color option allows to set the RGBA values of the background color.

The No Antialias option allows to remove the antialiasing from the exported sequence.

Tip: To export the current level:

1. Choose Level → Export Level. . .

2. In the File Browser tab, select the location and name of the level you want to save.

3. Do one of the following:

• Choose the file format you want the exported level to have.

• Activate the Retas Compliant option to export the level in the same format and with the same options that the
Retas software uses, when exporting painted drawings.

• In the Export Options tab, set the RGBA values for the background color.

• Activate the No Antialias option if you want to remove the anitialias from the exported levels sequence images.

4. If you are exporting a Toonz Vector Level:
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• Set the output size using the Vectors Export Box section options.

• Set Start and End percentage values for the lines thickness.

5. Click the Export button.

Note: The Export Level command creates a new version of the level with a different file name, location and format,
but does not change the name, location and format of the level used in the scene.

Tip: To set the file format options:

1. At the bottom of the window, choose a file Format from the dropdown.

2. Press the Options button for setting additional options for the format previously chosen.
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CHAPTER 12

Managing Palettes and Styles

In OpenToonz, Toonz Vector and Toonz Raster animation levels comes with their own palette, containing styles that
can be used to draw lines and paint lines and areas. Raster levels, on the contrary, can be just edited by using the
styles available in the Raster Drawing Palette, that is shared by all of the raster levels in the project.

In Toonz Vector and Toonz Raster levels, palette styles are interactively “linked” to drawn lines and filled areas by
using indexes. The main advantage of this method is that if you edit a style of the palette, all the lines and filled areas
using that style will be automatically updated. This allows you to change or calibrate colors, even after the painting
process has been done, without having to correct the style line by line, or area by area in the image.

In Raster levels, palette styles are simply used to draw or touch up the image, and no link exists between the styles and
the already drawn lines. This palette, named Raster Drawing Palette, is shared by all the Raster levels belonging to
a specific project and is stored in the +palettes project default folder (see Project Default Folders ).

Note: All the editing performed in palettes and styles is not saved until you save the related Toonz level, the palette
itself, or the Save All command is used (see Saving Levels ).

12.1 The Palette Editor

The Palette Editor displays the styles of the current animation level that are (or can be) used, to draw and paint the
level.
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The default palette of any new Toonz Vector level contains only the plain black color; the default palette of a Toonz
Raster level contains either the plain black color, for new levels, or the colors recognized during the cleanup process,
for cleaned up levels from scans. Any palette always contains the Color_0 item, that allows you to remove any style
from lines and filled areas.

Note: Each palette can contain up to 4096 styles.

Styles in the Palette Editor can be displayed in different modes:

• Small Thumbnails View displays styles as small squares. The style index is displayed at the bottom right
corner. Full name of the style can be displayed as a tooltip.

• Medium Thumbnails View displays styles as medium squares. You can read the first letters of the name of the
style directly inside the chips; the style index is displayed at the bottom right corner. Full name of the style can
be displayed as a tooltip.

• Large Thumbnails View displays styles as large squares. You can read the first letters of the name of the style
directly inside the chips; the style index is displayed at the bottom right corner. Full name of the style can be
displayed as a tooltip.

• List View displays style thumbnails next to their names in a list; the index of the style is displayed as a tooltip.
If the palette styles refer to a studio palette, its path will be displayed along with the style name (see Using the
Studio Palette ).

By default the Palette editor is active, that means that it automatically displays the styles of the current animation level,
but it can be made inactive in order not to be updated when you select a different level. In this way, by opening more
than one Palette editor it will be possible to simultaneously compare and edit several palettes referring to different
animation levels.
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Palettes also can be saved as independent files in TPL format to be loaded back into the scene to retrieve colors, or to
be used with the External Palette effect (see Using the File Browser and External Palette ).

Note: Most of the palette editing described below can be applied to the Palette viewer available in the Studio Palette
as well (see Using the Studio Palette ).

Tip: To change the palette display mode:

Do one of the following:

• Click the option button ( ) on the right of the top bar of the Palette Editor, and choose a display mode from
the menu that opens.

• Use the standard zoom + or - shortcut keys in the Palette Editor to increase or decrease the styles chips size.

Tip: To make the Palette editor inactive or active:

Click the Switch button ( ) on the right of the Palette Editor title bar.

Tip: To save a palette with a different name in a different location:

1. Click the Save Palette As button ( ) in the top bar of the Palette Editor.

2. In the browser that opens choose a location and name for the palette you want to save, and click the Save button.

Note: The Save Palette As command creates a copy of the palette with a different file name and location, but does
not change the name and location of the palette used in the scene.

12.1.1 Arranging Palette Styles and Pages

Palette styles can be added, named, reordered and arranged in pages. They can be copied and pasted from one position
to another, or from one palette to another.

Note: When styles used for painting drawings are Cut, lines and areas painted with them will be displayed in red;
if they are Deleted, you will be prompted whether to delete the styles only and show the lines and areas painted with
them in red, or to delete the lines and areas painted with them as well.

Tip: To select a style:

Do one of the following:

• Click it in the Palette Editor.

• Use the number keys on the main or numerical keyboards to select the corresponding style.
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Note: When in Medium/Large Thumbnails View a visual cue of which key shortcut corresponds to which style is
shown on the upper center of each style chip.

Note: In case of having more than 10 styles in the current palette, you can use the Tab key on the keyboard to switch
to the next bank of 10 styles.

Tip: To select multiple styles:

Do one of the following:

• Shift-click to extend the selection.

• Ctrl-click (PC) or Cmd-click (Mac) to add a style to, or remove it from the selection.

Tip: To add a new style:

Click the New Style button ( ) in the top bar of the palette editor.

Tip: To name a style:

When styles are displayed in Medium/Large Thumbnails View or List View modes, double-click the style name to
edit it.

Tip: To edit palette styles with the Edit menu commands:

1. Select the styles you want to edit.

2. Do any of the following:

• Use the Cut command to eliminate selected styles from the palette and keep them in memory for further opera-
tions.

• Use the Copy command to keep in memory selected styles for further operations.

• Use the Paste Insert command to paste styles kept in memory in the palette, after the currently selected style.
Cut styles will be added preserving their indexes; Copied styles will be added using new indexes.

• Use the Paste Color & Name command to paste styles kept in memory, over the styles selected in the palette,
overwriting their content. If the selection contains less styles than those kept in memory, styles in excess will be
ignored; if the selection contains more styles than those kept in memory, styles in excess will be left as they are.

• Use the Paste Color command to paste the red, green, blue and alpha values of the styles kept in memory in
the styles selected in the palette, preserving their name. If the selection contains less styles than those kept in
memory, styles in excess will be ignored; if the selection contains more styles than those kept in memory, styles
in excess will be left as they are.

• Use the Paste Name command to paste the names of the styles kept in memory in the styles selected in the
palette, preserving their colors. If the selection contains less styles than those kept in memory, styles in excess
will be ignored; if the selection contains more styles than those kept in memory, styles in excess will be left as
they are.

• Use the Delete command to delete selected styles.
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Note: All the Edit menu commands are also available in the menu that opens when right-clicking the selection.

Tip: To move selected styles:

Ctrl-click (PC) or Cmd-click (Mac) and drag the selection to the new position; the insertion point is marked while you
drag.

Tip: To move selected styles into a different page:

Ctrl-click (PC) or Cmd-click (Mac) and drag the selection to the tab of the page where you want to put selected styles.

Tip: To move styles into a new page:

Ctrl-click (PC) or Cmd-click (Mac) and drag the selection to the right of the last page tab: a new page will be created
containing the dragged styles.

Tip: To remove all the unused styles:

Right-click in the palette and choose Remove Unused Styles from the menu that opens.

Tip: To add a new page:

Do one of the following:

• Click the New Page button ( ) in the top bar of the Palette Editor.

• Right-click in the palette area where page tabs are displayed and choose New Page from the menu that opens.

Tip: To name a page:

Double-click the page name to edit it.

Tip: To move a page:

Click and drag the page tab to the new position.

Tip: To delete a page:

Right-click the page tab and choose Delete Page from the menu that opens. The current page cannot be deleted.
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12.2 Using the Studio Palette
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The Studio Palette allows you to store and manage an unlimited number of palettes. It is intended as a library of
character and prop palettes related to one or more specific productions. From here Palettes, or Styles contained in
them, can be retrieved, assigned, or merged to the current level palette, with no need to define the same styles again
and again.

It consists of a Palette Tree and a Palette Viewer: the Palette Tree lists two main folders: Global Palettes and Project
Palettes, and all the folders and palettes you add; the Palette Viewer displays the currently selected palette and allows
you to edit it as a standard palette (see The Palette Window ).

Any level palette can be added to the Studio Palette; if a Color Model is defined for that level, it will be saved along
with the palette and retrieved any time that palette will be assigned to a level (see Using a Color Model ).

Palettes added to the Global Palettes folder will be available in the Studio Palette in any OpenToonz session, regardless
of the current project.

Palettes added to the Project Palettes folder will be available only when the current project is the relevant one. For
example if your current project is Production One, and you add some palettes to the Project Palettes folder, those
palettes will be available only when the current project is Production One.

If you want to add to the Studio Palette a series of palettes you have previously created and stored in a folder, you can
also automatically retrieve them by searching that specific folder.

Styles that are imported from the Studio Palette to the palette of the current level are marked with a small white
square. This reference can be used to link styles to the original Studio Palette styles: the link can be activated or
deactivated anytime for any selection of styles.

When the link is activated, an arrow is displayed on the small white square, and the style will be updated according
to the original Studio Palette style. When the link is deactivated, the style can be modified regardless of the original
Studio Palette style.

Linking animation level palettes to the Studio Palette can assure color consistency for the whole production, because
as soon as a change is needed, it can be done in the Studio Palette, automatically updating all the linked animation
levels palettes and, consequently, drawings.

In the level palette, the information about which Studio Palette the palette styles refers to can be retrieved in the List
View mode, where, next to the style thumbnails and names, the path to the source studio palette is displayed.

When palettes are added to Global Palettes, they are copied to the studiopalette folder located where OpenToonz
projects are stored (see Setting up Projects ).

When palettes are added to Project Palettes, they are copied to the +palettes folder you specified for the current
project (see Project Default Folders ).

These folders can be used, for example, to move your Studio Palette, or the Project Palette, to a different network, or
to make a backup copy of it.

Tip: To add an empty palette:

1. Select the folder where you want to create the new palette.

2. Right-click the folder where you want to locate the palette and choose New Palette from the menu that opens.

Tip: To name a palette:
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Double click its name and type a new name.

Tip: To view a palette in the Studio Palette:

Select it in the Palette Tree.

Tip: To add a level palette to the Studio Palette:

1. Select the level to display its palette.

2. Do one of the following:

• Click the Palette button ( ) in the top bar of the palette editor and drag the current palette to the Studio
Palette folder where you want to locate it. The palette will retain its name.

• Add an empty palette in the Studio Palette editor, right-click it and select Replace with Current Palette from
the menu that opens.

Tip: To add palettes by searching in a computer folder:

1. Select the folder where you want to place palettes retrieved during the search.

2. Right-click the folder and select Search for Palettes from the menu that opens.

3. Browse to the computer folder you want to scan.

Tip: To add a new folder:

1. Select the folder where you want to create the new folder.

2. Right-click the folder where you want to locate your new folder and choose New Folder from the menu that
opens.

Tip: To name a folder:

Double click its name and type a new name.

Tip: To delete a palette or a folder:

1. Select it in the Palette Tree.

2. Right-click the palette or the folder you want to delete and choose Delete Palette from the menu that opens.

Tip: To rearrange palettes in the Studio Palette folders:

Click and drag the palette from the current location to the new one.

Tip: To load a palette from the Studio Palette to the current level palette:
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Do one of the following:

• Click and drag the palette, from the Studio Palette Tree to the Palette button ( ) in the top bar of the Palette
Editor.

• Right-click the palette you want to use and select Load into Current Palette from the menu that opens.

Note: In case the palette misses some styles used to paint the level drawings, you will be prompted whether to delete
the styles only and show the lines and areas painted with them in red, or to delete the lines and areas painted with them
as well.

Tip: To reorder the current palette using a specific Studio Palette as reference:

1. Select the level that uses the palette that has to be modified.

2. Select into the Studio Palette pane the palette you want to use as reference.

3. Right-click the palette and select Adjust Current Level to This Palette.

4. Insert a Tolerance value in the window that opens.

Note: The Tolerance parameter defines the range of RGB values that will be used for matching colors from the curret
palette to those of the Studio Palette. Default value of 0 means no range use, so just colors with the same RGB values
will be reordered and all the others will be added as new colors.

Note: All the colors of the Studio Palette will be transferred into the current palette, all of this colors will show
the Reference to Studio Palette box. The colors that are used in both palettes will be ordered, for positon and color
index, as in the reference Studio Palette. All the colors that are new into the curent palette will be moved after the last
transferred color. Pages will be added when required.

Tip: To merge a palette from the Studio Palette to the current level palette:

Do one of the following:

• Click and drag the palette from the Studio Palette tree to the level palette.

• Right-click the palette you want to use and select Merge to Current Palette from the menu that opens.

Tip: To replace a palette from the Studio Palette with the current palette:

1. Select the palette you want modify in the Global Palette, or Project Palette.

2. Right-click the palette and select Replace with Current Palette.

Tip: To copy styles from the Studio Palette to the current level palette, and vice versa:

1. Select the palette in the Studio Palette to display it in the palette viewer.

2. Select the styles you want to copy in one palette.
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3. Ctrl-click (PC) or Cmd-click (Mac) and drag the selection to the other palette.

Note: If you drag the selection to the right of the last page tab, a new page will be created containing the dragged
styles.

Tip: To activate a Style Link to the studio palette:

1. Select the styles that have been imported from the Studio Palette.

2. Right-click the selection and select Toggle Link to Studio Palette from the menu that opens.

Tip: To deactivate a style link to the Studio Palette:

1. Select the styles that have been linked to the Studio Palette.

2. Right-click the selection and select Toggle Link to Studio Palette from the menu that opens.

Tip: To remove style reference to the Studio Palette:

1. Select the styles that have a reference to the Studio Palette.

2. Right-click the selection and select Remove Reference to Studio Palette from the menu that opens.

Tip: To resize the Studio Palette sections:

Do any of the following:

• Click and drag the separator to resize sections.

• Click and drag the separator towards the pane border to hide a section.

• Click and drag the separator collapsed to the pane border towards the pane center to display again the hidden
section.

12.3 Animating Palettes

For Toonz Vector and Toonz Raster levels, colors in a palette can be animated and changed according to the frames of
the Xsheet/Timeline.

The animation is defined by keys that refer to the absolute timing of the Xsheet/Timeline: this means that there is no
relation between the level length and the length of the animation of the palette colors. For example you can create a
palette animated from frame 1 to 100 even if its level is only five frames long.

The color animation will always refer to the Xsheet/Timeline timing, even if you move the related level to a different
frame range. For example, if you animate a palette from frame 1 to frame 20, and the level is exposed after frame 20,
no color animation will be visible and the color used for the level will refer to the last key of the colors animation.

Keys are set for all the palette Colors and Settings (in the case of Generated styles and Textures) at once, and can be
navigated directly in the Palette Editor (with the expected update of the viewer content) to check the color animation.
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Tip: To define a palette key:

1. Select in the Xsheet/Timeline the frame where you want to define the key.

2. Click the Key button ( ) in the top bar of the Palette Editor.

Tip: To check if the palette has a key at a specific frame:

Select the frame you want to check: if the Key button ( ) in the top bar of the Palette Editor is blue, the colors have
a key at the current frame.

Tip: To navigate the palette keys:

Use the Previous Key ( ) and Next Key buttons ( ) available at the side of the key button in the top bar of the
palette editor.

Tip: To remove a palette key:

1. Do one of the following to select the frame you want to remove the key from:

• Select it in the Xsheet frame column or the Timeline frame ruler.

• Navigate the palette keys.

2. Click the Key button ( ) in the top bar of the Palette Editor to remove it.

12.4 Editing Styles

Palette styles can be modified with the Style Editor. There are four types of styles to choose from: Color, Texture,
Vector and Raster. Under the Vector tab, there are the Generated, Trail and Vector Brushes categories, available
for Toonz Vector levels only. For several types of styles, there is also control over various styles options in the Settings
tab.

An Auto button lets you decide whether the edits have to be assigned automatically to the style, or only after you click
on the Apply button. In the bottom right corner you can see swatches for the previous and new style status; if you
want to go back to the previous style, simply click on it.

Only the first style in the palette, labeled Color_0, cannot be edited: instead, it allows you to remove any style from
lines and filled areas.

Tip: To open the Style Editor as a floating window:

Do one of the following:

• Choose Windows → Style Editor.

• Double-click the style you want to edit in the Palette Editor.
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Tip: To automatically apply the editing to the style:

Activate the Auto button in the Style Editor.

Tip: To apply manually the editing to the style:

1. Deactivate the Auto button in the Style Editor.

2. Click the Apply button every time you want to apply the editing to the style.

Tip: To return to the old style cancelling the editing:

Click the style swatch in the very bottom right corner of the Style Editor.

12.4.1 Colors

Colors can be defined either by Hue / Saturation / Value or the Red / Green / Blue values. They can be used for both
drawing lines and filling areas.

You can also set the opacity with the Alpha slider: the lower the value, the more transparent the color. You can check
the opacity of the color with the checkerboard pattern visible beneath the color, whose visibility is proportional to the
color transparency.

To edit a color you can use either the sliders or the color wheel. To pick a color from the sliders or from the wheel,
click it; to adjust values you can use the arrowhead buttons available at each slider ends.
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Colors can also be picked from the Viewer content by using the RGB Picker tool ( ), whose Type: option lets
you choose the following: Normal, to pick values of a color; Rectangular, to pick the average values of the colors
included in the box you define; Freehand, to pick the average values of the colors included in the area you outline
by clicking and dragging; and Polyline, to pick the average values of the colors included in the area you outline by
defining a series of lines.

If the current style is not a plain color, the color you edit in the Color tab is the color used by the special style. If the
special style uses more than one color, you can select the color to edit in the row of thumbnails available below the
Auto and Apply buttons. (see Special Styles ).

Tip: To pick the color from the viewer content:

1. Select the RGB Picker tool ( ).

2. Do one of the following:

• Click in the viewer to pick the needed color values.

• Set the type to Rectangular, then click and drag in the viewer to define a box which picks the average values of
the colors included in the box.

• Set the type to Freehand, then click and drag in the viewer to outline an area which picks the average values of
the colors included in the area.

• Set the type to Polyline, then click in the viewer to outline an area by defining a series of lines and this will pick
the average values of the colors included in the area.

12.4.2 Textures

12.4. Editing Styles 177



OpenToonz Documentation, Release 1.7.1

Textures can be used both for drawing lines and filling areas. They can be selected from a list available in the Texture
tab, where your own textures can be added as well, or custom textures can be added by clicking the Custom Texture
button.

Texture styles can be used both in Toonz Vector and Toonz Raster levels, but only when applied to Toonz Raster levels
they react to the settings values in the Settings tab (see Texture Settings ).

Image sequences can also be loaded as textures, provided they follow the OpenToonz rules for being detected as
such. In the case an image sequence is loaded as a texture their frames will change with each new frame of the
Xsheet/Timeline, and will cycle when it reaches its last frame.

Tip: To add a new texture to the Texture library:

1. Create the image you want to use as a texture with the following characteristics:

• The number of pixels of the width and height of the image has to be equal to 2 to the power of any number (i.e.
2, 4, 8, 16, 32, 64, 128, 256, etc.); if not, texture images will show stretched.

• The file has to be saved in any of the following formats: TIF, TGA, PNG, BMP, JPG, NOL, RGB and SGI.

2. Save the texture file in one of the following folders: <projectroot>\library\textures or
Opentoonz stuff\library\textures (see Setting up Projects ).

Custom Textures

Custom textures can be loaded for drawing both lines and filling areas. The custom texture will be saved into the
Palette and its icon will be replaced with an icon of the loaded texture.

Tip: To add a custom texture:

1. Select a style in the Palette editor.

2. Go in the Texture tab of the Style Editor and press the Custom Texture button.

3. Go in the Settings tab, use the Load From File field and choose the image (or image sequence) you want to use
as texture.

4. In Toonz Raster levels, press the Preview button to visualize the texture.

Texture Mapping

Texture mapping is the way the texture is applied to the lines or areas using the style. It’s applied differently either if
the level is a Toonz Vector or Toonz Raster one:

• Toonz Vector: Texture mapping is performed using the vector stroke parametric coordinates; this means that for
lines the texture automatically “follows” the stroke’s shape and thickness, whether for areas the texture image
is tiled to cover the area painted with the style.

• Toonz Raster: Texture mapping is performed using standard mapping coordinates; this means that the texture
image is tiled to cover the lines or areas painted with the style.

Note: A more powerful texture mapping can be performed by using the Texture and Pinned Texture special FX (see
Toonz Level ).
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Texture Settings

Textures applied to styles used in Toonz Raster levels allow to set various parameters such as:

• Use As Pattern, allows to use the brightness of the image to modulate the brightness of the plain Color of the
style to which it is applied.

• Position, allows to control how the texture is applied to the drawing. Options include: Fixed (the texture will
be fixed and slide when the character moves), Automatic (the texture will follow the character’s position during
the animation) and Random (the texture position will change at each frame in a random way);

• Scale, allows to set the scale of the texture pattern.

• Rotation, allows to set a rotation angle to the texture pattern.

• X displ and Y displ, allow to offset the texture pattern horizontally or vertically.

• Contrast, allows to change the contrast of the image applied as texture.

12.4.3 Generated Styles

Generated styles use a number of mathematical functions to create effects that can be used either for vector strokes or
for filling areas defined by vectors. They can be selected from a list available in the Generated section of the Vector
tab, where styles suitable for vector strokes have a thumbnail representing how they will look as a diagonal line; styles
suitable for filling have a thumbnail representing the top right corner piece of an area.

Generated styles can simulate for instance a frieze, a leaf, or a pencil stroke along a vector, or allow you to fill areas
with special effects such as polka dots.

Generated styles can be customized by defining the parameters available in the Settings tab. This allows you to have
many similar styles, each with a different configuration of settings.

Colors used by generated styles can be modified by using the Color tab available in the Style Editor.
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The first item available in the list allows you to remove the Generated style, in order to return it to a Color style.

Tip: To change colors used by a generated style:

1. Move to the Color tab in the Style Editor.

2. Edit the color using the wheel and sliders.

3. If the generated style uses more than one color, select the color to edit in the row of swatches available below
the Auto and Apply buttons.

12.4.4 Trail Styles

Trail styles are available for vector levels only. A trail style repeats an image or an animation level, created with
OpenToonz or third party software, along the vectors of a vector level. Trail styles cannot be used to paint areas.

In the Trail section on the Vector tab you can select the image or the animation level you want to use as a style. You
can add to the list your own animation levels as well: both OpenToonz animation levels (PLI) and full-color images
or sequences of full-color images (BMP, JPG, NOL, PIC, PICT, PCT, PNG, RGB, SGI, TGA, TIF and TIFF) are
supported.

Note: PLI levels are rendered according to the vector length and thickness, thus appearing jagged when zoomed in.
If the output format is a vector one, then the PLI level will remain vector-based. (see Choosing the Output Settings ).

The images are repeated changing their placement and size according to the vector’s shape and thickness. If the
animation levels contains different drawings, they are repeated cyclically along the vector length.

Parameters such as the distance between subsequent images along the vector and their rotation can be defined in the
Settings tab (see Settings ).
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Tip: To add a new custom style:

1. Create an image or an animation level with OpenToonz, or with third-party software.

2. Save it in the folder Projectroot\library\custom styles (see Setting up Projects ).

12.4.5 Vector Brush Styles

Vector brush styles are available for vector levels only. A vector brush applies a vector image, created with OpenToonz,
along the vector strokes of a vector level. Vector brush styles cannot be used to paint areas.

In the Vector Brush section of the Vector tab, you can select the image you want to use as a style. You can add to the
list your own PLI images as well.

Note: PLI levels are rendered according to the vector length and thickness, thus appearing jagged when zoomed in.
If the output format is a vector one, then the PLI level will remain vector-based. (see Choosing the Output Settings ).

The Vector Brush image is applyed to each stroke of the drawing that use this style according to the stroke’s shape and
thickness. If the animation levels used as vector Brush contains different drawings, only the first one will be taken into
account.

Colors used by vector brushes can be modified by using the Color tab available in the style editor.

The first item available in the list allows you to remove the Vector Brush in order to return it to a Color style.

Tip: To add a new vector brush:

1. Create a PLI level with OpenToonz.
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2. Save it in the folder Projectroot\library\vector brushes (see Setting up Projects ).

Tip: To change colors used by a Vector Brush style:

1. Move to the Color tab in the Style Editor.

2. Edit the color using the wheel and sliders.

3. If the Vector Brush uses more than one color, select the color to edit in the row of swatches available below the
Auto and Apply buttons.

12.4.6 Raster Brushes

Raster brushes are available to paint in Raster levels and, with some limitations, in Toonz Raster levels. They are
essentially brushes compatible with the MyPaint open source painting software.

The Raster brushes use the Color from the current style as a base, and all its remaining options can be found in the
Settings tab of the Style Editor pane (see Settings for Raster Brushes ).

Note: In Toonz Raster levels, currently only additive Raster brushes can be used (i.e. brushes that add paint to a level,
not the ones that erase, blend or blur already painted strokes).

Note: In Toonz Raster levels, Raster brushes use only the Opacity values of the selected brush to paint with the
current style color, and cannot use any of the other Color related settings of that brush.
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Note: In Toonz Raster levels, Raster brushes can only paint lines (they cannot be used to fill areas).

12.4.7 Settings

The Settings tab is available for defining some style properties.

For Toonz Raster levels, it contains only the Autopaint for Lines option, that can be used to automatically paint border
lines of an area, with the same color used to fill that area (see Using the Autopaint for Lines Option ).

For Toonz Vector levels, it contains parameters only when the style is a Generated or Trail one.

When the style is a Generated one, the Settings tab contains one or more sliders that allow you to finetune the
predefined style to your needs. When the style is a Trail one, the Settings tab contains two sliders: Distance sets the
space between two subsequent images of the animation level used as a trail; Rotation sets the angle of all the images.

You can add the same Generated or Trail style as many times as you want, each time defining different settings for it.
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Settings for Raster Brushes
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Raster brushes have an extensive set of parameters to finetune their behaviour. These parameters can be changed in
the Settings tab of the Style Editor pane. They include:

Basic

• Radius, basic brush radius (logarithmic). 0.7 means 2 pixels; 3.0 means 20 pixels.

• Radius by random, alter the radius randomly in each dab. You can also do this with the by_random input on
the radius setting. If you do it here, there are two differences:. 1) the opaque value will be corrected such that a
big-radius dabs is more transparent. 2) it will not change the actual radius seen by dabs_per_actual_radius.

• Hardness, hard brush-circle borders (setting to 0 will draw nothing).

• Pixel feather, (info needed).

• Eraser, how much this tool behaves like an eraser. 0.0 for normal painting; 1.0 for standard eraser behavior; 0.5
pixels go towards 50% transparency.

• Jitter, add a random offset to the position where each dab is drawn. 0.0 is disabled; 1.0 standard deviation is
one basic radius away; <0.0 negative values produce no jitter.

• Elliptical dab: angle, this defines the angle by which elliptical dabs are tilted. 0.0 makes horizontal dabs; 45.0
produces 45 degree dabs, turned clockwise; 180.0 is horizontal again.

• Elliptical dab: ratio, aspect ratio of the dabs; must be >= 1.0, where 1.0 means a perfectly round dab.

• Direction filter, a low value will make the direction input adapt more quickly, a high value will make it
smoother.

• Snap to pixel, (info needed).

• Pressure gain, change the gain factor for the pressure of the brush.

Opacity

• Opacity, 0 means brush is transparent; 1 fully visible. (also known as alpha).

• Opacity multiply, this gets multiplied with Opacity. It is used for making opaque depend on pressure (or other
inputs).

• Opacity linearize, correct the nonlinearity introduced by blending multiple dabs on top of each other. This
correction should get you a linear (“natural”) pressure response when pressure is mapped to opaque_multiply,
as it is usually done. 0.9 is good for standard strokes, set it smaller if your brush scatters a lot, or higher if you
use dabs_per_second. 0.0 the Opacity value above is for the individual dabs; 1.0 the Opacity value above is for
the final brush stroke, assuming each pixel gets (dabs_per_radius*2) brush dabs on average, during a stroke.

• Lock alpha, (info needed).

Dabs

• Dabs per basic radius, how many dabs to draw while the pointer moves a distance of 1 brush radius (i.e. the
base value of the radius).

• Dabs per actual radius, same as above but the radius actually drawn is used, which can change dynamically
with pressure.

• Dabs per second, dabs to draw each second, no matter how far the pointer moves.
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Smudge

• Smudge, paint with the smudge color instead of the brush color. The smudge color is slowly changed to the
color you are painting on. 0.0 do not use the smudge color; 0.5 mix the smudge color with the brush color; 1.0
use only the smudge color.

• Smudge length, this controls how fast the smudge color becomes the color you are painting on. 0.0 immediately
change the smudge color; 1.0 never change the smudge color.

• Smudge radius, (info needed).

Speed

• Fine speed filter, how slow the input fine speed is following the real speed. 0.0 change immediately as your
speed changes (not recommended, but try it).

• Gross speed filter, same as Fine speed filter, but note that the range is different.

• Fine speed gamma, this changes the reaction of the Fine speed input to extreme physical speed. You will see
the difference best if Fine speed is mapped to the radius. -8.0 very fast speed does not increase Fine speed much
more; +8.0 very fast speed increases Fine speed a lot. For very slow speed the opposite happens.

• Gross speed gamma, same as Fine speed gamma for gross speed.

• Offset by speed, change position depending on pointer speed. = 0 disable; > 0 draw where the pointer moves
to; < 0 draw where the pointer comes from.

• Offset by speed filter, how slow the offset goes back to zero when the cursor stops moving.

Tracking

• Slow position tracking, slowdown pointer tracking speed. 0 disables it, higher values remove more jitter in
cursor movements. Useful for drawing smooth, comic-like outlines.

• Slow tracking per dab, similar as above but at brushdab level (ignoring how much time has past, if brushdabs
do not depend on time).

• Tracking noise, add randomness to the mouse pointer; this usually generates many small lines in random
directions; maybe try this together with Slow tracking.

Stroke

• Stroke threshold, how much pressure is needed to start a stroke. This affects the stroke input only. OpenToonz
does not need a minimal pressure to start drawing.

• Stroke duration, how far you have to move until the stroke input reaches 1.0. This value is logarithmic (negative
values will not inverse the process).

• Stroke hold time, this defines how long the stroke input stays at 1.0. After that it will reset to 0.0 and start
growing again, even if the stroke is not yet finished.. 2.0 means twice as long as it takes to go from 0.0 to 1.0;
9.9 and bigger stands for infinite.
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Color

• Color hue, (info needed).

• Color saturation, (info needed).

• Color value, (info needed).

• Change color hue, change color hue. -0.1 small clockwise color hue shift; 0.0 disable; 0.5 counterclockwise
hue shift by 180 degrees.

• Change color lightness (HSL), change the color lightness (luminance) using the HSL color model. -1.0 blacker;
0.0 disable; 1.0 whiter.

• Change color satur. (HSL), change the color saturation using the HSL color model. -1.0 more grayish; 0.0
disable; 1.0 more saturated.

• Change color value (HSV), change the color value (brightness, intensity) using the HSV color model. HSV
changes are applied before HSL ones. -1.0 darker; 0.0 disable; 1.0 brighter.

• Change color satur. (HSV), change the color saturation using the HSV color model. HSV changes are applied
before HSL ones. -1.0 more grayish; 0.0 disable; 1.0 more saturated.

• Save color, (info needed).

• Colorize, (info needed).

Custom

• Custom input, set the custom input to this value. If it is slowed down, move it towards this value (see below).
The idea is that you make this input depend on a mixture of pressure/speed/whatever, and then make other
settings depend on this ‘custom input’ instead of repeating this combination everywhere you need it. If you
make it change by random you can generate a slow (smooth) random input.

• Custom input filter, how slow the custom input actually follows the desired value (the one above). This happens
at brushdab level (ignoring how much time has past, if brushdabs do not depend on time). 0.0 no slowdown
(changes apply instantly).

12.4.8 Changing the Type of Style

When you select a Color, Texture, Generated, Trail, Vector Brush or Raster brush style in the Style Editor, you
automatically assign it to the current style, thus changing its style type.

A different case is when you want to change back from a Generated, Vector Brush or Raster brush style to a Color
one, because when the current style is one of those types, the Color tab is used for setting their colors. So, in this case
you first have to remove the Generated, Vector Brush or Raster brush styles by using the first swatch available in the
swatch list, and then move to the Color tab.

Also note that when you change from a style suitable for both lines and areas to a style suitable only for lines, the
areas painted with that style will become invisible, and vice versa. For example if you change a style from Color to
Trail, all areas painted with that style will become invisible. If you modify the style so that it’s suitable again for lines
and areas, the invisible parts will become visible again.

Tip: To change the type of style from Color to any other:

Choose an item in the Texture, Vector or Raster tabs.
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Tip: To change the type of style back to Color:

Choose the Color tab and start moving a slider or the selector in the color wheel.

Tip: To change the type of style from Generated, Vector Brush or Raster brush back to color:

1. In the Generated, Vector Brush or Raster brush sections of the Style Editor select the first style in the list (the
top-left most one) to remove any special type from the current style.

2. Choose the Color tab and start moving a slider or the selector in the color wheel.

12.4.9 Editing Several Styles at the Same Time

You can modify several styles at the same time by using the Palette Gizmo. It allows you to scale or shift the value,
saturation, hue and alpha of the selected styles, blend them, or fade them to a specific color.

Note: Only the Color styles are affected by the Palette Gizmo editing and the blending. e.g. Generated and Trail
styles will not be affected.

Tip: To open the Palette Gizmo:

Right-click the selected styles and choose Palette Gizmo from the menu that opens.

Tip: To change the value of the selected styles:

1. Set the percentage of variation or the shift magnitude you want to apply to the styles value.
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2. Do one of the following:

• Click the + button to increase the value on the set percentage or shift magnitude.

• Click the - button to decrease the value on the set percentage or shift magnitude.

Tip: To change the saturation of the selected styles:

1. Set the percentage of variation or the shift magnitude you want to apply to the styles saturation.

2. Do one of the following:

• Click the + button to increase the saturation on the set percentage or shift magnitude.

• Click the - button to decrease the saturation on the set percentage or shift magnitude.

Tip: To change the hue of the selected styles:

1. Set the shift magnitude you want to apply to the styles hue.

2. Do one of the following:

• Click the + button to increase the hue on the set shift magnitude.

• Click the - button to decrease the hue on the set shift magnitude.

Tip: To change the alpha of the selected styles:

1. Set the percentage of variation or the shift magnitude you want to apply to the styles alpha.

2. Do one of the following:

• Click the + button to increase the alpha on the set percentage or shift magnitude.

• Click the - button to decrease the alpha on the set percentage or shift magnitude.

Tip: To blend selected styles:

1. Select a set of styles in the Palette Editor.

2. Click the Blend button: style colors will be blended from the first to the last color of the selected styles.

Tip: To fade the selected styles to a specific color:

1. Choose the color you want to fade the selection to by doing one of the following:

• Set the Red, Green and Blue values.

• Click the color thumbnail and use the Style Editor to edit it (see Plain Colors ).

2. Set the percentage of the fading you want to apply to the styles.

3. Click the Fade button to fade styles to the set color, according to the set percentage.
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12.4.10 Using the Name Editor

The Name Editor allows to systematize the naming of styles used in a production, by defining preset names for
Character, Part and Suffix. In that way, styles in a palette can easily be given significant names that will ease its use
later on the production.

Note: Currently there’s no standard separator character inserted between the different preset names used, so if you
want to have those separated by an underscore, for example, you should insert that character at the beginning or end
of the different names in each category, as shown in the image above.

Tip: To open the Name Editor:

Right-click in the Palette Editor and choose Name Editor from the menu that opens.

Tip: To delete a preset name:

Right-click over the desired preset name and choose Remove from the menu that opens.
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CHAPTER 13

Painting Animation Levels

Toonz animation levels, both those cleaned up, and those made directly in OpenToonz, can be painted by using the
styles, stored in the palette, and a set of tools.

All Toonz level drawings are made of lines (determined by the strokes of scanned or vector drawings), and areas
defined by closed lines. Raster and vector lines can be painted or erased, partially or for their full extent; areas can be
filled with styles, or remain empty, with complete transparency.

Note: All the painting work is not saved until you save the related level, or use the Save All command (see Saving
Levels ).

Note: If the computer performance worsens during the painting process of Toonz Raster animation levels, try ac-
tivating the Minimize Raster Memory Fragmentation option in the Preferences. . . → General dialog section (see
Optimizing the Memory Usage ).

13.1 Painting Tools

Painting operations can be performed by using the Fill tool ( ) and the Paint Brush tool ( ).

In case you want to retrieve a style already used in the drawing, you can pick it with the Style Picker tool ( ).

The filling operation can be performed by activating different options, that can be combined together to perform
particular tasks, for example to fill several areas at the same time with the same style, or several frames, with a single
operation.

The Fill tool ( ) allows you to paint a drawing area or line by clicking it. Options available are the following:

• Type: has the options Normal, to fill an area by clicking in it; Rectangular, to fill all the areas included in the
box you define; Freehand, to fill all the areas included in the area you outline by clicking and dragging; and
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Polyline, to fill all the areas included in the area you outline by defining a series of lines.

• Mode: has the options Areas, to fill only areas, Lines, to paint only the strokes, and Lines and Areas, to
perform both operations.

• Selective prevents the fill operation to be performed on already filled areas.

• Fill Depth sets how much the fill style passes through the antialiasing of the area lines. With low values, even
a very thin line made of semitransparent pixels will be effective to stop de filling operation; with high values,
only the more opaque pixels will stop color from flooding outside. This option applies to Toonz Raster drawings
only. It is possible to set two values: the minimum value is used when using the tool with the standard mouse
click, the maximum value when using the tool with the Shift-click.

• Segment lets you apply the fill only to a segment of raster lines. A segment is determined by an abrupt change
of thickness or direction in the stroke. This is available for Toonz Raster drawings only.

• Onion Skin lets you pick the style to use for the filling operation from other drawings, visible in onion skin
mode, and apply it to the current drawing (see Using Onion Skin ).

• Frame Range allows you to perform the filling on a range of frames, by clicking in the first and then in the last
frame of the range. You can also Shift-click to define the filling position for intermediate frames.

The Paint Brush tool ( ) allows you to paint a drawing area or a line, as if you were using a brush. It is available
for Toonz Raster drawings only. Options are the following:

• Size sets the brush size.

• Mode: has the options Areas, to paint only inside areas, Lines, to paint manually only the drawing lines, and
Lines and Areas, to perform both operations.

• Selective prevents the painting operation to be performed on already painted areas.

13.2 Filling Areas

Areas can be filled when their outline is well-defined, with no gaps occurring along it. For vector drawings, the outline
can be defined by a single vector with overlapping or joined ends, or by different vectors.

Options available for the painting tools can help you to speed up the painting job. You can decide which options are
the most suitable for your task by following the guidelines below.

Note: In Toonz Raster levels, the areas that can be painted are limited either by the image border or by the image
Savebox, according to the Use the TLV Savebox to Limit Filling Operations option available in Preferences. . . →
Tools.

Note: Some styles may not be suitable for filling areas, such as the Trail or Vector styles or some of the Generated
styles. If you select one of these styles in the Palette, and you use it to fill an area, no operation will be performed.

Tip: To fill an area:

1. Select the Fill tool ( ), set the fill type to Normal and the mode to Areas, and select a style in the Palette.

2. Click in the area you want to fill.
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Note: If the filling color doesn’t flood the narrowest areas in raster drawings because of semitransparent pixels, try to
increase the minimum Fill Depth value, or Shift-click to use the maximum value (see Painting Tools ).

Tip: To fill several frames with a single command:

1. Select the Fill tool ( ), set the fill type to Normal and the mode to Areas, and activate the Frame Range
option.

2. Select the first frame of the range and click in the area you want to fill, for example the character’s face.

3. Do one of the following:

• Select the last frame of the range you want to apply the Fill to, and click in the same area, in the example the
character’s face: the areas in all of the frames in the range will be automatically filled according to the first and
second clicking positions.

• Select an intermediate frame of the range you want to apply the Fill to, and Shift-click in the same area, in the
example the character’s face: the areas in all of the frames in the range will be automatically filled according to
the first and second clicking positions. Select another intermediate frame and Shift-click again: the areas in all
of the frames in the new range will be automatically filled according to the second and third clicking positions.
Do the same as many times as you like, then click in the same area on the last frame of the range to complete
the multi frame filling mode.

Note: Since the Fill with the Frame Range option is applied making a linear interpolation from the first clicking
point to the following one, some painting mistakes may occur. The more the area you want to fill moves along the
frame range, the more mistakes may be made.

Tip: To fill several areas at once with the same style:

1. Select the Fill tool ( ), set the fill mode to Areas.

2. Do one of the following:

• Set the type to Rectangular and click and drag to define a box: all the areas completely included in the box will
be filled with the current style.

• Set the type to Freehand and click and drag to outline an area: all the areas completely included in the area you
outline will be filled with the current style. If the ends of the outline you draw are open, the area will be defined
as if joining the two open ends.

• Set the type to Polyline and click to outline an area by defining a series of lines: all the areas completely included
in the area you outline will be filled with the current style. If the ends of the outline you draw are open, the area
will be defined as if joining the two open ends.

Tip: To fill all remaining areas in a level drawing with the same style:

1. Select the Fill tool ( ), set the fill type to Rectangular and the mode to Areas, and activate the Selective
option.
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2. Click and drag to define a box: all the outlined non-filled areas completely included in the box will be filled
with the current style. This option combination may be useful if the drawing has a lot of areas to be painted with
the same style, that can be painted at the end at once by using this command.

Note: You can add to this combination the Frame Range option as well, to perform the same task extended to a
range of frames.

Tip: To fill drawing areas using as reference a previously painted drawing:

1. Activate the onion skin mode to display the painted drawing behind your current drawing (see Using Onion
Skin ).

2. Select the Fill tool ( ), set the fill mode to Areas and activate the Onion Skin option.

3. Click to pick the style to use from the drawing displayed in onion skin mode.

4. Do one of the following:

• Release to fill the area where the cursor is.

• Drag to the area you want to fill and release the mouse button.

Note: If several drawings are displayed in onion skin mode, only the drawing closest to the current one will be
considered.

Tip: To automatically fill a whole drawing using as reference a previously painted drawing:

1. Activate the onion skin mode to display the painted drawing behind your current drawing (see Using Onion
Skin ).

2. Select the Fill tool ( ), set the fill type to Rectangular, the mode to Areas, and activate the Onion Skin
option.

3. Click and drag to define a box: all the areas completely included in the box will be filled with the styles picked
from the painted areas of the drawing displayed in onion skin mode.

Note: If several drawings are displayed in onion skin mode, only the drawing closest to the current one will be
considered.

Note: If some areas are automatically painted with the wrong style, fix them to prevent the mistake to be amplified in
the following frames you are going to paint.

Tip: To retrieve a style from a drawing:

1. Select the Style Picker tool ( ).

2. Click in the area whose style you want to pick. The picked style becomes the current one.
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13.2.1 Closing Gaps in Drawing Outline

If the area outline is not perfectly defined, you will not be able to fill it. The gap can be closed by adding a line with

the Brush ( ) or Geometric ( ) tools (see Drawing Tools ), or by using the Tape tool ( ).

For Toonz Vector drawings the Tape tool ( ) allows you to join vector strokes manually or automatically, both
considering their endpoints and any point along the strokes themselves, according to the tool settings. Options available
are the following:

• Type: has the options Normal, to manually define joining vectors, or Rectangular, to automatically
close all the gaps detected in the box you define.

Note: When the type is set to Rectangular only gaps between endpoints, and between an
endpoint and a line, are considered.

• Mode: has the option Endpoint to Endpoint, to join two lines endpoints; Endpoint to Line, to
join an endpoint to any point along a line; and Line to Line, to join any point along a line to any
other point along another line.

• Distance sets the maximum distance between endpoints, and between an endpoint and a line, that
are automatically joined when using the Rectangular option.

• Join Vectors, when activated, connects the join stroke to the endpoint thus creating a single stroke;
if deactivated the join stroke will be a new independent stroke (see Joining and Splitting ).

Note: If the strokes you are going to join have different styles, the style of the first stroke you
click on will be assigned to the second one, after the joining.

• Smooth, when activated, creates a smooth joined stroke with no corners.

For Toonz Raster drawings the Tape tool ( ) automatically joins the open ends detected in the drawing according to
the tool settings. Options available are the following:

• Type: has the options Normal, to close all the gaps detected in the drawing by clicking in it;
Rectangular, to close all the gaps detected in the box you define; Freehand, to close on all the
gaps detected in the area you define by clicking and dragging; and Polyline, to close on all the gaps
detected in the area you define by drawing a series of straight lines.

• Frame Range allows you to perform the joining on a range of frames, by clicking in the first and
then in the last frame of the range.

• Distance sets the maximum distance between two open ends to be detected, in order to join them.

• Angle sets the maximum angle between two open ends to be detected, in order to join them.

• Style Index sets the style to be used for the line joining the open ends. If instead of a style index
you type current , the currentntly selected style will be used.

• Opacity sets the opacity of the style used for the line joining the open ends.

Note: Please note that by default Opacity value is set to 1, and with this value the gap will be
closed using a transparent line that will not be seen in the Viewer. Also, note that the value of
this option will equally affect how the Gap Check function is displayed in the Viewer.
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Tip: To close a gap in a vector drawing outline:

1. Select the Tape tool ( ), set the type to Normal and set whether to join vectors, or to create a smooth joining.

2. Do one of the following:

• Set the mode to Endpoint to Endpoint, then click a stroke endpoint and drag to a different endpoint; the pointer
snaps to the closest detected stroke endpoint, as start and end.

• Set the mode to Endpoint to Line, then click a stroke endpoint and drag to any point along a stroke; the pointer
snaps to the closest detected stroke endpoint as start, and to any closest point along a stroke as end.

• Set the mode to Line to Line, then click any point along a stroke and drag to any other point along a stroke; the
pointer snaps to the closest point along a stroke as start, and to the any other closest point along a stroke as end.

Tip: To close all gaps in a vector drawing outline in a specific area:

1. Select the Tape tool ( ), set the type to Rectangular.

2. Click and drag to define an area: all the gaps between endpoints, and between endpoints and lines, detected in
the area according to the set distance will be closed.

Tip: To close all gaps in a raster drawing outline:

1. Select the Tape tool ( ).

2. Click in the viewer to close all the gaps detected according to the set distance and angle.

Tip: To close a specific gap in a raster drawing outline:

1. Select the Tape tool ( ) and activate the Rectangular option.

2. Click and drag to define an area: all the gaps detected in the area according to the set distance and angle will be
closed.

Checking Gaps in the Drawing Outline

To control the drawing outline and see if areas are well-defined in order to be filled with colors, it is possible to activate
a series of checks:

• The Gap Check highlights with magenta lines the gaps that can be automatically closed by using the Tape tool

( ) with its current settings; if you change the Distance and Angle values of the Tape tool, while the check is
activated, you can check interactively if the gaps that are detected.

Note: Please note that the Tape tool Opacity value will affect the display of the Gap Check in Toonz
Raster levels, so if it is set to the default value of 1, you will not be able to see anything with the Gap
Check function. Set it to 255 instead, to be able to use this check.
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• The Fill Check displays all the well-defined areas that can be filled with colors in grey, all the lines or vector
strokes in black, and the not well-defined areas and the background in white; if the Black BG Check is activated,
all the lines or vector strokes are displayed in white (see Checking Painted Drawings ).

Note: All the checks can also be combined in order to achieve specific display modes (see also Checking Painted
Drawings ).

Tip: To check if gaps occur in the drawing outline:

Activate or deactivate the Gap Check from the View menu.

Tip: To check if the areas in the drawing are well-defined:

Activate or deactivate the Fill Check from the View menu.

13.2.2 Checking Painted Drawings

To control if all the drawings areas are properly painted, and to see if the filling left small gaps along the lines
antialiasing, or where a certain style is being used to paint lines or areas, it is possible to activate a series of checks:

• The Transparency Check displays all the painted areas in the color defined in Preferences → Colors → Paint
Color, all the lines or vector strokes in the color defined in Preferences. . . → Colors → Ink Color on White
BG (or Ink Color on Black BG, depending on the chosen background color).

• The Ink Check displays the lines or vector strokes, colored with the current style in red.

• The Paint Check displays the areas painted with the current color in red.

• The Black BG Check displays the background color, defined in the Scene Settings, in black (see Customizing
the Viewer ).

Note: All the checks can also be combined in order to achieve specific display modes (see also Checking Gaps in the
Drawing Outline ).

Tip: To activate or deactivate a check:

Activate or deactivate the check from the View menu.

13.3 Painting Lines

Lines of a drawing can be painted with the Fill tool ( ). For Toonz Raster drawings, the Fill tool ( ) affects
continuous lines sharing the same style; for Toonz Vector drawings, only a single vector stroke at a time.

For Toonz Raster drawings, lines can be also painted with the Paint Brush tool ( ) set to Lines mode. In this case
by setting the size of the tool, you can paint any section of the lines as if you were using a brush.
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For Toonz Vector drawings, a vector stroke can be also painted by selecting it first, then selecting the style you want
in the level Palette.

Tip: To paint a Toonz Raster line:

1. Select the Fill tool ( ), set the fill mode to Lines and select a style in the palette.

2. Click the line you want to paint.

Tip: To paint a Toonz Vector stroke:

Do one of the following:

• Select the Fill tool ( ), set the fill mode to Lines, select a style in the Palette and click the stroke you want to
paint.

• With the Selection tool ( ) select the strokes you want to paint, then select a style in the Palette (see Using
the Selection Tool ).

Tip: To partially paint a Toonz Raster line:

Do one of the following:

• Select the Fill tool ( ), set the fill mode to Lines, activate the Segment option, and click the line section you
want to paint.

• Select the Paint Brush tool ( ), set the mode to Lines and use it on the line section you want to paint.

• Use the Paint Brush tool ( ) with the proper style to split a continuous line into sections, then use the Fill

tool ( ) to paint the previously separated sections.

Tip: To paint several separated lines or vector strokes, at once:

1. Select the Fill tool ( ), set the fill mode to Lines.

2. Do one of the following:

• Set the type to Rectangular and click and drag to define a box: all the lines included in the box will be painted
with the current style.

• Set the type to Freehand and click and drag to define an area: all the lines included in the area you defined will
be painted with the current style. If the ends of the area you draw are open, it will be defined as if joining the
two open ends.

• Set the type to Polyline and click to define an area by drawing a series of straight lines: all the lines completely
included in the area you defined will be painted with the current style. If the ends of the area you draw are open,
the area will be defined as if joining the two open ends.

Note: A vector stroke will be painted only if it’s fully included in the area you define.
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Tip: To paint lines or vector strokes, in several frames with a single command:

1. Select the Fill tool ( ), set the fill mode to Lines and activate the Frame Range option.

2. Select the first frame of the range and click the line you want to paint.

3. Do one of the following:

• Select the last frame of the range you want to apply the paint to, and click on the same line: the line in all the
frames in the range will be automatically painted according to the first and second clicking positions.

• Select an intermediate frame of the range you want to apply the paint to, and Shift-click in the same line: the
line in all of the frames in the range will be automatically painted, according to the first and second clicking
positions. Select another intermediate frame and Shift-click again: the line in all of the frames in the new range
will be automatically painted, according to the second and third clicking positions. Do the same as many times
as you like, then click in the same line on the last frame of the range, to complete the multi frame painting mode.

Note: Since the Fill tool ( ) with the Frame Range option is applied making a linear interpolation from the first
to the second clicking point, some painting mistakes may occur. The more the line you want to fill moves along the
frame range, the more mistakes may be made.

Tip: To paint a line using as reference a previously painted drawing:

1. Activate the onion skin mode to display the painted drawing behind your current drawing (see Using Onion
Skin ).

2. Select the Fill tool ( ), set the fill mode to Lines and activate the Onion Skin option.

3. Click to pick the style to use, from the drawing displayed in onion skin mode.

4. Do one of the following:

• Release to paint the line where the cursor is.

• Drag to the line you want to paint and release the mouse button.

Tip: To retrieve a style from a drawing:

1. Select the Style Picker tool ( ).

2. Click the line whose style you want to pick. The picked style becomes the current one.

13.3.1 Using Match Lines

Sometimes it may be useful to split a hand-drawn animation level into several animation levels that can be scanned
separately, and later re-assembled before the painting process. For example you can draw an animation level with some
shadow lines that match perfectly a character animation, then apply them with a color different from the character lines
in order to paint them more easily.

Some other times you may need to merge two or several animation levels into a single one, or automatically add the
same drawing on all of the drawings of an animation level, for example a line closing the drawing areas that fall outside
the shot and that the animator left open.
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In both cases you can use the match lines feature to achieve your tasks, as it allows you to merge the levels exposed in
two columns/layers, and if needed to delete the merged match lines.

Match lines can only be applied to Toonz Raster (TLV) animation levels.

In the Xsheet, when two columns are merged, the column drawings on the right are considered as match lines applied
to the drawings on the left (in the Timeline, when two layers are merged, the layer drawings on top are considered as
match lines applied to the drawings on the bottom).

In both cases it’s possible to define the following:

• Add Match Line Inks preserves the original match line styles and adds them to the destination level palette in
a separate page named match lines.
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• Use Ink: allows you to define which style, among those in the destination level palette, has to be used for the
applied match lines, replacing any original styles the match lines may be painted with.

• Merge Inks if the target level has the same styles (i.e. with the same index and color) as the match lines inks,
the existing styles will be used. Otherwise, the original match line styles will be preserved and added to the
destination level palette in a separate page named match lines.

• Line Stacking Order let you graphically select which of the two columns (left or right) will be drawn on top,
and also how to merge them: Keep Halftones or Fill Gaps

• Line Prevalence sets whether the match lines have to be placed behind the lines of the destination level (value
set to 0), or on top of them (value set to 100).

Note: When the Line Prevalence value is set to 0, the match lines are applied without modifying the
lines in the destination level at all.

When the match lines are applied, any geometrical transformation achieved by editing and moving the related col-
umn/layer or pegbar, will be retained.

Match lines are associated to the animation level drawings according to the following guidelines:

• The Xsheet/Timeline frame numbering order is followed. This means that the match line drawing exposed at
frame 1 will be applied to the animation drawing exposed at frame 1.

• If two different match line drawings are associated to the same drawing of the animation level at different frames,
only the first one (according to the frame numbering order) will be applied.

• For all the drawings not corresponding to any match line drawing, no match lines will be applied.

• Match lines not corresponding to any drawing will be ignored.

• If several animation levels are exposed in the column/layer to which match lines have to be applied, only the
first one (according to the frame numbering order) will be considered.

• If several animation levels are exposed in the column used as match line, all of them will be applied.

• Several match lines can be added to the same animation level, by applying them one at a time.

Applied match lines can be deleted as a whole from the destination level, or it is possible to delete specific lines
according to their style indexes.

Tip: To apply match lines to an animation level:

1. Expose in a column/layer the level you want to apply the match lines to.

2. Expose the match line animation level(s) in another column of the Xsheet, to the right of the previous one (or if
using the Timeline, expose the match line animation level(s) in another layer, above the previous one).

3. Move, scale, rotate the match line drawings if needed.

4. Select the two columns by shift-clicking or click-draging their headers.

5. Choose Xsheet → Apply Match Lines. . .

6. In the dialog that opens choose the styles to be used for the match lines and the line prevalence, and click the
Apply button.

Tip: To delete all applied match lines:
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1. Select the columns/layers, the cells, or the Level Strip frames where the animation level with the applied match
lines is.

2. Choose Xsheet → Delete Match Lines.

Tip: To delete lines by selecting the style index:

1. Select the columns/layers, the cells, or the Level Strip frames where the animation level whose lines you want
to delete is.

2. Choose Xsheet → Delete Lines. . .

3. In the dialog that opens choose the indexes of the styles used for lines you want to delete, and the frames where
you want to apply the deletion.

4. Click the Delete button.

Note: To specify multiple indexes or frames, values have to be separated by a comma; to define a range of values,
you can type the first and the last separated by a dash (e.g. 4-7 will refer to values 4, 5, 6 and 7).

13.3.2 Using the Autopaint for Lines Option

Toonz Raster levels may include colored lines coming from a color cleanup session, or from some applied match line
levels (see Processing Colored Lineart Drawings and Using Match Lines for details).

In most of the cases these colored lines are meant to set the outline of the body shadow, or body highlight, and for this
reason usually they have to be painted with the same color of the shadow or highlight areas they help define.

This task can be performed automatically by setting a special property for the color, so that when you paint an area
defined totally or partially by a line whose color has this property, the line is automatically painted with the same color
you use for the area.

Tip: To set the autopaint property for a color:

1. Select the color in the palette.

2. In the Style Editor select the Settings page and activate the Autopaint for Lines option.

Tip: To automatically paint lines when painting areas:

Paint an area defined totally or partially by a line whose color has the Autopaint for Lines option activated: the line
is automatically painted with the same color you use for the area.

13.4 Using a Color Model

Color models, usually created for accurate color-referencing during a production, in the form of images or animation
levels, can be used while painting animation levels.
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Any image or animation level can be used as a reference by loading it in the Color Model viewer. In case an animation
level is loaded, you can select any frame as a reference at any moment; in this way you can also create color models
made of several drawings, for example one drawing for the Front view of the character, and one for the Back view.

When a color model is loaded for the current level, you can decide to load its palette, thus overwriting the current level
palette, or to keep the current animation level palette.

If the color model is a Toonz Raster or Vector level (TLV or PLI file), it already comes with a palette, whose style
names and page configuration will be preserved.

If the color model is a full-color Raster image or animation level, the palette is automatically generated by extracting
colors from the image, or the first image of the level. If the full-color image contains many shaded colors, the palette
will be optimized to reduce the number of colors.
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Note: Best results can be achieved by preparing models painted with flat colors and whose lines have no antialiasing.

When a color model is loaded for a certain animation level, it is associated to that level and the related palette, and it’s
displayed in the Color Model viewer every time that level is selected.

A color model can be associated to palettes stored in the Studio Palette. In this way every time you assign a palette to
an animation level retrieving it from the Studio Palette, its related color model will be automatically associated to the
level (see Using the Studio Palette for details).

You can also use any drawing belonging to the animation level as a color model to be used on the fly, but in this case
it will neither be associated to the level, nor to the palette saved in the Studio Palette.

When the image is displayed in the Color Model viewer, you can use it not only as visual reference, but also for picking

styles with no need to use the Palette or the Style Picker tool ( ). The color model can also be panned and zoomed
in or out, by using standard shortcuts.

Tip: To load a color model:

1. Do one of the following:

• Choose File → Load Color Model. . . , and load the Toonz level or the full color raster image you want to use
as a reference.

• Right-click in the Color Model viewer and choose Load Color Model. . . from the menu that opens.

• Drag and drop the Toonz level or the full color raster image you want to use as reference to the Color Model
viewer.

2. Choose whether to overwrite current palette with the Color Model palette, or to keep the current animation level
palette.

Note: If you decide to keep the current animation level palette, the current level palette will be applied
to the Color Model as well.

Tip: To select a frame from the loaded color model level:

Do one of the following:

• Use the playback buttons.

• Drag the frame bar cursor.

• Type in the frame bar field the number of the frame you want to view.

Tip: To pick styles from a color model:

Click the area or line whose style you want to pick, whatever your current tool is.

Note: If you are using a Raster image as reference and you decided to keep the current animation level palette, when
you click an area or a line, the closest style available in the palette will be picked.
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Tip: To navigate the color model viewer:

Do one of the following:

• Use the zoom shortcut keys (by default + and - keys) to zoom in and zoom out at specific steps (e.g. 50%, 100%,
200%, etc.).

• Use the mouse wheel to zoom in and zoom out.

• Use the Reset View shortcut (by default the 0 key), or right-click in the viewer and choose Reset View from the
menu that opens, to display the flipbook content at its actual size, centered on the image center.

• Middle-click and drag to scroll in any direction.

Tip: To create a color model from an original drawing:

1. Scan and cleanup, or draw, your color model.

2. Create the needed styles in the palette and paint the image.

3. Save the image and load it as color model whenever it is needed.

Tip: To use a drawing from the current animation level as a model:

1. Select the drawing you want to use as a reference for the current animation level.

2. Right-click in the Color Model viewer and choose Use Current Frame from the menu that opens.

Tip: To store a color model together with a palette in the studio palette:

1. Load the color model to associate it to the current level palette.

2. Store the level palette in the Studio Palette (see Using the Studio Palette for details).

Tip: To associate a color model to a palette already saved in the studio palette:

1. In the Studio Palette select the palette to which you want to associate a color model, and do one of the following:

• Choose File → Load Color Model. . . .

• Right-click the palette in the studio palette tree and choose Load Color Model. . . from the menu that opens
(see Using the Studio Palette for details).

2. Retrieve the color model from the browser that opens.

Note: If the color model uses a palette different from the one stored in the Studio Palette, you will be prompted
whether to keep it or to overwrite it.

Tip: To retrieve a color model stored in the studio palette:
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Load the palette it’s associated to from the Studio Palette as the current level palette (see Using the Studio Palette for
details).

Tip: To remove the association of a palette to a color model:

Right-click in the Color Model viewer and choose Remove Color Model from the menu that opens.
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CHAPTER 14

Working in Xsheet/Timeline

The Xsheet, the digital version of the traditional exposure sheet, allows you to control the timing of all of the elements
of a scene. It is organized in columns and rows: each column contains a layer of the animation and each row represents
a frame contents. Columns are divided into cells, representing the content of that column in a particular frame.

The Timeline is the horizontal counterpart of the Xsheet, it serves the same purpose, and has the same functionality.
The main differences with the Xsheet are that in the Timeline the different levels are laid out in horizontal layers, while
each frame content is represented by the columns of the Timeline.

In both of them, different items, generically called here as levels, can be loaded into the scene: animation levels,
images for the background and overlays, and video clips.

Other OpenToonz scenes can be loaded there as well: they will be nested inside a column/layer, and considered as a
Sub-Xsheet of the current Xsheet/Timeline.

All of the Xsheet/Timeline contents can be checked in the viewer, where the animation can be played back, and the
scene contents edited.

14.1 Using the Viewer

The viewer has different modes of visualizing the scene contents. According to your needs you can view the whole
work area, only the elements included in the current camera shot, or visualize the whole scene in a 3D environment.
The viewer can also be frozen, so that the visualization is not updated until you enter with the pointer in the viewer.
When the preview mode is activated, the viewer can display the rendered animation as in the final render (see Preview-
ing the Animation ).

At the bottom of the viewer another customizable set of buttons is available. Some are used for playback (see Using

the Viewer ), some others are relevant only when using the Animate tool ( ) to animate objects and when previewing
the animation in the viewer (see Animating Objects and Previewing the Animation ).

Additional elements like a field guide, or the table, can be displayed or hidden, and the background color can be set
(see Customizing the Viewer ).
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Fig. 1: Camera Stand view, 3D view and Camera view modes.

Tip: To switch the view mode in the viewer:

Use the buttons available in the viewer title bar to do the following:

• The Camera Stand View button ( ) is for standard view, where any part of the work area can be displayed.
When playing back the scene, the work area stands still, while all of the other elements, including the camera,
move in relation to its position.

• The 3D View button ( ) is for activating or deactivating the 3D view of the elements composing the scene (see
Working in a 3D Environment ).

• The Camera View button ( ) is for keeping the box representing the camera still, while all of the other elements
move in relation to its position. It can help you to better understand the shot when there are camera trucks, or
rotations.

Note: When a frame is selected in the Level Strip, the view mode is set accordingly to display that level only. Pressing
one of these buttons will revert the viewer back to showing the whole scene content.

Tip: To freeze/un-freeze the viewer:

Click the Freeze button ( ) in the viewer title bar to freeze/unfreeze the displayed content; when activated the word
frozen is displayed at the center of the work area.

Tip: To update the viewer content when it is frozen:

Move the pointer over the viewer.

14.2 Using the File Browser

All the elements you need for a scene can be retrieved by using a file browser.
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You can either use the standard OpenToonz file browser to drag and drop levels or folders to the Xsheet/Timeline or
the Scene Cast window, or use the Load Level. . . and Load Folder. . . commands from the File menu. In both cases
you can perform a multiple selection to load several levels or folders at the same time, that will be exposed each in a
separate column; if you use the Load Level. . . command, when loading an animation level you can also specify the
frame range to load. When you use the Load Folder. . . command all the files contained in the folder (if supported) are
loaded into the Xsheet/Timeline.

Note: When a level is loaded, OpenToonz checks if its syntax matches one of the level formats specified into
Preferences. . . → Loading → Level Settings by File Format. In this case the Level Settings specified will be
applied. It is possible to add as many formats as you want, defining them by using a Regular Expression. This way,
different settings can be automatically applied to different kind of levels.

Note: It is possible to Ignore Alpha Channel on Levels in Column 1 by activating the option in Preferences. . . →
Xsheet dialog section.

In the file tree available on the left there are the following main items:

• My Computer contains files and folders located in your computer.

• Network allows the access to network computers.

• My Documents contains files and folders located in the OS My Documents folder.

• Library displays files and folder located in the Projectroot\library folder (see Setting the Projectroot
).

• History contains recently saved scenes, organized in folders, one for each of the last seven days OpenToonz was
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used.

• Projectroot lists all the projects that have been created as folders containing the project information and mate-
rial; the actual path of the projectroot is displayed in brackets (see Using the Project Browser ).

Note: In case more than one projectroot is defined, each will be displayed with the related projectroot path in
brackets (see Setting the Projectroot ).

• Version control repository folder, labeled according to the version control configuration, contains the folders
and files under the version control system (see Using the Version Control ).

Note: In case several repositories are defined, each will be displayed with its appropriate label (see Configuring
the Version Control in OpenToonz ).

You can open folders and sub-folders in order to retrieve files that are displayed in the area on the right. The current
location path is displayed at the top of the browser; existing folders can be renamed and new folders can be created.
Files can be displayed as icons or as a list, displaying additional informations that can be also used to sort them.

Note: The way file icons are generated in the OpenToonz browser depends on the images resolution and on the Level
Strip Thumbnail Size option set for the Level Strip frames in the Preferences. . . → Interface dialog section (see
Using the Level Strip ).

14.2.1 Loading Levels

As part of the scene you can load Toonz Vector and Toonz Raster animation levels (PLI and TLV), Toonz palettes
(TPL), Raster full-color images or image sequences (BMP, JPG, NOL, PNG, RGB, SGI, TGA, TIF and TIFF), video
clips (AVI, MOV, and MP4 and WebM with the aid of FFMPEG, if installed), Photoshop documents (PSD), vector
images (SVG) and audio files (AIFF, WAV and MP3 with the aid of FFMPEG, if installed). Images or clips with alpha
channel information will retain their transparency information, once imported.

Note: It is also possible to load legacy TZU and TZP files created with Toonz version 4.x: in this case the files will
be automatically converted and loaded in the TLV format.

Note: SVG files are automatically converted and loaded in PLI format.

Note: Photoshop files can be loaded taking into account the layers the document is made of (see Loading Photoshop
Documents ).

Single image files can have numbers and letters as part of their names, but they must comply with certain rules to be
considered valid ones. Following are several descriptive examples of valid and invalid image file names:

• Valid name types: a1.tga, 1a1.tga, 1aa.tga, 1aaa.tga

• Invalid name types: 1.tga, 111.tga, 1a.tga, 111a.tga

Image sequences are recognized and loaded by OpenToonz file browser as a single animation level, if they are named
with a progressive four-digits number written between the base file name and the file extension, e.g. animation.
0001.tif , animation.0002.tif , etc. or animation_0001.tif , animation_0002.tif , etc..
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They are displayed in the file browser with a double dot or an underscore and a dot before the file extension: e.g.
animation..tif or animation_.tif

From the browser, you can View images and clips you are going to load as levels by opening a flipbook whose default
shrink factor and step can be set in the preferences dialog, and see the related file information by opening an Info box
(see Using the Flipbook ).

OpenToonz scenes (TNZ files) can be loaded as part of another scene as well, in such a case they are loaded as
Sub-Xsheets (see Loading a Scene as a Sub-Xsheet ).

When you load levels using the standard OpenToonz file browser, you can set whether to automatically expose them in
the Xsheet/Timeline or not, by setting the Expose Loaded Levels in Xsheet option in the Preferences. . . → Loading
dialog section. If activated, each level will be placed in a different column/layer, starting from the first empty one. If
deactivated, the loaded levels will be stored in the Scene Cast, from where they can be selectively exposed in Xsheet
columns or Timeline layers (see Using the Scene Cast ).

If you are loading one or several files located outside the default current project folders, you are prompted whether to
Import them to the project database or to Load them from where they are. In the former case files will be copied to
the appropriate project folder (PLI, TLV levels and their palettes in the +drawings folder; raster images, video clips
and audio files in the +extras folder; standalone palettes in the +palettes folder, etc.) and loaded with a relative path
from this new location (see Managing Projects ); in the latter case they will be loaded using an absolute path to their
original location.

If any of the files you want to import has the same name of a file already existing in the destination project folder, you
will prompted whether to keep the existing file, overwrite it with the new one, or rename it by adding a suffix you can
choose. In this way you can control if files you are importing have already been imported previously, or manage files
that just share the same name.

Note: WARNING: It is heavily recomended to Import assets to the current project folders, as OpenToonz can
ovewrite the files associated with levels exposed in the Xsheet/Timeline, each time the Save Level, Save All Levels,
or Save All commands are invoked.

Note: Files loaded in a scene without importing can be imported later all at once by using the Collect Assets command
(see Collecting Assets ).

Note: The OpenToonz file browser displays only the relevant files that can be loaded in OpenToonz. To check the
full content of a folder you can use the Show Folder Contents option (see below).

Tip: To choose the browser display mode:

Do one of the following:

• Click the Icon button ( ) in the bottom bar of the browser to display files with the related icons.

• Click the List button ( ) in the bottom bar of the browser to display files in a list with related s; click the labels
at the top of the columns to sort files accordingly; right-click the label at the top of the columns to open the
menu that allows to toggle the visualization of the columns.

Tip: To resize the browser sections:

Do any of the following:
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• Click and drag the separator to resize sections.

• Click and drag the separator towards the window border to hide a section.

• Click and drag the separator collapsed to the window border toward the window center to display again the
hidden section.

Tip: To rename an existing folder:

Double-click the folder name and rename it.

Tip: To create a new folder:

Click the new folder button ( ) in the bottom bar of the browser.

Tip: To move one folder up in the file tree:

Click the folder up button ( ) in the bottom bar of the browser.

Tip: To load levels from the Load Level browser:

1. Select the Xsheet/Timeline cell where you want to start exposing the level; if any level is already exposed in that
cell, a new column/layer will be inserted to expose the new level.

2. Do one of the following:

• Choose Level → Load Level. . .

• Right-click in the Xsheet/Timeline cell and choose Load Level. . . from the menu that opens.

3. In the browser that opens select the file you want to load as a level; if you select a video or image sequence file,
you can select the frame range you want to load by using the Load Subsequence Level options.

4. Click the Load button.

Tip: To load levels from the OpenToonz standard browser:

1. Select the Xsheet/Timeline cell where you want to start exposing the level; if any level is already exposed in that
cell, a new column/layer will be inserted to expose the new level.

2. In the OpenToonz browser select the file you want to load as a level.

3. Do one of the following:

• Drag and drop the selection to the Scene Cast pane or to the Viewer.

• Drag and drop the selection to the Xsheet/Timeline cell where you want to start exposing it.

• Right-click the selection and choose Load from the menu that opens.

Note: Files can also be loaded by dragging and dropping them from the Windows Explorer or macOS Finder to the
Scene Cast, Xsheet/Timeline or Viewer.
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Tip: To load folders:

1. Select the Xsheet/Timeline cell where you want to start exposing the levels; if any level is already exposed in
that cell, a new column/layer will be inserted to expose the new levels.

2. Use the File → Load Folder. . . command.

3. In the File Browser that opens select the folder you want to load.

4. Press the OK button.

Note: Folders can also be loaded by dragging and dropping them from the Windows Explorer or macOS Finder to
the scene cast, Xsheet/Timeline, or Viewer.

Note: When a level is loaded, OpenToonz checks if its syntax matches one of the level formats specified in Preferences
→ Loading → Level Settings by File Format. In this case the Level Settings specified when the corresponding Edit
button is opened will be applied. It is possible to add as many file formats as you want, defining them by using a
Regular Expression. This way, different settings can be automatically applied to different kind of levels.

Tip: To load back a recently loaded level:

Choose Level → Open Recent Level File, then select the level you want to load from the available submenu.

Tip: To make a multiple selection in the file browser:

Do one of the following:

• Click to select a file.

• Ctrl-click (PC) or Cmd-click (Mac) to add to or remove a file from the selection.

• Shift-click to extend the selection.

• Right-click in the right area of the browser and choose Select All from the menu that opens to select all the files
contained in the current folder.

Tip: To view a level in the flipbook:

Do one of the following:

• In the OpenToonz browser or in the Xsheet/Timeline right-click the level you want to view and
choose View from the menu that opens.

• Choose Windows → Flipbook and drag and drop in the window the file you want to view.

Note: By opening several Flipbook windows you can view several levels at the same time.

Tip: To set the default shrink factor and step for the file Viewer:
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1. Choose File → Preferences. . . → Interface.

2. Set the default Viewer Shrink and Step values.

Tip: To view a level file information:

In the OpenToonz browser or in the Xsheet/Timeline right-click the level whose info you want to view and choose
Info from the menu that opens; if the file is a video or a sequence of images, use the slider at the bottom of the box to
change the current frame and see the related information.

Tip: To view the entire contents of the current folder:

Right-click in the right area of the browser and choose Show Folder Contents from the menu that opens: the entire
folder contents are displayed in a default OS window.

14.2.2 Loading Photoshop Documents

Photoshop documents (PSD files) can be loaded as a scene element in OpenToonz taking into account the layers the
document is made of, and their layering order; text layers are considered as standard layers, while layer styles are
considered only when loading the document as a single image (see below).

Supported formats are RGB or grayscale images, using 8 or 16 bits per channel color depth.
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When a Photoshop document is loaded, a dialog opens to set the way the document has to be exposed in the Xsheet.
Options are the following:

• Single Image, flattens all the document layers into a single image. Only layers that were visible when the
Photoshop document was saved are considered. The level name and path in Level Settings, and the scene cast,
refer to the original name of the Photoshop document (see Editing Level Settings and Using the Scene Cast ).

Note: Photoshop documents can be loaded as a Single Image only if the Maximize Compatibility option
was checked when saving the original file from Photoshop. If the option was deactivated, a dummy image is
displayed instead; loading and saving again the document with the option activated fixes the problem.

• Frames, loads each document layer as a frame, and exposes them as a sequence in an Xsheet column. Any layer
group defined in the original document is ignored. The level name and path in Level Settings, and the Scene
Cast, refer to the original name of the Photoshop document with the #frames suffix (see Editing Level Settings
and Using the Scene Cast ).

• Columns, loads each document layer as a column, and it is possible to automatically create a Sub-Xsheet
containing the columns by activating the Expose in a Sub-Xsheet option.

When a Photoshop document is loaded as Columns, it is also possible to set how new Level Names asre assigned.
Options are the following:

• FileName#LayerName, uses the PSD file name and layer names as the names of newly created levels.
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• LayerName, uses the PSD layer names as the names of newly created levels.

When a Photoshop document is loaded as Columns, it is also possible to set the way groups of layers have to be
considered. Options are the following:

• Ignore groups, overlooks any group of layers defined in the document, and each layer is exposed in a different
column. The level name and path in Level Settings, and the scene cast, for each level refer to the original name
of the Photoshop document with the #layerName suffix (see Editing Level Settings and Using the Scene Cast ).

• Expose layers in a group as columns in a Sub-Xsheet, creates for each group a Sub-Xsheet containing each
layer of the group as a column. If a group contains other groups, the Sub-Xsheet will contain other Sub-Xsheets
that will contain the related layers as columns. The level name and path in Level Settings, and the scene cast,
for each level refer to the original name of the Photoshop document with the #layerID suffix (see Editing Level
Settings and Using the Scene Cast ).

• Expose layers in a group as frames in a column, creates for each group a column containing each layer of the
group as a cell. If a group contains other groups, they will be ignored. The level name and path in Level Settings,
and the scene cast, for each level refer to the original name of the Photoshop document with the #groupID#group
suffix (see Editing Level Settings and Using the Scene Cast ).

Note: In order to be properly displayed in the final rendering, images based on Photoshop document layers have to be
premultiplied either using the Premultiply option in the Level Settings dialog, or the Premultiply effect (see Editing
Level Settings and Premultiply ).

14.2.3 Executing Tasks in the File Browser

Some tasks concerning files can be executed directly in the File Browser.

Files can be duplicated, converted to a different format, converted to TLV (Toonz Raster image) format, renamed,
premultiplied, and you can choose to separate their colors.

When duplicating files, the new files will be renamed by appending an underscore followed by progressive numbering.

You can also separate the colors of an image or image sequence by using the Separate Colors. . . command. For more
details on its options, please see the Separate Colors section.

When renaming, files will be renamed according to the name you specify; an option allows you also to delete the
original files. This can be used both for renaming sequences of image files in one shot, and for converting sequence
numbering modes to the OpenToonz standard one (i.e. a progressive four-digits number written between the file name
and the file extension) by selecting only the first file of a sequence.

When premultiplied, the file alpha channel is modified to be properly displayed in OpenToonz. Images which have a
meaningful alpha channel come in two types: premultiplied or straight. A non-premultiplied (straight) image can be
recognized when it’s loaded in OpenToonz because its edges, where there is a complete transparence on one side and
opacity on the other, are not smooth, but displays show a solid halo; by premultiplying the image it’s possible to fix
this problem. This is available only for full-color images.

When converting files, a dialog prompts the frame range to convert, a saving location, a name, the new format with
related options and a color for the background of the converted file. It is also possible to select more files at once but,
in this case, the frame range and the file name fields won’t be available. All levels, images and clips supported by
OpenToonz can be converted. The PLI vector files can also be converted to the SVG format.

Note: The Convert. . . command is also available in the File menu as Convert File. . . .

When converting files to TLV format, it’s possible to choose the painted or unpainted TLV formats; all levels, images
and clips supported by OpenToonz can be converted, except for PSD files.
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The conversion to the unpainted TLV format is available when one or several files are selected and it’s meant for lineart
images: the images and levels are converted into black lineart images with a transparent background, so that they can
be painted with the same techniques and tools you can use for other Toonz Raster levels (see Painting Animation
Levels ). In particular if images have some transparency, transparent pixels remain transparent, while solid pixels are
transformed into black ones; if images have no transparency, white and lighter pixels will be assumed as transparent,
while dark pixels are transformed into black ones.

The conversion to the painted TLV format is available when two files are selected or when the selected files are Raster
Full color without antialiasing. In the case of the two files, one is meant to be the lineart and the other a painted version
of the same image: the images and levels are converted into painted lineart images with a palette, so that they can be
edited with the same techniques and tools you can use for other Toonz Raster levels (see Managing Palettes and Styles
and Painting Animation Levels ). In the case of conversion from Raster Full color without antialiasing, an Heuristic is
used to recognize lines and painted areas creating a TLV level where the lines are seen as ink and the painted areas as
paint.

In particular if images have some transparency, transparent pixels remains transparent, while solid pixels are trans-
formed into lines according to their color; if images have no transparency, white and lighter pixels will be assumed as
transparent, while dark pixels are transformed into black lines.

Note: When converting to the TLV format, sequence numbering modes different from the OpenToonz standard one
(i.e. a progressive four-digits number written between the file name and the file extension) are supported, so that only
the first file of a sequence is required to be selected to include the whole sequence in the conversion.

Tip: To Duplicate files:

1. Select the files you want to duplicate.

2. Right-click any of the selected files and choose Duplicate from the menu that opens.

Tip: To Rename files:

1. Select the files you want to rename.

2. Right-click any of the selected files and choose Rename from the menu that opens.

3. In the dialog that opens assign a new name to the file and choose whether to Delete Original Files by activating
the related option.

4. Click the Rename button.
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Tip: To Premultiply full-color images:

1. Select the files you want to premultiply.

2. Right-click any of the selected files and choose Premultiply from the menu that opens.

Tip: To Convert a file to a different format:

1. Right-click the file you want to convert and choose Convert. . . from the menu that opens. The Convert window
change depending on the format of the selected files.

2. Choose the frame range to convert, the saving location, a name, the new format, and the background color of
the converted file.

3. Activate the Skip Existing Files to to prevent overwriting already exixting files.

4. If needed, set the options for the file format chosen pressing the Options button and inserting the new values.

5. Click the Convert button.

Tip: To Convert several files at once to a different format:

1. Select the files you want to convert.

2. Right-click any of the selected files and choose Convert. . . from the menu that opens.
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3. Check the number of files you are going to convert reading the value from the header of the Convert window.

4. Choose the saving location, the new format, and the background color of the converted files.

5. Activate the Skip Existing Files to to prevent overwriting already exixting files.

6. If needed, set the options for the file format chosen pressing the Options button and inserting the new values.

7. Click the Convert button.

Tip: To Convert files to the unpainted TLV format:

1. Select the lineart files you want to convert.

2. Right-click any of the selected files and choose Convert from the menu that opens.
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3. Select Unpainted tlv from the Mode drop down menu.

4. Choose the saving location and, if you have selected one sequence, the frame range.

5. Activate the Skip Existing Files to to prevent overwriting already existing files.

6. Activate the Apply Autoclose.

7. Choose how to manage Antialiasing fom the drop down menu. You can preserve the original antialiasing
selecting Keep Original Antialiasing; add some antialiasing selecting Add Antialiasing with Intensity: and
writing an intensity value in the righthand input field; remove the antialiasing selecting the Remove Antialiasing
using Threshold: option and writing a threshold value in the righthand input field.

8. Choose how to manage the Palette of the TLV file(s) you are going to create. By default a new palette will be
created. If you prefer to use an existing palette press the button next the palette field and use the Browser to
locate the palette file (TPL) you wish to use. Set a Tolerance value for the correlation between the RGB value
of the areas and the indexes color of the palette.

9. Click the Convert button.

Tip: To Convert files to the painted TLV format from two images:

1. Select the lineart file and the painted version of the same file you want to convert.
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2. Right-click any of the selected files and choose Convert. . . from the menu that opens.

3. Select Painted tlv from two images from the Mode drop down menu.

4. Choose the saving location and, if you have selected one sequence, the frame range.

5. Activate the Skip Existing Files to to prevent overwriting already existing files.

6. Choose the folder where the unpainted files are located.

7. Specify the Unpainted File Suffix used for naming the unpainted version of the files (default is _np, but you can
use anything you like when preparing the files for convertion).

8. Activate the Apply Autoclose.

9. Choose how to manage Antialiasing fom the drop down menu. You can preserve the original antialiasing
selecting Keep Original Antialiasing; add some antialiasing selecting Add Antialiasing with Intensity: and
writing an intensity value in the righthand input field; remove the antialiasing selecting the Remove Antialiasing
using Threshold: option and writing a threshold value in the righthand input field.

10. Choose how to manage the Palette of the TLV file(s) you are going to create. By default a new palette will be
created. If you prefer to use an existing palette press the button next the palette field and use the Browser to
locate the palette file (TPL) you wish to use. Set a Tolerance value for the correlation between the RGB value
of the areas and the indexes color of the palette.

11. Click the Convert button.
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Tip: To Convert files to the painted TLV format from non AA source:

1. Select the raster full color file you want to convert.

2. Choose the saving location and, if you have selected one sequence, the frame range.

3. Activate the Skip Existing Files to to prevent overwriting already existing files.

4. Choose the output folder.

5. Activate the Apply Autoclose if needed.

6. Choose how to manage the Palette of the TLV file(s) you are going to create. By default a new palette will be
created. If you prefer to use an existing palette press the button next the palette field and use the Browser to
locate the palette file (TPL) you wish to use.

7. Click the Convert button.
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Separate Colors

The Separate Colors feature, allows for separating single drawing by colors of pencils, generating independent image
files to make it easier to use them in a subsequent compositing workflow.

Unlike conventional threshold-based algorithms, this feature can produce more natural results, since it separates pixels
in a more flexible way, by using the HLS color space.

Note: Currently this is a “utility” feature, which means that it’s independent from the current loaded scene or active
project. It just works on selected raster image files in the File Browser.

The produced output images contain an alpha channel equal to the line intensity.

Note: You can compose the line by loading the separated images as levels, or you can also connect the levels to a
MatteIn effect with some color card if you would like to alter the line color.

The available parameters are:

• Preview Frame:, defines the frame to be shown in the preview area.

• Show Mask, shows the Alpha Matting parameters results in the preview area.

• Show Alpha, shows the generated alpha channel in the preview area. This is the alpha channel that will be
present in the new generated image files, product of the separation work.

• Pick Color, lets the user pick a color from the left preview area. The picked color will be assigned to the
currently selected color swatch.
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Note: You can click and drag over any of the preview area images to pick an average color for the defined
rectangle.

• Paper Color:, allows to define the paper color, used to calculate transparency of the separated images.

• Main Color:, allows to define the color for the main ink in the drawings. For better results, it’s advised to pick
the darkest color possible.

• Sub Color1:, Sub Color2: and Sub Color3:, allows to define the color for the other respective color inks in
the drawings you whish to separate. For better results, it’s advised to pick the deepest (darkest, more saturated)
color possible.

Note: The Sub Color3: parameters will only show when Sub3 suffix is enabled, in the File Suffix:
parameters area.

• Sub Adjust:, allows to adjust the prevalence of sub-colors with respect to the black ink.

• Border Smooth, allows to make the intersection of lines having different colors smoother.

• Alpha Matting, allows to better remove noisy backgrounds, while preserving subtle faint parts of the pencil’s
stroke at the sme time.

Note: To be able to preview the Alpha Matting, the Show Mask option at the top of the preview area should
be activated.

• Mask Threshold, allows to make the noisy background pixels transparent.

Note: The regions to become transparent background in the output image are shown in red or
blue colors in the preview area.

• Mask Radius, can create a solid border area around the detected colored strokes, to preserve subtle
faint parts of them.

• Start: and End:, when separating image sequences it allows to set a frame range for the color separation work
to be done.

• Format:, defines the file format to use for the new generated files. Available options are: PNG and TIF.

• Save in:, defines where the new generated files will be saved.

• File Suffix:, allows the definition of file suffixes for the Main, Sub1, Sub2 and Sub3 color generated image
files.

Note: If Sub3 is enabled the left preview area will change to accomodate the new separation color. Also,
and additional Sub Color3: option will show in the right parameters area.

• Auto, toggles the automatic preview of the separation in the left preview area.

• Preview, allows to manually preview the separation in the left preview area. Only active when the Auto option
is disabled.

• Separate, executes the color separation operation on the selected files.
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Tip: To Separate Colors of an image into separate image files:

1. Right-click the file you want and choose Separate Colors. . . from the menu that opens. The Separate Colors
window shows, where you can select several options for the operation.

2. Choose the appropriate preview and separation options for the desired result.

3. Press the Separate button to execute the color separation job.

4. Close the window by pressing the Close button.

14.3 Exposing Levels

Toonz level files, images for backgrounds and overlays, audio files, video clips, and other OpenToonz scenes, have to
be exposed in the Xsheet/Timeline columns in order to be part of the scene.

If the asset you want to use has already been loaded but not exposed, or it was removed from the scene, it can be
retrieved from the Scene Cast window.

In case you need to retrieve some specific drawings from an animation level, you can display it in the Level Strip, in
order to select the drawings to expose.

Note: Animation levels you define directly in the scene, for instance levels you scanned, or drew directly in Open-
Toonz, are automatically exposed in the Xsheet/Timeline.

14.3.1 Using the Scene Cast

All the animation levels you create or load in the scene are stored in the Scene Cast pane. Levels remain available
in the Scene Cast even if they are not used in the scene anymore. From the Scene Cast, they can be exposed, edited,
saved and removed.
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In the tree available on the left you can find the following:

• A clapboard icon referring to the current scene.

• The Cast folder containing all the animation levels you create or load.

• The Audio folder containing all the audio files you load or create (see Creating a Soundtrack ).

You can create new folders and sub-folders where animation levels can be arranged. The current location path in
the cast tree is displayed in the cast top bar; folders can be renamed and new folders can be created. Levels can be
displayed with related icons, or in a list displaying additional informations that can be also used to sort files.

Note: Animation levels that are no longer available at the defined path are identified by a red color.

Tip: To display all the cast elements of a specific folder:

Click the folder icon in the cast tree on the left of the pane.

Tip: To display all the cast elements:

Click the clapboard icon at the top of the cast tree on the left of the pane.

Tip: To choose the cast display mode:

Do one of the following:

• Click the Icon button ( ) in the bottom bar of the cast to display levels with the related icons.
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• Click the List button ( ) in the bottom bar of the cast to display levels in a list; click the labels at the top of
the columns to sort files accordingly.

Tip: To resize the Scene Cast sections:

Do any of the following:

• Click and drag the separator to resize sections.

• Click and drag the separator towards the window border to hide a section.

• Click and drag the separator collapsed to the window border towards the window center to display again the
hidden section.

Tip: To rename an existing folder:

Double-click the folder name and rename it.

Tip: To create a new folder:

Click the New button ( ) in the bottom bar of the cast.

Tip: To move one folder up in the cast tree:

Click the folder up button ( ) in the bottom bar of the cast.

Tip: To perform a selection:

Do one of the following:

• Click to select a level.

• Ctrl-click (PC) or Cmd-click (Mac) to add a level to or remove it from the selection.

• Shift-click to extend the selection.

Tip: To move levels to a folder:

Select them and drag them to the folder in the cast tree.

Tip: To expose the selection:

Do one of the following:

• Choose Level → Expose in Xsheet.

• Right-click the selection in the Scene Cast and choose Expose in Xsheet from the menu that opens. In case of a
multiple level selection, each level will be placed in a different column/layer, starting from the first empty one.

• Drag and drop the selection to the Xsheet/Timeline cell where you want to start exposing it. In case of a multiple
level selection, each level will be placed in a different column/layer.
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Tip: To display an animation level in the Level Strip:

Do one of the following:

• Select it in the Scene Cast and choose Level → Display in Level Strip.

• Right-click it in the Scene Cast and choose Display in Level Strip from the menu that opens.

Tip: To remove the selected elements:

Right-click the selection in the Scene Cast and choose Remove Level from the menu that opens.

Note: Levels can be removed only if they are not used in the scene.

Tip: To remove all the unused elements:

Do one of the following:

• Choose Level → Remove All Unused Levels.

• Right-click in the Scene Cast and choose Remove All Unused Levels from the menu that opens.

14.3.2 Using the Level Strip

When an animation level is displayed in the Level Strip, you can select the specific drawings you want to expose in
the Xsheet/Timeline. This feature may prove useful especially when you need to retrieve some drawings that belong
to the level, but that are not available in the Xsheet/Timeline cells.
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Tip: To display an animation level in the level strip:

Do one of the following:

• Select any level drawing exposed in the Xsheet/Timeline.

• Select it in the Scene Cast and choose Level → Display in Level Strip.

• Right-click it the Scene Cast and choose Display in Level Strip from the menu that opens.

Tip: To select drawings in the Level Strip:

Do one of the following:

• Click to select a drawing.

• Ctrl-click (PC) or Cmd-click (Mac) to add a drawing to or remove it from the selection.
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• Shift-click to extend the selection.

Tip: To expose the selection:

Do one of the following:

• Copy and paste the selection in the Xsheet/Timeline, into the cell you want.

• Right-click in the Level Strip selection and choose Expose in Xsheet from the menu that opens.
Drawings will be exposed at the beginning of the first empty column.

• Drag and drop the selection to the Xsheet/Timeline cell where you want to start exposing it.

• Drag and drop the selection to the Xsheet/Timeline cell where you want to start exposing it and keep
the Shift key pressed, to insert them if other content is already exposed in the destination cells.

• Drag and drop the selection to the Xsheet/Timeline cell where you want to start exposing it and keep
the Alt key pressed, to overwrite any other content previously exposed in the destination cells.

Note: When it is not possible to expose the selection, a red outline is displayed instead of the selection.

14.3.3 Replacing Levels

An animation level exposed in the Xsheet/Timeline can be easily replaced by another animation level, preserving any
editing performed in the sequence of drawings exposed in the column/layer cells. In this way it is possible to reuse
the same edited sequence for different levels. For example you can reuse the edited sequence of a character level for
the related shadow level by copying and pasting the character sequence, then replacing the character level with the
shadow one.

It is possible to replace the level as a whole, or limited only to selected cells. In both cases only the content of the
selected cells will be replaced: if any drawing of the replaced level is exposed somewhere else in the Xsheet/Timeline,
it will not be affected by the replacing operation.

In case the new level does not contain some of the frames you are going to replace, the level name and number in the
cell turn red to warn you that there is no drawing available for that cell.

The original level is preserved in the Scene Cast from where it can be retrieved, or removed (see Using the Scene Cast
).

Tip: To replace a level in the Xsheet/Timeline:

1. Select the cells where the level you want to replace is exposed.

2. Do one of the following:

• Choose Level → Replace Level. . . .

• Right-click the selection and choose one of the options in the Replace Level submenu, from the menu that
opens.

3. In the browser select the new level, and click the OK button (see Using the File Browser ).
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14.4 Editing Level Settings

Once a level is exposed, its properties (path, DPI, subsampling, etc.), can be controlled in the Level Settings dialog.
Settings are the following:

• Name is the name used to identify the level, by default it is the same name of the file.

• Path displays the location of the file, using default folder aliases if needed. By typing in this field, or using the
browser button, you can update the path to a different location, or to different file.

Note: If in the browser you choose any project default folder, in the path field the full path will be replace by
the related default folder alias (see Project Default Folders ).
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• Scan Path displays the location of the scanned images that were cleaned up to obtain the actual level (see
Cleaning-up Scanned Drawings ). This is available only for Toonz raster levels.

• DPI lets you change the level DPI, thus changing its size. To return to the original image DPI set the option
menu above to Image DPI.

• Forced Squared Pixel forces a level that has a different horizontal and vertical DPI, and therefore is displayed
stretched, to have the pixel shape squared, and thus to be displayed properly.

• Width and Height let you set a different size for the level, thus changing its DPI. The level maintains its A/R.

• Use Camera DPI button applies to the level automatically the camera DPI. It is useful when the level has the
same size of the camera but different DPI, and you want it to match perfectly the camera.

• Information about Camera DPI, Image DPI and image Resolution are displayed for reference purposes.

• Premultiply premultiplies the alpha channel of the level. Images which have a meaningful alpha channel come
in two types: premultiplied or not. A non-premultiplied image can be recognized when it is loaded in OpenToonz
because its edge, where there is a complete transparence on one side and opacity on the other, is not smooth, but
displays a solid halo. With the premultiply operation it is possible to transform the image alpha-channel so that
it is correctly displayed in OpenToonz camera stand, preview and rendering.

• White As Transparent sets the pure white color (i.e. with red, green and blue values to 255) as transparent and
automatically adds some antialiasing to the level images. This option is meant for animation levels generated
from third-party software (such as Retas) that do not have a transparent background but a solid white one, and
whose lines do not have antialiasing.

• Add Antialiasing gives the user the possibility to add antialiasing to the level. The antialiasing value has to
be specified in the Antialias Softness field, which can range from 0 to 100. This option is available on Toonz
Raster and Raster levels.

• Subsampling sets the simplifying factor to be applied to animation levels, clips and images when displayed in
the work area in order to have a faster visualization and playback; for example if it is 2, one pixel every two
pixels is displayed. The default values are defined in Xsheet → Scene Settings dialog, where values for raster
(Image) and toonz raster (TLV) level subsampling can be defined.

Note: The subsampling factor can also be applied to all the animation levels exposed in selected columns by
right-clicking the header of any selected column and choosing one of the Subsampling commands from the
menu that opens.

Tip: To open the Level Settings dialog:

Do one of the following:

• Select a level in the Xsheet/Timeline and choose Level → Level Settings. . . .

• Right-click a level in the Xsheet/Timeline and choose Level Settings. . . from the menu that opens.

• Right-click a level in the Scene Cast and choose Level Settings. . . from the menu that opens.

14.5 Xsheet Toolbar
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The Xsheet Toolbar, at the top of the Xsheet and Timeline panes, is a place where the user can display favorite
OpenToonz tools and commands to have them readily available.

The Xsheet Toolbar pane can be toggled depending on user preferences.

Note: If the Xsheet Toolbar is too short to display all the command buttons, a double-arrow symbol will appear at the
right end of it, allowing to display a drop down menu with the rest of them.

Tip: To toggle the Xsheet Toolbar:

Do one of the following:

• Right click on any column/layer header and choose Toggle Xsheet Toolbar from the menu that opens.

• Activate the File → Preferences. . . → Xsheet → Show Toolbar in the Xsheet option.

Note: When the Xsheet Toolbar is shown, it’s also possible to activate the Expand Function Editor Header to
Match Xsheet Toolbar Height option to correctly match the frame rows in both editors, when put side by side.

Tip: To customize the Xsheet Toolbar buttons:

1. Right click on it and select Customize Xsheet Toolbar from the menu that opens. The Customize Xsheet
Toolbar window will open.
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2. To add a command: Search for a command in the Toolbar Items list (right) and drag it to the Xsheet Toolbar
list (left).

3. To add a separator: At the end of the Toolbar Items list (right), drag the —-Separator—- item to the Xsheet
Toolbar list (left).

4. To delete a command: Locate the command in the Xsheet Toolbar list (left), right click on it and select Remove
from the menu that opens.

5. Click OK to accept the changes or Cancel to discard them.

14.6 Working with Columns/Layers

When levels are exposed in the Xsheet they are placed in columns (layers, in the case of the Timeline). The col-
umn/layer stacking order sets which drawings and images are placed on top, or behind, other images. Its direction is
from left to right in the Xsheet, and from bottom to top in the Timeline, so what is on the left/bottom is behind what is
on the right/top. You can use the keyboard arrow keys to move between the columns/layers and time.
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The Xsheet is divided into sections divided by horizontal markers (vertical, in case of the Timeline), whose interval
can be customized; at each marker the name of the levels exposed can be displayed, when the option Display Level
Name on Each Marker is active in the Preferences. . . → Interface dialog section.

Column/layer cells may have different colors according to the type of level they contain. Toonz Vector levels are
displayed in dark yellow; Toonz Raster levels in green; Raster levels in light blue; Sub-Xsheets in violet (see Using
Sub-Xsheets ); Effect levels generated by OpenToonz in brown (see Using the FX Schematic ); Audio levels in pale
green (see Creating a Soundtrack ); and Note levels in grey.

Each column/layer header contains information about its content. These are:

• Name, by default is the name of the first exposed level. The area color indicates the type of level exposed in the
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column/layer.

• Render toggle ( ) allowing you to include or not the column/layer contents in the rendering.

• Camera stand toggle ( ) allowing you to hide or display the column/layer content in the viewer.

Note: The render and camera stand toggles work linked to similar toggles available in the Schematic nodes of
the column/layer (see Using the Stage Schematic and Using the FX Schematic ).

• Lock toggle ( ) allowing you to prevent any editing in the column/layer.

• Additional settings button ( ) allowing you to set an Opacity value or a Color Filter to the column/layer
content, when displayed in the viewer. When a column/layer has a partial opacity, its Camera stand toggle
changes to a faded icon to indicate it.

Note: Optionally you can make these additional properties also take effect at render time by activating the
Enable Column Color Filter and Transparency for Rendering option in the Xsheet → Scene Settings. . .
dialog.

• Preview icon of the first drawing or image exposed in the column/layer.

Note: The icons on the Xsheet column headers can either be displayed at once when the scene is opened, or on
demand by clicking on the column header, according to the Column Icon option available in Preferences. . . →
Xsheet dialog section.

• Parent information, is an area where the object (by default the Table) and center (by default center B) to which
each column/layer is parented is displayed (see Linking Objects ). Currently this is not shown in the Timeline
header.

In the Xsheet, the column on the far left displays the frame number, with the cursor indicating the current frame. The
cursor can be used to set the current frame and allows you to activate the onion skin mode to better check the animation
(see Using Onion Skin ). In the Timeline, the same controls are placed in the time ruler at the top of the Timeline,
having an equivalent functionality.

Note: When the animation is played back, the Xsheet/Timeline scrolls according to the current frame cursor position,
in order to display the current frame. To disable the scrolling deactivate the Xsheet Autopan during Playback option
available in the Preferences. . . → Xsheet dialog section.

Above the frame number column, there are buttons for creating and navigating Memos that can be posted in the
Xsheet/Timeline (see Using Memos ).

The Xsheet/Timeline can be scrolled to examine its content, while the header area and the frame column are always
visible; in this way it’s easier to understand how the scene is built.

Columns/layers you want to hide in the Xsheet/Timeline can be folded in order to save space in the interface. Once
folded they can be unfold at any moment and be visible in their original position by clicking on the column/layer
header area.

Tip: To scroll the Xsheet/Timeline:

Do one of the following:
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• Middle-click and drag to scroll in any direction.

• Use the mouse wheel to scroll up or down.

• Use the scrolling bars to scroll only within the exposed section of the Xsheet/Timeline.

• Use the Up Arrow and Down Arrow keys to move one frame backwards or forward in the Xsheet.

• Use the Left Arrow and Right Arrow keys to move one frame backwards or forward in the Timeline.

• Use Shift+Up Arrow and Shift+Down Arrow keys to move to the previous or next drawing, either in the Xsheet
or Timeline. Use this option if you want to skip the hold frames.

• Use the Page Up and Page Down keys to scroll the visible frames up or down in the Xsheet.

• Use the Home and End keys to scroll up to the beginning or the end of the Xsheet content.

Tip: To set the marker interval:

1. Choose Xsheet → Scene Settings. . .

2. In the dialog that opens use the Marker Interval to set the frame interval between two markers, and the Start
Frame to set at which frame the first marker has to be displayed.

Tip: To name a column:

Double-click the column/layer name in the header and type a new name.

Tip: To select columns/layers:

Do one of the following:

• Click the column/layer header to select a column.

• Click and drag in the column/layer icon to select contiguous columns.

• Ctrl-click (PC) or Cmd-click (Mac) to add a column/layer to or remove it from the selection.

• Shift-click to extend the selection.

Tip: To move a column/layer selection:

Click any area displaying the name of columns in the header, and drag it to the new position.

Tip: To edit a column/layer selection:

1. Select the columns/layers you want to edit.

2. Do one of the following:

• Use the Copy command to keep in memory the selection for further operations.

• Use the Cut command: to eliminate the selection from the scene and keep it in memory for further operations.
The column/layer elimination causes the following columns to shift left (or the layers above to shift down).

• Use the Paste command to paste the selection kept in memory starting from the selected column/layer. The
command causes following columns to shift right (or layers above to shift up).
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• Use the Delete command to delete the selection.

• Use the Insert command to insert empty columns before the selection; inserted columns/layers will be as many
as the selected ones.

Note: All of these commands are also available in the menu that opens when right-clicking the column/layer header.

Tip: To include or exclude a column/layer contents from the rendering:

Click the render toggle ( ) on the column/layer header. If you right-click the button you can select commands from
a menu that opens, that let you affect several columns/layers at the same time.

Tip: To show or hide a column/layer contents in the viewer:

Do one of the following:

• Click the camera stand toggle ( ) on the column/layer header. The icon is faded out in case a partial opacity
is set (see below). If you right-click the button you can select commands from a menu that opens that let you
affect several columns/layers at the same time.

• Right-click the column/layer content in the viewer and choose the Hide or Show command related to the col-
umn/layer you want to hide or show.

Tip: To lock or unlock a column/layer contents:

Click the lock toggle ( ) on the column/layer header. If you right-click the button you can select commands from a
menu that opens that let you lock or unlock several columns/layers at the same time.

Tip: To set Opacity for a column/layer content:

Click the triangle icon ( ) on the column/layer header, and do one of the following:

• Use the Opacity slider to set the column/layer opacity.

• Input the desired Opacity value in the numeric field, to set the column/layer opacity.

Tip: To set a Color Filter for a column/layer content:

Click the triangle icon ( ) on the column/layer header, and set the Filter parameter to one of its predefined colors.

Note: You can make Opacity and Color Filter take effect at render time by activating the Enable Column Color
Filter and Transparency for Rendering option in the Xsheet → Scene Settings. . . dialog.

Tip: To fold columns/layers:
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1. Select the columns/layers you want to fold.

2. Right-click the selection and choose Fold Column from the menu that opens.

Tip: To unfold columns/layers:

Click the fold visible between the column/layer headers.

14.7 Working with Cells

When a level is exposed in a column, each cell contains a reference to a particular image. You may empty some cells,
repeat some of them or change their order without affecting the real drawings sequence, because you are operating
on references. This means that when a scene contains several cells referring to a drawing of an animation level, they
all refer to the same drawing. This implies that when you modify a drawing of an animation level, all the cells in the
Xsheet/Timeline referring to that drawing will consequently change their content.

Note: When the scene contains a reference to a drawing that is eliminated from the level, the drawing name and
number in the cell turn red, to warn you that there is no drawing available for that cell anymore.

When you select a cell, you can work on the drawing it contains by using tools in the viewer.

When one or more cells are selected you can perform standard cut, copy, paste, delete and insert operations in the
Xsheet/Timeline. In this case you are not modifying the animation level frames but simply changing the way it is
exposed in the Xsheet/Timeline.

Selected cells can also be dragged to a new position in the Xsheet/Timeline, in duplicating, inserting or overwriting
mode as well. When they are dragged to an empty column, it is possible to move along the data of the column/layer,
i.e. the movement and special FX, where they were originally exposed.

Tip: To modify a drawing exposed in a cell:

1. Select the cell in the Xsheet/Timeline where the drawing is exposed.

2. Use the tools to edit it in the Viewer.

Tip: To select several cells:

Do one of the following:

• Click and drag to select a series of cells.

• Shift-click a cell to extend the selection up to that cell.

• Press Ctrl and drag to include keys in the selection. A red frame will be shown around the selection.

• Click the vertical strip available on the left of the cells in the Xsheet, to select the continuous sequence of
drawings belonging to the same animation level.

• Click the horizontal strip available on thetop of the cells in the Timeline, to select the continuous sequence of
drawings belonging to the same animation level.
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Tip: To edit cells with the Edit menu commands:

You can do the following:

• Use the Copy command to keep in memory the selection for further operations.

• Use the Cut command to eliminate the selection from the Xsheet/Timeline and keep it in memory for further
operations. The cell elimination causes the following cells in the Xsheet to shift up, or in the Timeline, to shift
to the left.

• Use the Paste command to paste the selection kept in memory into the Xsheet/Timeline, starting from the
selected insertion cell. The command causes the following cells in the Xsheet to shift down, or in the Timeline,
to shift to the right.

• Use the Delete command to empty the selected cells from any reference.

• Use the Insert command to insert blank cells before the selection; inserted cells will be as many as the selected
ones.

Note: All the Edit menu commands are also available in the menu that opens when right-clicking the Xsheet/Timeline
cells.

Tip: To edit cells with the Cells menu commands:

You can do the following:

• Use the Reverse command to invert the order of the selected cells.

• Use the Swing command to append the selected cells, at the end of the selection, in a reversed order. The last
cell of the selection will not be repeated.

• Use the Random command to rearrange the selected cells in a random order. The order changes every time you
use the command.

• Use the Autoexpose command to repeat the selected cells, as if filling the numbering gap between two subse-
quent drawings. For example if the command is applied to two cells where drawing 2 and 5 are exposed, the
result will be four cells with drawings 2, 2, 2 and 5. The command works only if the selection is increasingly
numbered.

Note: If the Autoexpose command is used on an level numbered 1, 3, 5, 7, etc., the level will be
automatically exposed step 2.

• Use the Repeat command to open a dialog that allows you to repeat cyclically the selected cells by specifying a
number of times, or the frame number up to which the selection has to be repeated.

• Use the Reset Step command to remove any animation step in the selected cells, preserving the order of the
exposed drawings.

• Use the Increase Step command to increase the animation step of the selected cells by one unit.

• Use the Decrease Step command to decrease the animation step of the selected cells by one unit; if a drawing
is exposed in one cell only, it will be preserved.

• Use the Step 2, Step 3 or Step 4 command to repeat the selected cells in order to have a step 2, step 3, or step 4
animation.
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• Use the Each 2, Each 3 or Each 4 command to preserve only one cell each 2, each 3, or each 4 of the selection,
and delete the others.

• Use the Roll Up command to shift the content of selected cells up, with the top cell content replacing the bottom
cell one.

• Use the Roll Down to shift the content of selected cells down, with the bottom cell content replacing the top
cell one.

Note: All the Cells menu commands are also available in the menu that opens when right-clicking the Xsheet/Timeline
cells.

Tip: To drag a cell selection in the Xsheet:

Do one of the following:

• Click the vertical strip available on the left of the cells, and drag to move them to a new position.

• Ctrl-click (PC) or Cmd-click (Mac) the vertical strip available on the left of the cells, and drag them to the new
position, duplicating them.

• Shift-click the vertical strip available on the left of the cells, and drag them to the new position, inserting them
if other content is exposed in the destination cells.

• Alt-click the vertical strip available on the left of the cells, and drag them to the new position, overwriting any
other content previously exposed in the destination cells.

Note: When it’s not possible to paste the selection, a red outline is displayed instead of the selection.

Tip: To drag a cell selection in the Timeline:

Do one of the following:

• Click the horizontal strip available on the top of the cells, and drag to move them to a new position.

• Ctrl-click (PC) or Cmd-click (Mac) the horizontal strip available on the top of the cells, and drag them to the
new position, duplicating them.

• Shift-click the horizontal strip available on the top of the cells, and drag them to the new position, inserting
them if other content is exposed in the destination cells.

• Alt-click the horizontal strip available on the top of the cells, and drag them to the new position, overwriting
any other content previously exposed in the destination cells.

Note: When it’s not possible to paste the selection, a red outline is displayed instead of the selection.

Tip: To drag a cell selection moving along the column/layer data:

1. Choose File → Preferences. . . → Xsheet.

2. Set the Cell-dragging Behaviour option to Cells and Column Data.
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Note: Column/layer data is moved along only when dragging the selected cells to an empty column/layer.

Note: Column/layer data is moved along except for the linked columns/layers, because linked columns/layers can
only have one parent column/layer.

14.7.1 Using the Smart Fill Handle

The Fill Handle allows you to edit cells directly from within the Xsheet/Timeline.

It’s the small tab appearing at the bottom of the cell selection in the Xsheet, or at the right of the cell selection in the
Timeline. By dragging this handle you can repeat a cell or a group of cells, you can add cells, or you can delete the last
cells of a sequence. The behavior of the handle is smart: this means that the way cells are repeated, added, or deleted
depends on the selection content.

Note: Editing cells with the Fill Handle makes the cells placed below the selection to shift up/down in the Xsheet (or
the cells placed to the right of the selection to shift left/right in the Timeline).

Tip: To edit cell content with the Fill Handle in the Xsheet:

Do one of the following:

• If you want to repeat a cell content for some frames, select the cell and drag the fill handle down.

• If you want to lengthen a progressive sequence, select the cells where the sequence is exposed, and drag the fill
handle down: sequence will be lengthen according to the progressive numbering. For example if the sequence
is 1, 3, 5, the added images will be 7, 9, 11, etc. This works for any step the sequence may have.

• If you want a random sequence to be repeated, select the sequence and drag the fill handle down: the sequence
will be lengthened according to the sequence numbering. For example if the sequence is 3, 6, 4, 1, the added
images will be 3, 6, 4, 1, 3, 6, etc.

• If you want a progressive sequence to be repeated, first copy the sequence first drawing at the end of the se-
quence, then select all and drag down the fill handle. For example if the sequence is 1, 2, 3, 4, copy the drawing
1 at the end of the sequence (the result will be 1, 2, 3, 4, 1), and the added drawings will be 2, 3, 4, 1, 2, etc.

• If you want to delete some cells, select a region so that the cells you want to delete are in the last columns, and
drag the fill handle up.

Tip: To edit cell content with the Fill Handle in the Timeline:

Do one of the following:

• If you want to repeat a cell content for some frames, select the cell and drag the fill handle to the right.

• If you want to lengthen a progressive sequence, select the cells where the sequence is exposed, and drag the
fill handle to the right: sequence will be lengthen according to the progressive numbering. For example if the
sequence is 1, 3, 5, the added images will be 7, 9, 11, etc. This works for any step the sequence may have.

• If you want a random sequence to be repeated, select the sequence and drag the fill handle to the right: the
sequence will be lengthened according to the sequence numbering. For example if the sequence is 3, 6, 4, 1, the
added images will be 3, 6, 4, 1, 3, 6, etc.
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• If you want a progressive sequence to be repeated, first copy the sequence first drawing at the end of the se-
quence, then select all and drag the fill handle to the right. For example if the sequence is 1, 2, 3, 4, copy the
drawing 1 at the end of the sequence (the result will be 1, 2, 3, 4, 1), and the added drawings will be 2, 3, 4, 1,
2, etc.

• If you want to delete some cells, select a region so that the cells you want to delete are in the last rows, and drag
the fill handle to the left.

14.7.2 Stretching the Timing

If you need to change the timing of a selection of cells, a selected frame range, or the whole Xsheet/Timeline, you can
use the Time Stretch dialog.

Options are the following:

• Stretch defines if the new timing has to be applied to the Selected Cells, the Selected Frame Range, or to the
Whole Xsheet.

• Old Range displays the frame duration of the selection.

• New Range defines the new frame duration of the selection.

Tip: To stretch the Xsheet/Timeline timing:

1. Select the cells, or define the frame range you want to stretch.

2. Do one of the following:

• Choose Cells → Time Stretch. . . .

• Right-click the selection and choose Time Stretch. . . from the menu that opens.

3. Define the time stretching options, then click the Stretch button.

14.8 Working Globally with Frames

It is possible to insert or delete frames affecting the Xsheet/Timeline as a whole, or a selection of Xsheet columns or
Timeline layers.

Inserting or deleting frames can be useful if you want to change the timing of the animation, for instance if you want
to slow down or speed up an animation.
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When a frame is inserted, the current frame cells are duplicated, and all the following cells are shifted down (right in
the Timeline). If animation keys are defined for object transformations and FX parameters, they will be shifted down
(or right in the Timeline) as well, to keep the animation consistency (see Animating Objects and Editing FX Settings ).

When a frame is removed, the current frame cells are deleted, and the following cells are shifted up (or left in the
Timeline). If animation keys for object transformations and FX parameters are defined in the removed frame, they
will be deleted and following keys will be shifted up (or left in the Timeline) (see Animating Objects and Editing FX
Settings ).

Tip: To insert a frame:

1. Select the frame before which you want to insert a new frame.

2. Choose Xsheet → Insert Frame.

Tip: To remove a frame:

1. Select the frame you want to delete.

2. Choose Xsheet → Remove Frame.

14.9 Using Sub-Xsheets

A Sub-Xsheet is a scene exposed in a single Xsheet column or Timeline layer. It can contain as many columns/layers
as you want, and other Sub-Xsheets as well.

When it’s opened, the Sub-Xsheet contents are displayed in the Xsheet/Timeline pane. When it is closed, it’s displayed
in the Xsheet/Timeline as a violet column/layer, with its icon displaying a render of its content. The column/layer cells
display the name of the Sub-Xsheet, and the cell number is a reference to the frame of the Sub-Xsheet content, i.e. cell
4 is a reference to frame 4 of the Sub-Xsheet.

The closed Sub-Xsheet level length depends on how many frames its content lasts at the time you create it, and it is
not affected when you edit the Sub-Xsheet content.

Sub-Xsheet levels can be animated like any other animation level, and FX can be assigned to it, affecting all the
Sub-Xsheet content as a whole.

Sub-Xsheet level cells can be edited, for example to create a cycle, or cut, copied and pasted like any other exposed
level (see Working with Xsheet Cells ). Like any other level, if some editing is performed in its frames, all the cells
in the main Xsheet/Timeline referring to that Sub-Xsheet frame will consequently change their content. In case you
want to create a copy of a Sub-Xsheet that refers to the same animation level database, but whose content can be edited
independently, you can choose to Clone it.

If you want to reset the editing of a Sub-Xsheet level, you can Resequence it, by resetting it to the original length and
order of its contents.

You can load a scene previously created with OpenToonz as a level of the current scene. You can also collapse selected
columns/layers to form a new Sub-Xsheet to better manage the scene, for example you can collapse into a Sub-Xsheet
all the columns/layers used to define a character, or explode a Sub-Xsheet to automatically bring all of its contents into
the Xsheet/Timeline where it is exposed.

As Sub-Xsheets can be loaded and saved, they can also be used for importing or exporting sections of an
Xsheet/Timeline from one scene to another. For example, if you create a scene where several levels compose a
character (head, body, shadow, etc.), you can save it and import it later in a different scene as a Sub-Xsheet.
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When working inside a Sub-Xsheet, by default only its own contents are displayed in the viewer. If you need to edit
the Sub-Xsheet contents while looking at the whole scene contents, you can activate the Edit in Place mode.

Like standard Xsheets/Timelines, Sub-Xsheets can also contain audio files to be used for synchronizing a soundtrack
with the animation. However, audio files loaded inside Sub-Xsheets are ignored when an output file supporting au-
dio is rendered, because the possibility to edit the Sub-Xsheet columns/layers frame order could make the resulting
soundtrack inconsistent (see Creating a Soundtrack ).

14.9.1 Creating Sub-Xsheets

Sub-Xsheets are managed by the Xsheet menu commands, and by buttons in the Xsheet Toolbar.

You can create a Sub-Xsheet by collapsing one or several columns/layers where levels are exposed, choosing to include
when needed the pegbars to which the columns are linked; or you can cut or copy columns/layers and drawings outside
of the Sub-Xsheet, then paste them inside of it.

Note: The main Xsheet/Timeline will share with its Sub-Xsheets the animation level database, so if the same level is
exposed in the main Xsheet/Timeline and in one of its Sub-Xsheets, the level and its properties will be shared.

When copying Sub-Xsheet columns/layers and cells, their copies refer always to the same Sub-Xsheet contents: if
changes are made in the Sub-Xsheet, all the cells in the main Xsheet/Timeline referring to that Sub-Xsheet will
consequently change their content. If you want to create a copy of a Sub-Xsheet whose contents can be changed
independently as concerning internal level exposure, object animation and applied FX, it is possible to Clone it.

Tip: To create a Sub-Xsheet by collapsing one or several columns:

1. Select the columns you want to be part of the Sub-Xsheet in the Xsheet/Timeline or in the Schematic.

2. Do one of the following:

• Choose Xsheet → Collapse.

• Click the Collapse button in the Xsheet Toolbar.

• Right-click any column header and choose Collapse from the menu that opens.

3. Choose whether to include relevant pegbars in the Sub-Xsheet or collapse selected columns only, then click the
OK button.

Tip: To exit a Sub-Xsheet:

Do one of the following

• Choose Xsheet → Close Sub-Xsheet.

• Click the Close Sub-Xsheet button in the Xsheet Toolbar.

Tip: To open a closed Sub-Xsheet:

1. Select the Sub-Xsheet column in the Xsheet/Timeline, or the Sub-Xsheet node in the Schematic.

2. Do one of the following:

• Choose Xsheet → Open Sub-Xsheet.

• Click the Open Sub-Xsheet button in the Xsheet/Timeline Toolbar.
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• Right-click the column header and choose Open Sub-Xsheet from the menu that opens.

Tip: To clone a Sub-Xsheet:

1. Select the Xsheet column (or Timeline layer) where the Sub-Xsheet you want to clone is exposed.

2. Do one of the following:

• Choose Xsheet → Clone Sub-Xsheet.

• Right-click the column header and choose Clone Sub-Xsheet from the menu that opens.

Tip: To toggle edit a Sub-Xsheet in its context:

Do one of the following

• Choose Xsheet → Toggle Edit in Place.

• Click the Toggle Edit in Place button in the Xsheet/Timeline Toolbar.

Tip: To resequence a Sub-Xsheet:

1. Select the column/layer containing the Sub-Xsheet.

2. Do one of the following:

• Choose Xsheet → Resequence.

• Right-click the column header and choose Resequence from the menu that opens.

14.9.2 Loading a Scene as a Sub-Xsheet

Previously saved OpenToonz scenes can be loaded in a Xsheet/Timeline as Sub-Xsheets.

Every time a scene is loaded as a Sub-Xsheet, its contents are imported into the current project database according
to the project default folders, in the same way as it would be if every single level was imported (see Using the File
Browser ).

This allows you to create a library of basic animations that can be loaded and edited in other Xsheets/Timelines to
create more complex animations without affecting the original files or drawings. Even when the same Sub-Xsheet
is loaded twice, it is handled as if two different Sub-Xsheets were loaded, whose contents and levels can be edited
separately.

To keep the database well-ordered you can also activate the Create Sub-folder when Importing Sub-Xsheet option
in the Preferences → Loading dialog, that will automatically create, in the project default folder, a folder named as the
Sub-Xsheet you are importing where the levels from the Sub-Xsheet will be copied.

Once a Sub-Xsheet is loaded, its levels are available in the Scene Cast in a sub-folder named as the scene you loaded.

If the camera settings of the scene you are loading as a Sub-Xsheet are different from those of your current scene,
you will be prompted whether to keep the Sub-Xsheet original camera settings, or to apply the camera settings of the
current scene to the Sub-Xsheet as well.

Note: If the scene you import contains a file whose name is the same of a file already existing in the destination
default folder, you will prompted whether to keep the existing file, overwrite it with the new one, or rename it adding
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a suffix you can decide. In this way you can control if files you are importing were already imported previously, or
manage files that share the same name.

Tip: To load a previously saved scene as a Sub-Xsheet:

Do one of the following:

• Choose Level → Load Level. . . and use the browser to load a TNZ file.

• Choose File → Load As Sub-Xsheet. . . and use the browser to load a TNZ file.

• Use the OpenToonz standard browser to drag the scene icon to the Scene Cast pane, the Xsheet/Timeline or the
Viewer.

• In the file browser right-click the scene icon and select Load As Sub-Xsheet in the menu that opens.

Note: OpenToonz scene files can also be loaded by dragging and dropping them from the Windows Explorer or
macOS Finder to the Scene Cast, Xsheet/Timeline, or the viewer.

14.9.3 Exploding Sub-Xsheets

Sub-Xsheets can be exploded to automatically bring their content into the Xsheet/Timeline where they are exposed.
When exploding a Sub-Xsheet it’s possible to choose to bring to the main Xsheet/Timeline, when needed, the pegbars
to which columns are linked.

Note: When a Sub-Xsheet is exploded, its columns/layers and the related FX nodes are displayed as a group in the
FX Schematic, in order to better retrieve them (see Using the FX Schematic ).

Note: If FXs are applied to the Sub-Xsheet column/layer, they will not be applied to the exploded columns, but the
disconnected FX nodes will remain as reference in the FX Schematic.

Tip: To explode a Sub-Xsheet:

1. Select the Sub-Xsheet column/layer in the Xsheet/Timeline or in the Schematic.

2. Do one of the following:

• Choose Xsheet → Explode Sub-Xsheet.

• Right-click the Sub-Xsheet column header and choose Explode Sub-Xsheet from the menu that opens.

3. Choose whether to bring relevant pegbars to the main Xsheet/Timeline, or to bring columns/layers only, then
click the OK button.

14.9.4 Saving a Sub-Xsheet as a Scene

The content of a Sub-Xsheet can be saved as a standard scene, i.e. a TNZ file, in order to be loaded as a stand-alone
scene or to be available for reuse in other scenes.
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The Sub-Xsheet content will be saved according to the current project settings for default folders, as if you were saving
a scene file (see Project Default Folders ).

Tip: To save a Sub-Xsheet as a scene:

1. Open the Sub-Xsheet you want to save, so that its contents are displayed in the Xsheet/Timeline.

2. Choose Xsheet → Save Sub-Xsheet As. . . and use the browser to save the scene file (see Saving and Loading
Scenes ).

14.10 Creating a Soundtrack

Audio clips can be loaded and edited in order to create a soundtrack for the scene; natively supported file formats
are non-compressed WAV and AIFF files at 8 and 16 bit. If FFmpeg is installed and configured in Preferences. . . →
Import/Export dialog section, MP3 audio files can be loaded too. There is no limit to the number of audio clips that
can be loaded in a scene.

To load an audio clip you can use the Browser room; if an audio clip is imported, it is saved in the +extras folder (see
Using the File Browser ). Loaded audio clips are also stored in the Audio folder of the Scene Cast.

Each loaded audio clip is exposed in a different Xsheet column or Timeline layer as a series of visible sound waves to
make the editing job easier; the number of frames it spans depends on the length of the audio file and the frame rate
set for the current scene. For example an audio clip 3 seconds long, imported into a scene whose frame rate is 12, will
occupy 36 frames; if imported in a scene whose frame rate is 24 will occupy 72 frames (see Setting the Frame Rate ).
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Audio columns/layers can be edited the way you edit any other column/layer. Its header contains the following
information about the content:

• Name, by default is the number of the column/layer the audio is exposed in. e.g. Col5.

• Render toggle ( ) allowing you to include or not the audio column/layer content in the rendering.

• Camera stand toggle ( ) allowing you to include or not the column/layer content when scrubbing the audio
with the current frame cursor (see below).
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• Lock toggle ( ) allowing you to prevent any editing in the column/layer.

• Additional settings button ( ) allowing you to set the volume.

• Loudspeaker icon that lets you play the contents back.

The Level Settings dialog is available for audio clips as well, allowing you to check the location of the related file, or
to update the loading path to a different location, or to a different file (see Editing Level Settings ).

The soundtrack you define with audio clips will be created by merging all of the contents of audio columns/layers
according to the volume you set for each of them. While it cannot be played back when using the playback controls
in the viewer, it can be scrubbed with the current frame cursor in the Xsheet frame column, the Timeline frame ruler
or in the viewer framebar, and played back when a scene is previewed (see Editing Audio Clips and Previewing the
Animation ).

When a scene is rendered in a file format supporting audio, (MP4, MOV, WebM or AVI), the soundtrack will be
included in the file (see Rendering the Animation ).

Note: Audio clips loaded in Sub-Xsheets will not be included in the output soundtrack (see Using Sub-Xsheets ).

Note: As the soundtrack cannot be played back when viewing files in the OpenToonz flipbook, you can activate the
Use Default Viewer for Movie Formats option in the Preferences. . . → General dialog section, in order to view files
with their own default viewer, e.g. QuickTime for the MOV format, thus playing back the soundtrack as well.

Tip: To play the contents of an audio column/layer back:

Click the loudspeaker icon available in the header of the column/layer. Click it again to stop the playback.

Tip: To set the volume of an audio column/layer:

Click the Additional settings button ( ) and use the Volume slider in there.

Tip: To include or exclude an audio when scrubbing the audio with the current frame cursor

Click the Camera stand toggle ( ) on the column/layer header. If you right-click the toggle you can select commands
from a menu that opens that let you affect several columns/layers at the same time.

Tip: To include or exclude the audio column/layer contents from the rendering:

Click the Render toggle ( ) on the column/layer header. If you right-click the toggle you can select commands from
a menu that opens that let you affect several columns/layers at the same time.

Tip: To lock or unlock a column/layer contents:

Click the Lock toggle ( ) on the column/layer header. If you right-click the toggle you can select commands from
a menu that opens that let you lock or unlock several columns/layers at the same time.
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14.10.1 Editing Audio Clips

Once loaded, audio clips can be moved up and down in a Xsheet column, left and right in a Timeline layer, or to a
different column/layer, in order to be played starting from a certain frame of the animation. They can be trimmed to
select a part of the whole clip and edited, by deleting or copying some sections, using standard edit commands the
same way you use them on standard levels.

When a clip is trimmed, the trimmed part is not eliminated, but hidden, and it has a colored horizontal marker at its
starting or ending, according to where it was trimmed: it is possible to retrieve the trimmed part by moving back the
markers.

When a clip is split into sections by deleting, cutting or moving operations, it is automatically duplicated and trimmed
to create the right result.

Note: Audio clips can be moved and pasted only to empty columns/layers, or to other audio columns/layers.

Note: All the editing does not affect the file on disk, as it refers only to the way the clip is used in the scene.

To find a particular section in an audio file, you can examine it by scrubbing it with the current frame cursor, either in
the Xsheet frame column, the Timeline frame ruler, in the viewer framebar, or by selecting any section and automat-
ically playing it back together with the animation. This allows you to easily spot and excerpt the sections you need
from an audio file.

Tip: To select audio clips:

Do one of the following:

• Click and drag to select a section of the clip.

• Shift-click a clip cell to extend the selection up to that cell.

• In the Xsheet, click the vertical strip available on the left of the clip, to select the whole clip.

• In the Timeline, click the horizontal strip available on the top of the clip, to select the whole clip.

Tip: To edit audio clips with the Edit menu commands:

You can do the following:

• Use the Copy command to keep in memory the selection for further operations.

• Use the Cut command to eliminate the selection from the Xsheet/Timeline and keep it in memory for further
operations. The cell elimination causes the following cells to shift up in the Xsheet or left in the Timeline.

• Use the Paste command to paste the selection kept in memory in the Xsheet/Timeline, starting from the selected
insertion cell. The command causes the following cells to shift down in the Xsheet or right in the Timeline.

• Use the Delete command to empty the selected cells from any reference.

• Use the Insert command to insert blank cells before the selection; inserted cells will be as many as the selected
ones.

Note: All the Edit menu commands are also available in the menu that opens when right-clicking the Xsheet/Timeline
cells.
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Tip: To move a clip selection in the Xsheet:

Do one of the following:

• Click the vertical strip available on the left of the clip cells, and drag them to move them to a new position.

• Ctrl-click (PC) or Cmd-click (Mac) the vertical strip available on the left of the clip cells, and drag them to the
new position duplicating them.

• Shift-click the vertical strip available on the left of the clip cells, and drag them to the new position inserting
them if other audio clips are loaded in the destination cells.

• Alt-click the vertical strip available on the left of the clip cells, and drag them to the new position overwriting
any other audio clips previously loaded in the destination cells.

Tip: To move a clip selection in the Timeline:

Do one of the following:

• Click the horizontal strip available on the top of the clip cells, and drag them to move them to a new position.

• Ctrl-click (PC) or Cmd-click (Mac) the horizontal strip available on the top of the clip cells, and drag them to
the new position duplicating them.

• Shift-click the horizontal strip available on the top of the clip cells, and drag them to the new position inserting
them if other audio clips are loaded in the destination cells.

• Alt-click the horizontal strip available on the top of the clip cells, and drag them to the new position overwriting
any other audio clips previously loaded in the destination cells.

Note: When it is not possible to release the selection, a red outline is displayed instead of the selection.

Tip: To trim an audio clip:

Do any of the following:

• Click and drag the starting of a clip to trim its starting part.

• Click and drag the ending of a clip to trim its ending part.

• Click and drag the marker of a trimmed clip to redefine the trimmed part.

Tip: To scrub audio clips:

Do one of the following:

• Drag the Xsheet frame cursor up or down to scrub all the audio columns whose Camera Stand toggle is active.

• Drag the Timeline frame cursor left or right to scrub all the audio layers whose Camera Stand toggle is active.

• Drag the frame cursor in the viewer framebar to scrub all the audio columns whose Camera Stand toggle is
active.

• Windows only: In the Xsheet, click and drag on the dashed vertical strip available on the right of the audio
column cells, the selected section will be automatically played back.
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• Windows only: In the Timeline, click and drag on the dashed horizontal strip available on the bottom of the
audio layer cells, the selected section will be automatically played back.

14.11 Lip Syncing

When you need to synchronize the movement of a character’s lips with the sound of the speech, you can take advantage
of the possibility to examine the audio files loaded in the scene.

Once you have created different mouth images, you can analyze the audio files to find where to place specific mouth
drawings. If mouth drawings belong to one single animation level, you can quickly change the mouth drawing at a
specific frame by picking drawings from the level strip or by flipping through drawings using one of the Skeleton tool

( ) features (see Using the Level Strip and Animating Models ).

The breakdown of audio files can be done by looking at the sound wave in the scene column, for example to spot where
each word starts; by scrubbing the loaded audio clips with the current frame cursor either in the Xsheet/Timeline frame
ruler or in the Viewer framebar; and by listening to specific sections of the audio files.

When mouth images are placed in the proper place, you can check the sync by scrubbing or selecting again the audio
file section you are interested in, because while listening to the selected audio section, the viewer will display the
related animation frames.

This technique can be used in any case you need the sound to be perfectly synchronized with the action, for example
a character playing an instrument, or a scene based on the rhythm of a music.

Tip: To scrub audio clips:

Do one of the following:

• Drag the Xsheet/Timeline frame cursor forward or backwards to scrub all the audio levels whose Camera Stand
toggle is active.

• Drag the frame cursor in the Viewer framebar to scrub all the audio columns whose Camera Stand toggle is
active.

• Windows only: click and drag on the dashed strip available on the audio level cells: the selected section will be
automatically played back.

Tip: To flip through the mouth drawings:

1. Do one of the following:

• Select in the Xsheet or Timeline the animation level containing the mouth drawings.

• Right-click in the viewer over the mouth drawing you want to flip through, and choose the Select command
related to the column/layer containing the drawing you clicked.

2. Choose the Skeleton tool ( ) and set the tool mode to Animate.

3. In the viewer click the label with the level name on the right of the current section pivot point and flip through
following and previous frames by doing one of the following:

• Drag up or down.

• Click the up or down arrowheads.
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14.11.1 Automated Lip-Synching using Rhubarb

Automatic lip-sync can be obtained by using the Rhubarb software (which is not bundled with OpenToonz, and must
be separately installed and then configured in Preferences window, as explained in ??? section). The Auto Lip-Sync
feature can analyze an audio track and automatically expose the appropriate drawing for each phoneme in the audio to
the corresponding cells in the Xsheet/Timeline.

Tip: To apply auto lip-sync to a column/layer:

1. Load the audio track onto its own column/layer, if it is not already there (right-click on the cell the audio should
begin and select “Load Level”).

2. Expose in the Xsheet/Timeline at least one drawing of the level containing the mouth shapes set.

3. Select the cell of the column/layer where you want the lip sync to start, and using the right-click menu, choose
the Lip Sync → Apply Auto Lip Sync to Column option.

4. In the Auto Lip Sync Dialog, choose the desired Xsheet/Timeline audio column/layer or a supported audio file
from disc, by using the Audio Source drop-down menu.

Note: Press play to preview the track if needed.

Note: You can optionally type a transcript of the spoken words in the Audio Script field, which will help improve
the accuracy of the lip syncing result.

5. Choose which level drawings to assign to each phoneme using the arrow buttons below each phoneme.
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Note: Rhubarb utilizes its own phonemes that have been interpreted as Preston Blair phonemes, without a unique
phoneme for WQ.

6. Click the “Apply” button

14.11.2 Importing Papagayo-NG Files

It is possible to import into the Xsheet/Timeline DAT files exported from Papagayo-NG, a lip-sync and animation
timing tool.

While Papagayo-NG takes care of the audio file analysis and phoneme recognition, importing the DAT file into Open-
Toonz allows you to assign a frame from an animation level to each phoneme and automatically expose the result in
an Xsheet column or Timeline layer; to be able to hear the synced sound, the correspondent sound level should be
manually loaded too.

Tip: To export the OpenToonz lip sync file in Papagayo-NG:

1. In Papagayo-NG, from the Export: dropdown menu, select MOHO.

2. Press the Export button, to export a .DAT file.

Tip: To import a Papagayo-NG file:

1. Expose in the Xsheet/Timeline at least one drawing of the level containing the mouth shapes set.
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2. Select the cell of the column/layer where you want the lip sync to start, and using the right click menu choose
the Apply Lip Sync Data to Column option or from Xsheet → Apply Lip Sync Data to Column.

3. A dialog opens letting you choose which level drawings to assign to each phoneme.

4. Use the Lip Sync Data File: browser to retrieve the DAT file you exported from Papagayo-NG, and click the
Choose button.

5. The Insert at Frame: parameter should already be showing the frame number of the cell you previously se-
lected. Still, you can change it to make the lip sync start at another frame.

6. Activate the Extend Rest Drawing to End Marker if you want to copy the Rest Drawing to all the remaining
frames between the loaded lip sync ending, and the frame where the End Marker of the Xsheet/Timeline is set.

7. Click the Apply button.

14.11.3 Importing Magpie Files

It is possible to import into the Xsheet/Timeline .TLS files (i.e. Toonz Lip Sync) exported from Magpie, a lip-sync
and animation timing tool.
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While Magpie takes care of the audio file analysis and phoneme recognition, importing the .TLS file into OpenToonz
allows you to assign a frame from an animation level to each phoneme and automatically expose the result in an Xsheet
column or Timeline layer; an additional column/layer displaying the speech text (as recognized in Magpie) is created
for reference.

Tip: To export the OpenToonz lip sync file in Magpie:

1. Copy the file export-toonz.lua available in OpenToonz stuff\config folder into
the C:\Program Files (x86)\Third Wish Software & Animation\Magpie
Pro\Scripts\Export folder.

2. In Magpie choose File → Export and choose Toonz among the 2D software list to export the TLS file.

Tip: To import a Magpie file:

1. Choose File → Import Toonz Lip Sync File. . . .

2. In the browser that opens retrieve the TLS file you exported from Magpie and click the Load button.

3. In the dialog that opens choose the following:

• Use Frame Range to define which section of the Magpie file you want to use to create the lip sync column in
the Xsheet/Timeline.

• Use the Animation Level section to retrieve the animation level you want to expose in the Xsheet/Timeline, and
to specify which frame of the level has to be assigned to each phoneme; you can also use the viewer available at
the bottom of the dialog to examine the frames of the selected animation level.

4. Click the Import button.

14.12 Using Memos

Memos can be posted in the Xsheet/Timeline at specific positions in order to add notes and comments to the scene.
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When editing a memo its color can be set, and the text you write can be formatted. Once posted, memos display the
first letters of their content in order to be identified, and can be retrieved in the Xsheet/Timeline by navigating them.

Tip: To post a memo:

1. Click the Add New Memo button at the top of the frame number column in the Xsheet (or at the top of the
layers headers, in the Timeline).

2. Type the memo text in the window that opens, format it and choose the memo color (see below) then click the
Post button: the memo is posted at the current frame in the current column.

3. Click and drag the posted memo to change its position.

Tip: To format the text in the memo:

1. Select the text you want to format.

2. Click the arrow ( ) displayed on the right of the selection to open the Text Toolbar.
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3. Choose the font family, size, color, style and paragraph alignment by clicking on the relevant menu and buttons
in the Text Toolbar.

Tip: To change the memo color:

Choose a color in the palette available at the bottom of the open memo; palette colors can also be selected and edited
by using the Style Editor.

Tip: To navigate the memos posted in the Xsheet:

Click the arrow buttons next to the Add New Memo button to check the previous or next memo: the Xsheet/Timeline
automatically pans to show where the selected memo is posted.

Tip: To open a memo:

Do one of the following:

• Double-click it.

• Right-click it and choose Open Memo from the menu that opens.

Tip: To delete a memo:

Do one of the following:

• Open it and click the Discard button.

• Right-click it and choose Delete Memo from the menu that opens.
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14.13 Saving and Loading Scenes

When working on a new scene the default name (untitled) followed by a progressive number is assigned to the scene
until you save it with a different name. This name is also used in case the $scenepath variable is used in the project
settings to store temporarily the material used in the scene.

Note: Untitled scenes and related material are stored in the OpenToonz stuff\projects\temp folder, and
deleted when the scene is saved with a proper name or not saved at all. Check regularly the temp folder, and if there
is some content, delete it to free disk space.

Scene files can be saved and loaded as TNZ files using the related menu commands. Scenes have to be saved in the
current project +scenes folder, or any of its sub-folders, in order to retrieve all the material when they are loaded back.

When you use the Save As. . . command, if the $scenepath is used in the default folders definition, all the material
used in the scenes and located in project default folders will be duplicated in folders related to the new scene (see
Using the $scenepath Variable in Folder Definition ).

An option Save Automatically allows to save the scene every given number of minutes, and is available in the Pref-
erences. . . → Saving dialog section. If the option is activated, during the saving operation a message is displayed to
notify the process.

Note: An asterisk to the right of the scene name in the Viewer and Xsheet/Timeline title bars, denotes that there are
unsaved changes for the current scene.

Tip: To work on a new scene:

Choose File → New Scene.

Tip: To save a scene and all its related levels:

Choose File → Save All.

Tip: To save a scene:

Choose File → Save Scene.

Tip: To save the current scene with a different name:

1. Choose File → Save Scene As. . .

2. In the browser that opens select the current project +scenes folder, or any of its sub-folders, where you want to
save the scene.

3. Assign a name to the scene and click the Save button.

Tip: To load a scene from the Load Scene browser:

1. Choose File → Load Scene. . .
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2. In the browser that opens retrieve, in the +scenes folder of the current project or any of its sub-folders, the scene
you want to load and click the Load button.

Tip: To load a scene from the OpenToonz standard browser:

Do one of the following:

• Right-click the scene icon and choose Load Scene. . . from the menu that opens.

• Drag and drop the scene icon to the clapboard icon in the scene cast pane.

Note: Scenes can also be loaded by dragging and dropping them from the Windows Explorer or Mac OS Finder to
the clapboard icon in the scene cast.

Tip: To load back a recently loaded scene:

Choose File → Open Recent Scene File, then select the scene you want to load from the available submenu.

Tip: To revert the current scene to the last saved version:

Choose File → Revert Scene.

Tip: To automatically save a scene every given number of minutes:

1. Choose File → Preferences. . . → Saving.

2. Activate the Save Automatically option and enter the number of minutes that have to pass between each saving
operation.

3. Choose to activate which file will be saved by this function, either or both of the Scene File and Non-Scene
Files.

14.14 Importing and Exporting Scenes

In OpenToonz each scene file belongs to a specific project, so that the material created and used in the scene is located
and can be retrieved from the project default folders.

If you need to copy the scene and the related material to a different project, it is possible either to import any scene
file in the current project, or to export it to any other project available in the projectroot (see Setting up Projects ).

14.14.1 Importing Scenes from a Different Project

When trying to load a scene created in a different project, or not located in the current project +scenes folder or any
of its sub-folders, you are prompted to decide whether you want to import the scene (Import Scene) or change the
current project (Change Project) (see Setting up Projects ).

If you decide to import the scene, the scene will be loaded, and all the scene material will be imported in the following
way:
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• All the files that were located in the original project default folders (i.e. the ones loaded in the scene by using
relative paths) will be copied into the related default folders of the current project (see Project Default Folders
).

• All the files that were located in external folders (i.e. the ones loaded in the scene by using absolute paths), will
remain where they are.

While the material is automatically imported and saved in the current project, the scene file will not be saved until you
will save it by using the Save Scene or Save Scene As. . . commands.

It is also possible to import one or several scenes into the current project with no need to load and save them by using
the Import Scene command.

In this case both the material files located in the original project default folders and the scene file will be copied in the
related default folders of the current project.

Note: If the scene you import contains a file whose name is the same as a file already existing in the destination
default folder, you will prompted whether to keep the existing file, overwrite it with the new one, or rename it adding
a suffix you can decide. In this way you can control if files you are importing were already imported previously, or
manage files that share the same name.

Tip: To load and import a scene from a different project:

1. Load the scene you want to import by using the Load Scene. . . browser or the OpenToonz standard browser.

2. Choose Import Scene in the dialog that opens: the scene is loaded and the related files will be copied into the
default folders of the current project.

3. Save the scene file in the current project +scenes folder

Tip: To import one or several scenes from a different project, without loading them:

1. Select the scenes you want to import in the OpenToonz standard browser.

2. Right-click the selection and choose Import Scene from the menu that opens: the scene and the related material
files copied in the default folders of the current project.

14.14.2 Exporting Scenes to a Different Project

Scenes can be exported if you need either to copy them from a project to any other existing project, or to copy them to
a new project that can be automatically created according to the current project settings.

In both cases the scenes files and the related assets will be automatically collected and copied in the related default
folders of the destination project (see Collecting Assets ).
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Note: If the scene you export contains any file whose name is the same of a file already existing in the destination
default folder, you will prompted whether to keep the existing file, overwrite it with the new one, or rename it adding
a suffix you can decide. In this way you can control if files you are exporting were already exported previously, or
manage files that share the same name.

Tip: To export one or several scenes to a different project:

1. Select the scenes you want to export in the OpenToonz standard browser.

2. Right-click the selection and choose Export Scene. . . from the menu that opens: the Export Scene dialog opens.

3. In the dialog do one of the following:

• Select the Choose Existing Project option if you want to export the selected scenes to an existing project, then
navigate the folder tree to choose the destination project.

• Choose the Create New Project option if you want to export the selected scenes to a new project based on the
current one, then assign a name for the new project.

4. Click the Export button.
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14.14.3 Collecting Assets

Files used in a scene can be located in the default folders of the current project, or loaded from an external folder (see
Project Default Folders and Using the File Browser ).

This means that when a project has to change location for any reason (e.g. for a backup), moving all the default folders
does not grant that all the files required for the project scenes are moved along, because files loaded from external
folders will remain where they are.

For this reason it’s possible to collect all the files used in a scene, thus importing automatically to the project default
folders all the files that were not imported at loading time. At the same time the scene file for which you are collecting
assets will be automatically updated in order to correct all the loading paths of the newly imported files to keep
consistency.

Tip: To collect the assets of one or several scenes:

1. Select the scenes for which you want to collect assets.

2. Right-click the selection and choose Collect Assets from the menu that opens: all the scene files that were
located in external folders are copied into the default folders of the project, and the related paths used in the
scene files are updated.

14.14.4 Scene Backup Files

When scenes are saved, backup files of previous versions are automatically stored in a folder named as the scene, that
is located in +scenes\backups of the current project.

The four previous scene versions are retained, and they are named as the scene, with a progressive backup number:
the highest the number, the more recent the backup.

For example if you have saved seven times the scene named my_scene, 4 backup versions of the
scene named my_scene_3 , my_scene_4 , my_scene_5 and my_scene_6 are available in the
+scenes\backups\my_scene folder.

If you want to recover a scene backup version of a scene, you have to remove the backup number so to have the correct
scene name, and move the file into the +scenes folder.

Tip: To recover a backup version of a scene:

1. Retrieve in +scenesbackups the folder named as the scene whose backup you want to recover.

2. In the folder, retrieve the TNZ file related to the latest backup you want to recover, and rename it, removing the
backup number so to have the correct scene name.

3. Copy and paste it into the +scenes folder to replace the version you want to scratch.

14.15 Printing Xsheets

An Xsheet can be saved as HTML file in order to view it on any computer by using an Internet browser, and to print it
on paper.

The HTML file contains a header with general information, several tables, whose length and width you can decide,
representing the Xsheet with exposed levels and objects movements, and a list of the levels exposed in the Xsheet with
the related location on disk.
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If any Sub-Xsheets are used in the scene, they are displayed after the main Xsheet where they are exposed.

The information displayed in the header and the appearance of the HTML table can be set by editing the following
files located in the folder OpenToonz stuff\profiles\layouts\settings :

• xsheet_html.xml contains the information used for the HTML Xsheet header, and the size for the tables
used to represent the Xsheet content.

• xsheet.css is a Cascading Style Sheet file that is used to define the colors, layout, and other aspects of the
HTML Xsheet file (see below ).

When using the Print Xsheet command, a dialog with information about the location and name of the generated HTML
file is displayed; then the generated HTML file is displayed in your default browser.

The HTML file is saved in the same location as the TNZ file; the CSS file used for its formatting is generated as well,
by copying the one located in the folder OpenToonz stuff\profiles\layouts\settings . If a CSS file
is already available in the location where the HTML Xsheet file is saved, it will be used instead of generating a new
one.

Note: If you want to move the HTML Xsheet file, you should move the CSS file as well, in order to preserve the
HTML file appearance as defined by the CSS file.

14.15.1 Editing the HTML Xsheet Header and Table Size

The HTML Xsheet header and the size for the tables used to represent the Xsheet content can be defined by editing
the‘‘ xsheet_html.xml‘‘ file available in the folder OpenToonz stuff\profiles\layouts\settings . It
can be edited with any text editor software, e.g. Notepad or TextEdit.

The whole text is included in the tag xsheet_html , that contains the elements page and info , where the different
users and roles are defined. The basic structure of the file is the following:

<xsheet_html>
<page rows="50">
<page columns="10">
<info name="Company" value="Company name"/>
<info name="Name" value="Value"/>

</xsheet_html>

By editing the page row and page columns values you can set the size of the table used for splitting the Xsheet
in sections. The size of the table allows you to fit each Xsheet section to the paper size you want to use to print the
Xsheet on paper.

The info lines allows you to set information to be displayed in the header, for example the production name.

In the example file you can find the following lines:

<info name="Company" value="Company name"/>
<info name="Name" value="Value"/>

These lines can be edited, and new lines, with the same syntax, can be appended, to provide all the information you
want to appear in the header of the HTML Xsheet file.

Note: By default the header contains the Project and Scene names and the number of frames the scene consists of;
this information cannot be edited, as they are retrieved automatically from the scene file.
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Note: The xsheet_html.xml file has to be well-formed, and so it can not contain an opening tag without its
related closing tag, otherwise OpenToonz will not run. If you decide to edit the xsheet_html.xml file, make a
backup copy first in case you need to revert the file to the original version.

Tip: To edit the xsheet_html.xml file:

Open the xsheet_html.xml file available in the folder OpenToonz
stuff\profiles\layouts\settings with a text editor application (e.g. Notepad or TextEdit).

Tip: To change the size of the table used for splitting the Xsheet in sections:

Change the page row and page columns values in the xsheet_html.xml file.

Tip: To edit the information displayed in the header:

Edit the info lines available in the xsheet_html.xml file, and append new ones if needed.

Tip: To check if the xsheet_html.xml file is well-formed:

Open it with an Internet browser and check if all the elements are displayed in a nested list where they can be opened
and closed to display or hide the related contents.

14.15.2 Editing HTML Xsheet Appearance

The HTML Xsheet appearance can be defined by editing thexsheet.css file available in the folder OpenToonz
stuff\profiles\layouts\settings .

The xsheet.css is a Cascading Style Sheet file that is used to define the colors, layout, and other aspects of the
HTML Xsheet file. It can be edited with any text editor software, e.g. Notepad or TextEdit.

Editing the CSS file requires some skill in the CSS language, but some changes like table ruling thickness, or cell
colors, can be easily done by expressing the thickness in pixels and colors as an RGB triplet in hexadecimal format.

Elements defined in the CSS are the following:

• header refers to the table used as header in the HTML Xsheet file.

• table refers to the table used for displaying the Xsheet sections.

• TH refers to the header cells of the tables.

• first_numeric refers to the first numerical column of the Xsheet tables.

• fxcell refers to the table cells belonging to special FX columns.

• subxsheetcell refers to the table cells belonging to Sub-Xsheet columns.

• TD refers to the generic table cells.

• TH.frame refers to the frame column

• TD.levelcell refers to the table cells belonging to standard level columns.
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Note: The CSS files have to be written according to a specific syntax. If you decide to edit the xsheet.css file,
make a backup copy first in case you need to revert the file to the original version.

Tip: To edit the xsheet.css file:

Open the xsheet.css file available in the folder OpenToonz stuff\profiles\layouts\settings with
a text editor application (e.g. Notepad or TextEdit).
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CHAPTER 15

Creating Movements

Each scene has a series of objects that can be transformed; they can be Xsheet columns (or Timeline layers), pegbars,
cameras, or the table.

Every transformation you set for an object at a specific frame automatically defines a keyframe. When keyframes are
defined at several frames, in-between positions are automatically interpolated.

To create more complex animations, you can also work in a 3D environment, where cameras and scene elements can
be placed like on a stage at different distances one from another.

15.1 Using the Stage Schematic

The Stage Schematic contains nodes for all of the objects used in a scene, making it possible to manage the way they
are linked to each other. It’s organized in a hierarchy starting from the animation table, where all the columns/layers
and pegbars are placed. A camera is available as well, and additional cameras can be defined.
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By default the Stage Schematic contains the table node and one camera node.

Column/layer nodes are added as soon as you load or create some content; pegbars and cameras can be added at any
time (pegbars will be automatically linked to the table).

When more than one camera is created, you can set which is the active one, used in the Viewer; the active camera node
is displayed in blue while the others are left idle in grey. Each camera can have a different size and resolution, and
each of them can be animated independently (see Defining Camera Settings ).

Objects nodes can be easily added and arranged and they can be selected in order to be cut, copied, pasted or deleted.
When selected, nodes’ edges are highlighted in white; the current node has its label displayed in yellow; when at least
one node is selected, its related links are displayed in cyan.

It’s also possible to group several nodes into one single node, in order to better manage a complex Stage Schematic.
Groups can be opened to be examined, and its components can be selected for further operations, like creating anima-
tions or new groups.

Note: Column/layer nodes have buttons defining their visibility in Camera stand ( ) and Render ( ) views, these
buttons are located at the top right of the nodes: the toggles are linked to the ones available in the Xsheet columns
(Timeline layers) headers (see Working with Xsheet Columns ).

Tip: To access the stage schematic:
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• Go to the Window menu, and choose the Schematic option.

• If necessary, click the FX/Stage toggle button ( ) in the bottom bar of the Schematic pane until the title bar
displays Stage Schematic.

Tip: To navigate the stage schematic:

Do one of the following:

• Use the mouse wheel, or the zoom shortcut keys (by default + and - keys) to zoom in and zoom out.

• Middle-click and drag to scroll in any direction.

• Use the Fit to Window button ( ) in the bottom bar of the stage window to display all the objects in the
current window.

• Use the Focus on Current button ( ) in the bottom bar of the stage window to center the stage on the current
object.

• Use the Reorder Nodes button ( ) in the bottom bar of the stage window to change the position of the nodes
in the schematic to a default arrangement.

• Use the Reset Size button ( ) in the bottom bar of the stage window, or use the reset view shortcut (by default
the 0 key) to display all the objects at the default size.

Tip: To add a column/layer:

Load or create some content for the Xsheet column (Timeline layer): it will be automatically displayed in the Stage
Schematic.

Tip: To add a pegbar:

Do one of the following:

• Click the New Pegbar button ( ) in the bottom bar of the Stage Schematic window.

• Right-click in the Stage Schematic and choose New Pegbar from the menu that opens.

Tip: To add a camera:

Do one of the following:

• Click the New Camera button ( ) in the bottom bar of the Stage Schematic window.

• Right-click in the Stage Schematic and choose New Camera from the menu that opens.

Tip: To set the active camera:

In the Stage Schematic right-click the camera node you want to set as active and choose Activate from the menu that
opens.
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Tip: To rename an object:

Ctrl + double-click the node name and type a new one.

Tip: To minimize or maximize column/layer nodes:

Do one of the following:

• Click the arrowhead button to the left of the node name to minimize/maximize it selectively.

• Click the Maximize Nodes ( ) button in the bottom bar of the Stage Schematic pane to minimize/maximize
all of the nodes.

Tip: To select objects and links:

Do one of the following:

• Click to select an object.

• Click and drag to select a group of objects.

• Ctrl-click (PC) or Cmd-click (Mac) to add an object to, or remove it from the selection.

Note: Links can be selected together with objects (see Linking Objects ).

Tip: To move the selection:

Click and drag any object of the selection.

Tip: To edit an objects selection:

Do one of the following:

• Use the Copy command to keep the selection in memory for further operations.

• Use the Cut command to eliminate the nodes selection from the Stage Schematic and keep them in memory for
further operations.

• Use the Paste command to paste the selection kept in memory in the Stage Schematic: the pasted selection will
be linked to the same object to which the copied or cut objects were linked.

• Use the Delete command to delete the selection.

Note: All of these commands are available in the menu that opens when right-clicking nodes and links.

Note: The table and the default camera cannot be removed from the Stage Schematic.
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Tip: To Group selected objects:

Right-click any selected nodes and choose Group from the menu that opens.

Note: Nodes can only be grouped if they share the parent node, and the parent node is included in the selection.

Tip: To open a Group:

Right-click the group and choose Open Group from the menu that opens: the group objects are displayed in a box,
showing links between group nodes, and links with nodes outside of the group.

Note: In the Stage Schematic, when the content of a group is displayed it’s not possible to edit the links between
group nodes, and links with nodes outside of the group.

Tip: To close a Group:

Click the Close button on the right of the group box bar.

Tip: To release a Group:

Right-click the group and choose Ungroup from the menu that opens.

Tip: To reorder nodes in the Stage Schematic:

Click the Reorder Nodes button ( ) in the bottom bar of the stage window.

15.2 Linking Objects

Objects can be linked in order to create shared movements (movements that all the linked objects share with the parent
object) and relative movements (movements that are the sum of the object’s own movement and the movement of its
parent object).

As parent objects can be linked, in their turn, to other moving objects, it is possible to define a complex hierarchy of
transformations.

The hierarchy between objects can be edited by setting links that allow you to set parent and linked objects:
columns/layers can be linked to other columns/layers, pegbars, the table or cameras; pegbars can be linked to other
pegbars, the table or cameras; cameras can be linked to any object in order to create complex shots, for example with
a camera following the movement of a character in the scene.

Links can be set by using the ports located at each side of the object node:

• The port on the left is for linking the object to a parent object.

• The port on the right is for linking the object to a child object.
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• The port at the bottom is for assigning the object a motion path to follow (see for Creating a Movement along
a Motion Path ).

Links can also be selected in order to be deleted: when selected, links are highlighted; when at least one object is
selected, the related links are displayed in blue.

Columns/layers and pegbars are always linked, at least to the table: this means that their links cannot be deleted, but
only replaced with different ones or restored to their default: the table.

Tip: To link a node to another:

In the Stage Schematic, click and drag from a node’s left port to the parent node’s right port, or viceversa.

Tip: To link a column/layer to another object:

Do any of the following:

• Define the link in the Stage Schematic.

• Select the Animate tool ( ) with the Pick: option set to Column, and in the viewer Shift-click the column
contents to which you want to link the current column.

Tip: To select the linked object to edit in the hierarchy:

Do one of the following:

• Select it in the Stage Schematic.

• Use the Animate tool ( ) with the Pick: option set to Pegbar to click a drawing in the viewer and select the
first pegbar in the hierarchy the column containing the drawing is linked to.

• Right-click a drawing in the viewer to choose from the menu that opens the Select command related to the object
that you want to edit.

Tip: To select links:

Do one of the following:

• Click to select a link.

• Click and drag to select several links.

• Ctrl-click (PC) or Cmd-click (Mac) to add a link to, or remove it from the selection.

Note: Objects can be selected together with links (see Using the Stage Schematic ).

Tip: To remove selected links:

Choose Edit → Delete, links will be replaced by default ones (i.e to the table).
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15.2.1 Advanced Linking

Optionally, the connector ports can be displayed as letters (instead of the default circles), to be able to control, in more
advanced ways, the position of the centers to be used when linking the nodes:

• Center B is the geometrical center of each object (and the default connection option).

• Center A is placed 8 inches to the left.

• Center C is placed 8 inches to the right.

• etc.

When a link is created, the letters at its ends set the way the linked object overlaps with the parent object. If at both
ends of the link you set the same letter, the two objects will overlap with no offset respect to their default centers;
while if for example, a column centered on B is linked to a pegbar centered on A, it will have an offset of 8 inches to
the left.

Apart from letters, columns have also numbered centers as well; these serve for setting links relative to the position of
Hooks assigned to these columns (see Using Hooks ).

• Center 1 is the center defined by hook number 1.

• Center 2 is the center defined by hook number 2.

• etc.
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Note: While in this mode, each node will have always a free connector port available in order to accept a link to a
different center. In this way if you want to link another object to the same parent object, you can choose whether to
use the same center or a different one.

Note: By defining parent and child objects you can also create cutout animation (see Creating Cutout Animation ).

Tip: To switch the connector ports display mode:

• Click the Switch Output Port Display Mode button ( ) in the bottom bar of the Stage Schematic pane until
you see the letters on each side of the nodes, instead of the default circles.

Tip: To set the center of an object:

1. Place the mouse pointer over the object left port and wait for the double-arrow button to appear.

2. Click and drag up or down the double-arrow button to scroll the options available: letters and numbers for
columns, and letters for all the other types of objects.

Tip: To set the way a child object overlaps its parent object:

Do any of the following:

• Set the same letter for the two ports at the end of a link to overlap the objects without an offset.

• Set the following letter in alphabetical order on the left port of the child object to offset it to the left: for each
successive letter there is an offset of 8 inches to the left.

• Set the following letter in alphabetical order on the right port of the parent object to offset it to the right: for
each successive letter there is an offset of 8 inches to the right.

15.2.2 Using Hooks

Hooks are reference points that can be defined for any animation level directly in the viewer, by using the Hook tool

( ).

Once defined for a column/layer, they can be used in the Stage Schematic to link another object to it in relation to a
specific hook, or to move it, according to any of its hook sets.

In the first case the hook is used as a tracking point to link another object (a column/layer or camera) to a specific
feature of the animation level. For example, if you have a character carrying a lamp, you can track the lamp position
with a hook, and link a radial gradient to it (placed over the lamp for every frame of the animation) to create a glow.

In the second case, the hook is used as the center of the column/layer where the hooked level will be exposed, thus
creating a different center and offset for each level frame. For example, if you have a walking animation cycle, you
can set a new center following the character’s feet with a hook, and make the level move accordingly to prevent a
moon-walking effect on the background.

Hooks can also be split and passed from one drawing feature to another, automatically creating an offset position.
For example, the hook following the character’s foot feature can pass from one foot to another, in order to make the
character move continuously onward.
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Fig. 1: The hook set 2 follows the lamp, while the hook set 1 follows the character’s feet, passing from one feet to
another when both are on the ground.

A hook can be created starting from any frame. Once it is created, it will appear on the following level frames in the
same position, from where it can be moved.

You can use up to 20 hooks for each level; each hook is labeled with a number, to reference it in each level frame.

By activating the Snap option, hooks for the current level can be accurately placed by snapping them exactly to the
same position of hooks defined for the other animation levels visible in the viewer. In case the current level is a Toonz
Vector level, hooks will snap also to the center of any closed shapes it may contain (e.g. rectangles, circles or single
vector shapes closed with the Tape tool). This option may prove useful especially when defining hooks for cutout
animation models (see Creating Cutout Animation ).

Hook information is saved along with each level, as a file in XML format, named as the file but with the _hooks suffix.
For example, hooks defined for the level mouse will be saved in the file mouse_hooks.xml .

Note: Hooks are also visible in Onion Skin mode (see Using Onion Skin ).

Note: Hooks can be also used to create a cutout animation model, as they allow you to link the model sections
according to specific pivot points (see Creating Cutout Animation ).

Tip: To define a hook for a level:

1. Select a frame from the level you want to set hooks for.

2. Choose the Hook tool ( ).

3. Do one of the following:

• Click to create a hook and drag to define the hook starting position.

• Click elsewhere to create another hook and the related hook starting position.

Tip: To select hooks:

Do one of the following:

• Click a hook to select it.

• Ctrl-click (PC) or Cmd-click (Mac) to add a hook to, or remove it from the selection.
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Tip: To move selected hooks:

Do one of the following:

• Drag them to a new position.

• Shift-drag to constrain an horizontal or vertical movement.

• Activate the Snap option to place the hook exactly at the same position of hooks defined for other animation
levels visible in the viewer, or in case the level is a Toonz Vector level, also at the center of closed shapes.

Tip: To pass a hook from one position to another:

1. Alt-click and drag the hook to split it into two.

2. Place the double circle where the hook has to be for the current frame.

3. Place the cross where you want the reference point to be from the next frame onwards.

Tip: To delete a hook:

Select the related hook in any frame and choose Edit → Delete.

Tip: To link an object to a level hook:

1. Link the object to the column containing the hook.

2. Place the mouse pointer over the column right port and wait for the double-arrow button to appear.

3. Click and drag up the double-arrow button to scroll the numbers available before letter A, and release the
mouse button to define the hook number to be used.

Tip: To make the level move according to one of its hooks:

1. Place the mouse pointer over the left port of the column containing the hook, and wait for the double-arrow
button to appear.

2. Click and drag up the double-arrow button to scroll the numbers available before letter A, and release the
mouse button to define the hook to be used.

Tip: To prevent an animation walking cycle from moon-walking:

Define a hook by following these guidelines:

• Place the hook on the same foot feature along the whole sequence, for example the tip of the foot.

• If the character is supposed to be moving horizontally on the ground, the hook should always lie on the ground
line (without changing its vertical position along the sequence). If the feature you are following leaves the
ground, still place the hook on the ground line, under the feature you were following.

• When both feet are on the ground line you can split the hook to pass it form one foot to the other.
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Fig. 2: Column 3 is linked to the hook set 2 of column 2, while column 2 is moving according to its own hook set 1.
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• If the animation is a cycle and you want the character to keep on walking, the last hook position has to be
connected to the first one, and the hook has to pass from one foot to the other by splitting it, and then to the first
one again by splitting it again.

15.2.3 Tracking Points

It is possible to automatically track specific regions in a sequence of images by using the Tracker tool ( ). The
results of the tool are a series of hooks that can be used to link an object to another (see above).

When selected, the Tracker tool ( ) allows you to define one or several regions in an image, by defining a center
and a size; regions can also be connected to one another to better track points having a visual geometrical relationship.
The region defined with the tool sets both, the pattern that the tracking system will try to recognize in the following
images, and the size of the search area where it will look for it (that will be of approximately twice that region).

Once areas to be tracked are defined in the first frame of a range, it’s possible to automatically track the regions in a
selected range, by specifying the following options:
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• Threshold sets the amount of difference between the defined pattern and the recognized one. When using low
values, the tracking system will look for an area with an almost identical pattern, and when using high values,
will look for an area that can be quite different from the original one. This means that if the value is too low, it’s
more likely for the tracking to fail on certain images; if too high, the tracking may fail by following the wrong
areas.

• Sensitivity sets how often the defined pattern has to be updated according to the variation it may have in the
following images. For the maximum value, the pattern will be updated after each image is tracked.

• Variable Region Size, when activated, will look for the defined pattern considering also the different sizes that
it can have in the following images.

• Include Background, when activated, it considers the background as part of the defined pattern. It can be
deactivated when tracking an element whose background does not affect the pattern, such as a green/blue screen
background.

Tip: To define a region to be tracked:

1. Choose the Tracker tool ( ) and click and drag in the image.

2. Use the handles along the defined region bounding box to resize it.

3. Click and drag elsewhere to define a second region: the center of the region will be labelled with a different
letter.

Tip: To define a region connected to another one:

1. Choose the Tracker tool ( ) and select the region to which you want to connect another region.

2. Click and drag elsewhere to define a connected region: the center of the region will be labelled with the same
letter of the first one.

Tip: To delete a defined region:

1. Choose the Tracker tool ( ) and select the region you want to delete.
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2. Choose Edit → Delete.

Tip: To track a defined region in a series of images:

1. Select the first image of the range you want to track.

2. Choose the Tracker tool ( ) and define the regions to be tracked.

3. Select the frame range in the Xsheet/Timeline or in the Level Strip.

4. Choose Level → Tracking. . . , set the tracking options and click the Track button.

Tip: To link an object to the tracked region:

Link the object to one of the hooks defined by the tracking process (see Using Hooks ).

15.3 Animating Objects

You can animate the position, rotation, scale and shear (plus edit the center) of columns, pegbars, cameras and the
table by using the Animate tool. Objects to be animated can be selected either in the Stage Schematic, the Viewer, the
Xsheet/Timeline or by using a dropdown menu in the Animate tool’s own options bar.

In the Animate tool ( ) options bar you can set the following:

• Object:, lets you select which scene object is to be effected by the tool. Here will be listed all
columns, cameras and pegbars created, plus the table itself.

• Mode:, lets you choose which transformation options to display in the tool options bar. Options are:
Position, Rotation, Scale, Shear, Center and All.

• Position, X: and Y: set the horizontal and vertical positions of the selected object, Z: sets its position
along the Z axis, for defining the depth of the object in 3D space (see Working in a 3D Environment
), and SO: sets the column/layer stacking order, that can override the default one defined by the
Xsheet column (or Timeline layer) order (see Changing Columns Stacking Order ).

• Rotation:, sets the rotation of the selected object around the Z axis.

• Scale, Global:, H: and V: set the global, horizontal and vertical scaling of the selected object.
Maintain: sets a constraint for scaling operations performed by using the Animate tool handle: if it
is set to A/R the object will maintain its proportions, if it is set to Mass the object will maintain its
overall volume.

• Shear, H: and V: set the horizontal and vertical shearing of the selected object.

• Center, X: and Y: set the horizontal and vertical position of the center of the selected object. The
Center of an object cannot be animated.
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• All displays all transformation types at the same time. In the viewer a handle will also be available
that let users visually change any of the transformation types: Position, Rotation, Scale, Shear and
Center.

• Pick: (only available in All mode) lets the user choose to automatically select columns/layers or
pegbars to be animated when the selection is done by clicking in the Viewer: when set to Column,
clicking a drawing automatically selects the related column/layer; when set to Pegbar, clicking a
drawing automatically selects the pegbar to which the column/layer containing the drawing is linked
(if there is one); when set to None the selection of drawings in the Viewer is disabled.

• Lock buttons ( ) define which values remain locked while transforming the object.

• Global Key when activated, sets a key for all of the object transformations as soon as a key is set
for any of its transformations interactively in the viewer. For example if you change the position of
an object, thus defining a keyframe for it, keys will also be automatically defined for the rotation,
scaling and shearing transformations as well. This option will not take any effect if the values for
the property are input directly in the toolbar, and not interactively.

Note: If the tool options bar is too short to display all the tool options, it can be scrolled by using arrow buttons
available at its ends.

Note: Position values are expressed in the default unit of measure set in the Preferences. . . → Interface dialog (see
Choosing the Working Unit ).

15.3.1 Animate Tool Handle

When the Animation tool is in All mode, you can also interactively control transformation values by using the handle
available in the viewer. The handle is made of an inner double circle with three arms that allow you to change any of
the following transformations:

Note: As you roll over the handles, the cursor changes shape to indicate to you the operations you may perform.

Note: For greater precision it is possible to keep the Alt key depressed before starting to perform any transformation.
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• Position: Click and drag anywhere to move the object; if the Shift key is pressed while dragging, the movement
will be constrained in the horizontal or vertical direction.

• Rotate: Click and drag the circle end to rotate the object;

• Scale: Click and drag the outer square of the double-square end to scale the object uniformly on the vertical
and horizontal; click and drag the inner square of the double-square end to scale the object according to the
constraint set in the options bar; if no constraint is set and the Shift key is pressed while dragging, the scaling
will be uniform.

• Shear: Click and drag the parallelogram end to shear the object; if the Shift key is pressed while dragging, the
shearing will be constrained in the horizontal or vertical direction.

• Center: Click and drag the double circle at the center to change the center of the object.

Note: The object center can be moved, but cannot be animated. Once it is set, or modified, it is retained in that
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position during all of the animation. If the Center is changed many times, and you want to set it back to its original
position, right-click the object in the Stage Schematic and choose Reset Center from the menu that opens.

When entering a value or operating the handle, a keyframe will be automatically generated at the current frame only
for the set transformation; if the Global Key option is activated, keys will be generated for all of the transformations.

If you want to set a key for an object transformation, maintaining its value as it is at the current frame, you can just
press Enter on the displayed value. If you want to set keys for all of the object transformations maintaining their

values as they are at the current frame, you can use the Set Key button ( ) available in the bottom bar of the viewer;
in this case keys are created for all of the object transformations, regardless of the Global Key option.

Note: Objects can also be animated by working in the Function Editor (see Editing Curves and Numerical Columns
).

Note: The movement of the column contents can be checked by activating the Onion Skin mode, as it will display
the position of drawings contained in the current column at different frames (see Using Onion Skin ).

Tip: To select the object to edit:

Do one of the following:

• Select it in the stage schematic.

• If the object is a column/layer, select it in the Xsheet/Timeline.

• Use the Animate tool ( ) with the Pick: option set to Column to click a drawing in the viewer to select the
related column.

• Use the Animate tool ( ) with the Pick: option set to Pegbar to click a drawing in the viewer to select the
pegbar that the column containing the drawing is linked to.

• Right-click in the Viewer a drawing to select an object from the list of scene objects.

Tip: To animate an object with the Animate tool:

1. Select the object you want to animate.

2. Choose the Animate tool ( ).

3. Set the frame where you want to define the key by doing one of the following:

• Move the current frame cursor in the Xsheet/Timeline or in the Function Editor.

• Use the Frame bar or the Playback buttons in the bottom bar of the viewer.

• When animating columns only, select the related cell in the column/layer.

4. Define a keyframe.

5. Select a different frame, and go on defining keyframes.

Tip: To define a keyframe only for some object transformations:
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1. Deactivate the Global Key option in the tool options bar.

2. Do one of the following:

• Enter values in the Animate tool options bar for the object transformations you want to set a key for.

• If in All mode, operate the handle to move, scale, rotate or shear the object, automatically generating a key only
for the modified transformation.

Note: As this keyframe is partial and refers only to some transformations, the Set Key button turns striped-blue.

Tip: To define a keyframe for all the object transformations:

1. Activate the Global Key option in the tool options bar.

2. Interactively move, rotate, scale or shear the object in the viewer.

Note: As this keyframe is global and refers to all the transformations, the Set Key button turns blue.

Tip: To define a key for an object transformation leaving its value as it is at the current frame:

1. Deactivate the Global Key option in the tool options bar.

2. In the Animate tool options bar click in the field of the object transformations you want to set a key for, and
press the Enter key.

Note: As this keyframe is partial and refers only to some transformations, the Set Key button turns striped-blue.

Tip: To define keys for all of the object transformations leaving their values as they are at the current frame:

Do one of the following:

• Click the Set Key button ( ).

• When animating columns/layers only, right-click in the column/layer cell and choose Set Key from the menu
that opens.

Note: As this keyframe is global and refers to all the transformations, the Set Key button turns blue.

Tip: To turn a partial keyframe to a global key:

Click the Set Key button ( ): it turns from blue-striped to blue.

Tip: To remove a set keyframe from the viewer bottom bar:
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Do one of the following:

• If the keyframe is global, click the Set Key button ( ): it turns from blue to grey.

• If the keyframe is partial, click twice the Set Key button ( ): with the first click it turns from striped-blue to
blue, with the second from blue to grey.

Tip: To navigate frames where keyframes are defined in the viewer bottom bar:

Use the Previous Key ( ) and Next Key ( ) buttons available at the side of the Set Key button.

Note: Keys can also be removed or navigated by working in the Function Editor (see Editing Curves and Numerical
Columns ).

Tip: To customize the Animate tool options bar:

Do any of the following:

• Use the Tool Mode: dropdown menu to choose from one of its modes: Position, Rotate, Scale, Shear, Center or
All: only the options for the selected transformation category will be displayed.

• Use the Lock button ( ) to choose which transformations have to be locked while transforming the object:
only selected items will be locked.

15.3.2 Changing Stacking Order of Columns/Layers

The column/layer stacking order, which sets which drawings and images are placed on top or behind, other images, by
default depends on how columns/layers are placed in the Xsheet/Timeline: Xsheet direction is from left to right, while
Timeline direction is from bottom to top, making what’s on the left/bottom to be behind of what’s on the right/top.

This would mean that if an animation element has to move behind another animation element and then in front of it,
it’d have to be exposed in two different columns, one before and one after the column containing the second animation
element.

By editing the SO (i.e. stacking order) value it’s possible to change and animate the element compositing order without
editing the columns/layers position in the Xsheet/Timeline.

The SO default value for all the columns is 0, meaning that the Xsheet column (or Timeline layer) order is what’s
taken into account when there are no modifications to the SO position. As soon as a column/layer has a higher SO
value, it will be placed on top, regardless of the position of the column/layer in the Xsheet/Timeline; conversely if the
SO value is lower it will be placed behind.

Note: In case a column/layer’s Z position is edited, columns/layers closer to the camera will be composited on top of
others, ignoring both its Xsheet/Timeline order and its SO value (see Working in a 3D Environment ).

Tip: To edit and animate a column/layer SO value:

1. Select the column/layer to which you want to edit the SO value.
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2. Choose the Animate tool ( ).

3. Set the frame where you want to define the key.

4. In the tool options bar enter the value in the SO field.

Note: Columns/layers SO values can also be edited and animated by working in the Function Editor (see Editing
Curves and Numerical Columns ).

15.3.3 Creating a Movement along a Motion Path

Objects can be moved along a motion path according to two different type of movements: one without changing the
object orientation, and the other with an automatic orientation, set according to the direction of the motion path.

A motion path can be assigned to an object node in the Stage Schematic, and it can be defined with drawing tools and
edited in the viewer as if it was a vector drawing. Once defined, it’s displayed as a dashed red line, with small numbers
indicating the control points defining the vector stroke.

As soon as a path is assigned to an object’s node, the object will be automatically placed at the beginning of the path
according to its center, and it will only be able to move along it (and not in the standard X and Y directions anymore).

The keyframes of the object on the motion path can be defined by dragging the object along it, and they are expressed
as a percentage where 0% is the starting point and 100% is the ending point of the path.

It’s also possible to link the keyframes of the objects to the positions of the control points defining the motion path,
so that they remain consistent when the motion path is edited. To help you better understand where the control points
are, the object snaps to them when it is dragged along the motion path.

Note: If you want to change the center of the object, you can move it using the Animate tool ( ), and then use the
Reset Center command in the Stage Schematic.

Note: A motion path can also be created by copying and pasting a drawing vector stroke, and conversely a drawing
vector stroke can be created by copying and pasting a motion path.

Tip: To create a motion path:

1. Select the object for which you want to define a motion path.

2. Do one of the following:

• Click the New Motion Path button ( ) in the bottom bar of the stage window.

• Right-click in the stage and choose New Motion Path from the menu that opens.

Tip: To define and edit a motion path:

Select the motion path node in the stage and do any of the following:

• Use the drawing tools to define it in the viewer.

• Use the modifier tools to edit it.
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Fig. 3: A motion path assigned to pegbar 2.
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• Draw a new line, and confirm in the dialog that opens, to replace a previously created motion path with the new
one.

Tip: To assign a motion path to an object:

Click and drag the motion path top port to the object node bottom port.

Tip: To remove a motion path from an object:

1. Select the link between the object and the motion path.

2. Choose Edit → Delete.

Tip: To set the type of movement along a motion path:

Click the button at the far left of the object bottom port to switch between two options: the Square button ( )

will preserve the object’s original orientation, and the Rotated Square button ( ) will automatically rotate the
object according to the motion path’s direction.

Tip: To link the object keyframes to the control points defining the motion path:

Click the button next to the object bottom port to activate or deactivate the Link to Control Points option ( ).

Tip: To change the center of the object:

1. Choose the Animate tool ( ).

2. Move the center of the object to the new position.

3. Right-click the object node in the Stage Schematic and select Reset Center from the menu that opens.

Tip: To save a motion path:

1. Right-click it and select Save Motion Path from the menu that opens.

2. In the browser choose a location and a name and click the Save button. The file will be saved with the MPATH
extension.

Tip: To load a motion path:

1. Right-click the motion path and select Load Motion Path from the menu that opens.

2. In the browser retrieve the MPATH file you want to load and click the Load button.
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Tip: To use a drawing vector stroke as a motion path:

1. Select the vector stroke you want to use as a motion path with the Selection tool ( ).

2. Copy/cut it.

3. Select the motion path you want to paste to, in the Stage Schematic.

4. Click in the viewer and paste the copied/cut vector that will automatically become the motion path.

Tip: To use a motion path as a vector stroke in a drawing:

1. Select the motion path in the Stage Schematic.

2. Select the motion path with the Selection tool ( ) in the viewer.

3. Copy/cut it.

4. Select the drawing where you want to paste the new stroke.

5. Paste the copied/cut motion path that will automatically become a stroke.

Tip: To remove a motion path from the Stage Schematic:

Do one of the following:

• Select the motion path node and choose Edit → Delete.

• Right-click the motion path node and choose Delete from the menu that opens.

15.4 Using Keys in Columns/Layers

When columns/layers are animated, their animation can be controlled in a quick way by managing keyframes and
interpolations directly in the Xsheet or Timeline, with no need to use the Function Editor.

As soon as a keyframe is defined for a column/layer, a Key icon is displayed on the right of the column/layer cell to
which it refers; the key is displayed regardless of how many parameters are animated. Keys can be moved within the
column/layer they refer to, and selected in order to be cut/copied and pasted from one cell to another.
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When the Global Key option is activated for the Animate tool, and the default interpolation is not set to Linear, as
soon as at least two keyframes are created for a column, a line connecting them with two arrowheads is displayed
(see Animating Objects and Setting Segment Interpolations ). The two arrowheads divide the line into three sections
indicating the speed in, the constant speed, and speed out phases of all the transformations defined. This allows you
to control the speed of the movement between the two keys as you wish, including a constant speed movement.

You can also cycle previously created keys, in order to repeat automatically all the previously defined keys for the
whole length of the scene, with no need to copy and paste keys from cells to cells.

All animations and interpolations set for the column/layer can be visible and edited with the Function Editor. When you
edit any column/layer transformation in the Function Editor, the arrowheads will not be displayed anymore between
keys, to stress the fact that a specific interpolation has been modified with the Function Editor. If needed, you can
Reset the whole column/layer transformation to the default interpolation values, and make the arrowheads available
again (see Editing Curves and Numerical Columns ).

Tip: To modify a key:

1. Select the cell the key refers to.

2. Do one of the following:
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• Use the Animate tool ( ) to modify position and size.

• Enter values you want to modify in the Animate tool ( ) options bar.

Tip: To select keys:

Do one of the following:

• Click a key icon to select it.

• Click a key icon and drag to select a range of keys on different columns and at different frames.

• Shift-click to extend the selection to a specific key.

• Ctrl-click (PC) or Cmd-click (Mac) to add to, or remove a key to the selection.

• Right-click a key icon and choose the related command from the menu that opens to perform specific selections,
such as all keys in the row, all previous ones, all following ones, etc.

Tip: To move a key selection:

Click any of the selected keys and drag the selection to the new position. Dragging is allowed only inside its own
column/layer.

Tip: To edit a key selection:

Do one of the following:

• Use the Cut command to eliminate the selection from the scene and keep it in memory for further operations.

• Use the Copy command to keep the selection in memory for further operations.

• Use the Paste command to paste the selection kept in memory starting from the selected cell.

• Use the Delete command to delete the selection.

Note: All these commands are also available in the menu that opens when right-clicking the key icon.

Tip: To set the speed of the movement or transformation:

Click the arrowheads available on the line connecting two subsequent keys, and drag them up or down to the new
position. In particular:

• To set a constant speed, drag the top arrowhead close to the first key icon to eliminate the ease in section, and
the bottom arrowhead close to the second key icon to eliminate the ease out section.

• To set a continuous acceleration, drag both arrowheads close to the second key icon in order to increase the
speed in section.

• To set a continuous deceleration, drag both arrowheads close to the first key icon in order to increase the speed
out section.
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Tip: To make the arrowheads available when they are not:

Right-click the line connecting two subsequent keys and choose Reset Interpolation from the menu that opens.

Tip: To activate/deactivate the cycling of previously created keys:

Click the Circular arrow icon ( ) visible after the last key of a series.The cells affected by the cycled movement are
marked on the right by a zigzagged line.

Tip: To open the Function Editor:

Do one of the following:

• Double-click a key.

• Right-click a key and choose Function Editor from the menu that opens.

15.4.1 Working with Multiple Column/Layer Keys

It is possible to insert or delete keys affecting the Xsheet/Timeline as a whole, or a selection of Xsheet columns (or
Timeline layers).

Inserting or deleting multiple keys allows you to manage keys for several columns/layers at the same time, for instance
when you are working on a cutout animation where keys may be required for all the columns/layers where model
sections are exposed (see Creating Cutout Animation ).

Note: Inserted keys are created for all the column transformations.

When a multiple key is inserted at the current frame, a key is created for each Xsheet column (or Timeline layer) where
an animation level is exposed; if a column/layer selection is defined, keys are created in selected columns/layers only
(see Working with Xsheet Columns ).

When a multiple key is deleted at the current frame, any key available in any Xsheet column (or Timeline layer) at the
current frame is deleted; if a column/layer selection is defined, keys are deleted in selected columns/layers only.

Tip: To create several keys at once:

1. Do one of the following:

• Select the columns/layers for which you want to create keys.

• Select no column by clicking anywhere in the Xsheet/Timeline, to create keys for all the columns/layers.

2. Select the frame where you want to insert keys.

3. Choose Xsheet → Insert Multiple Keys.

Tip: To remove several keys at once:

1. Do one of the following:

• Select the columns/layers from which you want to delete keys.
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• Select no column by clicking anywhere in the Xsheet/Timeline, to delete keys from all the columns/layers.

2. Select the frame where you want to delete keys.

3. Choose Xsheet → Remove Multiple Keys.

15.5 Working in a 3D Environment

You can place and move cameras, the table, pegbars and columns/layers in a 3D environment, as if they were elements
on a real 3D stage.

This means that it’s possible to move the camera automatically generating a multiplane effect, or truck it through char-
acters and elements simulating a perspective effect, or create complex 3D motion paths for any element by combining
a depth movement with movements in the X and Y directions.

The 3D environment can be activated, or deactivated, with the 3D View button ( ) available in the Viewer title bar.
When activated, the viewer displays the cone of the camera and all of the scene contents along the Z axis, which is the
direction from the camera to the table. The area displayed can be moved and rotated to set the best viewing angle, and
a side or top viewpoint can be set.

By default all the pegbars and columns are on the table: their Z position is equal to the number of horizontal fields
defined for the default camera (as the value represents the size of the area that is shot by the camera) (see Defining
Camera Settings ). By increasing the field value, objects are placed farther from the camera; by decreasing it, objects
are placed closer to the camera; at zero they are at the same Z position as the camera, and for negative values they are
behind the camera.

As concerning the camera, by default its Z position is equal to the number of horizontal fields defined for the default
camera. By increasing the field value, the camera moves farther from the table; by decreasing it, it moves closer; at
zero it is at the same Z position of the table and for negative values it is behind the table.

As soon as objects are moved, projections on an imaginary floor and side wall let you understand the position of the
drawings in relation to each other and to the camera. If the current object is a column/layer, a dotted bounding box
displays the area of it currently being shot by the camera.

The size of the objects changes according to its Z position, like in a real 3D environment, decreasing when an object
is farther from the camera and increasing when closer. To keep control of this behaviour it’s possible to define an
additional Z position value in the tool options bar, that sets the position at which the object has to keep its original size.

Note: Columns closer to the camera are displayed on top of others, ignoring the Xsheet/Timeline order and the SO
value. In case two or several columns have exactly the same distance, the SO value prevails; if two or several columns
have exactly the same distance and SO value, the Xsheet column (or Timeline layer) order prevails (see Changing
Columns Stacking Order ).

Tip: To enter the 3D environment:

Click the 3D View button ( ) available on the right of the viewer title bar.

Tip: To set an object position in the 3D environment:

1. Activate the 3D View.

2. Select the object you want to move.
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3. Select the Animate tool ( ).

4. Do one of the following:

• Enter a value for the Z position in the tool options bar.

• Use the double-arrow handle parallel to the floor of the 3D environment, to move the selected object and set
its Z position.

Tip: To set at which position the object has to keep its original size:

Enter a value for the additional Z position field displayed in brackets in the tool options bar. For example if you want
a column content to keep its original size when placed at the Z position 8, also enter 8 as the value in brackets.

Tip: To move the work area displayed in 3D:

Select the Hand tool ( ) and drag in the viewer.

Tip: To rotate the work area displayed in 3D:

Select the Rotate tool ( ) and drag in the viewer.

Tip: To set a side or a top view:

Do one of the following:

• To set a Side view use the button ( ) available on the side wall of the 3D environment.

• To set a Top view use the button ( ) available on the floor of the 3D environment.

Tip: To exit the 3D environment:

Click the Camera Stand ( ) or Camera View ( ) buttons available on the right of the viewer title bar.
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CHAPTER 16

Editing Using Spreadsheet and Curves

Changes in Object transformations and effects parameters are shown in the Function Editor window, where
keyframes and their related interpolations can be controlled and modified by using a Spreadsheet of numerical
columns or a Graph Editor.

The Spreadsheet displays changes in columns where each column represents a single animatable parameter and each
row shows the value of a parameter at each frame.
Blank cells represent the absence of a change in a parameters value due to no keyframes being defined.

The Graph Editor displays changes as curves in a graph, where frames are laid horizontally and values are laid
vertically.
Keyframes are represented as points and the interpolated values between them are visualized as red lines.

The spreadsheet’s columns and the graph editor’s curves are different representations of the same data, so any changes
made in one view are also reflected in the other.
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16.1 Using the Function Editor

The function editor window is divided into three sections. On the left there is an area where the Spreadsheet or
Graph Editor is displayed, on the right top is an area where the interpolation of the current transformation segment is
displayed, and on the right bottom is the objects/effects tree.

The tree has two main item folders, Stage and FX: in the first you can find folders for the defined cameras, the table,
used pegbars and columns; in the second one you can find folders for each used effect. Each folder contains the related
transformation parameters.

The objects/effects tree tells if the object/effect is animated and which parameter is animated, by using the following
icons:

• A plain folder is for non-animated objects/effects.

• A folder with an arrow is for animated objects/effects.

• An icon with a dotted straight line is for non-animated parameters.

• An icon with a continuos curve is for animated parameters.

Clicking these icons allows you to select which object/effect and which parameters have to be displayed as a spread-
sheet or curves in the area on the left.

Transformation data can be saved and loaded as a CURVE file, to allow the exporting and importing from one scene
to another, and they can be exported as well as a DAT file in order to be used in other software.

Tip: To resize the Function Editor sections:

Do any of the following:
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• Click and drag the separators to resize sections.

• Click and drag a separator toward the window border to hide a section.

• Click and drag the separator collapsed to the window border toward the window center to display again the
hidden section.

Tip: To display or hide column parameters:

1. Retrieve the object or the effect in the objects/effect tree.

2. Do one of the following:

• Click the folder to display or hide all columns or curves related to its parameters.

• Click the parameter icon to display or hide its related column or curve.

• Click a parameter icon and drag to display or hide all the columns or curves you pass upon.

• Right-click the folder and choose Show Animated Only from the menu that opens to display or hide only the
animated columns or curves related to its parameters.

• Right-click the folder and choose Show All from the menu that opens to display or hide all columns or curves
related to its parameters.

Tip: To open the Graph Editor in a separate window:

1. Make sure the option Graph Editor Opens in Popup is selected from the Function Editor: dropdown menu,
in the Preferences. . . → Interface dialog section. (Restart OpenToonz).

2. Click the Function Editor Toggle button ( ) in the top bar of the Function Editor.

Tip: To open the Spreadsheet in a separate window:

1. Make sure the option Spreadsheet Opens in Popup is selected from the Function Editor: dropdown menu, in
the Preferences. . . → Interface dialog section. (Restart OpenToonz).

2. Click the Function Editor Toggle button ( ) in the top bar of the Function Editor.

Tip: To switch between Spreadsheet and Graph Editor in the Function Editor:

1. Make sure the option Toggle Between Graph Editor and Spreadsheet is selected from the Function Editor:
dropdown menu, in the Preferences. . . → Interface dialog section. (Restart OpenToonz).

2. Click the Function Editor Toggle button ( ) in the top bar of the Function Editor.

Tip: To scroll the Spreadsheet:

Do one of the following:

• Middle-click and drag to scroll in any direction.

• Use the mouse wheel to scroll up or down.
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• Use the scrolling bars to scroll only within the actual spreadsheet extent.

• Use the Up Arrow and Down Arrow keys to move one frame up or down.

• Use the Page Up and Page Down keys to scroll the visible frames up or down.

• Use the Home and End keys to scroll up to the beginning or the end of the Xsheet/Timeline content.

Tip: To navigate the Graph Editor:

Do one of the following:

• Use the mouse wheel, or the zoom shortcut keys (by default + and - keys) to zoom in and zoom out.

• Click in the horizontal ruler and drag up to zoom in horizontally, down to zoom out; click in the value vertical
ruler and drag up to zoom in vertically, down to zoom out.

• Middle-click and drag the graph area to scroll in any direction, the horizontal ruler to scroll horizontally, and
the vertical ruler to scroll vertically.

• Use the reset view shortcut (by default the Alt + 0 key) or right-click the graph area and choose Fit from the
menu that opens, to display all the visible curves in the current Function Curve Editor window.

Tip: To save transformation data:

1. Right-click the relevant parameter in the objects/effects tree, and choose Save Curve from the menu that opens.

2. Use the Browser to choose a name and location for the file to be saved: the data will be saved as a CURVE file.

Tip: To load transformation data:

1. Right-click the relevant parameter in the objects/effects tree, and choose Load Curve from the menu that opens.

2. Use the Browser to retrieve the curve to load; valid files are in CURVE format.

Tip: To export transformation data:

1. Right-click the relevant parameter in the objects and effects tree, and choose Export Data from the menu that
opens.

2. Use the Browser to choose a name and location for the file to be saved: the data will be saved as a DAT file that
can be used in other software supporting this type of information.

16.2 Defining keyframes

Keyframes, including those belonging to object transformations done by using the Animate tool ( ) and those
defined for effects parameters in the FX Settings window, can be controlled and edited both using the Spreadsheet’s
numerical columns and the Graph Editor’s curves (see Animating Objects and Editing FX Settings ).

In the Spreadsheet, keyframes are displayed as orange cells; in the Graph Editor, keyframes are represented as control
points along the curve. In both cases they can be added, edited, moved and deleted.
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16.2.1 Using the Spreadsheet

The Spreadsheet displays transformations in columns like the ones available in the Xsheet/Timeline, having one for
each parameter. For each frame, the column’s cells display the related transformation values.

Keyframes are displayed in different-colored cells, and can be moved along the column to different frames positions.
In-between values are automatically generated according to the keyframes and to the set interpolation (see Setting
Segment Interpolations ).

All the columns referring to the same object or effects are grouped under one single header. For example under a
pegbar header you can find all the columns referring to its transformations.

Columns cells can be used to type in directly values for keys, edit or move them. Values contained in cells can be cut,
copied and pasted, so that transformations can be displaced, repeated and deleted.

Tip: To define keyframes directly in Spreadsheet columns:

1. Double click in the column cell where you want to define a keyframe: the cell becomes editable.

2. Type in the value for the key, and press Enter to confirm.

Tip: To move a keyframe:

Click the vertical strip at the left of a keyframe cell, and drag it up or down to the new position; the in-between values
change accordingly.
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Tip: To displace the channel along the column:

Click the vertical strip at the left of the selected column cells, and drag it up or down to the new position: the content
of the segments completely included in the selection will move along the column.

Tip: To copy/cut and paste column values:

Do one of the following:

• Click and drag to perform a selection; the selection can be extended to several columns.

• Use the Copy command: the selection will be kept in memory for further operations.

• Use the Cut command: the selection will be removed from the columns and will be kept in memory for further
operations. The cells removal causes the following cells to shift up.

• Use the Paste command: the selection kept in memory will be pasted starting from the selected insertion cell.
The command causes the following cells to shift down.

• Use the Delete command: selected cells will be deleted, causing the following cells to shift up.

16.2.2 Using the Graph Editor

The Graph Editor displays transformations as curves in a graph where time is laid horizontally, and parameter values
are laid vertically.

302 Chapter 16. Editing Using Spreadsheet and Curves



OpenToonz Documentation, Release 1.7.1

Curves are defined by control points representing keyframes. Points can be easily added by working directly in the

graph or using the Set Key button ( ) in the top bar of the Function Editor.

Control points can also be selected in order to be edited, moved or deleted.

The Set Key button ( ) is either grey when no keyframe is defined for the current curve at the current frame, or blue
when a keyframe is defined for the current curve at the current frame.

Frames and keyframes can be navigated by using the related buttons in the top bar of the editor. The Next Key ( )

and Previous Key buttons ( ) are available only if more than one keyframe is defined.

Tip: To set the current curve:

Do one of the following:

• Click the related parameter name in the objects/effects tree.

• Display the curve in the Graph Editor, then click to select it.

Tip: To set the current frame:

Do one of the following:

• Click in the frame horizontal ruler to set a position for the current frame marker.

• Click and drag the current frame marker in a horizontal direction.

• Type the frame number in the Frame text box, or use the Next Frame and Previous Frame buttons available
in the top bar of the editor.

• Move the current frame cursor in the Xsheet/Timeline.

• Use the frame bar or the playback buttons in the bottom bar of the main viewer.

Tip: To add a keyframe:

Do one of the following:

• Click the Set Key button ( ) to add a keyframe at the current frame.

• Type a value in the Value text box to add a keyframe at the current frame.

• Right-click and choose Set Key from the menu that opens.

• Ctrl-click (PC) or Cmd-click (Mac) the curve where you want to add the keyframe point to it.

Tip: To remove a keyframe:

Do one of the following:

• Select the keyframe to remove and choose Edit → Delete.

• Set the current frame where a keyframe is and click the Set Key button ( ).
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Tip: To select keyframes:

Do one of the following:

• Click to select a keyframe.

• Shift-click to add a keyframe to or remove it from the selection.

• Click and drag to select all of the keyframes that are in the area you define.

Tip: To select curve segments:

Select the segment or the control points at the ends of the segment.

Tip: To move the selection:

Click and drag any of the selected control points.

Tip: To edit curves:

Do one of the following:

• Use the Copy command: the selected segments will be kept in memory for further operations.

• Use the Cut command: the selected segments will be removed from the curve and will be kept in memory for
further operations.

• Use the Paste command: the segments kept in memory will be pasted starting from the selected keyframe,
preserving any other previously defined keyframes not replaced by the new ones.

• Use the Delete command: the selection will be deleted.

Tip: To navigate keyframes for the current curve:

Use the Next Key ( ) and Previous Key buttons ( ) available at the sides of the Set Key button.

Tip: To cycle previously created keyframes:

Right-click the dashed line after the end of the curve and choose Activate Cycle from the menu that opens.

Tip: To disable the cycle:

Right-click the curve and choose Deactivate Cycle from the menu that opens.

Note: Only keyframes included in the selection are considered when performing copy, cut and paste operations.
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Note: All the Edit menu commands are also available in the menu that opens when right-clicking in the
Xsheet/Timeline cells.

16.3 Setting Segment Interpolations

A transformation segment, that is to say the section between two keyframes, can have different interpolations affecting
the way the value changes from one key to another. The set interpolation will be displayed graphically in the Graph
Editor, and as a series of values, one for each frame, in the Spreadsheet.

Available interpolations are the following: Linear, Speed In / Speed Out, Ease In / Ease Out, Ease In / Ease Out
%, Exponential, Expression, File, Constant and Similar Shape. The Default Interpolation option can be set in the
Preferences. . . → Animation dialog section, but it can be changed at any time in the interpolation area of the Function
Editor, on the top right of the window.

In the same area it is also possible to define an interpolation Step, that is to say the number of frames for which
the interpolation values have to be repeated, for instance to match a movement with an animation level exposed at a
specific step. The default animation step can be set in the Preferences. . . → Animation dialog section.

Tip: To set the type of interpolation for a segment in the Spreadsheet:

1. Move the current frame cursor to a frame belonging to a segment.

2. Choose the interpolation from the option menu available in the Interpolation: area of the Function Editor.

3. Click the Apply button to apply the desired change.

Tip: To set the type of interpolation for multiple segments in the Spreadsheet:

1. Make a cell selection that encompases multiple keyframe segments.

2. Right click on one of the selected cells and choose the desired interpolation type in the menu that opens.

Tip: To set the type of interpolation for a segment in the Graph Editor:

1. Set the segment by doing one of the following:

• Click a segment to select it.

• Move the Current Frame Marker to a frame belonging to a segment.

2. Choose the interpolation from the dropdown menu available in the Interpolation: area of the Function Editor.

3. Click the Apply button to apply the desired change.

Note: The interpolation options are also available when right-clicking a segment.

Tip: To set the Step of the interpolation:

1. Specify the Step value in the interpolation area of the Function Editor.

2. Click the Apply button to apply the desired change.
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16.3.1 Using Linear Interpolations

When the interpolation is Linear the curve segment turns to a straight line and the speed of the transformation is
constant.

Tip: To set a Linear interpolation:

Do one of the following:

• Choose Linear from the option menu available in the Interpolation area of the Function Editor and click the
Apply button.

• Right-click the curve segment you want to set the interpolation for, and choose Linear Interpolation from the
menu that opens.
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16.3.2 Using Speed In / Speed Out Interpolations

When the interpolation is Speed In / Speed Out, both control points at the ends of the segment have handles whose
direction and length define the slope of the curve, therefore the speed of the transformation. The handles direction
and length can be set by entering values in the Interpolation area of the Function Editor, or by dragging the handles
themselves.

By default the handles are linked, making their degree of movement dependent on adjacent segments in order to define
a smooth curve, but the link can be broken in order to move the handle freely. For example if subsequent segments
have the Speed In / Speed Out interpolation, the handles of the shared points share the same direction, but breaking
the link each handle can have a different direction.

Handles can also be collapsed in control points in order to turn them into corner points; in this case to retrieve the
handles it is possible to reset their length and direction.

Tip: To set a Speed In / Speed Out interpolation:

Do one of the following:

• Choose Speed In / Speed Out from the dropdown menu available in the Interpolation area of the Function
Editor and click the Apply button.

• Right-click the curve segment you want to set the interpolation for, and choose Speed In / Speed Out Interpo-
lation from the menu that opens.

Tip: To set the speed of the interpolation:

1. Select the keyframe at the beginning or at the end of the curve segment you want to edit, or the curve segment
itself.

2. Set the slope of the curve after or before the keyframe by doing one of the following:

• Enter the Speed In and Speed Out direction and length values in the Interpolation area of the Function Editor
and click the Apply button.

• Click and drag the end of the handles to move them freely.
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• Shift-click and drag the end of the handles to move them with a constraint in the horizontal or vertical direction.

Tip: To move a control point handle free from the adjacent segments:

Right-click the control point and choose Unlink Handles from the menu that opens.

Tip: To link back handles to adjacent segments:

Right-click the control point and choose Link Handles from the menu that opens.

Tip: To turn a control point into a corner point:

1. Select the control point.

2. Move the handle ends to the control point, in order to collapse them.

Tip: To retrieve handles from a corner point:

Right-click the control point and choose Reset Handles from the menu that opens.

16.3.3 Using Ease In / Ease Out Interpolations

When the interpolation is Ease In / Ease Out, the segment is divided into three sections by two vertical lines: the first
section is an acceleration, the second is at constant speed, the third is a deceleration. The duration in frames of each
section can be set by entering values in the Interpolation area of the Function Editor, or by dragging the vertical lines
available on the segment.

Tip: To set an Ease In / Ease Out interpolation:
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Do one of the following:

• Choose Ease In / Ease Out from the dropdown menu available in the Interpolation area of the Function Editor
and click the Apply button.

• Right-click the curve segment you want to set the transformation for, and choose Ease In / Ease Out Interpo-
lation from the menu that opens.

Tip: To set the Ease In / Ease Out of the interpolation:

1. Select the keyframe before or after the Ease In / Ease Out curve segment you want to edit, or the curve segment
itself.

2. Do one of the following:

• Enter the Ease In and Ease Out values in the Interpolation area of the Function Editor and click the Apply
button.

• Move the vertical line setting the Ease In or Ease Out section of the segment, to change the curve after or before
the keyframe.

16.3.4 Using Ease In / Ease Out % Interpolations

The Ease In / Ease Out % interpolation is similar to the Ease In / Ease Out one, but the Ease In and Ease Out sections
of the segments are expressed as a percentage of the segment frame duration.

Tip: To set an Ease In / Ease Out % interpolation:

Do one of the following:

• Choose Ease In / Ease Out % from the dropdown menu available in the Interpolation area of the Function
Editor and click the Apply button.
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• Right-click the curve segment you want to set the transformation for, and choose Ease In / Ease Out % Inter-
polation from the menu that opens.

Tip: To set the Ease In / Ease Out % of the interpolation:

1. Select the keyframe before or after the Ease In / Ease Out curve segment you want to edit, or the curve segment
itself.

2. Do one of the following:

• Enter the Ease In and Ease Out values in the Interpolation area of the Function Editor and click the Apply
button.

• Move the vertical line setting the Ease In or Ease Out section of the curve segment, to change the curve after or
before the keyframe.

16.3.5 Using Exponential Interpolations

When the interpolation is Exponential the curve segment turns to a curve that continually becomes steeper, because of
that, the higher the frame, the faster the related value grows. Only positive values are significant for this interpolation.

Tip: To set an Exponential interpolation:

Do one of the following:

• Choose Exponential from the dropdown menu available in the Interpolation area of the Function Editor and
click the Apply button.

• Right-click the curve segment you want to set the transformation for, and choose Exponential Interpolation
from the menu that opens.
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16.3.6 Using Interpolations Based on Expressions

When the interpolation is defined by an Expression, the segment values come from a mathematical formula that can be
typed by using algebra notations. In this case the keyframes at both ends of the segment may change as well, according
to the typed expression.

While typing the expression, if the syntax is recognized, a menu automatically opens suggesting you the possible
terms: from the menu you can select the term both to display in a tooltip box its correct syntax, and to insert it in the
expression.

As soon as terms are recognized, different colors are used to highlight them: operators and functions are displayed
in dark blue, variables in light blue, constants in green. When the expression is entered, any syntax error will be
displayed in red.

The Unit used for the function is displayed in a box next to the expression; in case the unit refers to a movement, the
default unit can be changed, and the values will be automatically converted to the default one.

Apart from the standard operators and functions, some variables and predefined functions can also be used in expres-
sions.

Supported terms are the following:

Operators
+ , - , * , / Addition, Subtraction, Multiplication, Division
% Modulus: 10%6=4 .
^ Exponentiation: a^2 means a*a ; a^0.5 is square root of a .
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Math Functions
sin(), cos(),
tan(), atan(),
atan2()

Angles are expressed in degrees.

sinh() , cosh() ,
tanh()

Hyperbolic functions.

log() , exp()
floor(value) The greatest whole number less or equal than value .
ceiling(value) The smallest whole number less or equal than value .
round(value) The integer closest to value .
abs() Absolute value: abs(a) is a without the sign.
sign(value) Returns 0 if value is 0; -1 if negative; 1 if positive.
sqrt(value) Returns square root of value .
min(a,b,c,...) Returns argument with minimum value.
max(a,b,c,...) Returns argument with maximum value.
clamp(value,min,
max)

Returns min if value is less than min ; max if value is greater than max ;
otherwise it returns value .

crop(value,min,
max)

Returns min if value is less than min ; max if value is greater than max ;
otherwise it returns value .

step(value,min) Returns 0 if value is less than min , otherwise it returns 1.
smoothstep(value,
min,max)

Returns 0 if value is less than min , 1 if value is greater than or equal to max
, and perform a smooth interpolation between 0 and 1 in interval min to max .

Logical Operators
< Less
<= Less or equal.
> More
>= More or equal.
== Equal.
!= Not equal.

Boolean Operators
&& And.
|| Or.
! Not.

Conditional Expression
(logical_expression)?
value1:value2

If logical_expression is true, it returns value1 , otherwise it
returns value2 .

Variables
t Ranges from 0.0 to 1.0 along the transition allowing position/lenght-independent transitions.
f , frame The current frame number.
r , rframe It is relative to the transition.

Constants
pi 3.141593. . .
numeric constant E.g. 1, 2, 4.3.
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Predefined Functions
cycle(period) Cycles the transition of the period previous frames.
pulse(pos) ,
pulse(pos,length)

Generates a pulse ranging from 0.0 to 1.0 set at position pos , with a different
breadth depending on the length of the pulse itself.

bump(pos) , bump(pos,
length)

Generates a bump ranging from 0.0 to 1.0 set at position pos , with a different
breadth depending on the length of the bump itself.

random Generates random sequences between 0.0 and 1.0.
random(max) Generates a random number between 0.0 and max .
random(min,max) Generates a random number between min and max .
random_s(seed) Works like random, but allows the user to specify the seed to modify the value

of the random function.
random_s(seed,max) Like above, with max as the maximum value of the transition.
random_s(seed,min,
max)

Like above, with min and max as the minimum and maximum values of the
transition.

saw(length) ,
saw(length,height)

Generates a periodic sawtooth shaped curve according to the length and
height values; if height is not expressed it is assumed to be equal to length
.

sawtooth(length)
, sawtooth(length,
height)

Generates a periodic sawtooth shaped curve according to the length and
height values; if height is not expressed it is assumed to be equal to length
.

wave(length) The same as sin(f*2*pi/length) .

Note: The predefined function saw , wave and pulse use implicitly a variable independent from the frame number.
You can provide explicitly a variable using the form: fun (var; argument...) .

Tip: To set an interpolation based on an Expression:

Do one of the following:

• Choose Expression from the dropdown menu available in the Interpolation area of the Function Editor and click
the Apply button.

• Right-click the curve segment you want to set the transformation for, and choose Expression Interpolation
from the menu that opens.

Tip: To set the expression:

1. Type the expression in the Interpolation area of the Function Editor. As you type, if the syntax is recognized, a
menu automatically opens suggesting you the possible terms.

2. Press Enter to submit the expression and check its syntax.

3. If the expression refers to a movement, change the unit if needed.

4. Press the Apply button to apply the desired change.

Tip: To select a suggested term:

Do one of the following:

• Use the Up Arrow and Down Arrow keys to select the term in the menu that opens, then press Enter.
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• Click the term in the menu that opens.

Note: When selecting a term with the Arrow keys a tooltip box displays the term correct syntax.

Using Transformation References

It is possible to use in expressions references to any object, effect or Plastic vertex transformation. In this way,
expressions can be used to create relationships between different transformations belonging to different items that can
be of any of the aforementioned types.

The syntax to create a reference to an object transformation is the following:

object.transformation or object.transformation(delta)

where object is the ID name of a camera, column, pegbar or the table, as can be read in the Stage and FX Schematic
nodes’ tooltips; transformation can be any of its available transformations; and delta is the difference between
the target frame and the current one.

For example camera1.y refers to the Y position of the Camera1. Whereas camera1.y(f-5) refers to the Y
position of the Camera1, 5 frames before the current frame.

Supported terms are the following:

Objects
cam<n> , camera<n> Refer to the camera n .
col<n> Refers to the column n .
peg<n> , pegbar<n> Refer to the pegbar n .
tab , table Refer to the table.

Transformations
x , y Refer to the horizontal and vertical position.
path , pos Refer to the position along the motion path.
rot Refers to the rotation around the z axis.
scale , scaleh , scalev Refer to the global, horizontal and vertical scaling.
shearh , shearv Refer to the horizontal and vertical shear.
z Refers to the position along the z axis.

The syntax to create a reference to an effect parameter is the following:

fx.name.parameter or fx.name.parameter(delta)

where name is the ID name of an effect, as can be read in the FX Schematic nodes’ tooltips, parameter is any of
the available effect parameters, and delta is the difference between the target frame and the current one.

When an effect parameter has multiple sub-parameters, for example the Center parameter has X and Y sub-parameters,
the syntax has to be the following:

fx.name.parameter.subparameter or fx.name.parameter.subparameter(delta)

where name can be any used effect, parameter the main effect parameter, subparameter is the effect sub-
parameter, and delta is the difference between the target frame and the current one.

For example fx.blur2.value refers to the Value parameter of the effect Blur2; fx.blur2.value(f-5) refers
to the Value parameter of the effect Blur2, 5 frames before the current frame; and fx.raylit1.center.x refers
to the X sub-parameter of the Center parameter of the effect Raylit1.
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Note: If the effect parameter name consists of several words, they have to be typed in expressions without blank
spaces.

The syntax to create a reference to a Plastic vertex transformation is the following:

vertex(column_number, "vertex_name").transformation or vertex(column_number,
"vertex_name").transformation(delta)

where column_number is the ID number of the column in which the referenced vertex exist, vertex_name is the
exact name of the referenced Plastic vertex, transformation is any of the available vertex transformations (see
below), and delta is the difference between the target frame and the current one.

Plastic Vertex Transformations
angle Refers to the angle between the vertex and its parent.
distance Refers to the distance between the vertex and its parent.
so Refers to the vertex sorting order.

See Use Mathematical Expression in Plastic Animation for further details on animating a Plastic mesh using expres-
sions.

16.3.7 Using Interpolations Based on File Data

When an interpolation is based on File data, the segment values are retrieved from the contents of a file. In this case
the keyframes at both ends of the segment may change as well, according to the file data.

The file can be created by an external device or other applications, such as motion-control cameras or 3D software;
supported file formats are BAT, DAT, RTF and TXT.

The value for each frame is taken from the file content, that must consist of a series of numbers listed in several lines.

In case the file contains several values in each line, it is possible to define which value in each line has to be used by
specifying a column number. For example, if you have a file like this:

100, 200, 300
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101, 201, 301

102, 202, 302

the value 2 will cause 200, 201, 202 to be loaded.

The unit used for the data is displayed in a box next to the file path; in case the unit refers to a movement, the default
unit can be changed, and the values will be automatically converted to the default one.

Tip: To set an interpolation based on File data:

Do one of the following:

• Choose File from the option menu available in the Interpolation area of the Function Editor and click the Apply
button.

• Right-click the curve segment you want to set the transformation for, and choose File Interpolation from the
menu that opens.

Tip: To set the File information:

1. Type in the File Path field, or use the browser button, to set the path to the data file.

2. Specify which value in each line has to be used by specifying the Column number.

3. If the File data refers to a movement, change the unit if needed.

Note: If in the Browser you choose any project default folder, in the path field the full path will be replaced by the
related default folder alias (see Project Default Folders ).

16.3.8 Using Constant Interpolations
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When an interpolation is Constant, the segment values are always equal to the value of the first key defining the
segment.

Tip: To set a Constant interpolation:

Do one of the following:

• Choose Constant from the option menu available in the Interpolation area of the Function Editor and click the
Apply button.

• Right-click the curve segment you want to set the interpolation for, and choose Constant Interpolation from
the menu that opens.

16.3.9 Using Interpolations Based on Similar Shapes

When the interpolation is based on a Similar Shape, the segment values changes according to the shape of the curve
you specify as reference (see Using Transformation References ). As soon as the interpolation is set, whenever the
reference curve is edited, the segment will change accordingly.

This interpolation proves useful when you want to control at once several curves: if all of them share the same reference
curve, by modifying the reference curve you will modify automatically all the curves referring to it.

It is also possible to set a Frame Offset value so that the interpolation will refer not to the same frame range of the
reference curve, but to a different one.

Tip: To set an interpolation based on a Similar Shape:

Do one of the following:

• Choose Similar Shape from the option menu available in the Interpolation area of the Function Editor and click
the Apply button.

• Right-click the curve segment you want to set the transformation for, and choose Similar Shape Interpolation
from the menu that opens.
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Tip: To set the reference curve:

1. Set the Reference Curve: in the Interpolation area of the Function Editor by typing the reference to an object
or an effect transformation by using the appropriate syntax (see Using Transformation References ).

2. Set a Frame Offset in the Interpolation area of the Function Editor if you want the interpolation to refer not to
the same frame range of the reference curve, but to a different one.

3. Click the Apply button to apply the desired change.

16.4 Controlling Several Function Curves at the Same Time

It’s possible to control the keys and the interpolations of all the function curves visualized in the Function Editor by
using widgets available in a horizontal strip at the top of the Graph Editor area, below the frame ruler.

This allows you to define keys and control the interpolation speed for different curves at the same time, such as a
camera truck and pan, or an effect animation and a pegbar movement.

With respect to keys, a keyframe is visible in the strip for each keyframe defined for any curve visible in the Graph
Editor; a line connects the keyframes for all the frames where there is an animation going on. The strip keyframe can
be moved, automatically moving the keyframes it refers to; in case the strip keyframe refers to keyframes at the same
frame in several curves, all the keyframes will move along.

With respect to interpolation, if all the visible curves have a key at the same specific frame, and the segment on the
side of the key has the same Ease In / Ease Out value or the same Speed In / Speed Out horizontal component, a
marker will be visible in the strip on the side of the strip keyframes. The marker shaped as an opening square bracket
is for the segment to the right of the keyframe, the one shaped like a closing square bracket is for the segment on the
left of the keyframe. The markers can be moved, automatically changing the Ease In / Ease Out or the Speed In /
Speed Out values of all the segments they refer to.

Tip: To set which curves have to be controlled:

Display the curves in the Graph Editor (see Using the Graph Editor ).

Tip: To add a keyframe:

Ctrl-click (PC) or Cmd-click (Mac) the frame ruler where you want to add the keyframe: a keyframe will be added to
all the visible curves.

Tip: To move a keyframe:

Click and drag the strip keyframe: all the keyframes it refers to will move along.

Tip: To control the speed of the interpolation:

Move the markers visible on the sides of the strip keyframes.
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16.5 Example expressions

16.5.1 Example Expressions

Aim At

This expression rotates column 1 (col1) to face column 2 (col2):

atan2(col2.ns - col1.ns, col2.ew - col1.ew)
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Creating Cutout Animation

Cutout animation is based on characters made of several sections connected together to create a character model. For
example a basic model can be made of a drawing for the head, one for the body, one for each arm, and one for each
leg.

Animations in this case can be created not by adding drawings depicting the new animated poses, but by transforming
(i.e. moving or rotating) the model sections individually at different frames, in order to create different actions.
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In OpenToonz it’s possible to create links between a model’s different sections and to set pivot points for each one of
them, in order to better manage the animation. For example, you can link a hand to an arm at the wrist, and link the
arm to the trunk at the shoulder: in this way when you move the trunk, you will move both arm and hand as well;
when you move the arm, it will turn around the shoulder and the hand will follow its movement; when you move the
hand, it will turn around the wrist.

Tip: To create a cutout animation:

1. Place each section (that can be a single drawing or an animated level) of your character in a different col-
umn/layer.

2. Use the Skeleton tool ( ) to link each section to the other and set the related pivot points.
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3. Create keyframes for each section at different frames to animate the cutout character.

17.1 Using the Skeleton Tool

The Skeleton tool ( ) allows you to define a model by setting hierarchical links between its different sections
exposed in different Xsheet columns (or Timeline layers), and animate it.

It basically makes possible, by using a single and more immediate tool, the same tasks that could be achieved by

using the Stage Schematic and the Animate tool ( ), when used to create links and animate the transformations of

columns/layers (see Linking Objects ). Indeed, any editing performed with the Skeleton tool ( ) can also be seen
happening in the Stage Schematic and the columns/layers transformation values, and vice versa.

In the tool options bar you can set the following:

• Mode sets the operation to perform with the tool. Options are: Build Skeleton, to create links between the
different sections, Animate, to animate the character model, and Inverse Kinematics, to animate the character
model using inverse kinematics.

• Global Key when activated sets a key for all the object transformations as soon as a key is defined by animating
the skeleton. This means that if you rotate a model section, automatically a key will be defined for the position,
scaling and shearing transformations as well.

• Show Only Active Skeleton when activated displays only the pivot points and the skeleton from the current
section up to the parent section: in this way it will be easier to manage characters with skeletons of a higher
complexity.

17.2 Building a Skeleton

When the Skeleton tool ( ) mode is set to Build Skeleton, it’s possible to set pivot points and links between sections
by using the handle available in the Viewer.

The handle is made of a small circle, with an arm that by default extends upwards. This allows you to perform the
following tasks:

• Click and drag the yellow circle to set the pivot point position.

• Click and drag the square at the end of the extended arm to set the link to another section.
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Note: The section pivot point can be moved, but cannot change its position during the animation: once it is set, or
modified, it is retained during all the animation. If the pivot point is changed many times, and you want to set it back
to its original position, right-click the section in the Stage Schematic and choose Reset Center from the menu that
opens.

The handle refers to the current section; when you link a section to another, the link is graphically displayed connecting
the centers of the two sections. When one or several sections are linked, all their links and the related centers, are
displayed as well, configuring the skeleton for the model.

17.3 Creating Basic Models

A basic model is made of sections linked to each other by their centers. It’s simpler to create if compared to a model
based on hooks (see Creating Models with Hooks ), and has some limitations, but it is suitable for most of the cases of
cutout animation.
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By default each section has a center that’s placed at the center of the viewer. When creating a model, this center has
to be moved to where the pivot point for that specific section has to be.

The Skeleton tool ( ) allows you, both, to change the center position of the currently selected model section, and to
link it to the center of another section visible in the Viewer.

Usually it’s simpler to start working from the parent section, then link the other sections one by one, following one
limb at a time. For example first set the center of the model trunk, then set the arm pivot point and link the arm to the
trunk, then set the forearm pivot point and link the forearm to the arm, then set the hand pivot point and link the hand
to the forearm, and so on.

In case the sections of your model are drawn in the right place, setting the pivot points and the links is all you have
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to do to define a skeleton. If they are not, you can set the section right position either before or after setting links by
using the Animate tool or the Skeleton tool in Animate mode (see Animating Objects and Animating Models ).

Tip: To select a model section:

Select the Skeleton tool ( ), set the mode to Build Skeleton, and click the section in the Viewer.

Tip: To set the pivot point of the selected section:

Click and drag the yellow circle.

Tip: To Link the selected section to another section:

1. Click and drag the square at the top of the handle to the section you want to be parent. The section you drag to
is highlighted by displaying its bounding box and a label displays information about the link you are going to
create.

2. Release to set the link.

Tip: To Break the link between the selected section and its parent:

Click and drag the square at the middle of the graphical link between the linked sections away from the parent one.

Tip: To visualize only the skeleton from the current section up to the parent section:

Activate the Show Only Active Skeleton option in the tool options bar.

17.4 Creating Models with Hooks

Sometimes basic models may not produce the desired results because the positions of the pivot points in the skeleton
are fixed, and therefore cannot follow the changes of model sections which are animated levels themselves.
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For example suppose you have a character whose trunk is an animated level made of several drawings of the trunk
bending: as the animation of the trunk goes on, the limbs linked to it will not follow the movement of the trunk
(because the trunk is neither moving nor rotating in terms of its transformation values).

By using hooks you can specify, drawing by drawing, where the pivot points have to be placed: in this way the model
will maintain its consistency even when different drawings from an animation level are used, during the course of the
action (see Using Hooks ).

For example, by placing hooks on the drawings of the trunk and on the limbs (where they have to be connected), and
defining the links by using hooks instead of centers, the limbs will follow the trunk even if it is bending.

The Skeleton tool ( ) allows you, both, to set a hook as the pivot point for the section, and to link it to a specific
hook of another section visible in the Viewer.

Hooks have to be placed for each character model section where you want the joints to be. For example, a trunk may
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have five hooks, one for the head, two for the arms and two for the legs; a forearm may have two hooks, one for the
elbow and one for the wrist.

When using the Hook tool ( ) for defining hooks for the model sections, the Snap option can be activated (see
Using Hooks ). In this way it’s possible to place hooks exactly in the same position of hooks already defined for other
animation levels visible in the Viewer, or, in case the level is a Toonz Vector level, at the center of closed shapes (e.g.
rectangles, circles or single vector shapes closed with the Tape tool).

This means that, in case the model sections are drawn in the right place, you can define perfectly overlapping hooks,
so that limbs preserve their position when hooks are linked; or you can use regular shapes in Toonz Vector drawings
(such as circles), to define the overlapping areas of the model limbs, and consequently place hooks exactly at their
center to achieve a perfect match when hooks are linked.

Note: The hook number is just a label to identify hooks, and it is not relevant when performing links.

Usually it’s simpler to start working from the parent section, then link the other sections one by one, following one
limb at the time.

When starting to build a skeleton with hooks, two different cases may take place: the model sections are not drawn in
the right place, one in relation to another; or they are drawn in the right place one in relation to another.

In the first case the appropriate hook has first to be set as the pivot point for the model section, then the link can be
created. Note that when setting a hook as the new pivot point, the hook, and consequently the section, shifts to the
center of the work area; as soon as you link that section to the hook of another section, it goes to the right place, with
the two hooks perfectly overlapping.

In the second case a hook of the selected section and a hook of another section are overlapping (e.g. the hook on
the wrist of the hand section overlaps the hook on the wrist of the forearm section), and a special button displaying
information about the overlapping hooks can be used to automatically link the two sections with a single click.

328 Chapter 17. Creating Cutout Animation



OpenToonz Documentation, Release 1.7.1

Tip: To select a model section:

Select the Skeleton tool ( ), set the mode to Build Skeleton, and click the section in the Viewer.

Tip: To set a hook as the pivot point of the selected section:

Click the hook label displayed close to the hook.

Tip: To Link the selected section to a hook another section:

1. Click and drag the square at the top of the handle up to the section you want to be its parent. All the hooks are
displayed and the section you drag to is highlighted by displaying its bounding box.

2. Drag towards the hook you want to link the section to: the hook label is displayed and another label displays
information about the link you are going to create.

3. Release to set the link.

Tip: To Link two overlapping hooks:

Click the label close to the overlapping hooks displaying information about the link you are going to create.

Tip: To Break the link between the selected section and its parent:

Click and drag the square at the middle of the graphical link between the linked sections away from the parent one.
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Tip: To visualize only the skeleton from the current section up to the parent section:

Activate the Show Only Active Skeleton option in the tool options bar.

17.5 Animating Models

When the Skeleton tool ( ) mode is set to Animate, it is possible to set positions for the model sections at different
frames, thus defining an animation.

In the viewer it’s possible to select a model section and perform the following tasks:

• Click anywhere to rotate the current section.

• Click and drag the green square with the four arrows to move the current section.

Note: As you roll over the handle, the cursor changes shape to indicate to you the operations you may perform.

Every time a position for a section is set, a keyframe is automatically generated for the Xsheet column (or Timeline
layer) where that section is exposed, at the current frame. Keys are created only for the transformation you modify:
rotation, displacement, or both.

It is also possible to activate the Global Key option in order to set a keyframe for all the section transformations,
including scaling and shearing, as soon as a keyframe for one transformation is set. This may result useful if you want
to animate the model first, and then refine the animation by adding stretching and squashing transformations.

If you want to create a keyframe without operating the handle, in order to leave the section position and rotation as they

are, you can use the Set Key button ( ) available in the bottom bar of the Viewer. In this case keys are created for
all the object transformations (see Animating Objects ). It is also possible to manage keys for several model sections
at once by inserting or deleting keys affecting the Xsheet/Timeline as a whole, or a selection of Xsheet columns (or
Timeline layers) (see Working with Multiple Column Keys ).

Keys and interpolations you define in this way are displayed in Xsheet columns (or Timeline layers), where they can
be directly managed (see Using Column Keys ).

As keyframes can be defined at specific frames for specific sections only, you may calibrate the animation and the
movement speed of your model the way you prefer.

Note: Columns/layers can also be animated by working in the Function Editor (see Editing Using Spreadsheet and
Curves )

In case a model section is an animation level consisting of several drawings instead of a single one (for example, if
the character’s hand is an animation level consisting of drawings of the hand in different positions), the Skeleton tool

( ) lets you also flip through the drawings to choose the one you need.

Tip: To Select a model section:

Choose the Skeleton tool ( ), set the mode to Animate, and click the section in the Viewer.

330 Chapter 17. Creating Cutout Animation



OpenToonz Documentation, Release 1.7.1

Tip: To Rotate the selected section:

Click and drag anywhere in the Viewer.

Tip: To Move the selected section:

Click and drag the green square with the four arrows available on the right of the current section pivot point.

Tip: To visualize only the pivot points of the current section up to the parent section:

Activate the Show Only Active Skeleton option in the Skeleton tool options bar.

Tip: To flip through the drawings belonging to the animation level:

Click the label with the level name on the right of the current section pivot point and flip through following and
previous frames by doing one of the following:

• Drag up or down.

• Click the up or down arrowheads.

17.6 Using Inverse Kinematics

When the Skeleton tool ( ) mode is set to Inverse Kinematics, it’s possible to move the model considering the
articulation of all the sections its skeleton is made of. This means that if you want to move the end of a model limb to
a particular position, all the rest of the sections belonging to that limb will move consequently, with no need to move
each section separately.

For example, if you want the hand of a character to reach a particular point, you don’t need to animate the arm and
the forearm separately, but instead you can move the hand to the final position, automatically adjusting the arm and
forearm sections.
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When the Inverse Kinematics mode is activated, the full skeleton with pivot points and links is displayed.

When moving the model, a rotation keyframe is automatically defined for all the sections involved in the movement,
unless the Global Key option is activated thus generating a keyframe for all the section transformations.

Note: When using inverse kinematics the movements of the parent section of the skeleton are automatically computed
to allow the right configuration of the skeleton; this means that they cannot be edited anymore by using standard
movement editing tools like the Animate tool or the Function Editor. To return to the standard movement editing
mode, you have to reset the pinned centers information.

17.6.1 Pinned Center

One single center (by default located on the section that is the parent of the skeleton), is displayed as a blue square:
indicating that it’s pinned and its position won’t change throughout the animation when the character sections are
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animated.

The pinned center can be moved from a joint to another along the animation in order to have a center pinned only for
a specific frame range. When the pinned center is changed at a specific frame, all the previous frames will retain the
previously pinned center; all the following frames will have the new pinned center up to the frame where another
pinned center position, if any, is defined in advance.

Changing the pinned center allows for a more complex animation where fixed points have to change while the model
is moving, for example a walk where one ankle is pinned while the character is doing the first step, and the other ankle
is pinned during the second step.

Note: Once the pinned center is defined, it will remain active when animating skeleton sections both with the

Skeleton tool ( ), and with the Animate tool ( ). To freely animate any skeleton section again, reset the pinned
center information (see below).

17.6.2 Temporarily Pinned Centers

Multiple additional centers can be temporarily pinned at any frame in order to constrain additional joints to a specific
position. Unlike the pinned center, temporarily pinned centers are not preserved when the current frame changes, as
they are used only to define the position of the sections at a certain frame.

Using temporarily pinned centers allows for the definition of specific poses at specific frames, for example the rising
of an arm by pinning the shoulder joint.

According to the pinned center, and the temporarily pinned centers, it’s possible to click any point of any section and
drag to move the model: all the parent sections up to the first pinned center along the skeleton will move consequently,
while all the linked sections down to the free end of the limb will move rigidly with the picked section. The sections
affected by the movement are highlighted by displaying the link wires in red.

The pinned centers information and coordinates are saved along with the scene; in case you want to delete it or start
the animation by using the inverse kinematics from scratch, this information can be reset to the default, where only the
center of the parent section of the skeleton is pinned.

Tip: To animate the model with Inverse Kinematics:

1. Choose the Skeleton tool ( ) and set the mode to Inverse Kinematics.

2. Click any point of any model section and drag it to the desired position.

Tip: To set the skeleton Pinned Center:

Click the center: it turns from an orange circle to a blue square to indicate it is pinned.

Tip: To change the skeleton Pinned Center:

1. Select the frame where you want the new center to be set.

2. Click the center: all the previous frames will retain the previously pinned center; all the following frames will
have the new pinned center up to a frame where another pinned position might have been defined in advance.

Tip: To set a Temporarily Pinned Center:

17.6. Using Inverse Kinematics 333



OpenToonz Documentation, Release 1.7.1

Shift-click the center: it turns from an orange circle to a light blue square to indicate it is temporarily pinned.

Tip: To unset a Temporarily Pinned Center:

Shift-click the temporarily pinned center: it turns from a light blue square to an orange circle to indicate it’s no
longer temporarily pinned.

Tip: To Reset the Pinned Centers information:

1. Choose the Skeleton tool ( ).

2. Right-click in the viewer and choose Reset Pinned Center from the menu that opens.
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Create animations using Plastic tool

Plastic is a powerful tool ( ) that can be used as complement in a cutout animation context, as well as a stand-alone
animation tool capable of bringing to life a character starting from a single drawing. Using a reference skeleton and a
deformable mesh, Plastic allows to curving and deforming each element it’s applied to, creating smooth animations.
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18.1 Using Plastic tool

The Plastic tool needs as starting input at least one column of the Xsheet (or layer of the Timeline) where one or more
drawings are exposed; from now on this will be referred to as the texture-column (or TC). Using the outlines of the
exposed drawing/s as references, the Plastic tool generates a triangular mesh contained in a new kind of column/layer:
the Mesh column/layer. Each newly created Mesh column/layer is automatically connected to the proper TC. This link
is a core point in the way Plastic works: every column/layer linked to a mesh will be deformed by it, and displayed
within the mesh boundaries while rendering.

For animating/deforming a Mesh level, Plastic allows the building of a specific skeleton structure active on the mesh.
The skeleton is a set of connected vertices, and, for each vertex, different parameters can be specified as: Position,
Angle Bounds, Rigidity and Staking Order. Thus a great range of animations and effects can easily be created.

Note: The Plastic tool is applied to a column of the Xsheet (or layer of the Timeline), and the content of it can be an
animated level.

18.2 Building a Plastic mesh

The first step for using Plastic is creating a mesh for the Xsheet column (or Timeline layer) that we are going to
animate using the Plastic tool. The Mesh is a special kind of level, and can be saved as any other kind of levels.

The Mesh level can be seen as purple column/layer created when the button Create Mesh of the Plastic tool is pressed.

The mesh is the real object that the Plastic tool modifies when a plastic skeleton is animated. For this reason all the
elements, that are going to be animated by the Plastic tool, need a mesh.

Tip: To create a Plastic mesh:

1. Select the column/layer that is going to be animated using the Plastic tool. This will be the texture-column (TC)
of the mesh that is going to be created.

2. Choose the Plastic tool ( )

3. Press the Create Mesh button in the tool options bar.

4. Check, in the dialog that opens, the Mesh density in the preview area. Adjust as needed the density using the
Mesh Edges Length slider.
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Note: The density of the mesh is crucial for having smooth curves when rotating the skeleton vertex.
Lower the Mesh Edges Length value and higher the density of the mesh will be, thus a better quality of
the animation will be assured, but more computing resources will be required.

Note: The preview will show you just one level at time, even if you have selected multiple
columns/layers, to check the preview of each column/layer you have to select them one by one while
the Plastic tool is active. Each time you change the column/layer selection the preview will update for the
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new content.

5. If needed, change the value of the Rasterization DPI parameter. This value represents the DPI used when the
TC is rendered as a texture for the mesh. It’s recommend using a value consistent with the Camera resolution.
A DPI too high compared to the Camera resolution might cause the contours of the TC not to be very soft.

Note: The Rasterization DPI parameter is available only when you are creating the mesh from Toonz
Vector levels.

6. Adjust the Mesh Margin value. This parameter is expressed in pixels because it’s used when the texture is
projected on the mesh, an appropriate amount of margin will be needed to preserve the aliasing of the picture.

7. If you are creating a mesh from a Sub-Xsheet, you can choose which elements of the Sub-Xsheet will be used
by the Plastic tool for computing the mesh: simply turn off visibility for the elements that will not contribute to
the mesh outline.

8. Click the Apply button to create the mesh. Now you can see the mesh drawn in green colour in the Viewer, and
a new purple column in the Xsheet (or layer in the Timeline) next to the TC.

Note: In the Stage Schematic you can see that the TC node is now connected to the Mesh node just
created, its node has a purple header for easing recognition.

If the Create Mesh is applied to a column/layer that is already modified by the Plastic tool (then already linked to a
Mesh level) a dialog will prompt asking how to manage the new and the old Mesh files, and the user can choose from
one of three options:

• Delete the old level entirely : the original mesh file is replaced by a new one with the data of the
last mesh generated; a new column for the new mesh is created as the old column retains the old
structure but exposes only the new created mesh.

• Keep the old level and overwrite processed frames : the original mesh file is updated and the old
mesh column exposes the new content for the selected frames, a new column is created exposing
just the contents of the selected frames.

338 Chapter 18. Create animations using Plastic tool



OpenToonz Documentation, Release 1.7.1

• Choose a different path (same name as the original level plus _X where X is the ordinal number of
the copy): an entirely new mesh file is generated and a new column exposes the new contents while
the old column exposes the old ones.

Note: All the above options cause the creation of a new Mesh column and the building of a chain, linking
the texture-column and the meshes columns in the Stage Schematic. In this chain, the older mesh is linked
to the younger and the youngest mesh is linked to the texture-column. Rearranging the links in the Stage
Schematic can be needed for avoiding undesired results while animating.

18.3 Modifying a Plastic mesh

It’s not always easy to estimate the right density for a mesh. Sometimes a higher density could be needed to avoid
straight lines on bending elements, or a lower density could be used for saving computing resources in a complex
scene, or, simply, the drawings of an element are changed. In all this occurrences, modifying the mesh can solve the
problem.

Tip: To update a Plastic mesh to reflect changes in the Level Strip:

1. Select the Mesh column/layer that needs to be modified.

2. Press the Create Mesh button.

3. In the dialog that opens change the Mesh Edges Length slider value as needed, checking the result in the
preview area.

4. Click the Apply button to create the mesh. The new mesh replaces the old one, and now is visible drawn in
green colour in the main viewer.

Tip: To add new mesh frames to an existing mesh level:

1. Select the Mesh column/layer that needs to be modified.

2. Create the new frames (inserting or appending them) as it’s usually done for any standard Toonz level, corre-
sponding to the new frames created for the Texture Column.

3. Activate the Plastic tool.

4. Press the Create Mesh button and adjust the Mesh Edges Length slider.

5. Press the Apply button.

18.4 Edit a Plastic mesh

The mesh created using the Create Mesh button can be edited in several ways. It’s possible to: Move a mesh point,
Swap, Collapse, Split and Cut the mesh by its edges.
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Swap an edge if you want to change the shape of a mesh triangle; Collapse an edge if you want to join the ends of the
edge; Split an edge if you want to increase the density of the mesh at any given point; Cut the mesh if you want to
duplicate an edge to have the possibility, for example, to create a hole in the mesh and be able to animate it.

Note: The Cut Mesh command is visible only if the selected edges can be cut.

Tip: To enter Plastic mesh editing mode:

1. Select the mesh column/layer you want to modify.

2. If not already active, choose the Plastic tool ( )

3. In the Tool Options bar set the Mode: to Edit Mesh.

Tip: To move selected mesh points:

1. Select the mesh points you want to modify. Use the Ctrl key to select multiple points. Selected mesh points
become red.

2. Drag to move the point to its new position.

Tip: To swap an edge of the mesh:

1. Select a mesh edge.

2. Click the right mouse button to open the context menu.

3. Choose the Swap Edge command.

Tip: To collapse an edge of the mesh:
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1. Select a mesh edge.

2. Click the right mouse button to open the context menu.

3. Choose the Collapse Edge command.

Tip: To split an edge of the mesh:

1. Select a mesh edge.

2. Click the right mouse button to open the context menu.

3. Choose the Split Edge command.

Tip: To cut edges of the mesh:

1. Select several mesh edges.

2. Click the right mouse button to open the context menu.

3. Choose the Cut Mesh command.

18.5 Building a Plastic skeleton

The Plastic skeleton is a control structure linked to a mesh level that provides handles for deforming/animating the
chosen elements of the Xsheet/Timeline.

Tip: To create a Plastic skeleton:
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1. Select in the mesh column/layer for which you want to build the skeleton.

2. If not already active, choose the Plastic tool ( )

3. In the Tool Options bar set the Mode: to Build Skeleton.

4. Move the mouse pointer on the Viewer. A small red square is now visible near the tip of the cursor.

5. In the Viewer click (to set in place) or click and drag (to adjust its positioning) to place the first vertex. A purple
square is now visible in the Viewer.

Note: The first time you release the mouse button, you are setting the position of the parent of all the
hierarchy, the Root vertex. This vertex differs visually from the others vertices: its square is solid while
the others are hollow in the middle, giving a visual hint for determining the right hierarchical order in the
skeleton chains. The Root vertex will be static in Animate mode, but it can still be moved while in Build
Skeleton mode by selecting it and dragging.

6. Move to the position where you want to add the second vertex and click or click and drag to place it. An orange
line with a black border will connect the two vertices.

7. Continue clicking or clicking and dragging until all the vertices are in the right places and the skeleton is
completed.

18.6 Using multiple skeletons on a mesh level

Every mesh level uses at least one skeleton for animating, but this is just the easier configuration for working: a mesh
level can have multiple skeletons active at different frames for building more complex animations: like a character
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turn-around, or for animating a level with multiple drawings of different shapes. Every time the drawings change
in shape, a new ad-hoc skeleton structure can be built with the number of vertices needed and placed in the right
positions.

Tip: To add a new skeleton on a mesh level

1. In the Xsheet/Timeline select the Mesh level and the frame where the new skeleton is needed.

2. In the Tool Options bar press the + button to the right of the options menu labeled Skeleton:. A new numeric
entry is added to the list and a keyframe is created at the selected frame.

3. Start building the new skeleton as usual.

Tip: To link an available skeleton to a chosen frame of a mesh level

1. In the Xsheet/Timeline select the frame of the Mesh level where the skeleton has to change.

2. In the Tool Options bar open the option menu labeled Skeleton:, a list of the ID numbers of the already built
skeletons opens.

3. Select the ID number matching the skeleton you need.

4. The selected skeleton is now visible in the main Viewer, and a keyframe is created at the chosen frame.

Tip: To delete a skeleton from the Skeleton list

1. In the Xsheet/Timeline select the Mesh level owning the skeleton that has to be deleted.

2. Select from the Skeleton: drop down the ID matching the skeleton to delete.

3. Press the - button.

18.7 Modifying a Plastic skeleton

While drawing the skeleton or after finishing its creation, some adjustments to the positions or the number of vertices
may be required:

Tip: To Select a vertex:

1. While in Build Skeleton mode, move the mouse pointer on an already placed vertex.

2. Click, when the name of the vertex appears and a dashed square encloses the vertex position.

Tip: To Delete a vertex:

1. While in Build Skeleton mode, select the vertex that has to be deleted.

2. Press the Del key.
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Tip: To Insert a vertex:

1. While in Build Skeleton mode, move the mouse pointer over the line connecting the two vertices that need a
vertex between them.

2. Click to set the new vertex in place, or click and drag to adjust the position of the new vertex.

Tip: To Move a vertex:

Click on the vertex to select it, and drag for adjusting its position.

Tip: To Prevent a vertex from Stretching the mesh:

1. Select the vertex that you wish to modify.

2. Uncheck the Allow Stretching option in the Tool Options bar.

Note: The square marking the vertex position becomes yellow, and from now on the vertex will not stretch the Mesh
while you are moving it.

Tip: To Snap a vertex to the mesh

1. While in Build Skeleton mode, activate the Snap To Mesh option.

2. Select the vertex you wish to snap.

3. Drag it near the mesh point at which you want to snap it.

Tip: To Branch the skeleton:

1. While in Build Skeleton mode, select the vertex from which the new branch will start.

2. Move to the position where the first vertex of the new branch will be positioned.

3. Click to create it.

Tip: To Copy a skeleton:

1. While in Build Skeleton mode, select the Root vertex and click the right mouse button.

2. From the context menu that opens, select the Copy Skeleton option.

344 Chapter 18. Create animations using Plastic tool



OpenToonz Documentation, Release 1.7.1

Tip: To Paste a skeleton:

1. Select a mesh column in the Xsheet/Timeline.

2. If needed press the + button to create a new empty skeleton.

3. Click the right mouse button and select the Paste Skeleton option.

Note: Pasting the skeleton on an already existing one will cause the deletion of the old structure and all its animation.
This can be reverted to the previous state by using the Undo command.

18.8 Animating Plastic elements

Creating an animation in Plastic is quite an easy task: just select the vertices and move them to the desired positions at
a specific frames and animation keyframes will be automatically created. Play back the sequence to check the results.

Tip: To animate Plastic elements:

1. Select the mesh column/layer you like to animate.

2. Select Plastic tool and set Mode: to Animate. Now, in the Viewer, you can see the skeleton and the mesh of
the selected column/layer.

3. Select the first frame of the animation in the Xsheet/Timeline.

4. Select the vertices of the skeleton and move them to the desired positions to set the relative keyframes, or write
the desired values into the text fields of the Tool Options bar.

5. Move to the next keyframe of the animation and modify the vertices positions to define a new pose.

6. Repeat the step 5 until the end the animation is finished.

Tip: To Set a Rest Position key for one vertex:

The first time you draw a skeleton you are also creating the rest position of this structure. This pose is automatically
stored and you can recall it on any vertex.

1. Select a vertex and click the right mouse button.
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2. From the context menu that opens, select Set Rest Key.

3. A new keyframe at the current frame is created for the vertex, using its rest values.

Tip: To Set a Global Rest Position key for the whole skeleton:

The first time you draw a skeleton you are also creating the rest position of this structure. This pose is automatically
stored and you can recall it on all the vertices.

1. Select a vertex and click the right mouse button.

2. From the context menu that opens, select Set Global Rest Key.

3. A new keyframe at the current frame is created for all the vertices, using their rest values.

Tip: To preserve the distance between vertices while animating:

If it’s required that the distance between two joints stays constant during the animation, check the Keep Distance
checkbox in the Tool Options bar.

Tip: To Set Keyframes on all vertices at the same time:

By default when you move a vertex in Animate mode, you set a keyframe just for this selected vertex. For setting
a keyframe simultaneously for all the vertices of the skeleton, when just moving one of them, check the Global Key
checkbox.

Tip: To Set a Keyframe for a vertex which hasn’t changed position:

1. Select the vertex for which you want to create a keyframe.

2. Click the right mouse button.

3. Select the Set Key option from the context menu that opens.

Tip: To Set a Keyframe for all the skeleton vertices which hasn’t changed position:
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1. Select a skeleton vertex.

2. Click the right mouse button.

3. Select the Set Global Key option from the context menu that opens.

Tip: To animate the Stacking Order of a vertex:

Using Plastic you can simulate the effect of overlapping limbs defining a stacking order for the vertices involved in
the animation.

1. Select the vertex you wish to animate.

2. Input the Stacking Order value you wish to assign to the vertex into the SO text field in the Tool Options bar.

Note: Plastic stacking order is a per vertex characteristic, you have to define the value you wish for each vertex
required. The default value is 0 for all vertices, and can be modified freely using positive or negative values as needed.

Tip: To define an Angle Bounds for a vertex:

1. Select the desired vertex.

2. Set the minimum and maximum Angle Bounds values for the vertex rotation.

18.9 Defining Rigidity for a Plastic mesh

In many occasions it may be required that certain portions of a Mesh that’s being animated using the Plastic tool,
preserve their shape even if following the overall transformations of the whole element, simulating a more rigid
structure or a part of it. To achieve this kind of effect a Rigidity value can be painted directly on the Mesh.

When activating the Paint Rigid mode in the Plastic Tool Options bar, a specific drawing tool becomes available. In
the Viewer a red circle is visible near the tip of the mouse pointer, the size of the circle is the size of the brush you are
going to use for painting the rigidity on the mesh.

Tip: To paint Rigidity on a mesh:

1. Select the mesh column/layer in the Xsheet/Timeline.

2. Choose the Plastic tool ( )

3. Set the Mode: to Paint Rigid.

4. Set the size of the brush moving the Thickness slider or entering a value into the text field.

5. Select Rigid from the option menu to the right of the Thickness slider (Rigid is the default value).

6. Move the cursor on the Viewer and start painting on the selected Mesh. The colour of the mesh will change to
red where painted. Now the red areas behave as rigid portions of the Mesh.
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Tip: To modify, correct, erase Rigidity on a mesh:

1. Select the mesh column/layer in the Xsheet/Timeline.

2. Choose the Plastic tool ( )

3. Set the Mode: to Paint Rigid.

4. Set the size of the brush moving the Thickness slider or entering a value into the text field.

5. Select Flex from the option menu to the right of the Thickness slider.

6. Move the cursor on the Viewer and start painting on the selected Mesh. The colour of the mesh will change to
green where painted. Now the green areas behave as flexible portions of the Mesh.

Note: The default colour of a mesh is green; it means that the whole mesh is flexible. The red colour is used to point
out the rigid areas of the mesh (if there are any defined). But if a mesh is all painted in red colour it behaves as a
flexible one too.

18.10 Displaying Plastic elements and properties

While working with the Plastic tool there is an easy way for customizing which information have to be displayed in
the Viewer. Clicking the right mouse button on the Viewer while the Plastic tool is active brings up a context menu.
There are four checkboxes that set the display properties for the Mesh, the Rigidity, the SO (Stacking Order) and the
Skeleton Onion Skin.
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If Show Mesh is enabled, the mesh will be visible as a triangulated wire frame shape.

If Show Rigidity is enabled, continuous green areas will show the flexibility, while red areas will show rigidity.
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If Show SO is enabled a grey shading shows the Stacking Order values of the vertices, where lighter areas will be on
top, and darker ones behind.
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If Show Skeleton Onion Skin is enabled, ghosts of the skeleton at the selected frames will be displayed with incre-
mental levels of transparency.
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All of this information can be displayed at once (by checking all the options), giving an overall description of the
vertices state.

18.11 Parenting Plastic levels using vertices and hooks

For building interesting and complex animations it could be useful and time saving to create a hierarchical relation-
ship between standard levels and Plastic modified levels, or between Plastic modified levels themselves, so that the
children levels inherit the transformations of the parent automatically. It’s always possible to link the levels using
the column/layer center as target, but what if something more subtler is needed as using Hooks? We have already
described similar techniques for OpenToonz standard elements (see Linking Objects or Using Hooks ), but Plastic
modified levels works in a slightly different way because the Hook tool is not enabled on this kind of levels. Plastic
modified levels use their skeleton vertices instead of the hook points.

Tip: To link a standard level to a Plastic modified level

1. Select in the Xsheet/Timeline the level that has to be linked.

2. Use the Hook tool in the Viewer to create a hook on the spot that will be used as pivot for the level.

3. Go to the Stage Schematic and select the node of the column/layer that has to be linked. Click on the small
square on its left side, and drag to one of the small squares on the right side of the Plastic modified node target
of the link. Now the two levels are linked but the reference points for the link are probably wrong (by default
the column/layer centers are used).
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4. Hover on the small square on the left side of the node of the standard level until two small arrows (pointing up
and down) appear.

5. Click on the arrows and drag to change the value in the small square. Stop when the number of the hook point
that has to be used as pivot point is reached. In the Viewer the level moves using the chosen point as new center.

6. Do the same procedure of point 5 on the small square on the right of the Plastic modified node that was used as
target for the link. Select the number of the skeleton vertex that has to be used as target reference point for
the link. Into the Viewer the standard level moves to overlap the position of the hook point selected as reference
to the position of the skeleton vertex selected on the Plastic modified level.

Note: A mirror procedure can be used for linking a Plastic modified level to a standard level.

Tip: To link Plastic modified levels

The procedure requires that all the levels involved and that need to be linked using determined positions, have at least
one skeleton built and one of its vertices has to be positioned at the desired spot for the linking. As said, the Hook tool
doesn’t work on the Plastic modified levels so, for exact positioning, skeleton vertices are needed as reference points
both on the source and on the target of the link.

1. Go to the Stage Schematic and select the node of the column/layer that has to be linked. Click on the small
square on its left side, and drag to one of the small squares on the right side of the target of the link. Now
the two levels are linked but the reference points for the link are probably wrong (by default the column/layer
centers are used).

2. Hover on the small square on the left of the node of the first node until two small arrows appear.

3. Click on the arrows and drag to change the value in the small square. Stop when the number of the skeleton
vertex point that has to be used as pivot point is reached. In the Viewer the level adjusts its position in respect
of the new selected center.

4. Do the same procedure of point 3 on the small square on the right of the Plastic modified node that was used as
target for the link. Select the number of the skeleton vertex that has to be used as target reference point for
the link. Into the Viewer the first level moves to overlap the position of its selected skeleton vertex to that of the
target skeleton vertex just selected.

18.12 Function Editor representation of Plastic data

While animating Plastic elements, keyframes are created for the vertices of the skeleton. You can see them as standard
keyframes in the Xsheet/Timeline, or you can operate on the values of each vertex into the Function Editor.

The keyframess of the Xsheet/Timeline mark a keyframe for the Plastic skeleton at the specified frame, but don’t give
any information about the number of vertices involved or their actual keyframed properties; they can be indifferently,
one, some or all. Moving these keyframes you can easily change the timing of the whole animation.

The keyframes into the Function Editor are more detailed, giving you the chance for fine-tuning and modify each
vertex parameter animation.

When in the Function Editor Tree, you open the folder of a column/layer that has the Plastic tool applied, you can see
a Plastic Skeleton folder. This folder contains the Skeleton Id channel, the Root subfolder, and one subfolder for
each vertex of the Plastic skeleton, labeled with the name of the related vertex.
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The Skeleton Id channel contains the data related to which skeleton is active at a certain frame. If the level is using
multiple skeletons here you can see the switches from one skeleton to the other, both as numeric values and in a
graphical format.

The Root subfolder shows all the parameter channels, but only the SO (Staking Order) parameter can be animated
when this vertex is actually used as root of the skeleton

The Vertex subfolders (one for each vertex of the skeletons), contain three parameters: Angle, Distance and SO, that
are used to determine the position of the vertex at every frame during the animation.

The values of these parameters can be visualized in the Function Editor as a spreadsheet or as curves, and modified as
required.

Note: The vertices of multiple skeletons are shown as a single list, and not grouped for each skeleton. In this way the
animation curve of Vertex_1 is built using the animation values of the vertices named Vertex_1 of all the skeletons of
the mesh, so just one curve can be modified to adjust the animation of related vertices on different skeletons.
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18.13 Use Mathematical Expressions in Plastic Animation

To use OpenToonz mathematical expressions in the Plastic Animation, you can link the vertices of the skeleton to each
other or to a column/layer, pegbar or camera.

This allows to set some automatic actions of the skeleton, for example you can link the main vertices of the shoulders,
so that moving just one shoulder automatically moves the other.

Suppose that the main vertices of the shoulders are named Shoulder_left and Shoulder_right, and the Mesh is in
column 2 of the Xsheet (or layer 2 of the Timeline). You can set the rotation of Shoulder_left vertex to be the same
amount of that of Shoulder_right, by setting in the Function Editor the following expression in the Angle parameter
of Shoulder_left:

vertex(2, "Shoulder_right").angle

If you prefer the rotation of the left shoulder to react opposite to the one of the right shoulder, you could add a
multiplication as following:

vertex(2, "Shoulder_right").angle*-1

The general syntax is:

vertex(column_number, “vertex_name”).parameter

For more information about the mathematical expressions usage refer to (See Using Interpolations Based on Expres-
sions ).

18.14 Plastic and Sub-Xsheets

A Sub-Xsheet is a valid object for the Plastic tool, and all or some of its columns can have a mesh for animating. When
a Sub-Xsheet is selected as a starting element, all of the columns in the Sub-Xsheet visible when the Create Mesh
button is pressed, are taken into count for the creation of the Mesh. These levels will be visible in render and will be
deformed by Mesh transformations. If, after creating the Mesh, hidden levels are set to visible, they will behave in a
slightly different way: they will be deformed by Mesh transformations, but they will be shown in render only inside
the mesh boundaries (i.e. the Mesh acts as a mask that determines what is visible in the rendered image, even if the
newly-shown levels are placed into a nested Sub-Xsheet with its own mesh and skeleton).
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CHAPTER 19

Applying Effects

Effects can be applied to animation levels, images and clips exposed in Xsheet columns (or Timeline layers) in the FX
Schematic, where each element is represented as a node.

The relationship between the contents of columns/layers and effects can be managed by connecting or disconnecting
links between nodes.

19.1 Using the FX Schematic

In the FX schematic all columns/layers are displayed as nodes having an output port connected to the Xsheet node:
this means that their content is part of the scene and is rendered as it is.

When effects are added, they are displayed as nodes as well, with ports to create links that let you set the way the
effect modify the scene contents.

Column/layer nodes have the Camera Stand ( ) and the Render ( ) toggles on the top right: these toggles are
the same as the toggles available in the Xsheet column (or Timeline layer) headers (see Working with Xsheet Columns

). Effects nodes only have the Render toggle ( ) allowing you to include or exclude temporarily the effect in the
rendering.

Nodes can be easily selected and arranged. When selected, nodes are highlighted in white; the current node has its
label in yellow.
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Tip: To access the FX Schematic:

Click the Schematic toggle button ( ) at the right of the bottom bar of the Schematic window until the title bar
displays FX Schematic.

Tip: To navigate the FX Schematic:

Do one of the following:

• Use the mouse wheel, or the zoom shortcut keys (by default + and - keys) to zoom in and zoom out.

• Middle-click and drag to scroll in any direction.

• Use the Fit to Window button ( ) in the bottom bar of the Schematic window to display all of the nodes in
the current window.

• Use the Focus on Current button ( ) in the bottom bar of the Schematic window to center the Schematic on
the current node.

• Use the Reorder Nodes button ( ) in the bottom bar of the Schematic window to reorder all the nodes.

• Use the Reset Size button ( ) in the bottom bar of the Schematic window, or use the Reset View shortcut (by
default the Alt + 0 key) to display all of the nodes at the default size.

Tip: To rename a node:

Ctrl + double-click the node name and type a new name.

Tip: To minimize or maximize the column/layer and effect nodes:

Do one of the following:

• Click the arrowhead to the left of the node name to minimize/maximize columns selectively.

• Click the Minimize/Maximize ( / ) button in the bottom bar of the Schematic window to mini-
mize/maximize all the column nodes.

Tip: To select nodes:

Do one of the following:

• Click to select a node.

• Click and drag to select a group of nodes.

• Ctrl-click (PC) or Cmd-click (macOS) to add a node to, or remove it from the selection.

Note: Links can be selected together with nodes (see Editing the FX Schematic ).

358 Chapter 19. Applying Effects



OpenToonz Documentation, Release 1.7.1

Tip: To move the selection:

Click and drag any node of the selection.

Tip: To include or exclude temporally an effect from the rendering:

Click the Render toggle ( ) on the upper right corner of the effect node.

19.1.1 Grouping Nodes

It’s possible to group several nodes into one single node, in order to better manage the whole FX Schematic. Groups
can be opened to be examined and edited, and its components can be selected for further operations, like editing effect
settings, or creating new groups.

Tip: To Group selected nodes:

Do one of the following:

• Right-click any selected node and choose Group from the menu that opens.

• Press the Ctrl-G (PC) or Cmd-G (macOS) shortcut.

Tip: To open a Group:

Right-click the group and choose Open Group from the menu that opens: the group nodes are displayed in a box,
showing links between group nodes, and links with nodes outside of the group.

Note: In the FX Schematic, when the content of a group is displayed, it’s possible to edit the links between Group
nodes and links with nodes outside of the group.

Tip: To close a Group:

Click the Close button on the right of the group box title bar.

Tip: To release a Group:

Right-click the Group and choose Ungroup from the menu that opens, or press the shortcut Ctrl-Shift-G (PC) or
Cmd-Shift-G (macOS).

19.1.2 Inserting Effects

You can Insert effects to selected nodes, Add effects to the Schematic, or Replace previously added effect nodes. This
can be done from the FX Browser window or by using the drop-down menu that opens when right-clicking nodes or
an empty area of the FX Schematic. Both are organized in folders/submenus containing sets of effects; if some Presets
are defined for an effect, an additional folder/submenu is available (see Creating Presets ).
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When inserting effects, they will be placed along the link that starts from the selected node output port; when adding
effects, they will be placed at the end of a new link that will start from the selected node output port.

In case several nodes are selected, the effect will be added/inserted for each selected node, but all the added/inserted
effects will be Linked, and connected visually by a green line. This means that every time the effect is edited, all the
linked nodes will be edited as well, unless you break the link to start editing them separately.

To globally apply effects it’s possible to use the Xsheet node as if it were a standard column node (representing the
whole content of the scene) and inserting effects from there.

Three different types of effects can be used in the Schematic, each with a different type of node:

• Basic effects, such as the Blur effect, that simply modify the contents of a column; they are displayed as a
yellow node with an input port on the left, labelled Source, and an output port on the right.
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To affect a column/layer, they have to be inserted in the link from the column/layer node to the Xsheet node, so that
the column/layer node is connected to the effect input port, and the effect node output port is connected to the Xsheet
node.

If several effects are applied in a chain, they will be applied one after the other, following the order from the col-
umn/layer node to the Xsheet node.

• Combined effects, such as the Matte In effect, that modify the column/layer contents according to the contents
other columns/layers; they are displayed with a yellow node with two or more input ports on the left, and one
output port on the right.

To affect a column/layer, they have to be inserted into the link from the column/layer node to the Xsheet node, so that
the column/layer node is connected to the first effect input port labelled Source, while the other columns/layers are
connected to the other input ports, whose labels depend on the effect; the effect node output port has to be connected
to the Xsheet node.
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For example in case of a Matte In effect, the column to be matted has to be linked to the Source input port, the matte
column has to be linked to the Matte input port, and the output port has to be connected to the Xsheet node.

• Effects that create computer generated images, such as the Radial Gradient, that are exposed in Xsheet
columns (and Timeline layers) and therefore are similar to columns; they are displayed with an orange node
with only an output port on the right. These effect nodes have to be connected to the Xsheet node to be rendered,
or can be connected to other effect nodes.
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Tip: To open the FX Browser:

Do one of the following:

• Choose Xsheet → New FX. . .

• Click the New FX button ( ) in the bottom bar of the FX Schematic window.

Tip: To Insert an effect:

Do one of the following:

• Select the nodes for which you want to insert a new effect, select the effect you want to insert in the FX Browser
and click the Insert button.

• Select the nodes for which you want to insert a new effect, right-click any of them and choose Insert FX from
the menu that opens, then select the effect you want to insert from the available submenus.

• Select the links where you want to insert a new effect, right-click any of them and choose Insert FX from the
menu that opens, then select the effect you want to insert from the available submenus (see Editing the FX
Schematic ).

Tip: To Add an effect:
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1. Select the nodes for which you want to add a new effect at the end of a new link.

2. Do one of the following:

• Select the effect you want to add in the FX Browser and click the Add button.

• Right-click any of the selected nodes and choose Add FX from the menu that opens, then select the effect you
want to add from the available submenus.

Tip: To Replace an effect:

1. Select the effect nodes you want to replace with a new effect.

2. Do one of the following:

• Select the effect you want to add in the FX Browser and click the Replace button.

• Right-click any of the selected nodes and choose Replace FX from the menu that opens, then select the new
effect from the available submenus.

Tip: To Insert/Add effects globally:

1. Select the Xsheet node.

2. Do one of the following:

• Select the effect you want to insert/add in the FX Browser and click the Insert or Add buttons.

• Right-click any of the selected nodes and choose Insert FX or Add FX from the menu that opens, then select
the effect you want to a insert/add from the available submenus.

Tip: To rename a node:

Ctrl + double-click (PC) or Cmd + double-click (macOS) the node name and type a new name.

19.1.3 Editing the FX Schematic

Links between nodes have to be considered like flows going to the right, from the column/layer nodes to the Output
node, via the Xsheet node. If along the way there is one or several effects, the column content will be consequently
processed before becoming part of the output.

From the nodes output port several links can start at the same time, thus allowing, for example, a column/layer to be
rendered as it is, and to be also used as a mask for another column/layer. It is also possible to determine permanently
whether columns/layers will be rendered or not, by leaving or deleting the link to the Xsheet node.

By editing the links between nodes, or by creating new ones, you can control how column/layer nodes will interact
with each other and with effects before being rendered.

Note: In the effects that accept multiple input nodes it is possible to change the stacking order of the input nodes by
clicking and dragging in the ports area.

Effect nodes and links can be selected in order to be cut, copied, pasted or deleted. When selected, nodes and links are
highlighted in white; the current node has its label in yellow; when at least one object is selected, the related links are
displayed in blue.

364 Chapter 19. Applying Effects



OpenToonz Documentation, Release 1.7.1

When pasting a copied/cut selection, several options are available:

• Use Paste to paste the copied/cut selection into the FX Schematic.

• Use Paste Insert to insert the pasted selection into the selected links.

• Use Paste Add to add the pasted selection from the selected nodes at the end of new links.

• Use Paste Replace to replace selected effects nodes with the pasted selection.

Note: Links have to be selected together with nodes when copying/cutting a selection if you want to preserve the
links among them when pasting.

Tip: To create links between nodes:

Click and drag the output port of the node to the input port of the effect node.

Tip: To select nodes and links:

Do one of the following:

• Click to select a node or a link.

• Click and drag to select a group of nodes and links.

• Ctrl-click (PC) or Cmd-click (macOS) to add a node or a link to, or remove it from the selection.

Tip: To delete links between nodes:

Select the links you want to delete and do one of the following:

• Choose Edit → Delete.

• Right-click any selected link and choose Delete from the menu that opens.

Tip: To connect a node to the Xsheet node:

Do one of the following:

• Click and drag the output port of the node to the input port of the Xsheet node.

• Right-click the node you want to connect to the Xsheet node, and choose Connect to Xsheet from the menu
that opens.

Tip: To disconnect a flow from the Xsheet node:

Do one of the following:

• Delete the link from the node to the Xsheet node.

• Right-click the node you want to disconnect from the Xsheet node, and choose Disconnect from Xsheet from
the menu that opens.
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Tip: To insert an effect node into a link:

Alt-click and drag it onto the link.

Tip: To extract an effect node from a link:

Alt-click and drag it away from the link.

Tip: To edit an effect nodes selection:

Do one of the following:

• Use the Copy command to keep the selection in memory for further operations.

• Use the Cut command to eliminate the selection from the schematic and keep it in memory for further opera-
tions.

• Use the Paste command to paste the selection kept in memory in the FX Schematic.

• Right-click a link and use the Paste Insert command to insert the selection kept in memory into the selected
link.

• Right-click any node and use the Paste Add command to add the selection kept in memory from the selected
nodes at the end of the new links.

• Right-click an effect node and use the Paste Replace command to replace the selected effect nodes with the
selection kept in memory.

• Use the Delete command to delete the selection.

Note: All these commands are available in the menu that opens when right-clicking nodes and links.

Tip: To create a linked effect:

1. Select the effect nodes you want to duplicate.

2. Right-click any of the selected nodes and choose Create Linked FX from the menu that opens.

Tip: To break linked effects:

1. Select the effect nodes you want to unlink.

2. Right-click any of the selected nodes and choose Unlink from the menu that opens.

19.1.4 Using Multiple Output Nodes

In the FX Schematic by default the Xsheet node is connected to an Output node: this means that all the nodes connected
to the Xsheet node will be rendered both in the preview and in the final rendering.
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The scene rendering can be limited to a specific node of the schematic by creating additional Output nodes, connected
to the node where you want to limit the rendering.

When more than one Output node is defined, you can set which is the active one (the one that will be considered for
previewing or rendering the scene); the active output node is displayed in blue, while the others in grey.

Tip: To limit the output to a specific node:

1. Select the node to which you want to limit the output.

2. Do one of the following:

• Click the New Output button ( ) in the bottom bar of the schematic window.

• Right-click the node and choose New Output from the menu that opens.

Tip: To add an Output node:

Do one of the following:

• Click the New Output button ( ) in the bottom bar of the schematic window.

• Right-click in the schematic and choose New Output from the menu that opens.

Tip: To connect a node to an Output node:

Click and drag the output port of the node to the input port of the Output node.

Tip: To set the current Output node:

Right-click the Output you want to set as current and choose Activate from the menu that opens.

Tip: To remove an Output node:

Do one of the following:

• Select it and choose Edit → Delete.

• Right-click it and choose Delete from the menu that opens.

Note: The last Output node remaining cannot be removed from the Schematic.

19.2 Editing Effects Settings

Effects parameters and their animation can be controlled in the FX Settings window. According to the selected effect,
it displays a different layout of sliders, check boxes, text fields, etc.

At the bottom of the window a preview area is available to check the result of the applied effect: you can expand it or
contract it, activate it or deactivate it, navigate its content, set its size, its background color, and limit it to the camera
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shot. The preview area can be expanded or contracted by clicking on the +/- symbol to the left of the Swatch Viewer
text, at the bottom left of the FX Settings window.

Parameters can be animated by setting keyframes at specific frames. A Set Key button ( ) is available in the preview
area, at the bottom bar of the window, to set keyframes for all of the parameters. For each of the parameters that can

be animated there is also a specific Set Key button ( ) to the right of the parameter name, in order to set keyframes
for each parameter independently.

The Set Key button ( ) may have the following colors:

• It is grey when no keyframes for any parameter is defined at the current frame.

• It is blue-striped when keyframes are defined at least for one parameter.

• It is blue when keyframes are defined for all the parameters.

The parameter specific Set Key button ( ) may have the following colors:

• It is grey if no key value is defined for the parameter at the current frame.

• It is orange when a key value is defined for the parameter at the current frame.

• It is pale yellow if the parameter is animated but no key value is defined at the current frame.

• It is yellow if you changed the parameter value and the current frame does not have a key for the parameter.

Frames and keyframes can be navigated by using the related buttons in the bottom bar of the window. The Next Key

( ) and Previous Key buttons ( ) are available only if more than one keyframe is defined.
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If no keyframes are defined, parameters you set will be used throughout the scene.

Tip: To open the FX Settings window:
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Do one of the following:

• Right-click the effect node, and choose Edit FX. . . from the menu that opens.

• Double-click the effect node.

Tip: To define values for the effect:

Use the available sliders, check boxes, text fields, etc., to configure the effect the way you prefer.

Tip: To set the current frame:

Do one of the following:

• Type the frame number or use the Next Frame and Previous Frame buttons available in the bottom bar of the
window.

• Move the current frame cursor in the Xsheet/Timeline or in the Function Editor.

• Use the frame bar or the playback buttons in the bottom bar of the Viewer.

Tip: To set keyframes for all the effect parameters at the current frame:

1. Do one of the following:

• If the current frame is not a key, click the Set Key button ( ) in the bottom bar of the window: it turns from
grey to blue and current values become keyframes for all the parameters at the current frame.

• If the current frame is a keyframe for some parameters only, click the Set Key button ( ): it turns from
blue-striped to blue and current values become keyframes for all the parameters at the current frame.

2. Define the values for the parameters.

Tip: To set keyframes for a specific parameter at the current frame:

1. If the current frame does not have a keyframe for the parameter, click the squared Set Key button ( ) to the
right of the parameter: it turns from grey to orange, and the current value becomes a keyframe for the parameter
at the current frame.

2. Define the value for the parameter.

Note: If the current frame is not a keyframe for the parameter, and you changed it, the Set Key button ( ) to the
right of the parameter turns yellow. Click it to set the key.

Tip: To remove all keyframes for the effect parameters at the current frame:

Do one of the following:

• If the keyframes are set for all the parameters, click the Set Key button ( ) in the bottom bar of the window:
it turns from blue to grey.

370 Chapter 19. Applying Effects



OpenToonz Documentation, Release 1.7.1

• If the keyframes are set for some parameters only, click twice the Set Key button ( ) in the bottom bar of the
window: with the first click it turns from blue-striped to blue (as you set keys for all the parameters); with the
second click, it turns from blue to grey.

Tip: To remove a keyframe for a specific parameter at the current frame:

Click the Set Key button ( ) to the right of the parameter: it turns from grey to orange.

Tip: To navigate frames where keyframes are defined:

Use the Next Key ( ) and Previous Key buttons ( ) available at the side of the Set Key button.

Tip: To activate/deactivate the preview:

Do any of the following:

• Click the Camera Preview button ( ) in the bottom bar of the FX Settings window to limit the preview to the
camera shot.

• Click the Preview button ( ) in the bottom bar of the FX Settings window to preview the results regardless
of the camera shot.

Tip: To resize the preview area:

Do any of the following:

• Click and drag the horizontal separator.

• Click and drag the separator toward the window border to hide the preview area.

• Click and drag the separator collapsed to the window border toward the window center to display again the
preview area.

Note: The A/R of the preview area depends on the A/R of the current camera.

Tip: To change the background color of the preview area:

Use the buttons in the bottom bar of the FX Settings window to choose a White ( ), Black ( ) or Transparent

( ) background.

Tip: To navigate the preview area:

Do one of the following:

• Use the mouse wheel, or the zoom shortcut keys (by default + and - keys) to zoom in and zoom out.

• Middle-click and drag to scroll in any direction.
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• Use the Reset View shortcut (by default the Alt + 0 key) to display preview at its actual size.

19.2.1 Using Effects Gadgets

Some effects parameters related to positions or dimensions have some gadgets available in the Viewer in order to be
set by using the camera box and the scene elements as a reference. For example the Radial Gradient effect has two
circular gadgets that can be edited to set the inner size and the outer size of the gradient.

As soon as an effect node is selected in the schematic, the Animate tool becomes the current tool and the related effect
gadgets, if available, are shown. The Animate tool settings will refer to the column the effect is applied to, but in case
the effect creates a computer generated image (e.g. a radial gradient or a light spot) the settings will refer to the effect
column itself (see Animating Objects ).

Tip: To visualize effects gadgets in the Viewer:

Select the effect node in the FX Schematic.

Tip: To edit effects gadgets:

Click and drag the effects gadgets visible in the Viewer. As you roll over the gadget and the related handles, the cursor
changes shape to indicate you are editing an effect gadget.

Note: Some gadgets have a handle for reference; however any point along the gadget shape can be clicked and
dragged.

19.2.2 Defining Colors and Color Spectrums

Some effects may require the definition of a color, or a color spectrum.

Colors can be defined by editing the related Red, Green, Blue and Alpha values, or by using the Style Editor.
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Color spectrums, i.e. a series of colors defining a continuous gradient, can be defined by adding any color you need,
and editing each color separately. The color in the spectrum can be moved to set the distance between two colors and
the related gradient.

Tip: To define a color:

Do one of the following:

• Set the Red, Green, Blue and Alpha values.

• Click the color thumbnail and use the Style Editor to edit it (see Plain Colors ).
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Tip: To set a color of the spectrum:

Select the arrow below the spectrum identifying the color, and edit the related color.

Tip: To add a color to the spectrum:

Click the spectrum where you want to add the new color.

Tip: To move a color in the spectrum:

Click and drag the arrow identifying the color to a new position.

Tip: To remove a color from the spectrum:

Click and drag the arrow identifying the color down.

19.3 Creating Presets

A particular configuration and animation of an effect parameters can be saved as a Preset to be available later on, both
in the FX Browser and the drop-down menus that open when right-clicking nodes or in the Schematic area.

When a preset for a particular effect is saved, in the FX Browser the effect icon turns into a folder containing the saved
preset, with the folder icon still selectable to insert the effect with its default values; in the drop-down menus the effect
has an additional drop down menu where the first item can be selected to insert the effect with its default values.
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Presets are saved in the <projectroot>\fxs\preset folder. This allow the presets to be available on all the
computers sharing the same Projectroot (see Setting the Projectroot ).

Note: Currently the statement above if not true, as by default presets are being saved in OpenToonz
stuff\fxs\presets. On Windows it can be changed to any other path by going to the registry and changing
the System\HKEY_LOCAL_MACHINE\SOFTWARE\OpenToonz\OpenToonz\TOONZFXPRESETS key to the
desired location.

Once a preset is applied there is no link between the saved preset and the applied preset: the applied preset can be
edited without affecting the saved one.

Note: When you save a preset with a name already used, a confirmation dialog will open, asking you whether you
want to overwrite the previously saved preset.

Tip: To save a preset:
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1. Right-click the effect node you want to save as a preset and choose Save As Preset from the menu that opens.

2. Assign a name to the preset and click the Save button.

Tip: To retrieve a saved preset:

Do any of the following:

• Open the FX Browser and open the folder related to the effect for which you saved the preset.

• In the right-click menus Insert FX, Add FX or Replace FX, choose the sub-menu related to the effect for which
you saved the preset.

Tip: To remove a preset from the FX Browser:

Right-click the preset in the FX Browser and choose Remove Preset from the menu that opens.

19.4 Creating Macro FX

Effects can be combined to create a macro effect that can be saved and retrieved when needed.

When a macro effect is defined, you can edit its settings either in the standard way with the FX Settings window that
contains a tab for each effect combined to define the macro, or by opening it and editing one effect at a time.

A macro effect can be opened also to check how the effect nodes are connected, and can be exploded to dissolve it and
put its effect nodes back in the Schematic.

When saved, the macro effect will be available in the FX Browser and in the drop-down menus that open when
right-clicking nodes or in the Schematic area, inside the Macro folder, at the bottom of the list.

Note: Macro effects can’t contain zerary effect nodes in them (i.e. any effects in the Background or Render cate-
gories). If any zerary effect node is selected when trying to use the Make Macro FX command, no macro effect will
be created.

Tip: To create a macro effect:

1. Select the effect nodes you want to combine to create the macro effect.

2. Right-click the selection and select Make Macro FX from the menu that opens.

Tip: To open a macro effect:

Right-click the macro node and choose Open Macro FX from the menu that opens: the macro nodes are displayed in
a box, with the right links to the rest of the schematic.

Note: When the content of a macro is displayed it is not possible to edit the links between macro nodes and links
with nodes outside the macro.

376 Chapter 19. Applying Effects



OpenToonz Documentation, Release 1.7.1

Tip: To close a macro effect:

Click the Close button on the right of the macro box bar.

Tip: To release a macro effect:

Right-click the macro node and choose Explode Macro FX from the menu that opens.

Tip: To edit a macro effect:

Do one of the following:

• Right-click the macro node and choose Edit FX. . . from the menu that opens.

• Right-click the macro node and choose Open Macro FX from the menu that opens, then edit the macro effect
nodes.

Tip: To save a macro effect:

1. Right click the macro effect node you want to save and choose Save As Preset from the menu that opens.

2. Assign a name to the macro effect and click the Save button.

Tip: To remove a macro effect from the FX Browser:

Right-click the macro effect in the FX Browser and choose Remove Macro FX from the menu that opens.

19.5 Effects List

19.5.1 Background
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Checkerboard

Creates a new column/layer containing a checkerboard defined by two Colors, and a grid Size.

Note: The grid size can also be set by using a square gadget with a handle in the Viewer (see Using FX Gadgets ).
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Color Card

Creates a new column/layer containing the set Color. It can be used, for example, as a background color or to create a
colorize effect by applying it combined with a multiply effect.
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Kaleido

Repeats the Source generating a kaleidoscopic effect.

The center of the effect can be defined interactively, moving the small red cross widget in the preview area, or writing
the desired values in the X and Y text fields.

The angle of reflection, and the number of iterations can be set in the appropriate input text fields (Angle and Count).
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Tile

Repeats the Source content in order to define a larger image: the Tile mode forms a pattern that completely fills the
camera shot, the Tile Horizontally repeats the source content horizontally; the Tile Vertically repeats the source content
vertically.

The Mirror Horizontally and Mirror Vertically options repeat the tiles by flipping them respectively in the horizontal
and vertical directions; If both the options are activated, tiles will be mirrored in both directions.

The Margin value sets the size of a margin around each tile, with positive values adding some space around the tiles,
and negative values collapsing them.

19.5.2 Blur
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Blur

Softens the Source content, creating an out of focus effect, according to a specific Intensity.

Directional Blur

Blurs the Source content according to a specific Intensity along a specific direction defined by the Angle.
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The Bidirectional option applies the blur also on the other side of the direction.

Note: The intensity and the angle can also be set by using an arrow gadget with a handle in the Viewer (see Using
FX Gadgets ).

Note: The directional blur does not depend on the movement and the speed of the column to which it is applied.

Local Blur

Blurs the Source content according to the brightness value of the node content connected to the Reference input handle.
The Intensity value amplifies uniformly the blur given by the Reference node content.

Motion Blur

Creates a motion-blur effect, according to the movement of the Source content in the previous and current frame. The
movement has to be defined by an animated column, pegbar or table: the higher the speed, the more visible the effect.

If the movement is constant between consecutive frames, you can increase or decrease the Intensity to have a more or
less visible effect. If there is no movement between the previous and the current frame, no motion blur will be visible
even though you may have set a high Intensity.

Note: No result will be visible if the motion blur is applied to a column that always stands in the same position while
the content is a level where the movement is drawn.
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Radial Blur

Blurs along radial lines whose origin is the set Center, defined by horizontal (X) and vertical (Y) coordinates, starting
from an unaffected inner area defined by the Radius.

Note: The center and the radius can be also set by using a point and a circle gadget with a handle in the Viewer (see
Using FX Gadgets ); the center can be set in the FX Settings preview as well.

Spin Blur
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Blurs along concentric circular lines as if the Source content turns around the set Center, defined by horizontal (X) and
vertical (Y) coordinates, starting from an unaffected inner area defined by the Radius.

Note: The center and the radius can be also set by using a point and a circle gadget with a handle in the Viewer (see
Using FX Gadgets ); the center can be set in the FX Settings preview as well.

19.5.3 Distort

Free Distort

Distorts the Source content according to the position of four points, defined by horizontal (X) and vertical (Y) coor-
dinates. For each point you can set the actual position and its origin, to determine which feature of the image will be
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distorted to the new position.

The Mode option menu lets you set the way the distortion is applied: Bilinear distorts the images according to the four
points end positions, and Perspective forces the distortion to fit a perspective projection plane.

To better set the origin position for each point, you can use the Deactivate option that lets you see the image without
distortion.

Note: The position of the four points and their origins can be also set by using arrow gadgets with handles at the ends
in the Viewer (see Using FX Gadgets ) and in the FX Settings preview as well.

Linear Wave

Distorts the Source content creating a wave effect that uses an automatically generated displacement map image. The
Quantity value sets the number of waves; the Period sets the distance between waves; the Phase shifts distortion in the
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wave direction.

You can also add a Transverse Wave on the main linear waves: the Amplitude sets the intensity of the distortion; the
Frequency sets the number of waves creating the distortion; the Cycle shifts the distorting waves.

A rotation for the whole wave effect can be set by using the Angle value.

The amount of distortion is controlled by the Intensity value; the detail of the distortion, by the Sensitivity parameter;
the Sharpen option allows you to decrease the blur on the final result.

Perlin Noise

Distorts the Source content by using a computer-generated displacement map image whose type can be chosen between
Clouds and Marble/Wood.

The amount of distortion is controlled by the Intensity value; the , by the Size of the displacement map grid. The
Horizontal and Vertical Offset, and the Evolution stage of the displacement map image can be controlled as well;
by setting the variation of these values between two keys, you can set how much the displacement map moves and
changes during the animation.

The Alpha option adds also a transparency displacement to fully-opaque images.
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Note: The horizontal and vertical offset can also be set by using a point gadget in the Viewer (see Using FX Gadgets
).

Random Wave

Distorts the Source content creating a random wave effect that uses an automatically generated displacement map
image. It can be used, for instance, to create a reflection on a water surface, or an underwater view.

The stage of the displacement map image can be controlled by using the Evolution value; by setting the variation of
this value between two keys, you set how much the displacement map image changes during the animation.

The position of the displacement map image can be shifted along the Horizontal and the Vertical axis. By setting the
variation of this value between two keys, the distortion effect can be animated in any direction.

The amount of distortion is controlled by the Intensity value; the detail of the distortion, by the Sensitivity parameter;
the Sharpen option allows you to decrease the blur on the final result.

Note: The position along the horizontal and vertical axis can also be set by using a point gadget in the Viewer (see
Using FX Gadgets ).
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Ripple

Distorts the Source content creating a circular wave effect that uses an automatically generated displacement map
image. The Quantity value sets the number of ripples; the Period value sets the distance between ripples; the Cycle
shifts the ripple distortion, with increasing values expanding the ripples, and decreasing values collapsing them.

The Center of the circular waves can be set with a Horizontal and Vertical value; circular waves can be scaled in the
Horizontal and Vertical directions, and rotated according to a set Angle.

The amount of distortion is controlled by the Intensity value; the detail of the distortion, by the Sensitivity parameter;
the Sharpen option allows you to decrease the blur on the final result.

Note: The center and the period can be also set by using a point and a circle gadget with a handle in the Viewer (see
Using FX Gadgets ); the center can be set in the FX Settings preview as well.
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Warp

Distorts the Source content according to the brightness variation of the node content connected to the Warper input
handle, that is used as a displacement map image affecting the Source content.

The amount of distortion is controlled by the Intensity value; the detail of the warp, by the Size of the displacement
map grid; the Sharpen option allows you to decrease the blur on the final result.

19.5.4 Gradients
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Diamond Gradient

Creates a new column/layer containing a gradient, that goes hyperbolically from the center to the four corners, defined
by a color spectrum (see Defining Colors and Color Spectrums ) and a Size value.

Note: The size can also be set by using a circle gadget with a handle in the Viewer (see Using FX Gadgets ).
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Four Points Gradient

Creates a new column/layer containing a gradient defined by four Colors, defined by Red, Green, Blue and Alpha
values, whose source Points can be placed where needed defining horizontal (X) and vertical (Y) coordinates.

Note: The source points can also be set by using point gadgets in the Viewer (see Using FX Gadgets ) and in the FX
Settings preview as well.
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Linear Gradient

Creates a new column/layer containing a gradual blend between two Colors defined by Red, Green, Blue and Alpha
values. The Size controls the area of the gradient between the two colors.

You can also add a Distortion Wave on the linear gradient: the Amplitude sets the intensity of the distortion; the
Frequency sets the number of waves creating the distortion; the Phase shifts the distorting waves.

Note: The size can also be set by using a gadget with two handles at the ends in the Viewer (see Using FX Gadgets ).
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Multi Linear Gradient

Creates a new column/layer containing a multi linear gradient defined by a color spectrum (see Defining Colors and
Color Spectrums ). The Period value sets the size of a spectrum gradient; the Quantity is the number of times the
spectrum is repeated; the Phase shifts the gradient colors.

You can also add a Wave distortion on the multi linear gradient: the Amplitude sets the intensity of the distortion; the
Frequency sets the number of waves creating the distortion; the Phase shifts the distorting waves.

Note: The period can also be set by using a gadget with two handles at the ends in the Viewer (see Using FX Gadgets
)
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Multi Radial Gradient

Creates a new column/layer containing a multi radial gradient defined by a color spectrum (see Defining Colors and
Color Spectrums ). The Period value sets the size of a spectrum gradient; the Quantity is the number of times the
spectrum is repeated; the Phase shifts the gradient colors.

Note: The period can be also set by using a circle gadget with a handle in the Viewer (see Using FX Gadgets ).
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Radial Gradient

Creates a new column/layer containing a gradual blend between two colors, defined by Red, Green, Blue and Alpha
values, shading them in a circular pattern. The Inner Size controls the area where the gradient between the two colors
begins; the Outer Size where it ends.

Note: The inner and outer sizes can be also set by using circle gadgets with a handle in the Viewer (see Using FX
Gadgets ).
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Spiral

Creates a new column/layer containing a spiral pattern gradient defined by a color spectrum (see Defining Colors and
Color Spectrums ). The Frequency sets the size and number of the spires; the Phase shifts the gradient colors.

Square Gradient
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Creates a new column/layer containing a square gradient, that goes linearly from the center to the four corners, defined
by a color spectrum (see Defining Colors and Color Spectrums ) and a Size value.

Note: The size can also be set by using a rotated square gadget with handles in the Viewer (see Using FX Gadgets ).

19.5.5 Image Adjust

Adjust Levels

Adjusts the highlights and shadows of the Source content by remapping pixels intensity according to the Input and
Output levels values for the RGB, Red, Green, Blue and Alpha channels; it also controls the Gamma value for each
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channel separately.

For each channel the Input values remaps pixel intensity whose value is equal or lower than the Minimum value, to 0,
and those whose value is equal or higher than the Maximum value, to 255. This may be helpful to increase the contrast
of an image.

For each channel the Output values remaps pixel intensity whose value is lower than the Minimum value, to the
Minimum value, and those whose value is higher than the Maximum value, to the Maximum value. This may be
helpful to decrease the contrast of an image.

Brightness & Contrast

Increases or decreases the brightness and contrast of the Source content.

19.5. Effects List 399



OpenToonz Documentation, Release 1.7.1

Channel Mixer

Swaps the channels of the Source content. For each channel you can set if it remains as it is, or if you want it to have
another channel mixed. For example to leave the red channel as it is, Red to Red is 1, the other channels to Red are 0;
by setting Green to Red to 0.5 adds half intensity of the green channel to the red one.
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It can be used for example to create a black and white key for an image with the alpha channel, by setting all the values
to 0 but the Alpha to Red, Green, Blue and Alpha to 1.

Curves

Adjusts the tonal range of the Source content by remapping pixels intensity according to a tonal curve for the RGB,
Red, Green, Blue and Alpha channels.

The horizontal axis of the graph represents the original brightness levels of the pixels (Input levels); the vertical axis
represents the new brightness levels (Output levels).

The default diagonal line indicates that no pixels are mapped to new values, so all pixels have the same Input and
Output values.

It is possible to use many adjustment points to correct the curve: to add a point, click the curve; to change the curvature,
use the point tangent handles; to delete a point, select it and use the delete shortcut (by default the Delete key).
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The Linear option constrains the curve to a series of straight segments.

Despeckle

Elimantes small imperfections (dirt, scratches, stains and similar) of the drawing. The size in pixels of the details that
will be retouched can be defined in the Size input text field. The background of the images can be Transparent or
White, the choice is available in the Detect On menu.

In the preview area is possible to check the results to avoid erasing details relevant for the drawing.
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Gamma

Changes the gamma value of the Source content.
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HSV Scale

Shifts the Hue, Saturation and Value values of the Source content. Hue ranges from -180 to 180; Saturation and Value
from -100 to 100. All the three settings preserve their original value at 0.
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Invert

Inverts the color values of the Source content, e.g. makes a positive black and white image negative, or a positive one
from a scanned black and white negative.
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Multitone

Applies to the Source content the colors defined by a color spectrum (see Defining Colors and Color Spectrums )
according to the image brightness. The original image is turned into black and white and the color on the far left of the
spectrum will be use for black pixels, the color on the far right for white pixels, and in-between colors for in-between
grey pixels.
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RGBA Cut

Delimits the Minimum and the Maximum values of the Red, Green, Blue and Alpha components of the Source content.
The maximum can be decreased from 255, the original value, to 0, when no red, green, blue or alpha component will
be visible. The minimum can be increased from 0, the original value, to 255, when the red, green, blue components
will be saturated, and alpha will be fully opaque.
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RGB Fade

Fades the Source content toward a color defined by Red, Green and Blue values. The Intensity, expressed as a percent-
age, ranges from 0 (no fade) to 100 (fade to full color).
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RGBA Scale

Changes the percentage of the Red, Green, Blue and Alpha components of the Source content. At 0 there is no red,
green, blue or alpha component; at 100 the components have their original value.
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Sharpen

Increases the sharpness of the Source content according to a specific Intensity.

19.5.6 Layer Blending

Add
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Adds the red, green and blue values of the Up node content to the Down one, pixel by pixel.

If no Down node is defined, the adding operation is applied to all the images underlaying the Up node content according
to the Xsheet/Timeline layering order.

The Intensity value expresses the percentage of values used in the addition; a negative value defines a subtraction
instead of an addition.

Color Burn

Darkens the pixel colors of the Down node content in order to reflect the color of the Up node content. The white in
the Up node content does not affect the result.

If no Down node is defined, the color burning operation is applied to all the images underlaying the Up node content
according to the Xsheet/Timeline layering order.
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Color Dodge

Brightens the pixel colors of the Down node content in order to reflect the color of the Up node content. The black in
the up node content does not affect the result.

If no Down node is defined, the color dodging operation is applied to all the images underlaying the Up node content
according to the Xsheet/Timeline layering order.

Cross Dissolve
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Creates a cross-dissolve between the Up and Down node content. When the Intensity value is 0, only the Down node
content is visible; when it is 100, only the Up one.

Darken

Compares the pixels color of the Up and Down node content and selects the darker one as the result color. The white
in the Up node content does not affect the result; the black gives a black result.

If only one node is defined, the darkening operation is applied to all the images underlaying its content according to
the Xsheet/Timeline layering order.
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Lighten

Compares the pixels color of the Up and Down node content and selects the lighter one as the result color. The black
in the Up node content does not affect the result; the white gives a white result.

If only one node is defined, the lightening operation is applied to all the images underlaying the connected node
according to the Xsheet/Timeline layering order.
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Local Transparency

Applies a transparency to the Source content according to the brightness value of the node content connected to the
Reference input port.

The Intensity value amplifies uniformly the transparency given by the Reference node content.
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Multiply

Multiplies the red, green, blue and alpha values of the connected noded content.

The Intensity value expresses the percentage of values used in the multiplication. By activating the Alpha option, also
the alpha information is considered.

If only one node is defined, the multiplying operation is applied to all the images underlaying theupper node content
according to the Xsheet/Timeline layering order.
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Over

Puts the connected nodes one over the other. Each time a node is connected a new port will be added, this way the
overlap of columns can be defined regardless from the Xsheet columns (or Timeline layers) order. The contents order
is up to bottom, where the node connected on the upper port will be over the other ones. This can be used when you
need to combine several nodes in a single one, for example to mask several columns with the same mask.

Premultiply

Premultiplies the alpha channel of the Source node content.

Full-color images which have a meaningful alpha channel come in two types: premultiplied or not. A non-
premultiplied image can be recognized when it is loaded in OpenToonz because its edge, where there is a complete
transparence on one side and opacity on the other, is not smooth, but displays a solid halo. With the premultiply effect
it is possible to transform the image alpha-channel so that it is correctly read by OpenToonz.

Note: Full-color images can also be premultiplied by using a Level Settings option, or processed permanently in the
browser, so that there is no need to apply the effect in the schematic (see Editing Level Settings and Using the File
Browser ).
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Screen

Combines by multiplying the inverse of the pixels color of the Up and Down node content, giving a result color that
is lighter than both Up and Down node pixels, except when one of them equals 0. The black in the Up node content
does not affect the result; the white gives a white result.

If no Down node is defined, the screening operation is applied to all the images underlaying the Up node content
according to the Xsheet/Timeline layering order.

Subtract

418 Chapter 19. Applying Effects



OpenToonz Documentation, Release 1.7.1

Subtracts the red, green and blue values of the Up node content from the Down one, pixel by pixel. By activating the
Alpha option, also the alpha information is considered.

If only one node is defined, the subtraction operation is applied to all the images underlaying connected node content
according to the Xsheet/Timeline layering order.

Transparency

Sets the transparency of the Source content. The Intensity, expressed as a percentage, ranges from 0, fully opaque, to
100, fully transparent.

19.5.7 Light
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Backlit

Creates a backlit effect, using the Light node content as a light source affecting the Source node content by the set
Intensity. The light node content can be also faded to a Color defined by Red, Green and Blue values, according to the
set Fade.
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Body Highlight

Creates a highlighted area for the Source node content, according to its alpha channel. You can set the Color of the
highlight, as well as a Transparency and a Blur value to be applied.

The shifting of the highlighted area is defined by horizontal (X) and vertical (Y) Offset values, that can also be
interactively set in the preview of the FX Settings window, where the offset center is displayed with a cross.

Enabling the Invert option the effected areas will be toggled.

The effect can be used to create a body shadow as well, by defining a black color for the highlight.
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Cast Shadow

Turns the Source content into a shadow that can be distorted and faded to a color with a variable transparency and blur.

The distortion can be done like in the Free Distort effect (see Free Distort ). The fade Color can be defined by Red,
Green and Blue values and a Fade intensity can be set. A different Blur and Transparency value can be set for the top
and the bottom part of the Source content, in order to have a more realistic shadow.
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Glow

Creates a glowing effect, using the Light node content as a light glowing on the node content connected to the Source
input port. The Blur and Brightness of the glowing can be set; the Light node content can be also faded to a color
defined by Red, Green and Blue values, according to the set Intensity.

If no Source node is defined, the glowing is applied to all the images underlaying the Light node content according to
the Xsheet/Timeline layering order.
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Light Spot

Creates a new column/layer containing a light spot whose size and color can be set respectively with the Width and
Height values, and the Reg, Green, Blue and Alpha values. The Softness sets the light diffusion in the area outside the
spot.

Note: The width and height can be also set by using a box gadget with handles in the Viewer (see Using FX Gadgets
).
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Raylit

Places a source of light behind the Source node content, casting rays of light outside or inside the image outline.

The light source position is defined by horizontal (X) and vertical (Y) coordinates. By changing the light source
position you change the way rays are cast along the image outline; by changing the Distance value you can make the
light source approach to or go away from the image.

Properties of the light can be set by defining the Intensity, the Color, that is set by Red, Green, Blue and Alpha values,
the Decay, that is the decrease of the light intensity according to its distance from the image, and the Smoothness, that
determines how sharp the rays are along the image outline.

The Invert option switches the casting of rays of light from the outside of the image to the inside.

The Keep Image check-box determines if the original drawing is rendered in the output or not.

Note: The center can be also set by using a point gadget in the Viewer (see Using FX Gadgets ) and in the FX Settings
preview.

Note: The Source node content needs to have a significant alpha channel in order to have an effective result.
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Color Raylit

Places a source of light behind the Source node content, casting rays of light outside the image outline.

The light source position is defined by horizontal (X) and vertical (Y) coordinates. By changing the light source
position you change the way rays are cast along the image outline; by changing the Distance value you can make the
light source approach to or go away from the image.

The colours of the rays are calculated from the original drawing colours.

Properties of the light can be set by defining the Intensity, the Decay, that is the decrease of the light intensity according
to its distance from the image, and the Smoothness, that determines how sharp the rays are along the image outline.

The Keep Image check-box determines if the original drawing is rendered in the output or not.
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Target Spot

Creates a new column/layer containing a light spot whose size and color can be set respectively with the Width and
Height values, and the Red, Green, Blue and Alpha values. The direction of the spot can be set by defining the Distance
of the light from the table and the Angle between the light spot direction and the table. The Decay, that is the decrease
of the light intensity according to the distance from table, can be controlled as well.

19.5.8 Matte
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Erode/Dilate

Morphologically erodes or dilates the alpha channel of the connected node by the specified value, where positive
values correspond to dilations and negative ones to erosion.

The Type parameter defines the shape of the corners of the frame, applied around the image, when the Radius value is
positive.
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HSV Key

Defines a chroma key for the Source content using the set Hue, Saturation and Value values. You can set the range for
each value by using the related Range slider. The selection can be inverted using the Invert button.
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Matte In

Makes the Source content visible only inside the opaque areas of the node content connected to the Matte input port.

Matte Out

Makes the source content visible only outside the opaque areas of the node content connected to the Matte input port.
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RGB Key

Defines a chroma key for the Source content using the set Red, Green and Blue values. You can set the range for each
value by using the related Range slider. The selection can be inverted using the Invert button.
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Visible Matte In

Makes the Up node content visible only inside the opaque areas of the node content connected to the Down input port,
keeping the Down node still visible.

19.5.9 Noise

Dissolve
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Eliminates randomly pixels from the Source content according to the set Intensity.

Noise

Adds a noise effect to the Source content according to the set Intensity. You can decide which noise component among
Red, Green and Blue you want to activate, and if the result has to be in Black and White.
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Salt & Pepper Noise

Adds a black and white noise effect to the Source content according to the set Intensity.

19.5.10 Render
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Clouds

Creates a new column/layer containing a fractal image whose type can be chosen between Clouds and Marble/Wood.
The Size affect the grid used for generating the fractal image; a color spectrum defines the used colors (see Defining
Colors and Color Spectrums ).

Increasing the Minimum value shifts the color spectrum to the right, and consequently more pixels will be colored as
the color defined at the far left of the spectrum. Decreasing the Maximum value shifts the color spectrum to the left,
and consequently more pixels will be colored as the color defined at the far right of the spectrum.

The Evolution stage of the fractal image can be controlled as well; by setting the variation of this value between two
keys, you set how much the fractal image changes during the animation.
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Particles

The Particles effect creates a new level in the selected column/layer containing particles.

It allows you to simulate a wide range of phenomena, such as rain, snow, sparkles, smoke, and a random configuration
of elements, for example a field of shining stars starting from one shining star or the waving grass in a meadow starting
from one animated blade of grass.

See Using the Particles Effect .
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Text Iwa

Creates a new column/layer containing editable and animatable text, using the following parameters:

• Source, specifies the text source. You can choose one from:

– Nearby Note Column: Get the text from Note Level column put on the directly left side of the Text Iwa
effect column, in the Xsheet (for Timeline view, the Note Level layer just under the effect layer is used).
If the respective column/layer does not contain a Note Level or the cell is empty, text will not be rendered.

– Specified Note Column: It’s similar to the Nearby Note Column option, but the Note Level column
number to use can be specified using the Column Index field below.

– Input Text: The text typed in the Text field below will be used (as shown in the image on top).

• Column Index, specifies the source Note Level column number to use. Only used in Specified Note Column
Source mode.

• Text, specifies the source text. Only used in Input Text Source mode.

• Horizontal Align, specifies the text align. Options are: Left, Right, Center, and Justify.

• Center X:, Y: specify the position of the text.

• Width, Height, define the dimension of the text box. Just like in the Text items of the Clapperboard feature, the
font size will be automatically adjusted in order to fit the box (see Using The Clapperboard ).

• Font, specifies the font family to use.

• Style:, specifies the font style to use.

• Size:, specifies the maximum font size to use.
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Note: The Size value will only take effect if the automatically-calculated font size (in order to fit the
specified text box) is bigger than the value specified for this parameter.

• Text Color, specifies the color of the text. This color will also be used for the border line.

• Box Color, specifies the background color of the text box.

• Show Border, when activated, a border line will be rendered around the text bounding box. Please note that the
text box (specified by the user) and the text bounding box (automatically computed from the rendered text) may
become different, especially when the maximum font Size parameter is set to a small value.

Note: Known Issue: When you are using a Note Level column for the source text, a change in the note text will not
automatically trigger the preview regeneration. You will need to manually regenerate the preview using the context
menu of the Viewer.

19.5.11 Stylize

Color Emboss

Traces the edges of the Source content with a combination of highlights and shadows. You can set the Intensity of
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the effect, and the Distance and Direction of the light that create the emboss effect. The Radius sets the depth of the
embossing.

By connecting a node to the Controller port, the Source content will be embossed according to the Controller node
content.

Emboss

Turns the Source content to grey areas and traces its edges with a combination of highlights and shadows. You can set
the Intensity of the effect, and the Distance and Direction of the light that create the emboss effect. The Radius sets
the depth of the embossing.
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Mosaic

Turns the Source content in a series of tiles according to the specified Size and Distance. The color and transparency
of the tiles are sampled from the source content.

A Background Color can be set, and will be visible around the tiles. The tile shape can be chosen between Square and
Round.
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Posterize

Converts the Source content into a number of shades according to the set number of Levels. The shades depends on the
brightness values of the source content and the levels are intended for each channel; for example, two levels produces
six colors: two for the red, two for the green, and two for the blue.
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Solarize

Blends a negative and a positive version of the Source content, as if exposing a photographic print briefly to light
during development. You can set the Intensity of the effect and control the Peak Edge, that is the amount of positive
and negative image that is used in the blend.

19.5.12 Toonz Level

Toonz Level type of effects can be applied only to Toonz Vector and Toonz Raster (PLI and TLV files). They usually
affect the drawings they are applied to according to Style indexes. Style indexes can be retrieved in the Palette after
the # symbol in the Style tooltip, or in the bottom right corner of the style in any of the Thumbnails View modes.

Index numbers can be specified in the related text field, separated by a comma. To define a range of indexes, you
should type the first and last separated by a dash (e.g. 4-7 will refer to indexes 4, 5, 6 and 7). To select all indexes,
type all ; to select no index, type none .

Toonz Level type of effects have to be always applied first when a series of effects are applied to an animation level,
as they work only on Toonz Vector or Toonz Raster levels that have not been transformed by other type of effects.
However two or more Toonz Level type of effects can be applied to the same animation level.
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Art Contour

Creates in the Source content a pattern, by repeating the Controller node content, along lines painted with styles whose
indexes are specified in the Color Indexes text field. It can be used for example to create scattered brush, or hair and
fur effects along drawing lines.

The Keep Color option assigns the color of the line to the applied pattern; while the Keep Contour option retains the
drawing line that will be visible beneath the pattern.

The way the contents of the Controller node create the pattern depends on the Pattern settings.

The Density sets the amount of pattern to be applied along the line. By setting the Density to 0, you can specify a
Minimum and Maximum Distance between two subsequent images applied as pattern on the line.

The Size sets the Minimum and Maximum resizing percentage applied to the images used as the pattern; the value 100
is the original size of the images.

The Orientation sets the Minimum and Maximum rotation angle for the images used as the pattern, according to the
line direction; the value 0 display the images perpendicular to the line direction. If the Absolute Orientation option is
used, the orientation values do not depend on the direction of the lines: the value 0 is the original images orientation.
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Calligraphic Line

Changes in the Source content the thickness of the drawing lines painted with styles whose indexes are specified in
the Color Indexes text field.

You can specify the Thickness increase and how it is applied, as a percentage, to the different line directions Horizontal,
Vertical, Up Diagonal, Down Diagonal.

The Smoothness sets the smoothness of the passage between sections of the lines affected by the effect, and those not
affected; while the Noise sets the regularity of the edge of the line.
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Color Blending

Blends in the Source content lines and areas painted with styles whose indexes are specified in the Color Indexes text
field. It can be used for example to blend shadow and highlight areas with the plain colored area, or to create gradients
of colors.

The Intensity sets how wide the blended area between the selected colors will be; while the Smoothness sets how
smooth the dithering between blended colors is.

The No Blending over Other Colors option stops the blending as soon as a line, or an area, whose index is not included
in the selection, is detected; if deactivated, the blending between selected colors continues under excluded lines and
areas.
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External Palette

Applies to the Source content the palette node connected to the Palette input port; if a column node is connected to the
Palette input port, the palette related to its content will be considered.

The original styles of the Toonz levels contained in the source node are replaced with those of the levels contained in
the palette node according to their style indexes.
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Outline

Changes in the Source content the thickness of the drawing external outline.

You can specify the Thickness increase and how it is applied, as a percentage, to the different line directions Horizontal,
Vertical, Up Diagonal, Down Diagonal.

The Smoothness sets the smoothness of the passage between sections of the lines affected by the effect, and those not
affected; while the Noise sets the regularity of the edge of the outline.
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Palette Filter

Filters the styles of the Source content palette according to the indexes specified in the Color Indexes text field.

The Apply To option menu lets you choose if you want to affect Lines & Area, only Lines or only Areas, even if
painted with the same styles; the Action option menu lets you choose if you want to keep or remove the specified
styles.
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Pinned Texture

Distorts the Texture node content and applies it to the Source content areas that are painted with styles whose indexes
are specified in the Color Indexes text field.

The distortion can be done like in the Free Distort effect (see Free Distort ) and the texture can be applied like in the
Texture effect (see below).
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Texture

Applies the Texture node content to the Source content lines and areas that are painted with styles whose indexes are
specified in the Color Indexes text field.

As the texture node content can be animated as you like, this effect allows you to generate animated texture as well.

The Action option menu lets you choose if you want to apply the texture to the specified styles (Keep) or to apply it to
all styles except for the specified ones (Delete).

The Mode option menu lets you set how the texture node content will be applied: Texture uses the texture to replace
selected styles; Pattern preserves the original colors but varies them according to the texture brightness; Add, Subtract,
Multiply, Lighten and Darken defines the way the texture is applied to the original colors (see Layer Blending ). In
case the Add, Subtract or Multiply mode are selected, you can also set the Value of the effect.

Note: To repeat the texture image and tile it to create a larger texture, you can apply the Tile effect to the texture
column before linking it to the Texture node (see Tile ).
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19.5.13 Shaders

OpenToonz enables support for effects rendered through hardware-accelereted pixelshaders. Shaders are simple pro-
grams compiled by a graphics processing unit that harness the massively parallel architecture of modern graphics
devices, to execute with extreme speed. OpenToonz’s shader effects are written in the OpenGL Shading Language
(GLSL), and are located in OpenToonz stuff/library/shaders. Refer to the readme.txt file there for further
details on editing or creating new shader effects.

Caustic

Creates a new column/layer containing a simulation of the reflection of light on a water surface. Sets the color of the
water defining the RGBA values of the Water Color parameter.

The stage of the displacement map image can be controlled by using the Evolution value; by setting the variation of
this value between two keys, you set how much the displacement map image changes during the animation.
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Fireball

Creates a new column/layer containing a ball of flames erupting from a point.

A range of colors can be defined setting the RGBA values of color 1 and color 2. The stage of the displacement map
image can be controlled by using the Evolution value; by setting the variation of this value between two keys, you set
how much the displacement map image changes during the animation.
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Glitter

Adds cross-shaped light rays extending from the brightest part of an image.

Use Threshold to specify the cut-out on the input image’s brightest part. Higher values will make the fx add lights also
to darker image parts, producing more lights. The Brightness specifies the brightness of added light rays; the Radius
specify how much the light rays will extend from bright input pixels; the Angle specify the angle of light crosses. A
value 0 means that produced light crosses will be axis-aligned. Halo is the amount of light disperion orthogonal to the
direction of light rays. Higher values will produce broader rays.
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Star Sky

Creates a new column/layer containing a simple star field with variable brightness with overlayed clouds. Sets the
color of the overlayed clouds defining the RGBA values of the Cloud Color parameter.

The stage of the stars displacement can be controlled by using the Evolution value; by setting the variation of this
value between two keys, you set how much the displacement map image changes during the animation.

Use the Brightness parameters to define the brightness of the stars.
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Sun Flare

Creates a new column/layer containing rays of colored light extending from a radial gradient at the center. Sets the
color of the sun rays defining the RGBA values of the Color parameter. The number of rays is defined by the Rays
parameter while their brightness is set by the Intensity one. The angle parameter sets the direction of the rays and the
Bias parameter define the size of the rays. Use the Sharpness parameter to make the rays sharper or smoother.

19.5. Effects List 455



OpenToonz Documentation, Release 1.7.1

Wavy

Creates a new column/layer containing a simple gradient with a colored ‘wavy’ pattern. The waves colors are definied
by setting the RGBA values of the Color 1 and Color 2 parameters. The stage of the displacement map image can be
controlled by using the Evolution value; by setting the variation of this value between two keys, you set how much the
displacement map image changes during the animation.
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GPU Radial Blur

Blurs along radial lines whose origin is the set Center, defined by horizontal (X) and vertical (Y) coordinates, starting
from an unaffected inner area defined by the Safe Radius. The Blur Factor parameter sets the amount of blur.
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GPU Spin Blur

Blurs along concentric circular lines as if the Source content turns around the set Center, defined by horizontal (X) and
vertical (Y) coordinates, starting from an unaffected inner area defined by the Safe Radius. The Blur parameter sets
the amount of blur.
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Using the Particles Effect

The Particles effect creates a new level in the selected column/layer containing particles.

It allows you to simulate a wide range of phenomena, such as rain, snow, sparkles, smoke, and a random configuration
of elements, for example a field of shining stars starting from one shining star or the waving grass in a meadow starting
from one animated blade of grass.

Using a wide variety of parameters available, the Particles effect can be completely customized. A series of Presets,
simulating some basic events, are also available. You can look at these Presets to better understand how to set the
parameters; or you can use them as the starting point to create your own effects.

Particles are defined by parameters organized in different folders: Source, Birth Params, Environment, Animation and
Colors.

Note: Particles effect may have unexpected results when the Stretch option in Output Settings is used to set a higher
FPS value, as this effect requires the original timing information (see Choosing the Output Settings ).

20.1 Defining Particle Images

Any column/layer content can be used as a particle: its animated content and its animation will be reflected by the
particle animation, using the transformations and the drawings exposed in the column/layer cells at the related frame
in each point of the particle life.

For example if a level is exposed in the column/layer at step two, the particle Texture will be animated at step two as
well; or if you have a drawing that’s spinning because the column/layer is animated, the particle will be spinning as
well.

To use a column/layer content as a particle, the column/layer node has to be linked to the Texture port of the particles
effect node. As soon as a column/layer is linked to the texture input port, a new texture port is available: in this way it
is possible to use the content of several columns/layers as particles.
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Note: Image formats containing DPI information are loaded using that image DPI; in this case the particles level will
be camera resolution independent.

20.2 Defining Control Images

A column/layer contents can also be used to control some parameters of the particles effect: its animated content and its
animation will affect the particles parameter according to specific image properties, such as brightness or transparency.

For example if the level exposed in the column/layer is animated, and the column/layer is used to control the particles
Source, the particles Source will follow the animation of the level; or if the column/layer is moving and it’s used to
control the Gravity field, the Gravity field will move as well.

To use a column/layer contents as a Control Image, connect the column/layer node to a Control input port of the
Particles effect node. As soon as the column/layer is linked to the Control input port, a new Control port is available:
in this way it’s possible to use the contents of several columns/layers to control the Particles effect.

To apply the control image to a parameter, use the related field available in the FX Settings pane: to specify a Control
Image, type the number related to the control image port; to use no control image, type the number 0.

Note: When the control images brightness is used to affect a particles parameter, transparent areas are considered as
being completely black.

20.3 Source

The particles Source is the area where the particles are generated. It can be defined in the Source page, by specifying
its size and position, or a control image. The way particles are generated, for example their birth rate, can be controlled
as well.
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20.3.1 Source

Control Image

Sets if and which control image has to be used for the particles source (see Defining Control Images).

If used, particles are generated only inside the opaque areas of the Control Image.

Fig. 1: Particles generated according to an image-controlled source.

Threshold

This value defines which pixels of the Control Image are to be used for placing the paricles, defining a range based
on the opacity value of its pixels. Lower the value and more opaque the pixels have to be for being used as particles
generators.

Multiple Generators in Control Image

When activated, each defined opaque area of the Control Image will have the same number of generated particles,
totalling the Birth Rate. For example if the Birth Rate is 20, and the Control Image has 4 defined opaque areas, 5
particles will be generated in each area.

Use Control Image Gradation

When activated, the intensity of the opacity in the Control Image defines the generation density of the particles. This
option cannot be used at the same time as Multiple Generators in Control Image.
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Center

Sets the source Center position, defined by horizontal (X) and vertical (Y) coordinates; it can also be interactively set
in the preview of the FX Settings pane, where the Center point is displayed as a cross.

If you want to animate the Source to create a trail of particles, you can do it either by animating the Center coordinates,
or by animating a column/layer, containing the source area, that has to be used as the Control Image for the Source
(see above).

Note: The Center can be also set by using a point gadget in the viewer (see Using FX Gadgets ).

Note: The Center is not considered in case a Control Image is used.

Width and Height

Sets the size of the Source area.

Note: The Width and Height can be also set by using a box gadget with handles in the viewer (see Using FX Gadgets
).

Note: These values are not considered in case a Control Image is used.

Fig. 2: Particles generated according to a small square source at the center of the camera, and according to a wide box
placed at the top of the camera.

20.3.2 Particle Generation

Starting Frame

Sets the frame at which the particles generation starts.
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When you need a particles event to start before frame 1, you can set a negative Starting Frame value. For example
if you need at frame 1 a snowfall, you cannot make the event start at frame 1, otherwise you will see only the first
generated snowflakes; in this case you can set a negative value, for example -20, so that the snowfall has already
evolved for 20 frames before being displayed at frame 1.

As the Starting Frame is an effect parameter, moving the Particles effect level up or down in the Xsheet (or left or right
in the Timeline) will not change the actual starting frame: the parameter itself has to be edited.

Note: If the Starting Frame is higher than the first frame where a Birth Rate is set, the former value is used as the
starting point of the event. For example if the Starting Frame is 20 and first frame with a positive Birth Rate is frame
15, from frame 15 to 20 no particles will be generated.

Birth Rate

Sets the number of particles to be generated in each frame. When the value is constant, in each frame the same number
of particles will be generated. For example if the Birth Rate at frame 1 is 20, the first frame will contain 20 particles,
the second 40, the third 60, and so on.

The Birth Rate value considers also decimal numbers. For example, if you set the birth rate to 0.2, a particle each five
frames will be generated (0.2 multiplied by 5 is equal to 1 particle).

By animating the Birth Rate, you can control the quantity of particles in the effect. For example if you want only 20
particles starting from frame 1, you need to set a key at frame 1 with the Birth Rate set to 20, and another key at frame
2 with the Birth Rate set to 0.

Animation Step

Sets the step of the whole particles animation. This allows you to match the animation of the particle effect with the
animation in the scene, in case the scene uses an animation step different from 1.

Random Seed

Creates a different particles configuration. With the same parameters values and the same Random Seed the particles
configuration is always the same; changing the Random Seed allows you to retain all the set parameters but to change
the particles configuration. Only integer numbers are considered.

20.3.3 Particle

Animation

The particle animation follows the source node content, but you can decide how that content is used, especially in case
the Particles effect is longer than the Texture columns/layers content. The following options are available:

• Hold Frame randomly assigns a frame from the Texture node content to each generated particle; that frame is
kept throughout the life of the particle.

• Random Frame randomly assigns a frame from the Texture node content to each generated particle, changing
it randomly at each frame of the particle lifetime.

• Column assigns the first frame from the Texture node content to each particle when it is generated; the animation
cycles following the Texture node content order throughout the life of the particle.
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• Column - Random Start randomly assigns a frame from the Texture node content to each particle when it is
generated; the animation cycles following the Texture content order throughout the life of the particle starting
from the assigned frame.

• Column Swing - Random Start randomly assigns a frame from the Texture node content to each particle when
it is generated; the animation moves from the assigned frame to the last or to the first, then keeps on swinging
back and forth along the frames sequence, throughout the life of the particle.

20.4 Birth Parameters

Each particle, when generated at the current frame, has some parameters that are assigned and retained throughout its
life. Those attributes can be set in the Birth Params page.

20.4.1 Speed

Assigns a speed and a direction for each generated particle.
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Speed

Assigns randomly a speed to each particle, according to the minimum and maximum values.

The speed value makes the particle move constantly as frames increase, and is expressed in the chosen unit of measure
per frame. A negative value makes the particle move in the opposite direction of the one set by the angle.

Control Image

Sets if and which control image has to be used to control the particles speed (see Defining Control Images ).

If used, the speed value range defined above will be distributed according to the brightness value of the control image
pixel where the particle is generated: particles will be faster where the image is brighter.

Linked to Scale

Assigns to each particle a speed value, taken between the minimum and maximum speed, according to the Size value
applied to the particle. This causes the largest particles to be the fastest, emphasizing a depth of field effect.

Speed Angle

Assigns randomly to each particle an angle value defining the speed direction, according to the minimum and maxi-
mum values.

The value 0 is for an upward direction; higher values turn the direction clockwise.

Fig. 3: A particle animation with different random speed, and with different random speed and direction angle.

Use Gradient Angle

When activated, adjusts the initial velocity to the gradient vector of the Control Image Speed Angle.

20.4.2 Size, Mass and Orientation
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Size

Assigns randomly a size to each particle, according to the minimum and maximum values. The size is expressed as a
percentage, where 100 is the original size.

Fig. 4: Particles generated with a fixed size and with a random one.

Perspective Distribution

When activated, and if a Control Image for Size is conected, particles size will be inversely proportional to their
density. It can be used for placement of depth particles, as in a sea waves level. When this option is active, the Use
Control Image Gradation option will be ignored.

Control Image

Sets if and which control image has to be used to control particles size (see Defining Control Images ).

If used, the size value range defined above will be distributed according to the brightness value of the control image
pixel where the particle is generated: particles will be larger where the image is brighter.

Use Control Image for the Whole Lifetime

If activated, the defined control image is used to set the particles size for each frame of the particles life, ignoring any
Size Increase value.

If deactivated the control image is used only at the birth of the particles, and any size variation depends only on the
Size Increase value (see Size Increase ).

Mass

Assigns randomly a mass to each particle, according to the minimum and maximum values. The mass is taken into
account when gravity affects the particles behavior.
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Orientation

Assigns randomly an orientation to each particle, according to the minimum and maximum angle values.

The value 0 leaves the image as is; increasing values turn the particle clockwise.

Control Image

Sets if and which control image has to be used to control particles orientation (see Defining Control Images ).

If used, the orientation value range defined above will be distributed according to the brightness value of the control
image pixel where the particle is generated.

Fig. 5: Different random orientation assigned to same-size and to different-sized particles.

20.4.3 Trail

Trail

Allows you to define a trail according to the particle motion by specifying how many previous frames positions have
to be used to generate the trail. The number of frames the trail lasts is randomly assigned according to the minimum
and maximum values.

Step

Sets how many particles will be visible in the trail. For example, if the trail value is 10 and the step is set to 2, the trail
will be 10 frames long, but only five particles, one every two frames, will be visible.

20.4.4 Lifetime

Lifetime

Assigns randomly a lifetime to each particle, according to the minimum and maximum values. The lifetime is the
number of frames the particle will last before disappearing.
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For example if a particle is generated at frame 15 with an assigned lifetime value of 20, it will last till frame 35,
disappearing at frame 36.

Control Image

Sets if and which control image has to be used to control particles lifetime (see Defining Control Images ).

If used, the lifetime value range defined above will be distributed according to the brightness value of the control
image pixel where the particle is generated: particles will live longer where the image is brighter.

Use Column Duration for Lifetime

Limits the particles lifetime to the number of frames the column/layer content used as particles source lasts.

The particle animation remains the one defined in the Animation parameters (see Animation ).

20.4.5 Top Layer

Top Layer

Defines the layering order of the generated particles. Options are the following:

• Younger places the latest generated particles on top of all the others.

• Older places the latest generated particles behind the previously generated ones.

• Smaller places smaller particles on top of the bigger ones.

• Bigger places bigger particles on top of the smaller ones.

• Random places each particle randomly in-between the previously generated particles.
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20.5 Environment

Particles behavior defined by their birth parameters can be affected by external events, such as gravity and wind, that
can be defined in the Environment page.

20.5.1 Gravity

Simulates a single direction force that accelerates the particles, as gravity does.

Gravity

Sets the acceleration of gravity acting upon the particles: the motion generated by the intensity of the gravity increases
as frames increase.

A negative value makes the particle accelerate in the opposite direction of the one set by the angle.

Gravity Angle

Defines the gravity direction. The value 0 is for a downward direction; higher values turn the direction clockwise.

Control Image

Sets if and which control image has to be used to define a gravity field affecting the particles motion (see Defining
Control Images ).
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Fig. 6: A particle animation without and with gravity.

If used, the particles will be attracted by the brighter areas of the image, ignoring the set Gravity Angle value: the
brightest areas of the image will have the Gravity value you set. For best results, the dark and light areas should be
smoothly blended.

Fig. 7: A single particle movement without and with an image-controlled gravity.

20.5.2 Friction

Friction

Simulates a force which has a direction opposite to the motion of the particles, in order to slow them down, or to stop
them.

A negative value makes the particles accelerate in the direction of their own motion.

Control Image

Sets if and which control image has to be used to define a friction field affecting the particles speed (see Defining
Control Images ).
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If used, the particles motion will be affected by the brighter areas of the image: the brightest areas of the image will
have the Friction value you set. For best results, the dark and light areas should be smoothly blended. If you want the
particles to stop suddenly, use a high intensity value.

Fig. 8: A particle animation with an image-controlled friction.

20.5.3 Wind

Simulates a speed that is added to the particles speed. The speed is constant, this means that there is no acceleration
in the motion of the particles.

Wind Intensity

Sets the wind speed. A negative value makes the particle move in the opposite direction of the one set by the angle.

Wind Angle

Sets the angle value defining the wind speed direction.The value 0 is for an upward direction; higher values turn the
direction clockwise.

For example if a particle is standing still, and at frame 10 a wind starts with an intensity of 50 and an angle of 90, the
particle will move constantly rightward at each frame.

20.5. Environment 471



OpenToonz Documentation, Release 1.7.1

20.5.4 Scattering

Sets a random horizontal and vertical displacement that is added to the movement of the particles.

Horizontal

Sets the minimum and maximum displacement that can be generated and randomly added to the horizontal component
of the particle movement. Positive values shifts the particle to the right; negative ones to the left.

Vertical

Sets the minimum and maximum displacement that can be generated and randomly added to the vertical component
of the particle movement. Positive values shifts the particle to the top; negative ones to the bottom.

H Control Image

Sets if and which control image has to be used to control the horizontal scattering value (see Defining Control Images
).

If used, the horizontal scattering value range defined above will be distributed according to the brightness value of the
control image: the horizontal scattering will be higher where the image is brighter.

V Control Image

Sets if and which control image has to be used to control the vertical scattering value (see Defining Control Images ).

If used, the vertical scattering value range defined above will be distributed according to the brightness value of the
control image: the vertical scattering will be higher where the image is brighter.

Swing Mode

Sets the way the scattering values are used; options are the following:

• Random adds the horizontal and vertical scattering values to the particle movement at each frame.

• Smooth reaches the horizontal and vertical scattering values by interpolating values, in order to create a smooth
movement. The interpolation lasts as many frames as set by the swing value set below; when the scattering
values are reached, new values for each parameter are generated.

Swing

Sets the minimum and maximum number of frames throughout which the horizontal and vertical scattering values will
vary, while remaining either positive or negative. This allows you to set a swinging movement where each swing lasts
a random number of frames, still having a random scattering at each frame.

For example with a horizontal scattering between 1 and 8, and a Swing value with the minimum and maximum set to
10, the particle will be shifted with a random value of between 1 and 8 to the right for 10 frames; then at frame 11
the scattering changes, so that the random value between 1 and 8 will shift the particle to the left for the following 10
frames.
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20.6 Animation

Particles birth properties can be transformed during their lifetime, for example particles can rotate, or change size, by
using additional settings available in the Animation page.

20.6.1 Rotation

Controls the way each particle rotates around its center throughout its life.

Rotation Speed

Makes the particles rotate constantly as frames increase, and is expressed in degree per frame. Positive values makes
the particle spin clockwise.

Unlike the directional Speed parameter, this parameter is not a birth attribute. This means that if in a 20 frames
animation you animate the Rotation Speed value from -30 to 30, during the animation all the particles will rotate
together, counterclockwise for the first 10 frames, then clockwise for the next 10 frames.

Extra Speed

Sets the minimum and maximum value that is randomly added to the rotational speed, thus creating a more chaotic
rotation.

Swing Mode

Sets the way the spinning is performed; options are the following:
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Fig. 9: A particle animation with a fixed rotation speed, and with extra speed including smooth swing.

• Random, adds the extra speed values to the rotation of the particles at each frame.

• Smooth, reaches the rotational extra speed value by interpolating values, in order to create a smooth movement.
The interpolation lasts as many frames as set by the swing value; when the extra speed value is reached, new
values for each parameter are generated.

Rotation Swing

Sets the minimum and maximum number of frames throughout which the extra speed values will vary, while remaining
either positive or negative. This allows you to set a swinging movement where each swing lasts a random number of
frames, having a random extra speed at each frame.

Follow Particles Movement

Rotates the particles according to their movement direction. The particle preserves its original orientation when the
movement is horizontal to the right.

Fig. 10: A particle animation without and with the Follow Particles Movement option.
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20.6.2 Opacity

Sets a fade-in process at the beginning of particles life, and a fade-out process at the end, according to the set minimum
and maximum opacity values.

Opacity

Sets the minimum and maximum opacity values for the fade-in and fade-out processes. Values are expressed as a
percentage, where 100 is the original opacity.

The fade-in process begins from the minimum value and reaches the maximum value at the end; the fade-out process
begins from the maximum value and reaches the minimum value at the end.

Fade-in Frames

Sets the number of frames the fade-in process lasts, starting from the first frame of the particle life.

Fade-out Frames

Sets the number of frames the fade-out process lasts, starting from the last frame of the particle life and counting
backward.

Trail

Sets the opacity of the images used for the trail: the minimum value is the opacity of the oldest particle in the trail; the
maximum value is the opacity of the youngest one (see Trail ).

20.6.3 Size Increase

Size Intensity

Sets the minimum and maximum scaling factor to be applied to the particle in each frame. Positive values are for
increasing the size of the particles, negative ones for decreasing it. Values are expressed as a percentage.

Control Image

Sets if and which control image has to be used to control particles size increase (see Defining Control Images ).

If used, the size increase value range defined above will be distributed according to the brightness value of the control
image: particles will increase in size faster where the image is brighter.
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20.7 Colors

Particles can fade to specific colors at their birth, during their life and just before their death, by specifying settings
in the Color page. The color parameters are birth attributes, i.e. they are assigned to the particles when they are
generated.

20.7.1 Birth Color

Birth Color

Sets the range of colors to which particles fade at their birth, by defining a color spectrum (see Defining Colors and
Color Spectrums ).

Control Image

Sets if and which control image has to be used to define the particles birth colors (see Defining Control Images ).
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If used, particles will pick their birth color from the control image pixels according to their birth position.

Fig. 11: A control image used to assign color to the generated particles.

Birth Spread

Sets a spread value that will be added to the red, green and blue values of the color to which particles fade at their
birth.

In this way particles will fade to a range of colors spreading from the colors defined in the spectrum or in the control
image.

Birth Intensity

Sets the intensity of the birth color-fading.

Pick Control Image’s Color for Every Frame

When activated, at every frame the Control Image pixels will be sampled in the current position of the particles,
changing their color.

20.7.2 Fade-in Color

Fade-in Color

Sets the range of colors to which particles fade at a certain number of frames after their birth, by defining a color
spectrum (see Defining Colors and Color Spectrums ).

Control Image

Sets if and which control image has to be used to define the particles fade-in colors (see Defining Control Images ).

If used, particles will pick their fade-in color from the control image pixels according to their position.
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Fade-in Spread

Sets a spread value that will be added to the red, green and blue values of the color to which particles fade in.

In this way particles will fade to a range of colors spreading from the colors defined in the spectrum or in the control
image.

Frame Range

Sets the number of frames the fade-in process lasts, starting from the first frame of the particle life.

Fade-in Intensity

Sets the intensity of the fade-in process.

20.7.3 Fade-out Color

Fade-out Color

Sets the range of colors to which particles fade starting from a certain number of frames before their death, by defining
a color spectrum (see Defining Colors and Color Spectrums ).

Control Image

Sets if and which control image has to be used to define the particles fade-out colors (see Defining Control Images ).

If used, particles will pick their fade-out color from the control image pixels according to their position.

Fade-out Spread

Sets a spread value that will be added to the red, green and blue values of the color to which particles fade out.

In this way particles will fade to a range of colors spreading from the colors defined in the spectrum or in the control
image.

Frame Range

Sets the number of frames the fade-out process lasts, starting from the last frame of the particle life and counting
backward.

Fade-out Intensity

Sets the intensity of the fade-out process.
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Previewing and Rendering

In order to generate the final animation, including all the transformations and effects applied to the scene elements,
the scene has to be rendered.

It is also possible to preview the animation for performing checks and tune-ups before the full rendering process.

21.1 Previewing the Animation

Animations can be previewed directly in the OpenToonz Viewer, including in the Preview mode all the Flipbook
features, or by rendering a preview and visualizing it in a separate Flipbook window.

In both cases the Flipbook window tools can be used, and its appearance can be customized (see Using the Flipbook ).

Note: If the computer performance worsens during the preview process of raster animation levels, try activating the
Minimize Raster Memory Fragmentation option in the Preferences. . . → General dialog section (see Optimizing
the Memory Usage ).

21.1.1 Previewing Frames in the Viewer

In the Viewer it is possible to activate the Preview mode to render the current frame according to the current camera
(see Using the Stage Schematic for s).

When changing the current frame, for example by using the playback buttons, it is possible to render other frames of
the scene as well. The framebar displays already rendered frames in dark grey, frames that have yet to be rendered in
light red, and the current frame, while being rendered in light green and when already rendered in light grey.

For the current camera it is also possible to define a Sub-camera, having an area smaller than the camera frame, inside
which the preview will be rendered, and outside which the scene elements will be displayed as they are.
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Note: To optimize the preview time, only the area visible in the Viewer will be rendered: if you zoom out the viewer
the preview will resume to render the new visualized area.

When the Preview mode is activated, every change made in the scene will cause the preview of frames affected by
the changes to be recomputed. If, for some reason, the preview fails during the update process, you can regenerate the
preview, which will automatically delete previously previewed frames, and compute them again.

Once the frames are previewed, the results can be saved to disk.

The background colors of the preview window, including the colors of the camera background, the window background
and the checkerboard visible when transparent images are rendered, are those defined for the Flipbook (see Using the
Flipbook ).

Note: When previewing frames in the Viewer it is possible to display blank frames after each preview playback, when
looping (see Using the Flipbook ), and to limit the range of frames to be considered when playing back the animation
by using the Playback Markers (see Using the Playback Markers ).

Note: The Camera Box, the Field Guide, the Safe Area and the Guides can be shown or hidden in the Viewer during
Preview as well (see Customizing the Viewer ).

Note: If the Apply Shrink to Main Viewer option is activated in the Preview Settings dialog, the previewed frames
may have a reduced resolution (see Using the Preview Window ).

Tip: To activate and deactivate the preview:

Click the Preview button ( ) in the viewer title bar to activate or deactivate the Preview mode.

Tip: To define a preview Sub-camera for the current camera:

1. Activate the Define Sub-camera button ( ) in the viewer bottom bar.

2. Click and drag in the Viewer to define the box for the Sub-camera area; once the box is defined you can resize
it by clicking and dragging its sides and corners, and move it by clicking and dragging inside of it.

Tip: To hide the Sub-camera box:

Deactivate the Define Sub-camera button ( ) in the Viewer bottom bar.

Tip: To activate and deactivate the Sub-camera preview:

Click the Sub-camera Preview button ( ) in the Viewer title bar to activate or deactivate the Sub-camera Preview
mode.
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Tip: To regenerate the preview:

Right-click in the viewer in Preview mode and choose from the menu that opens one of the following:

• Regenerate Frame Preview to delete and recompute the current frame only.

• Regenerate Preview to delete and recompute the whole previewed frame range.

Tip: To save previewed frames:

1. Do one of the following:

• Click the Save Images button ( ) in the Viewer bottom bar.

• Right-click in the Viewer, and choose Save Previewed Frames from the menu that opens.

2. Use the Browser to choose a name and location for the file to be saved.

Note: The saved files format will be the one currently defined in the Output Settings dialog, and the format options
used at save time will also be the ones defined by using the Options button there (see Choosing the Output Settings ).

Note: The saved files color depth will always be 8 bit, regardless of the options chosen in the Output Settings or
Preview Settings dialogs.

21.1.2 Using the Preview Window

The animation can be previewed in a separate window according to specific Preview Settings, that can be different
from the Output Settings. In this way the preview can be configured so that it is faster to compute then the final output,
for example because it uses a camera with a smaller resolution.

It is possible to define the range of previewed frames both in the Preview Settings and by using the Playback Markers
in the Xsheet/Timeline: any change made in one mode is reflected in the other one as well (see Using the Playback
Markers ). It is also possible to display blank frames after each preview playback, when looping.

It is possible to activate the Preferences. . . → Preview → Fit to Flipbook option to ensure that the previewed images
fit the size of the preview window, regardless their resolution.

It is possible to clone the Preview window, or to automatically open as many Preview windows as needed by activating
the Preferences. . . → Preview → Display in a New Flipbook Window option, for example to examine or compare
specific frames by using the Flipbook tools (see Using the Flipbook ).

21.1. Previewing the Animation 481



OpenToonz Documentation, Release 1.7.1

Note: As when changes are made in the scene all the preview windows automatically update, it is possible to check
the animation before and after some editing by freezing any of the Previews.

The Preview window framebar displays rendered frames in grey, frames that have yet to be rendered in light red, and
the current frame that is being rendered in light green.

Note: To optimize the preview time, only the area visible in the Preview window will be rendered: if you zoom out
the Viewer the preview will resume to render the new visualized area.

The Preview Settings dialog lets you define the resolution, range, step and shrink of the preview frames. Settings are
the following:

• Output Camera: sets which camera, among the ones defined in the scene, has to be used to set the resolution
and preview the animation.

• Frame Start: and End: set the frame range of the scene to preview; by default these values refer to the whole
scene length.

• Step: sets the step for the rendered sequence; for example if it is two, one frame each two will be rendered.

• Shrink: sets the reduction value for the previewed sequence resolution; for example if it is 2, one pixel each
two will be rendered, thus resulting in previewed frames having half of the original output camera resolution.

482 Chapter 21. Previewing and Rendering



OpenToonz Documentation, Release 1.7.1

• Apply Shrink to Main Viewer if activated uses the shrink value set in the preview settings to the preview mode
of the viewer as well (see Previewing Frames in the Viewer ).

• Resample Balance: controls the resample that is used when images are scaled or rotated. In scenes where
images are strongly resampled, for instance when their size changes dramatically, the final rendering may appear
slightly out of focus. By balancing the resample you can give some sharpness back to the rendered frames.

There are several options to choose from. Originally Toonz provided three options: Standard, Improved, High.
The higher the balance chosen, the longer the time needed for rendering the output. Additionally, OpenToonz
provides several other standard resampling filters that could help improve the final results in a wider range of
situations.

• Channel Width: sets the color depth for rendered images; choices are 8 bit or 16 bit per color channel.

• Dedicated CPUs: sets, in case your computer has multiple CPUs, how many processors will be assigned to the
previewing process. Setting the value to All will generate a number of rendering threads equal to the number of
processors, thus speeding up the previewing process. However it is suggested to use the Half or Single values if
the scene to preview is very complex, because the higher the dedicated CPUs, the more the memory required to
perform the preview.

• Render Tile: allows the preview of very complex scenes whose frames will be computed in tiles that are
automatically stitched to create the final preview: the smaller the size of the tile, the longer the preview process.
Setting the value to Medium or Small will allow the preview of very high resolution outputs of very complex
scenes, that otherwise may fail to be previewed; setting the value to None may prevent some artifacts that the
tile stitching may generate. In most of the cases the Large value will do the work, because it is not slower than
the None option, and yet is able to preview complex scenes.

• Use Sub-camera, when activated, uses the sub-camera defined for the selected camera in the preview frames
(see Previewing Frames in the Viewer ).

Tip: To set the scene preview settings:

1. Choose Render → Preview Settings. . . .

2. Set the options you want to use for the preview.

Tip: To open the preview window:

Choose Render → Preview.

Tip: To clone the preview window:

Right-click in the Flipbook window and choose Clone Preview from the menu that opens.

Tip: To freeze the preview rendering:

Right-click in the Flipbook window and choose Freeze Preview from the menu that opens.

Tip: To open a new Flipbook window every time you run a preview:

1. In File → Preferences. . . → Preview.

2. Activate the Display in a New Flipbook Window option.
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Tip: To rewind the preview content automatically after playback:

1. In File → Preferences. . . → Preview.

2. Activate the Rewind After Playback option.

Tip: To display blank frames after each preview playback when looping:

1. In File → Preferences. . . → Preview.

2. Do any of the following:

• Use Blank Frames option to set how many blank frames you want to be displayed after each preview playback,
when looping.

• Use Blank Frames Color option to set the color for the blank frames.

Previewing and Caching Effect Nodes in the Schematic

The Preview window can also be opened from the FX Schematic, to check the compositing result up to a specific node.
The behaviour of the FX Schematic Preview window is the same as the standard one (see Using the Preview Window
).

Note: In case the Sub-camera is used, the Preview window will fit the Sub-camera area (see Using the Preview
Window ).

It is also possible to cache the preview up to a specific node, so that the result of the compositing up to that node is
stored in the computer memory and will be reused with no need to recompute it the next time the preview is run.

Of course if something changes in the flow up to the cached node (for example if an object transformation or an effect
parameter is changed), the cached preview will be discarded and will be stored again the next time the Preview is run.

Tip: To open a Preview window referring to an FX Schematic node:

Right-click the node and choose Preview from the menu that opens.

Tip: To cache an effect node:

Right-click the node and choose Cache FX from the menu that opens: the effect node will be displayed with a fold at
the bottom right corner to highlight that it has been cached.

Tip: To uncache an effect node:

Right-click the node and choose Cache FX from the menu that opens: the cached preview images will be discarded.
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21.1.3 Using the Flipbook

The Flipbook is an image viewer where animation levels, images, clips and rendered frames can be displayed. In
OpenToonz it is used to display the scene contents in the Viewer, including the Preview mode, and to display the
previewed or rendered animations. It is also used to view files and levels from the browser or the Xsheet/Timeline,
and to display the loaded Color Model.

Note: The Safe Area is the only element that can be shown or hidden in the Flipbook when previewing the animation
(see Customizing the Viewer ).

The Flipbook title bar displays the information about the content on the left, and the zoom percentage on the right.

At the bottom a customizable set of buttons is available:

• The Option button ( ) sets which buttons and elements have to be displayed in the bottom bar.

• The Save Images button ( ) opens a browser to save the flipbook content.

• The Snapshot ( ) and Compare to Snapshot ( ) buttons allow the comparison between different frames
of the flipbook content.

• The Define Sub-camera button ( ) allows the definition of a region, smaller than the size of the loaded image
sequence, that will limit the portion of the images that will be displayed in the Flipbook. It may prove useful to
speed up the loading time and increase the playback speed, when you are only interested in a certain region of
the full camera image.

• The Sub-camera Preview button ( ) lets you activate or deactivate the defined sub-camera region (see above).

• The Background color buttons sets a White ( ), Black ( ) or Checkered ( ) background for transparent
images.

• The framerate slider sets the number of frames per second to be displayed during playback.

• The playback buttons can be used to play the Flipbook content back and set the current frame.

• The Channel buttons display the Red, Green, Blue and Alpha channels of the Flipbook content, both in colors
and grey-scale.

• The Histogram button ( ) opens a window displaying histograms mapping the amount of the darkest and
lightest pixels in each channel.

Note: If the bottom bar is too short to display all the options, it can be scrolled by using arrow buttons available at its
ends.

In an opened Flipbook it is possible to load new contents both replacing the previous animation, or appending the new
contents to it. When several Flipbooks are opened, their playback can be linked, so that moving the current frame or
playing the contents back in one of them, automatically moves the current frames and plays the contents back in all
the other Flipbooks as well.

The colors displayed as background in the flipbook can also be customized so that they can better fit the color scheme
of the production.

Tip: To open a Flipbook:
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Choose Windows → Flipbook.

Tip: To load some contents into a Flipbook:

Do one of the following:

• Right-click in the Flipbook and choose Load Images from the menu that opens, then use the Browser to retrieve
the file you want to load.

• Drag and drop the file you want to load from the OpenToonz file browser to the Flipbook.

Tip: To append some content to the Flipbook content:

Right-click in the Flipbook and choose Append Images from the menu that opens, then use the Browser to retrieve
the file you want to append to the current content.

Tip: To navigate the Flipbook content:

Do one of the following:

• Use the zoom shortcut keys (by default + and - keys) to zoom in and zoom out at specific steps (e.g. 50%, 100%,
200%, etc.).

• Use the mouse wheel to zoom in and zoom out.

• Click and drag to define an area you want to zoom to.

• Use the Reset View shortcut (by default the Alt + 0 key), or right-click in the Viewer and choose Reset View
from the menu that opens, to display the Flipbook content at its actual size, and centered on the image center.

• Middle-click and drag to scroll in any direction.

Tip: To fit the size of the Flipbook window to its content:

Double-click the Flipbook title bar.

Tip: Windows only - to enter/exit the Flipbook full screen mode:

Right-click the Flipbook and choose Full Screen Mode / Exit Full Screen Mode from the menu that opens.

Tip: To customize the Flipbook bottom bar:

Use the Option button ( ) to choose which buttons and elements have to be displayed: only selected items will be
displayed.

Tip: To play the Flipbook content back:

Do one of the following:

• Use the Play button.
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• Drag the frame bar cursor.

Tip: To rewind the Flipbook content automatically after playback:

1. In File → Preferences. . . → Preview.

2. Activate the Rewind after Playback option.

Tip: To set the current frame:

Do one of the following:

• Use the playback buttons.

• Drag the frame bar cursor.

• Type in the frame bar field the number of the frame you want to view.

Tip: To link the playback of all the open Flipbook windows:

Choose Play → Link Flipbooks to activate or deactivate the linked playback mode.

Tip: To set the playback frame rate:

Use the frame rate slider; by default the framerate is the one set in the Scene Settings dialog (see Setting the Frame
Rate ).

Tip: To save the Flipbook content:

1. Do one of the following:

• Right-click in the Flipbook and choose Save Images from the menu that opens.

• Click the Save Images button ( ) in the Flipbook bottom bar.

2. Use the Browser to choose a name, a format and a location for the file to be saved.

Tip: To take a snapshot of a frame and compare it to another frame:

1. Select the frame you want to store and click the Snapshot button ( ) in the Flipbook bottom bar.

2. Move to a different frame, or load some different content, and click the Compare to Snapshot button ( ).

3. Click and drag the vertical or horizontal marker to display the taken snapshot under the current frame.

4. Click again the Compare to Snapshot button ( ) to exit the compare mode.

Tip: To Define the Loading Box:

1. Load in the Flipbook the sequence of images you want to visualize.
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2. Activate the Define Loading Box button ( ) in the Flipbook bottom bar.

3. Click and drag in the image to Define the Loading Box; once the box is defined you can resize it by clicking and
dragging its sides and corners, and move it by clicking and dragging inside it.

Tip: To activate and deactivate the Loading Box:

Click the Use Loading Box button ( ) in the Flipbook bottombar to activate or deactivate the loading box.

Tip: To set the Flipbook background color for transparent images:

Click the White Background ( ), Black Background ( ) or Checkered Background ( ) buttons in the
Flipbook bottom bar to activate/deactivate the desired background color.

Note: In the Preview window and when the Viewer is in Preview mode the background color will be visible behind
the Camera BG Color (see below ).

Tip: To set the image channels to be displayed:

Do one of the following:

• Click the top section of the Red, Green and Blue buttons in the Flipbook bottom bar to display, or hide, the
related image channel in colors.

• Click the bottom section of the Red, Green and Blue buttons in the Flipbook bottom bar to display, or hide, the
related image channel in grey-scale.

• Click the Alpha Channel button in the Flipbook bottom bar to display, or hide, the image alpha channel.

Note: When no channel button is activated the full image is displayed.

Tip: To display the Histograms of the Flipbook content:

1. Do one of the following:

• Click the Histogram button ( ) in the Flipbook bottom bar.

• Right-click the Flipbook content and choose Show Histogram from the menu that opens.

2. Choose the channel for which you want to see the histogram.

Tip: To define the previewed images background color:

1. Choose Xsheet → Scene Settings. . .

2. Set the Camera BG Color by doing one of the following:

• Set the Red, Green and Blue values.

488 Chapter 21. Previewing and Rendering



OpenToonz Documentation, Release 1.7.1

• Click the color thumbnail and use the Style Editor to edit it (see Plain Colors ).

Note: This color is relevant only in the Preview window and when the Viewer is in Preview mode.

Tip: To define the Flipbook checkerboard colors:

1. Choose Xsheet → Scene Settings. . .

2. Set the Checkerboard Color 1 and Color 2 by doing one of the following:

• Set the Red, Green and Blue values.

• Click the color thumbnail and use the Style Editor to edit it (see Plain Colors ).

21.1.4 Using the Playback Markers

Two markers, Playback Start Marker and Playback End Marker, are available in the frame column of the Xsheet
(and the frame row of the Timeline) to define the playback range.

The user can manually set the playback markers to define the starting and ending frames to be considered when playing
back the animation, or leave them unset, so OpenToonz automatically defines a playback range that includes all of the
Xsheet/Timeline contents.

Note: When the playback markers are activated, the frame range in the Preview Settings. . . dialog changes accord-
ingly (see Using the Preview Window ).

Tip: To set a playback range:

1. Set the starting frame by doing one of the following:

• Drag the Playback Start Marker to the desired frame.

• Right-click on the desired frame in the frame column/bar and select Set Start Marker from the menu that
shows.

2. Set the ending frame by doing one of the following:

• Drag the Playback End Marker to the desired frame.

• Right-click on the desired frame in the frame column and select Set Stop Marker from the menu that shows.

Tip: To set the playback range to match the duration of a block of contiguous exposed cells:

1. In the Xsheet/Timeline, select an exposed cell from the desired column/layer.

2. Right-click on the desired frame in the frame column and select Set Auto Markers from the menu that shows.

Note: There must be an exposed cell in that column/layer at that frame for the Set Auto Markers option to be
available.
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Note: No matter to what block of contiguous exposed cells the selected cell belongs to, this function will take into
account the frame in which the user performed the right click operation to set the markers.

Tip: To set a single-frame playback range:

Right-click on the desired frame in the frame column/bar and select Preview This from the menu that shows.

Tip: To unset the playback markers:

Right click on the frame column and select Remove Markers from the menu that shows.

Note: When deactivated, playback markers turn grey.

21.2 Rendering the Animation

Final animations can be rendered directly by loading the related scene, or in batch mode. In both cases the rendering
properties are defined in the Output Settings dialog.

Note: Information about the scene name and frame number can be included when needed in rendered frames by
activating the Show Info in Rendered Frames option in the Preferences. . . → General dialog section.

21.2.1 Choosing the Output Settings

The Output Settings dialog lets you define the file format, location and properties for the final rendering. Settings are
the following:
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Camera Settings

• Output Camera: sets which camera, among the ones defined in the scene, has to be used to render the anima-
tion.

• Frame Size sets the frame size of the current camera, also available in the Xsheet → Camera Settings. . . dialog
(see Defining Camera Settings ).

• Frame Start: and End: set the frame range of the scene to render; by default these values refer to the whole
scene length.

• Step: sets the step for the rendered sequence; for example if it is 2, one frame each two will be rendered.

• Shrink: sets a reduction value for the defined render resolution; for example if it is 2, one pixel each two will
be rendered, thus resulting in frames having half of the original output camera resolution.

File Settings

• Save in: is for setting the location where the output is saved; the location can be set by typing or by using the
Browser button.

Note: If in the Browser you choose any default folder of the active project, in the path field the full path will
be replaced by the related default folder alias (see Project Default Folders ).

• Name: is the name you want to assign to the output file; by default it’s the name of the scene.

In case the chosen file format produces image sequences, the base name will be assigned to all rendered frames,
that will be identified by a progressive four-digits number written between the base name and the file extension,
e.g. animation.0001.tif , animation.0002.tif , etc. These file sequences will be displayed in the
OpenToonz File Browser with a double dot before the file extension, e.g. animation..tif , and treated as
a single animation level when loaded back into OpenToonz.

• File Format is the format for the output; natively supported formats are the following: 3GP, AVI, BMP, GIF,
JPG, MOV, NOL, PNG, RGB, SGI, Spritesheet, TGA, TIF and TIFF.

Note: OpenToonz supports the 3GP and MOV formats by using the 32-bit version of QuickTime.

To save in other popular video formats, like MP4 and WebM, OpenToonz uses FFmpeg (a free software project
that produces libraries and programs for handling multimedia data). Once FFmpeg is installed in the system, and
configured to work with OpenToonz, MP4 and WebM will be listed along the other standard output file formats.
For detailed instructions on how to install and configure FFmpeg, please see Using FFmpeg with OpenToonz .

Note: Apart from 3GP, AVI, GIF, MOV, MP4 and WebM, all other formats will output image sequences.

• Options button, opens a dialog to set specific properties related to the chosen file format, such as codecs for
video files, color depth for TIF images, etc.

• Resample Balance: controls the resample that is used when images are scaled or rotated. In scenes where
images are strongly resampled, for instance when their size changes dramatically, the final rendering may appear
slightly out of focus. By chosing a different resampling algorithm you can give some sharpness back to the
rendered frames.

There are several options to choose from. Originally Toonz provided only three options: Standard, Improved,
and High. The higher the balance chosen, the longer the time needed for rendering the output. Currently
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OpenToonz also provides several other standard resampling options that could help improve the final results in
a wider range of situations. These include: Triange filter, Mitchell-Netravali filter, Cubic convolution, Hann
window, Hamming window, Lanczos window, Gaussian convolution, Closest Pixel and Bilinear.

• Channel Width: sets the color depth for rendered images; choices are 8 bit and 16 bit per color channel. If
using the 16 bit channel width, be sure to select an output file format supporting it, for example the TIF format
with the 64(RGBA) option activated.

• Dedicated CPUs: sets, in case your computer has multiple CPUs, how many processor threads will be assigned
to the rendering process. Setting the value to All will generate a number of rendering threads equal to the
number of processors, thus speeding up the rendering process. However in systems with limited RAM resources,
it’s suggested to use the Half or Single options if the scene to render is very complex, because the higher
the dedicated CPUs, the more RAM will be required to perform the rendering, leading to potentially longer
rendering times or system instability.

• Render Tile: allows the rendering of complex scenes, by dividing each frame in a certain number of tiles, which
are individually rendered and finally stitched together to create the final output frame: the smaller the size of the
tiles, the longer the rendering will take but the less RAM will require. Setting the value to Medium or Small
will allow the rendering of very high resolution outputs of very complex scenes, that otherwise may fail to be
rendered; setting the value to None may prevent some artifacts that the tile stitching may generate. In most
cases the Large value will do the work, because it’s not slower than the None option, and yet is able to render
complex scenes.

Other Settings

• Add Clapperboard allows to add a Clapperboard. A clapperboard is a static image intended to display infor-
mation of the scene. It will be added before the rendered frames, in order to record and convey information to
subsequent phases of the pipeline.

Note: For this option to be enabled you must first choose any video file format from the File Format dropdown
menu (i.e. 3GP, AVI, MOV, MP4 or WebM).

• Edit Clapperboard. . . button, opens a dialog for designing the clapperboard and setting its properties. For
detailed information on using the Clapperboard feature, please see the Using The Clapperboard section.

• Gamma: performs a gamma correction on rendered images before writing them to a file; the value you specify
can include decimal fractions.

• Dominant Field: allows you to render two images per frame, then keeping only odd lines from one image, and
even lines from the other to compose a final frame. This process is called interlacing.

Interlaced images are useful when experiencing a strobe effect due to a fast camera or object movement, as
all movement interpolation will be effectively doubled (having one odd-lines image and one even-lines image,
instead of just one full progresive frame), thus becoming smoother.

Field rendering is only relevant for scenes that are intended for video output. Options are None (for rendering
progresive frames), Even (PAL) and Odd (NTSC) (for chosing which of the rendered interlaced fields is to be
shown in first place). Usually you should choose it according to the video standard you are outputting to.

• Frame Rate: is the frame rate of the scene, also available in the Xsheet → Scene Settings. . . dialog (see Setting
the Frame Rate ).

• Stretch from FPS: To: changes the timing of the Xsheet when outputting files; in this way you can output a
number of frames that is independent from the frame rate set in the scene settings.

For example, if you are working at 25 fps, a 150 frames Xsheet will produce 6 seconds of animation. If you
need to transfer the frame rate to 30 fps using the same Xsheet, the animation will last 5 seconds (150 frames
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divided by 30 fps is equal to 5 seconds), and consequently it will be a little bit faster. Stretching from 25 to 30
fps, the output will include an increased number of frames to retain the original time length, and the rendered
frames will be 180 (6 seconds multiplied by 30 fps is equal to 180 frames).

When going from a higher frame rate to a lower one, some level drawings will not be used because the number of
output frames decreases. When doing the contrary, some level drawings will be repeated because the number of
output frames is higher. Interpolations for object movements and special effects variations will be re-computed
according to the final frame rate, in order to keep all the interpolations as smooth as possible.

Note: When the field rendering is used (by using the Dominant Field option) and the Stretch feature is set for
passing from a lower frame rate to a higher one, drawings and images will be interlaced as well, to create newly
added frames.

Note: The Particles effect may have unexpected results when the scene is stretched to a higher FPS value, as
the effect requires the original timing information.

• Multiple Rendering: creates automatically for a single scene several output files based on the Xsheet columns
(or Timeline layers) content, and according to the FX Schematic. Options are None, FX Schematic Flows and
FX Schematic Terminal Nodes (see Creating Multiple Renderings ).

• Do stereoscopy activates the stereoscopic 3D output of the scenes. Each frame will be rendered from two
different camera view creating two sequences of files, one for each view. The suffixes _l (left) and _r (right)
will be used to identify sequences.

• Camera Shift: sets the distance between the two camera views.

Note: For working properly at least some elements of the scene must have Z-Depth values other than 0 in
their positioning. OpenToonz uses these values and the Camera Shift parameter for rendering the stereoscopic
effect.

• Render button, starts rendering the scene using the current render settings.

Tip: To set the scene output settings:

1. Choose Render → *Output Settings. . .

2. Set the options you want to use for the final rendering.

Using The Clapperboard

A clapperboard is a static image intended to display information of the scene. It will be added before the rendered
frames, in order to record and convey information to subsequent phases of the pipeline.
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The clapperboard consists of board items. At the bottom-right of the Clapperboard Settings dialog there is a list of all
the clapperboard items, which can be layered by moving them Up or Down in the list by using the appropriate buttons.
Items can also be created or deleted by using the Add or Remove buttons.

Settings for the currently selected item are displayed above the items list, at the top-right of the Clapperboard Settings
dialog. Each item has an information Type:. Most of them will automatically retrieve the correspondent data from the
current scene or the system, such as: scene Duration, Scene location, Current date, etc. Other types, such as Text
or Image allow to input user defined data to be displayed in the Clapperboard.

The settings can be saved as a Preset in order to be reused later, using the Save as Preset and Load Preset buttons.
They can also be stored in the project’s default settings by using the File → Save Default Settings command.

Note: WARNING: Adding the Clapperboard will make the scene file to lose compatibility with older versions of
OpenToonz. Setting the Duration: back to 0 will remove the clapperboard data from the scene, so that compatibility
can be restored.

Tip: To Add a Clapperboard:

1. Open the Render → Output Settings. . . dialog.

2. Select any movie type file format (3GP, AVI, MOV, MP4 or WebM).

3. In the More Settings section, enable the Add Clapperboard option.

4. Click Edit Clapperboard. . . button. The Clapperboard Settings dialog opens.

5. Set the Duration (frames): option to any value greater than 0.

Note: Setting the duration to 0 frames will remove the clapperboard data from the scene when it’s saved.

Tip: To temporarily deactivate the Clapperboard:
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1. Open the Render → Output Settings. . . → More dialog section.

2. Disable the Add Clapperboard option.

Tip: To Delete the Clapperboard:

1. Open the Render → Output Settings. . . → More dialog section.

2. Click Edit Clapperboard. . . button. The Clapperboard Settings dialog opens.

3. Set the Duration (frames): option value to 0.

4. Save the scene.

Creating Multiple Renderings

With Multiple Rendering: it’s possible to render automatically, from a single scene, several output files based on the
Xsheet columns (or Timeline layers) content and according to the FX Schematic. Options are None, FX Schematic
Flows and FX Schematic Terminal Nodes.

Flows: creates as many outputs as the flows connecting the column nodes to the Xsheet node. Any effect nodes
with multiple input ports met along the flow (such as Matte effects) will be ignored.

Terminal Nodes: creates as many outputs as the number of nodes linked to the Xsheet node; all the columns and
effects linked to each of these nodes will be taken into account for the rendering.

The names of the different output files are automatically generated in order to avoid any name conflict between file
names. In particular they are built by appending to the output file name: the column name, then the column ID (as
can be read in the node tooltip), then the effect name, then the effect ID (as can be read in the node tooltip) in case the
effect node was renamed. For example scene01_B(Col3)_My Blur(Blur1)..tif is one of the output files
of the scene scene01 , related to the flow going from column B (whose ID is Col3) to the effect node My Blur (whose
ID is Blur1).

Note: No output will be displayed after the rendering, regardless of Open Flipbook after Rendering being activated
in Preferences. . . → Preview dialog section.

Note: If you need more control on the way scene elements are rendered, you may consider using Sub-Xsheets and the
Over effect (see Using Sub-Xsheets and Over ). For example if you want a single output for a set of columns/layers,
you may collapse them in a Sub-Xsheet (in case of Flows type multiple rendering) or connect them to several Over
nodes (in case of Terminal Nodes type multiple rendering).

21.2.2 Rendering Animations with Alpha Channel Information

It’s possible to render a scene with a transparent background color in order to export it to editing systems supporting
alpha channel information.

In this case no image has to be used as background, and the output file format has to support alpha channel information,
e.g. TIF at 32 or 64 bits per pixel, TGA at 32 bits per pixel, or MOV with codecs supporting alpha (i.e. Animation).

Tip: To render animation with alpha channel information:
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1. Choose Xsheet → Scene Settings. . . .

2. Set the alpha channel of the Camera BG Color to 0 (i.e. transparent).

3. Choose an output file format supporting alpha channel information.

21.2.3 Rendering A Loaded Scene

The current scene can be rendered directly while being loaded in OpenToonz according to the defined Output Settings.

By choosing the appropriate range in the Output Settings it’s possible to render the scene in chunks, for example by
rendering a section first, and then another one. In this case the animation available in the Output location will always
include all frames rendered up to that point, both if the format is a multiple-files output (e.g. TIF or TGA), and a
single-file one (e.g. MP4 or MOV). The same applies if a section of the scene has to be rendered again because some
corrections were needed.

If the scene contains some audio files and is rendered in a file format supporting audio (for example MP4), all the
audio files will be merged to form the soundtrack of the movie (see Creating a Soundtrack ).

Note: Audio files loaded in Sub-Xsheets will not be included in the output soundtrack (see Using Sub-Xsheets ).

As soon as the rendering is over, the rendered animation can be automatically displayed in a OpenToonz Flipbook
by activating the Open Flipbook after Rendering option in the Preferences. . . → Preview dialog section; it’s also
possible to display blank frames after each rendering playback when looping. If a soundtrack is available for the
rendered scene, it’s also possible to listen to it.

When displayed in the Flipbook, the rendering can be checked by using the Flipbook tools (see Using the Flipbook ).

You can also activate the Use Default Viewer for Movie Formats option in the Preferences. . . → General dialog
section, in order to play back the output with its own default viewer, e.g. QuickTime Player for the MOV format.

Tip: To render the currently loaded scene:

Choose Render → Render.

Tip: To display blank frames after each rendering playback when looping:

1. Choose File → Preferences. . . → Preview.

2. Do any of the following:

• In Blank Frames: set how many blank frames you want to be displayed after each preview playback, when
looping.

• In Blank Frames Color: set the color for the blank frames.

21.2.4 Rendering Scenes in Batch Mode

The rendering of a scene can be added to a task list and performed in batch mode, in order to run it in the background
while you perform other work on your computer.

Render tasks can be submitted from the OpenToonz Browser and can be managed and executed in the Tasks pane,
together with Cleanup tasks (see Cleaning up Drawings in Batch Mode ).
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The Tasks pane is divided into two sections: on the left there is the Task tree where all of the Render tasks are
displayed with a clapboard icon and all the Cleanup tasks with a brush icon; on the right there is Information about
the task selected in the Task tree.

The Task list can be saved as TNZBAT files and loaded back later, in case you want to manage it through different
working sessions.

Tip: To Save a Task list:

1. Do one of the following:

• Click the Save ( ) or the Save As ( ) buttons in the top bar of the Tasks pane.

• Right-click the Tasks item at the top of the list and choose Save Task List or the Save Task List As from the
menu that opens.

2. Use the Browser that opens to save the list.
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Tip: To Load a Task list:

1. Do one of the following:

• Click the Load ( ) button in the top bar of the Tasks pane.

• Right-click the Tasks item at the top of the list and choose Load Task List from the menu that opens.

2. Use the Browser that opens to retrieve and load a previously saved list.

Tip: To resize the Tasks pane sections:

Do any of the following:

• Click and drag the separator to resize sections.

• Click and drag the separator toward the window border to hide a section.

• Click and drag the separator collapsed to the window border toward the window center to display again the
hidden section.

21.2.5 Managing and Executing Render Tasks

When a Render task is selected in the tree, in the section on the right of the Tasks pane task-related properties are
displayed, some of which can be edited to configure the task. Properties are the following:

• Name displays the task name; it can be edited to better identify the task.

• Status shows if the task is: Waiting, Running, Completed or Failed.

• Command Line displays the command line related to the task execution with arguments and qualifiers.

• Server displays the computer that is running, or will run, the task.

• Submitted By displays the user that submitted the task.

• Submitted On displays the computer from where the task was submitted.

• Submission Date displays when the task was submitted.

• Start Date displays when the task execution started.

• Completion Date displays when the task execution was completed.

• Duration displays how long the execution lasted.

• Step Count displays the number of frames rendered.

• Failed Steps displays the number of frames that failed to be rendered.

• Successful Steps displays the number of frames successfully rendered.

• Priority sets the importance or urgency of the task: tasks with a higher priority will be executed first. It can be
edited to change the task priority.

• Output displays the location, name and extension of the rendered output; this information comes from the scene
output settings but can be edited here before the rendering.
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• Frames Per Chunk sets how the task is divided into sub-tasks in order to distribute the rendering job in the
render farm, one sub-task for each computer. It can be edited to change the chunk size (see Using Chunks when
Rendering Tasks ).

• From and To set the scene frame range to render; this information comes from the scene output settings but can
be edited here before the rendering (see Choosing the Output Settings ).

• Step sets the step for the rendered sequence; this information comes from the scene output settings but can be
edited here before the rendering (see Choosing the Output Settings ).

• Shrink sets the reduction value of the rendered sequence resolution; this information comes from the scene
output settings but can be edited here before the rendering (see Choosing the Output Settings ).

• Dedicated CPUs sets how many processors are assigned to the rendering process; this information comes from
the scene output settings but can be edited here before the rendering (see Choosing the Output Settings ).

• Render Tile sets if the rendering has to be computed in tiles; this information comes from the scene output
settings but can be edited here before the rendering (see Choosing the Output Settings ).

• Dependencies lets you set which of the other submitted tasks have to be successfully completed before starting
the current task execution: these tasks can be added from the box on the right where all submitted tasks are
displayed.

Task execution can be started and stopped from the task list.

When the tasks are executed, the icon color tells the status of the task according to the following color code:

• Grey, when the task is waiting or is not executed yet.

• Yellow, when the task is being executed.

• Green, when the task is successfully executed.

• Orange, when the task is executed with some errors.

• Red, when the task execution has failed.

Tip: To Add scenes to render in the task list:

Do one of the following:

• Click the Add Render button ( ) in the top bar of the Tasks pane and use the Browser to select a scene file.

• Select the scenes in the OpenToonz Browser, then right-click any of them and choose Add As Render Task
from the menu that opens.

Tip: To Configure the render task in the task list:

1. Select a render task in the task list.

2. Configure it by using the options available on the right of the list.

Tip: To select tasks in the task list:

Do any of the following:

• Click a task to select it.

• Shift-click a task to extend the selection up to that task.

• Ctrl-click (PC) or Cmd-click (Mac) a task to add it to, or remove it from the selection.
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Tip: To Execute selected tasks:

Do one of the following:

• Click the Start ( ) button in the top bar of the Tasks pane.

• Right-click any selected task icon and choose Start from the menu that opens.

Tip: To Stop the execution of selected tasks:

Do one of the following:

• Click the Stop ( ) button in the top bar of the Tasks pane.

• Right-click any selected task icon and choose Stop from the menu that opens.

Tip: To Remove selected tasks from the list:

Do one of the following:

• Click the Remove ( ) button in the top bar of the Tasks pane.

• Right-click any selected task in the list and choose Remove from the menu that opens.

Tip: To Add or Remove tasks from the Dependencies list:

Do one of the following:

• To Add a task to the dependencies list, select a task in the task list on the right and click the << Add button.

• To Remove a task from the dependencies list, select a task in the dependencies list on the left, and click the
Remove >> button.

Using Chunks when Rendering Tasks

If you are using the OpenToonz render farm, it’s possible to divide a task into chunks so that each computer of the
farm will render a section of the same render task (see Using the Toonz Farm ).

The default value for the chunk size (expressed in number of frames) can be set using the Render Task Chunk Size
in the Preferences. . . → General dialog section. If the default value is higher than the duration (in frames) of the
submitted scene, the value will be automatically adjusted to be equal to the duration of the scene.

Once a task is submitted, it’s possible to change the chunk size by editing the related value in the task properties.

When a task is divided into chunks, each chunk of the task is represented in the task tree as a sub-task.

Render tasks and sub-tasks will be distributed on the farm, one for each computer, so that several tasks can be executed
at the same time (see Using the Toonz Farm ).

If you are not using the OpenToonz render farm, dividing the task into chunks is not only useless, but it slows down
the rendering process as well. For this reason it’s suggested to use a high Render Task Chunk Size value (e.g. 1000)
in the Preferences. . . → General dialog section.
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Note: Chunk size is relevant only when animations are rendered as image sequences (for example in TIF or TGA
formats).
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Using the Toonz Farm

The Toonz Farm allows you to process OpenToonz scenes submitted as cleanup tasks or render tasks in the task list by
using a series of computers connected on the same network using TCP/IP (see Cleaning up Drawings in Batch Mode
and Rendering Scenes in Batch Mode ).

When tasks are executed, they are automatically assigned to the computers belonging to the farm in order to balance
the workload. When all computers are busy, remaining tasks are not assigned until a machine is ready to process them.

Note: If you have divided a render task into chunks, each chunk will be assigned to a different computer of the farm,
thus speeding up the rendering of a single render task (see Using Chunks when Rendering Tasks ).

The Toonz Farm is composed by the following:

• Controller node: is the computer that dispatches the tasks to server (rendering) nodes. This computer runs
the controller program, named tfarmcontroller.exe on Windows and tfarmcontrollerd on Mac-
intosh. One controller node is needed for defining a farm.

Note: The controller node can also be used as a server (rendering) node.

• Server (rendering) nodes: are the computers that execute tasks dispatched by the controller. Each of these com-
puters runs a server program, named tfarmserver.exe on Windows and tfarmserverd on Macintosh,
that is in charge of running tasks, notifying the controller when a task has been completed, etc.

• Root folder named FARMROOT: is a shared folder where a number of configuration files are stored. The
controller node and all the rendering nodes must be able to access this shared folder (see Configuring the Toonz
Farm ).

• Client program: is the program run by the user to queue new tasks and to monitor the Toonz Farm. OpenToonz
itself is the client program of the Toonz Farm, and can be run on any computer on the network, not necessarily
on a controller node or a sever (rendering) node.

Note: In order to render the scenes successfully all the computers involved in the Toonz Farm, controller, servers and
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clients have to share the same projectroot folders (see Setting the Projectroot ).

22.1 Installing the Toonz Farm on Windows

To install the Toonz Farm, you have to install the Farm Controller component on the controller node, and the Farm
Server component on the server (rendering) nodes.

Note: If you want to use a computer both as controller and as server (rendering) node, you have to install both the
components.

During the installation of any of the components you must specify the full-path of the FARMROOT folder. This path
must be expressed using the UNC format, like the following:

\\HostName\ShareName\FolderName

The drive where the FARMROOT folder is located has to be shared on the network, giving full control to any user by
setting the right permissions.

When you choose to install the Farm Controller component, the installation program will create for the controller
program a Windows Service, named Toonz Farm Controller.

When you choose to install the Farm Server component, the installation program will create for the server program a
Windows Service, named Toonz Farm Server.

Note: As the Toonz Farm requires exchanges of data between computers in the network by using TCP/IP protocol,
any firewall system that may block access on computer ports has to be disabled.

22.1.1 Setting the Controller Node

On the controller node the controller component is installed as a Windows service, named Toonz Farm Controller.
By default a Windows Service runs under the security credentials of the Local System account. By default this account
is not granted the right to access folders shared by remote hosts.

Since the Toonz Farm Controller needs to access the FARMROOT folder, typically shared by a remote host, please
run this service as a user with the proper rights.

Note: It is possible to start the service from a DOS shell by navigating to the folder where the binaries of OpenToonz
are installed, and then using the following command line:tfarmcontroller -console

Tip: To run the Toonz Farm Controller as a user with the proper rights:

1. Choose Control Panel → Administrative Tools → Services, and right-click the Toonz Farm Controller service
to open the Properties panel.

2. Select the Log On page, check the This Account: option.

3. Choose the network where the Toonz Farm is going to work and set an account that has administrator rights on
that network. Insert and confirm the related password.

4. Click the OK button.
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22.1.2 Setting the Server Nodes

On the server (rendering) nodes, the server component is installed as a Windows service, named Toonz Farm Server.
By default a Windows Service runs under the security credentials of the Local System account. By default this account
is not granted the right to access folders shared by remote hosts.

Since the Toonz Farm Server, for rendering purposes, needs to access one or more folders shared by remote hosts,
please run this service as an user with the proper rights.

Note: It is possible to start the service from a DOS shell by navigating to the folder where the binaries of OpenToonz
are installed, and then using the following command line:tfarmserver -console

Tip: To run the Toonz Farm Controller as an user with the proper rights:

1. Choose Control Panel → Administrative Tools → Services, and right-click the Toonz Farm Server service to
open the Properties panel.

2. Select the Log On page, check the This Account: option.

3. Choose the network where the Toonz Farm is going to work and set an account that has administrator rights on
that network. Insert and confirm the related password.

4. Click the OK button.

22.2 Installing the Toonz Farm on Macintosh

To install the Toonz Farm, you have to install the Farm Controller component on the controller node, and the Farm
Server component on the server (rendering) nodes.

Note: If you want to use a computer both as controller and as server (rendering) node, you have to install both the
components.

After the installation of the toonz farm components, a FARMROOT folder has to be defined, and on all the computers
belonging to the farm, both controller and servers, the full-path of the FARMROOT folder has to be specified.

To define the FARMROOT folder you can take as model the toonzfarm folder stored in OpenToonz stuff. You
can take the toonzfarm folder from any computer where OpenToonz in installed, choose the location you prefer,
and share it on the network, giving full control to any user by setting the right permissions.

To specify the path to the FARMROOT on the computers, both controller and servers, belonging to the farm, you have
to edit the configfarmroot.txt file by typing in it the full path to the FARMROOT folder.

To retrieve this file open the Applications/OpenToonz folder, right-click the OpenToonz icon and choose Show
Package Contents from the menu that opens; in the folder that opens browse to the Contents/Resources folder
and retrieve the configfarmroot.txt file.

Note: As the Toonz farm requires exchanges of data between computers in the network by using TCP/IP protocol,
any firewall system that may block access on computer ports has to be disabled.
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22.3 Configuring the Toonz Farm

Once the installation has been completed, you have to configure the Toonz Farm by editing some configuration files
stored in the FARMROOT folder.

The FARMROOT folder must be accessible by all the nodes that compose the Toonz Farm: the controller node, the
server (rendering) nodes and the computers running OpenToonz. This means that the drive where the FARMROOT
folder is located has to be shared on the network, and the permissions for users have to be maximum, in order to give
full control to any users.

For the same reason the computer where the FARMROOT is located has to be started before all the other computers
involved in the farm.

The FARMROOT folder contains the following:

• the config folder containing the servers.txt , the controller.txt and the id.txt .

• the logs folder.

The controller.txt and the servers.txt configuration files must be edited to define the controller node and
the server (rendering) nodes before using the Render Farm.

22.3.1 Defining the Controller Node

The controller node is defined in the controller.txt configuration file placed in the FARMROOT\config folder.

The file must contain a single text line that describes the node you want to use as a controller.

For the controller node you must specify the following:

• Computer name.

• IP address.

• The port number you intend to use for the controller service.

Note: Be sure that the port you set is not blocked by any firewall system, and is open for all the computers belonging
to the Toonz farm.

Each of the above information must be separated by a single space. Here is an example of a controller.txt file:

render1 10.10.0.130 10000

In the above example, render1 is the controller node, its IP address is 10.10.0.166 and the controller program
runs on the 10000 port.

22.3.2 Defining the Server Nodes

The server (rendering) nodes are defined in the servers.txt configuration file placed in the FARMROOT\config
directory.

The file must contain a text line for every computer you want to use as a server (rendering) node.

For each sever (rendering) node you must specify the following:

• Computer name.

• IP address.
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• The port number you intend to use for the server service.

Note: Be sure that the port you set is not blocked by any firewall system, and is open for all the computers belonging
to the Toonz Farm.

The above information must be separated by a single space. Here is an example of a servers.txt file:

render1 10.10.0.166 8002
render2 10.10.0.195 8002
render3 10.10.0.111 8002
render4 10.10.0.180 8002

In the above example, render1 is a server node whose IP address is 10.10.0.166 and the server program runs
on the 8002 port; render2 is a server node whose IP address is 10.10.0.195 and the server program runs on the
8002 port; etc.

If you want to add or remove a server (rendering) node from the servers.txt file, you have to restart the controller
node in order to make the changes effective.

22.3.3 Defining the Toonz Farm in OpenToonz

OpenToonz is the Toonz Farm client program: it allows you to submit new tasks and monitor the status of the farm.

If the computer where you run OpenToonz is a controller or a server (rendering) node for the Toonz Farm, no further
settings are required.

If the computer is neither a controller nor a server (rendering) node for the Toonz Farm, the FARMROOT has to be
defined.

Tip: To define the FARMROOT in OpenToonz:

1. Run OpenToonz and go to the Farm room.

2. In the Batch Servers pane, set the Process with: option menu to Render Farm.

3. In the dialog that opens specify the full path to the FARMROOT folder.

4. Click the OK button.

22.4 Using the Toonz Farm

In OpenToonz you can find the Farm room that allows you to monitor the farm processes. This room contains two
main windows: the Tasks window and the Batch Servers window.

The render farm can be monitored by using both the Tasks pane, where the list of tasks can be managed and executed,
and the Servers pane, where the computers executing the tasks can be managed.

Note: All shared disks involved in the task processing, i.e. disks where files resulting from the task execution have
to be written, must be shared granting full permissions to any user, otherwise tasks execution will not succeed. For
Windows, disks must have a Share Permission set to Full Control for Everyone; for Macintosh, the sharing settings
must allow any user to read from and write to disks.
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22.4.1 Monitoring the Server Nodes

The Batch Servers pane is divided in three areas: at the top there’s an option menu to set whether the tasks execution
has to be performed with the Local computer or with the Render Farm; then there is the list of server (rendering) nodes
in the farm; at the bottom you can see information about the server currently selected in the list.

The server (rendering) nodes included in the list are those defined in the server.txt configuration file (see Defining
the Server Nodes ). If a server node is down at the controller startup, it will not be available in the farm: this means
that all the server nodes must be up before starting up the controller node. For the same reason if you want to restart
or shut down a server (rendering) node, you have to restart the controller node in order to make the changes effective.

If the Process with: option menu is set to Local, all the tasks you run will be executed by the local computer; if it’s
set to Render Farm, the tasks will be executed by the Toonz Farm.

Note: When you select Render Farm you could be prompted to define the FARMROOT (see Defining the Toonz
Farm in Toonz ).

When a server is selected in the list, the following related information are displayed in the area at the bottom of the
window:

• Name: displays the name of the server (rendering) node.

• IP Address: displays its IP address.

• Port Number: displays the port number used to exchange data with the farm.

• Tasks: displays the task being executed.

• State: displays if the server is Ready, Busy or Down.

Note: A server node state may be down if the server port you set is blocked by a firewall system, and is
not open for all the computers belonging to the Toonz Farm (see Defining the Server Nodes ).

• Number of CPU: displays the number of CPUs available on the server.

• Physical Memory: displays the amount of physical memory available on the server.

Tip: To use the Local computer to execute tasks:

Set the Process with: option menu to Local.

Tip: To use the Toonz Farm to execute tasks:

Set the Process with: option menu to Render Farm.

22.4.2 Checking the Toonz Farm Processing

When the Toonz Farm is used, any problem that may be experienced during the processing is recorded in LOG files,
that can be opened and used to diagnose problems.

The LOG files are saved in the OpenToonz stuff\toonzfarm folder of the computer experiencing the problem;
each LOG refers to the processing performed by that computer only.

The LOG files that may be generated by the Toonz Farm processing are the following:
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• server.log logs all the operations concerning the server computer activity.

• controller.log logs all the operations concerning the controller computer activity.

• tcomposer.log logs all the operations concerning the render activity performed by the server computers.

• tcleanup.log logs all the operations concerning the cleanup activity performed by the server computers.
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CHAPTER 23

Using the Version Control System

The version control system keeps in a central repository a constant history of revisions for every file in the production
database.

The central repository must be located in a shared resource (that can be a computer in your local network or an
internet-based repository), while the local copy of files, called working copy, at a specific time or revision, should be
located on the computer you use.

When you need to work on a file, you can get it from the central repository to your working copy, and edit it; when
you finish working on the file and you want to submit the changes, you can put it back from your working copy to the
central repository.

The file you put will be saved as the last revision of the file, while the previous revisions will be retained as file history,
and all the users sharing the same central repository can get if from there. In case a previous version of the file is
needed, it is always possible to retrieve it from the central repository.

OpenToonz supports the Subversion version control system, which is one of the most popular version control systems,
used in many high-scale open source projects.

Note: The central repository defined for your version control system behaves exactly as an OpenToonz project-
root, therefore the project management under the version control system is the same, only referencing to the central
repository instead of the projectroot (see Managing Projects ).

23.1 Installing the Version Control System

The version control system works as a client/server tool: the server stores all of your files in a central repository, and
a client is used to get files to your working copy and put file changes to the server.
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23.1.1 Installing the Version Control Server

It’s possible to configure a computer in your local network as the version control server by installing Subversion 1.6
or later, or it’s possible to use an on-line service (e.g. Assembla).

You can go to the Subversion starting page for downloading it.

Contact your system administrator to configure a version control server.

23.1.2 Installing the Version Control Client on Windows

On Windows the setup of a version control client requires the download and installation of the Subversion client 1.6
or later.

You can go to the Subversion download page for downloading it. There you should look for the available binary pack-
ages and download a version control client for Windows. We suggest the use of CollabNet Subversion Command-
Line Client.

Note: If an older Subversion release is used some version control features might not work.

23.1.3 Installing the Version Control Client on Macintosh

On Macintosh the setup of a version control client depends on the OS version.

If the OS is Snow Leopard (version 10.6) or later, the setup requires no installation as the version control client is
included in the operating system.

If the OS is older than Snow Leopard, the setup requires the download and installation of the Subversion client 1.6
or later.

You can go to the Subversion download page for downloading it. There you should look for the available binary
packages and download a version control client for Macintosh.

After the installation is very important to check where Subversion is installed, as this information is needed to configure
the version control in OpenToonz: this information is displayed in the last page of the installation process and by
default is usually /opt/subversion/bin .

Note: If a Subversion release older than v1.6 is used, some version control features might not work.

23.1.4 Configuring the Version Control in OpenToonz

Once the version control server is configured and the version control client is installed it’s possible to configure
OpenToonz in order to use the version control.

In OpenToonz the version control information is stored in the versioncontrol.xml file located in the
OpenToonz stuff\config folder. By default the file has the following content:

<?xml version="1.0" encoding="UTF-8"?>
<Repositories>

<!-- REMOVE ENTIRELY THIS LINE TO ENABLE SVN
<repository>

<name>PutYourRepositoryName</name>

(continues on next page)
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(continued from previous page)

<localPath>putYourWorkingCopyPath</localPath>
<repoPath>putYourRepositoryPath</repoPath>

</repository>
REMOVE ENTIRELY THIS LINE TO ENABLE SVN -->

<svnPath></svnPath>
</Repositories>

By editing the file with a text editor it’s possible to set the information for the central repository and the working copy
location.

Together with the configuration file, version control users must be defined by editing the permissions.xml file
located in the OpenToonz stuff\config folder.

Note: The versioncontrol.xml and permissions.xml file have to be well-formed, and so cannot contain
an opening tag without its related closing tag, otherwise OpenToonz will not run. If you decide to edit the files, make
a backup copy first in case you need to revert the file to the original version.

Tip: To configure the version control in OpenToonz:

1. Open the versioncontrol.xml file located in the OpenToonz stuff\config folder with a text editor.

2. Delete the line

<!-- REMOVE ENTIRELY THIS LINE TO ENABLE SVN

and the line

REMOVE ENTIRELY THIS LINE TO ENABLE SVN -->

3. In the line

<name>PutYourRepositoryName</name>

type between the tags the name you want the repository to have in the OpenToonz browser.

4. In the line

<localPath>putYourWorkingCopyPath</localPath>

type between the tags the path to where you want the working copy to be located on the local computer
(e.g. C:\myworkingcopy\ for Windows or /myworkingcopy for Macintosh).

5. In the line

<repoPath>putYourRepositoryPath</repoPath>

type between the tags the URL of the central repository according to how it was defined on the ver-
sion control server (e.g. http://10.0.0.1/mySVNrepository/ for a repository located in the
local network; file:///C:/mySVNrepository for a repository located in the local Windows com-
puter or file:///mySVNrepository for a repository located in the local Macintosh computer; and
https://subversion.assembla.com/svn/mySVNrepository for an internet-based repos-
itory).

For Macintosh only, if the OS is older than Snow Leopard and you installed the Subversion client 1.6 or
later, in the line

<svnPath></svnPath>

type between the tags the path to the folder where Subversion is installed (this information is displayed in
the last page of the installation process and by default is /opt/subversion/bin ).
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6. Save the versioncontrol.xml file.

Tip: To define the version control users:

1. Open the permissions.xml file located in the OpenToonz stuff\config folder with a text editor.

2. In the user section define a user and assign him the version control user name and password as configured on
the server. For example to assign to the user JohnDoe the user johnd whose password is johndpassword, add the
following user:

<user name="JohnDoe">
<roles>toonzer</roles>
<svn name="johnd" password="johndpassword" />

</user>

3. Save the permissions.xml file.

Tip: To define several version control repositories:

1. Open the versioncontrol.xml file located in the OpenToonz stuff\config folder with a text editor.

2. Add after the lines defining a repository the following lines:

<repository>
<name>PutYourRepositoryName</name>
<localPath>putYourWorkingCopyPath</localPath>
<repoPath>putYourRepositoryPath</repoPath>

</repository>

and set the related information.

3. Save the versioncontrol.xml file.

Tip: To define users for different repositories:

1. Open the permissions.xml file located in the OpenToonz stuff\config folder with a text editor.

2. In the user section assign to a user the version control user name and password as configured on the server of
the second repository. For example to assign to the user JohnDoe the user johnd2 whose password is johnd-
password2 defined for the second repository, add a svn name line so that the user name section in the
permissions.xml file will look like the following:

<user name="JohnDoe">
<roles>toonzer</roles>
<svn name="johnd" password="johndpassword" />
<svn name="johnd2" password="johndpassword2" />

</user>

3. Save the permissions.xml file.
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23.1.5 Initializing the Version Control in OpenToonz

Before starting to use the version control system, it has to be initialized by setting an option in the Preferences dialog
and restarting OpenToonz.

At this point the repository will be displayed in the OpenToonz browser, and you will be able to start using it.

Tip: To initialize the version control system:

1. In OpenToonz open the Preferences. . . → Version Control dialog section and activate the Enable Version
Control option.

Note: If the version control is not correctly installed or the configuration file is not correctly defined,
activating the option will prompt a warning message.

2. Quit and restart OpenToonz.

3. In the OpenToonz browser look for the repository at the end of the folder tree, named as you defined it in the
configuration file; right-click it and choose Get from the menu that opens to establish the connection between
the central repository and the local working copy.

23.2 Using the Version Control System

The central repository and the local working copy are displayed in the OpenToonz browser at the end of the folder tree
as one single folder. By navigating the contents of this folder it’s possible to retrieve the folders and files.

When a folder is selected in the folder tree a refresh operation occurs automatically, to check the status of the folder
and its content. As this operations may require some time according to the connection speed on the local network or
in the Internet, the automatic refresh operation can be disabled.

Note: If several repositories are defined, each of them will be displayed with the name previously assigned.

Tip: To disable the automatic refresh for folder content:

1. Choose File → Preferences. . . → Version Control.

2. Deactivate the Automatically Refresh Folder Contents option.

Tip: To manually refresh a folder content visualization:

Right-click the folder icon in the folder tree and choose Refresh from the menu that opens.

23.2.1 Getting and Putting Folders and Files

The basic operations in the version control system involves getting files from the central repository to the local working
copy; and then putting the modified files back from the local working copy to the central repository.
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Fig. 1: One online repository defined (svn_test) hosting the active project (mySVNproject).
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In case you are putting folders, in the dialog that opens you can check which files and folders contained in the selected
folder have to be put in the central repository. Every time files and folders are put, it is also possible to type a comment
to let the other users know about s of the performed modifications.
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In case you are getting or putting scene files (TNZ format), in the dialog that opens it’s possible to check the Get
Scene Contents or the Put Scene Contents option to include with the request, or return back, the materials used in
the scene as well.

Note: The first time you get a folder not previously available in the working copy (folder with grey icon), you get the
files contained in the folder, but not the sub-folders. The next time you get the folder (folder with a colored icon), you
get the entire contents of the folder, including sub-folders and the related contents.

Tip: To get the latest version of a folder or a file from the central repository to the local working copy:

1. Right-click the folder icon in the folder tree, or the file icon in the browser, and choose Get from the menu that
opens.

2. In the dialog that opens if you are getting a scene file (TNZ format) activate the Get Scene Contents if you
want to get the files used in the scene as well.

3. Click the Update button.

Tip: To put your modified version of a folder or a file from the local working copy to the central repository:

1. Right-click the folder icon in the folder tree, or the file icon in the browser, and choose Put from the menu that
opens.

2. In the dialog that opens do any of the following:

• If you are putting a folder, check which files and folders contained by the selected folder have to be put in the
central repository.

• If you are putting a scene file (TNZ format) activate the Put Scene Contents if you want to put the files used in
the scene as well.

3. Type a comment if required and click the Put button.

518 Chapter 23. Using the Version Control System



OpenToonz Documentation, Release 1.7.1

23.2.2 Editing Files

When using the version control system, in order to modify files you have to put them in Edit mode before loading
them into OpenToonz; if not, they will be loaded as read-only.

The Edit operation “locks” the file, so only the user running the command will be able to modify it (preventing other
users using the same central repository from unlocking it and being able to modify it). At the moment a file is about
to be edited, it’s possible to type in a Comment, to let the other users know about your editing operation.

When editing a scene file (TNZ format), in the dialog that opens it’s possible to check the Edit Scene Contents option,
in order to be able to edit the materials used in the scene as well. If you choose to edit only the scene file, or if some
material used in the scene is currently being edited by other users sharing the same central repository, the locked
frames of that levels will be displayed with a forbidden icon in the Level Strip.
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The Edit Frame Range command is available as well, to let a user edit only the needed frames of any Toonz Vector
or Toonz Raster animation level. This way, different users can work at the same time on different frame ranges of the
same animation level.

When you want to release files from the editing mode, so that others can work on them, you can use the Unlock
command.

Note: Files are in read-only mode (or in locked mode) in case a user is editing them, by setting the file system
read-only attribute. For this reason, manually using the OS (instead of the appropriate version control commands) to
change this status, may cause serious inconsistencies in the version control system.

Tip: To edit an updated file:

1. Right-click the file and choose Edit from the menu that opens.

2. In the dialog that opens if you are editing a scene file (TNZ format) activate the Edit Scene Contents if you
want to edit the files used in the scene as well.

3. Type a comment if required and click the Edit button.
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Tip: To edit a file that is older than the version available in the central repository:

1. Right-click the file and choose Edit from the menu that opens.

2. In the dialog that opens if you are editing a scene file (TNZ format) activate the Edit Scene Contents if you
want to edit the files used in the scene as well.

3. Type a comment if required and do one of the following:

• Click the Get and Edit button to get the latest version of the files and edit them.

• Click the Edit button to edit the version of the files that is currently in your local working copy.

Tip: To edit only the needed frames of a Toonz level file:

1. Right-click the file and choose Edit Frame Range from the menu that opens.

2. In the dialog that opens set the frame range you want to edit.

3. Type a comment if required and click the Edit button.

Tip: To release a file from the editing mode:

Right-click the file and choose Unlock from the menu that opens.

Tip: To check the editing state of a locked file:

Right-click the file and choose Edit Info from the menu that opens.

23.2.3 Retrieving File Revisions

One of the main advantages of using a version control system is that the history of the revisions for every file in the
production database is always available. This means that it’s possible to very easily retrieve previous versions of any
file.

To retrieve older file versions it’s possible to use the Get Revision command. When used on a single file it displays
a timeline with all the file versions; in the timeline you can check the different file versions with the related icons and
information, and select which version to get in order to edit it.

23.2. Using the Version Control System 521



OpenToonz Documentation, Release 1.7.1

When getting a revision of a scene file (TNZ format), in the dialog that opens it’s possible to check the Get Scene
Contents option in order to get the revisions of the materials used in the scene as well.
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When used on a multiple files selection it opens a dialog that allows you to specify the time, day, week or date of the
files version you want to retrieve.

Tip: To retrieve an older revision of a file:

1. Right-click the file and choose Get Revision from the menu that opens.

2. In the dialog that opens look for the file version you are interested in and select it; if you are editing a scene file
(TNZ format) activate the Edit Scene Contents if you want to get the revision of the files used in the scene as
well.

3. Do one of the following:

• Click the Get Selected Revision button to get the selected file version.

• Click the Get Last Revision button to get the latest file version.

Tip: To retrieve an older revision of a selection of multiple files:

1. Right-click any of the selected files and choose Get Revision from the menu that opens.

2. In the dialog that opens specify how much older the version of the files you want to retrieve has to be, by doing
one of the following:

• Specify a time in hours and minutes.

• Specify a number of days.

• Specify a number of weeks.

• Specify and exact date and time.

3. Click the Update button.
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23.2.4 Understanding the Folder and File Icons

According to the folder and file icons you can tell if the folder or the file in the working copy is updated or not to the
latest version available in the central repository, and if files are edited by other users and locked.

Note: If the File Browser displays files as a List, the information about the version control status is displayed in the
column labeled Version Control.

For folders the following icons are used:

• A grey folder icon is used for folders available only in the repository. You can use the Get command to
copy them to the local working copy.

• A colored folder icon with a yellow mark is used when the folder contents in the working copy is not up to
date and does not match to the folder contents in the repository: this is the case when there are modified or new
files in the working copy or there are modified or new files in the repository. You can use the Get command to
copy them to the local working copy.

• A colored folder icon with a green mark is used when the folder contents in the working copy is up to date
and matches to the folder contents in the repository.

• A colored folder with a plus mark is used for folders available only in the working copy. You can use the
Put command to copy them to the central repository.

For files the following icons are used:

• A generic grey icon is used for files available only in the repository. You can use the Get command to copy
them to the local working copy.

• The file icon with a grey check mark is used when files in the working copy are up to date and match to the
latest version available in the repository. The files are in read-only mode, and they have to be in edit mode in
order to be modified.

• The file icon with a green check mark is used when files in the working copy are in edit mode.

• The file icon with a green check mark on a grey and white background is used when files in the working
copy are partially in edit mode.

• The file icon with a red exclamation mark is used when files in the working copy are newer than the latest
version available in the repository, because you modified them. You can use the Put command to copy them to
the central repository.

• The file icon with a red exclamation mark on a grey and white background is used when files in the working
copy are partially newer than to the latest version available in the repository, because you modified them. You
can use the Put command to copy them to the central repository.

• The file icon with an orange exclamation mark is used when files in the working copy are older than the
latest version available in the repository, because someone modified them. You can use the Get command to
copy them to the local working copy.
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• The file icon with an lock mark is used when files are in edit mode by other users. For these files it is only
possible to check the information about the user editing the file.

• The file icon with a lock mark on a grey and white background is used when files are partially in edit mode
by other users.

• The file icon with the plus mark is used for files available only in the working copy. You can use the Put
command to copy them to the central repository.
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CHAPTER 24

ToonzScript

ToonzScript is the scripting language used in OpenToonz. Using ToonzScript allows users to create sequences of
commands, thus avoiding the need to perform repetitive tasks manually. ToonzScript is based on QtScript and is built
on the ECMAScript standard. A reference guide for the ECMAScript standard can be found at the following URL:

ECMAScript Reference

Note: Several well known scripting languages are based on the ECMAScript standard such as JavaScript, JScript, and
ActionScript. The ToonzScript syntax is similar to that of JavaScript, for this reason, a good introduction to JavaScript
can be very useful to better understand ToonzScript’s basics.

The original ToonzScript page with some (rather old) examples is available at the following URL:

ToonzScript page

Scripts can be run using the File → Script → Run Script... command. Alternatively, commands can
be typed and executed directly in the Script Console, which can be opened using the File → Script → Open
Script Console... command.

Note: When a script is running, the Script Console will open automatically to show the commands contained within
the script.
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24.1 File management

The ToonzScript file extension is .js, scripts need to be in the OpenToonz stuff/library/script folder, to
be automatically retrieved by opening the Run Script command browser.
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24.2 Using the Script Console

The Script Console allows the user to directly enter commands, additionally, dragging & dropping external text files
into the console will automatically insert the path of the file(s).

Start a series of lengthy operations from the console does not block the interface.

24.2.1 Console use conventions

The following conventions are implemented in the use of the Script Console:

• Only the text of the last paragraph can be edited.

• The Up and Down arrow keys allow the navigation of the command history.

• The execution of time consuming commands doesn’t prevent interaction with the software interface.

• The ctrl+y shortcut interrupts the execution of time consuming commands.

• When entering a path in a string, any and all backslashes must be doubled. Following this rule the path:
C:\tmp\test.jpg becomes C:\\tmp\\test.jpg .

• Even if working on a Windows family OS the slash and the backslash can be used in the same way, thus the path
C:\tmp\test.jpg is equivalent to the path C:/tmp/test.jpg .

• The drag & drop of an external file into the console generates a string containing the file’s path and the back-
slashes are doubled automatically.

• While you can copy multiple lines of text from the console is allowed only one line paste.

24.3 ToonzScript specifications

Built on the foundaments of ECMAScript, ToonzScript retains a degree of similarity to the JavaScript syntax but, at
the same time, implements some functions and several classes specifically built to make easier the interaction with the
OpenToonz software architecture. Here follows the list of the ToonzScript specifications:

24.3.1 Commands

• print(arg1, arg2, . . . ): writes a message on console.
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The print command doesn’t return the undefined value.

Example:

print(“result=”,12*3);

• run(filename): runs the script saved in filename.
The relative path are referred to the folder “<opentoonz library>/scripts/”

Examples:

run(“test.js”)
run(“C:\\Users\\Username\\Tests\\another_test.js”)

• view(image): allows to view an image.
The view command can be legally used in the following context: view(new Image(filename))

• view(level): allows to view a level.

Example:

view(new Level(“C:\\OpenToonz stuff\\sandbox\\drawings\\A.pli”))

• The variable ToonzVersion can be used to check the current version of OpenToonz.

24.3.2 Classes

For each class, the related constructor, methods and attibutes are listed.

File path

contains the path of an object.

Constructor:

• new FilePath(path)

Methods:

• path2 = path.withExtension(e)

• path2 = path.withName(name)

• path2 = path.withParentDirectory(d)

• path2 = path.concat(f) - where f can be a FilePath or a string

• files = path.files() - if path is a folder then this method returns the files inside the folder.

Attributes:

• path.extension - read and write attribute

• path.name - read and write attribute

• path.parentDirectory - read and write attribute

• path.lastModified - read only attribute

• path.exists - read only attribute

• path.isDirectory - read only attribute
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Examples:

myRoot = new FilePath(“C:\\Users\\username\\”);

f = myRoot.concat(“tests”).concat(“name.0001.tif”);

print(f.extension); // => “tif”

print(f.name); // => “name”

print(f.parentDirectory); // => “C:\Users\username\tests”

if(f.exists) print(“the file “,f,”exists”); else print(“the file “,f,”does not
→˓exist”);

d = new Date().getTime() - f.lastModified.getTime();

d.setDate(d.getDate()-1);

if(f.lastModified>=d) print(“file modified in the last 24 hours);

files = myRoot.files();

for(k in files) print(files[k]); // print all files in myRoot

Image

contains an image, supported types are: tlv, pli or fullcolor.

Constructor:

• new Image() or new Image(filename)

Methods:

• img.save(filename) - the file extension has to be compatible with the kind of used level

• img.load(filename)

Attributes:

• img.width - has value 0 if the image is a pli

• img.height - has value 0 if the image is a pli

• img.dpi - has value 0 if the image is a pli

• img.type - accepted values (“Empty”, “Raster”, “ToonzRaster”, “Vector”)

Examples:

img = new Image(“C:/images/basename.0003.tif”);

view(img);

print(img.width,img.height,img.dpi);

img = new Image(“C:/images/name.pli”); // reads only the first frame.

view(img);

(continues on next page)
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(continued from previous page)

img.save(“C:/images/name.pli”);

Level

contains a level, the supported types are: tlv, pli or fullcolor.

Constructor:

• new Level() or new Level(filename)

Methods:

• level.load(filename)

• level.save(filename) - the file extension has to be compatible with the kind of usedlevel

• level.getFrameIds() - lists the names of all the frames

• level.getFrame(frameId) - retrive the image of the specified frame

• level.getFrameByIndex(index) - gets the frame specified by the index value (first value of index is 0)

• level.setFrame(frameId, image) - sets a frame (if the level is not empty its content and the type of image has to
be compatible)

Attributes:

• level.name - is a read and write attribute

• level.path - is a read and write attribute

• level.frameCount - is a read only value

• level.type (“Empty”, ”Raster”, ”ToonzRaster”, ”Vector”) - is a read only value

Examples:

// This example produces a "renumber"

inputLevel= new Image(“C:/images/name.pli”);

outputLevel = new Level();

for(i=0;i<inputLevel.frameCount;i++)
{

outputLevel.setFrame(i+1, inputLevel.getFrameByIndex(i));

outputLevel.save(“C:/images/name.pli”);
}

// instead this keeps the sequence of frames, but reverses the order

outputLevel = new Level();

fids = inputLevel.getFrameIds();

for(i=0;i<fids.length;i++)
{

img = inputLevel.getFrame(fids[fids.length-1-i]);

(continues on next page)
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(continued from previous page)

outputLevel.setFrame(fids[i], img);
}

view(outputLevel);

Scene

contains a Toonz scene.

Constructor:

• new Scene() or new Scene(filename)

Methods:

• scene.load(filename)

Note: If the path is relative, scenes of the current project are used.

• scene.save(filename)

• scene.setCel(row, col, cell) , scene.setCell(row, col, level, frameId)

Note: cell is the kind of object returned by getCell() .

• The following syntax is allowed scene.setCell(1, 0, scene.getCell(0,0))

• To delete a cell: scene.setCell(row, col, undefined)

• cell is a standard JavaScript object that includes the attributes:level and fid , the following use is allowed:
scene.setCell(row, col, {level:a, fid:1})

• level can be a Level or a level name. The level has to be already in the scene.

• fid supports numeric values or string values as “2” or “2a”.

• cell = scene.getCell(row, col) - returns a JavaScript object with level and fid attributes

• scene.insertColumn(col)

• scene.deleteColumn(col)

• scene.getLevels() - returns an arrray that contains all the levels belonging to the scene

• scene.getLevel(name) - returns the level basing on its name. If a level using the name specified does not exists
the value undefined is returned.

• level = scene.newLevel(type, name) - Adds a layer to the scene. Type can be “Raster”, “ToonzRaster” or
“Vector”. Name must not be already ‘used in the scene.

• level = scene.loadLevel(name, path) - Load a level (mode ‘“links”) in the scene. The path must exist and be an
absolute path.The name must not have been already used for another level of the scene.

Attributes:

• scene.frameCount - is a read only value

• scene.columnCount - is a read only value

Examples:

24.3. ToonzScript specifications 533



OpenToonz Documentation, Release 1.7.1

filename = “test.tnz”; // relative to “+scenes”

scene = new Scene(filename);

print(scene.frameCount, scene.columnCount);

// Move the cells of the first column on the first frame of the other columns.

for(r=1;r<scene.frameCount;r++)
{

scene.setCell(0,r, scene.getCell(r,0));

scene.setCell(r,0,undefined); // delete the old cell.
}

scene.save(“name.tnz”);

//Create a new scene.

scene = new Scene();

level = scene.load(“A”,”C:/levels/name.pli”);

fids = level.getFrameIds();

for(i=0;i<fids.length;i++) scene.setCell(i,0,level,fids[i]);

scene.save(“name.tnz”);

// writes name, path and number of frames of each level in the scene.

scene = new Scene(“name.tnz”);

levels = scene.getLevels();

for(i=0;i<levels.length;i++)
{

level = levels[i];

print(level.name, level.path, level.frameCount);
}

Transform

represents a geometric tansformation (composed by rotation, translation and scale). Used by ImageBuilder.

Constructor:

• new Transform()

Methods:

• transform.translate(dx, dy)

• transform.rotate(degrees)

Note: Positive values correspond to a counterclockwise rotation.

534 Chapter 24. ToonzScript



OpenToonz Documentation, Release 1.7.1

• transform.scale(s)

• transform.scale(sx, sy)

Examples:

transform = new Transform().rotate(45).translate(10,2);

print(transform);

ImageBuilder

allows to modify an image (rotate, scale, crop), or to make an over between two or more images.

Constructor:

• new ImageBuilder() or new ImageBuilder(xres, yres)

Methods:

• builder.add(img)

• builder.add(img, transform)

Note: The component of translation of the transform means expressed in pixels for Raster and Toonz Raster levels,
and in Camera Stand units for Vector levels.

• builder.fill(color)

Attributes:

• builder.image - returns the actual result.

Examples:

ib = new ImageBuilder(800,800);

img = new Image(“C:/levels/name.0001.tif”);

scale = 1;

phi = 0;

for(i=0;i<20;i++)
{

tr = new Transform().scale(scale).translate(0,-200).rotate(phi);

ib.add(img, tr);

phi -= scale*30;

scale *= 0.9;
}

view(ib.image);
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OutlineVectorizer

vectorize raster images using an outline algorithm.

Constructor:

• new OutlineVectorizer()

Methods:

• v.vectorize(level or image) - returns the new vectorized level (or image), supports as input: Raster or Toonz
Raster images and levels.

Attributes:

• v.accuracy

• v.despeckling

• v.preservePaintedAreas

• v.cornerAdherence

• v.cornerAngle

• v.cornerCurveRadius

• v.maxColors

• v.transparentColor

• v.toneThreshold

Examples:

v = new OutlineVectorizer();

v.preservePaintedAreas = true;

a = new Image("C:/Users/username/name.tif");

b = v.vectorize(a);

view(b);

CenterlineVectorizer

vectorize raster images using a centerline algorithm.

Constructor:

• new CenterlineVectorizer()

Methods:

• v.vectorize(level or image) - returns the new vectorized level (or image), supports as input: Raster or Toonz
Raster images and levels.

Attributes:

• v.threshold

• v.accuracy

• v.despeckling
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• v.maxThickness

• v.thicknessCalibration

• v.preservePaintedAreas

• v.addBorder

Examples:

v = new OutlineVectorizer();

v.preservePaintedAreas = true;

a = new Image("C:/Users/username/name.tif");

b = v.vectorize(a);

view(b);

Rasterizer

converts vector images into Raster or ToonzRaster images.

Constructor:

• new Rasterizer()

Methods:

• out = r.rasterize(vimg) - converts to raster an image or a level

Attributes:

• r.colorMapped - if its value is set to True the generated image is of ToonzRaster type

• r.xres

• r.yres

• r.dpi

Examples:

a = new Level("C:\\Users\\username\\PLI\\name.pli");

r= new Rasterizer();

r.xres=768; r.yres=576; r.dpi=40;

b = r.rasterize(a);

b.save(“C:\\Users\\username\\PLI\\name.tif”);

r.colorMapped = true

c = r.rasterize(new Level("C:\\Users\\username\\PLI\\name.pli"))

c.save(“C:\\Users\\username\\PLI\\bimba.tlv”);
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Renderer

renders a whole scene or part of a scene, creating levels or images.

Constructor:

• new Renderer()

Methods:

• level = c.renderScene(scene)

• image = c.renderFrame(scene, frameIndex)

Note: frameIndex starts from 0

Attributes:

• r.columns (list of indices of columns to render. e.g. r.columns = [0,3])

• r.frames (list of indices of frames to render. e.g. r.frames = [0,1,2,3])

Examples:

scene = new Scene("testscene.tnz”);

r= new Rasterizer();

view(r.renderScene(scene ,0));

r.columns = [0,2];

view(r.renderScene(a,0)); // frame 1; columns 1 and 3

r.frames = [0,2,4,6];

output = r.renderScene(scene ); // frames 1,3,5,7; columns 1 and 3

output.save(“C:\\Users\\username\\output\\name..tif”);

r.columns = [];

output = r.renderScene(scene ); // frames 1,3,5,7; all columns

output.save(““C:\\Users\\username\\output\\name..tif””);

24.4 Code examples

Following there are some examples of scripting code:

24.4.1 Outline vectorization

This brief script is an example of using the OutlineVectorizer on a single image. The script is commented, explaining
what each section does:
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//Define the input and output folders

dir = "C:\\OpenToonz stuff\\SCRIPT IMAGES IN\\";

dir2 = "C:\\OpenToonz stuff\\SCRIPT IMAGES OUT\\";

//Load image toad3.0001.tif from disk

a = new Image(dir+"toad3.0001.tif");

print("loaded",a);

//Initialize a vectorizer and specify any relevant options

v = new OutlineVectorizer();

v.maxThickness = 1;

v.preservePaintedAreas = false;

v.accuracy = 10;

v.maxColors = 10;

//Run the vectorization process and save the result

v.vectorize(a).save(dir2 + "vec.pli");

print("vectorized");

24.4.2 Rotating an image

This example explains how to load an image and then create an animation in a level, rotating the loaded frame:

\\Define the input and output folders

dir = "C:\\OpenToonz stuff\\SCRIPT IMAGES IN\\";

dir2 = "C:\\OpenToonz stuff\\SCRIPT IMAGES OUT\\";

//Load the toad3.tif image

a = new Level(dir+"toad3..tif");

print("loaded\n",a);

//Initialization of the new objects and creation of a list containing the IDs of all
→˓the frames

t = new Transform();

(continues on next page)
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(continued from previous page)

b=new Level();

ll=a.getFrameIds();

//For loop that builds the new level. At each step a new frame is added to the level
→˓b using the
setFrame method that adds the myimage frame rotated of a step degrees value using the
→˓ib ImageBuilder

for(i=0; i<a.frameCount;i++)
{

ib = new ImageBuilder();

step=360/a.frameCount;

myimage=a.getFrame(ll[i]);

b.setFrame(ll[i], ib.add(myimage, t.rotate(step)).image);

print("building frame " + ll[i] + "\n");
}

//Save the result prompting a status message

b.save(dir2+"rottoad3..tif")

print("saved\n",b);

//Shows the resulting level in a flipbook window

view(b);

540 Chapter 24. ToonzScript



541



OpenToonz Documentation, Release 1.7.1

CHAPTER 25

Keyboard Shortcuts

25.1 Configuring Shortcuts
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Predefined shortcuts are available for OpenToonz tools, modifiers and menu commands. They can be customized, and
new shortcuts can be added for undefined items.

Shortcuts are specific to each user, meaning that each user in the system can have a different set of shortcuts.

Tip: To configure a shortcut:

1. Choose File → Configure Shortcuts. . .

2. Search for the command or tool you want to configure the shortcut for in the appropriate folder, or by using the
Search field at the top of the window.

3. Select the command or tool name in the list.

4. Press the keyboard key, or combination of keys, you want to assign as shortcut.

Tip: To remove a configured shortcut:

1. Choose File → Configure Shortcuts. . .

2. Search for the command or tool you want to configure the shortcut for in the appropriate folder, or by using the
Search field at the top of the window.

3. Select the command or tool name in the list.

4. Click the Remove button.

25.2 Predefined Keyboard Shortcuts

The following are some of the predefined shortcuts available in OpenToonz.
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Tools

Animate A

Selection S

Brush B

Geometric G

Type Y

Fill F

Eraser E

Tape T

Style Picker K

RGB Picker R

Control Point Editor C

Pinch M

Skeleton V

Hook O

Plastic X

Zoom Shift + Space

Rotate Ctrl/ Cmd + Space

Hand Space

Note: If you press and hold a tool keyboard shortcut, you perform a temporary tool selection: when you release the
key you will return to the previously selected tool.

Tool Modifiers
Brush Size - Decrease max U
Brush Size - Increase max I
Brush Size - Decrease min H
Brush Size - Increase min J
Rectangular/Normal type F5
Frame Range F6
Selective F7
Segment F8

544 Chapter 25. Keyboard Shortcuts



OpenToonz Documentation, Release 1.7.1

Visualization
Actual Pixel Size N
Fit to Window Alt/ Option + 9
Reset View Alt/ Option + 0
Zoom in +
Zoom out -
Onion Skin Toggle /
Maximize Panel ‘
Full Screen Mode Alt/ Option + F
Main Window Full Screen Mode Ctrl/ Cmd + ‘

Playback Controls
Play P
Loop L
Previous Drawing ,
Next Drawing .
Previous Frame Shift + ,
Next Frame Shift + .
Previous Keyframe Ctrl/ Cmd + ,
Next Keyframe Ctrl/ Cmd + .

File Menu
New Scene Ctrl/ Cmd + N
Load Scene. . . Ctrl/ Cmd + L
Save All Ctrl/ Cmd + S
Save Scene Ctrl/ Cmd + Shift + S
Preferences. . . Ctrl/ Cmd + U
Quit Ctrl/ Cmd + Q

Edit Menu
Undo Ctrl/ Cmd + Z
Redo Ctrl/ Cmd + Y
Cut Ctrl/ Cmd + X
Copy Ctrl/ Cmd + C
Paste Insert Ctrl/ Cmd + V
Paste Insert Above/After Ctrl/ Cmd + Shift + V
Delete Del
Insert Ins
Insert Above/After Shift + Ins
Select All Ctrl/ Cmd + A
Group Ctrl/ Cmd + G
Ungroup Ctrl/ Cmd + Shift + G
Bring to Front Ctrl/ Cmd + ]
Bring Forward ]
Send Backward [
Send to Back Ctrl/ Cmd + [
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Level Menu
New Level. . . Alt/ Option + N

Xsheet Menu
Set Key Z
New FX. . . Ctrl/ Cmd + F
Edit FX. . . Ctrl/ Cmd + K
Apply Lip Sync Data to Column Alt/ Option + L

Cells Menu
Duplicate Drawing D
Increase Step ‘
Decrease Step ;
Drawing Substitution Backward Q
Drawing Substitution Forward W
Similar Drawing Substitution Backward Alt/ Option + Q
Similar Drawing Substitution Forward Alt/ Option + W

Play Menu
Play P
Loop L
First Frame Alt/ Option + ,
Last Frame Alt/ Option + .
Previous Frame Shift + ,
Next Frame Shift + .
Previous Keyframe Ctrl/ Cmd + ,
Next Keyframe Ctrl/ Cmd + .
Previous Drawing ,
Next Drawing .

Render Menu
Preview Ctrl/ Cmd + R
Output Settings. . . Ctrl/ Cmd + O
Render Ctrl/ Cmd + Shift + R
Fast Render to MP4 Alt/ Option + R

Windows Menu
History Ctrl/ Cmd + H
Record Audio Alt/ Option + A
Startup Popup. . . Alt/ Option + S
Maximize Panel ‘
Main Window Full Screen Mode Ctrl/ Cmd + ‘

Help Menu
Online Manual. . . F1
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FX Reference

Note: The FX Reference is not complete at this time

26.1 Layer Blending

26.1.1 Local Transparency

Inputs:

Source, The image that will be affected.

Reference, The luminance of the Reference image will control the opacity of the Source.
The Source will be made transparent where the Reference is light, and opaque where the Reference is dark.

Parameters:

Intensity, Controls the overall strength of the effect.
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A value of 50 will produce a result halfway between the Source image and the full effect.

Usage Example:

We can use a checker pattern to control the opacity of a circle

This is how the two levels are connected in the FX Schematic; by connecting the checker level to the Reference input,
we will use its luminance to mask portions of the circle

Here is the result; the red circle is visible within the black areas of the checker pattern and not in the white areas
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26.1.2 Transparency

Inputs:

Source, The image that will be affected.

Parameters:

Intensity, Controls the overall strength of the effect.
A value of 50 will produce a result halfway between the Source image and the full effect.

Usage Example:

We will see the transparency of a yellow circle on top of a black rectangle background
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This is how the image levels are connected in the FX schematic; by connecting the circle level to the source input we
can control the circle’s transparency

Here is the result; the first image is with zero percent transparency, the second image is with fifty percent transparency,
and the third image is with seventy five percent transparency
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Special Thanks

This documentation is based on Toonz Harlequin 7.1 User Guide, originally created by Digital Video S.p.A., Rome
Italy.
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